Talk:Wireless Bridge

From DD-WRT Wiki

Jump to: navigation, search

The 63 character key maximum in the instructions is not a bug. 63 printable characters = 256 bit encryption, which should be enough for WPA2.



I don't use MAC filtering on my network. Is that a required step?


The title is "Wireless Bridge", but the content is "Client-bridge". Why ? The term "Wireless-bridge" is usually used for connection of two APs (both running in AP mode), sometimes referred to as "WDS".



[edit] Operating Mode must be set to Router

I was playing around with this today. It seems to only work if the Client-Bridge device is set to some type of routing and NOT set to Gateway under the Advanced Routing tab.

[edit] Set AP Isolation to disabled for the Host Router

Hi! Thanks for a great walk-thru! It worked excellent, except for one thing. My clients connected wirelessly with the host router was not visible for the computers connected to the client router. (And since all my computers use wireless connections, this was a little showstopper....)

But when I disabled AP Isolation on the Host Router, everything works fine!

I now have a KiSS VR558 connecte to a DD-WRT modified Linksys WRT54G(Bridge client), which connects wirelessly to my WRT300N (Host w/Internet access). My main computer where all my movies and music is located, is wirelessly connected to the main WRT300N via a WMP300N. It is now accessible from the KiSS via the brigde and main router.

Thanks again!!

[edit] WPA not working on WHR-G54S bridge with Actiontec AP.

Great summary, except I can't get the client-bridge working using WPA-PSK. WEB works fine, though. My bridge is a Buffalo WHR-G54S running DD-WRT v32 SP2 and my AP is an Actiontec MI424-WR (supplied by Verizon FIOS). WPA otherwise works with the AP. I can connect using WPA-supplicant just fine.

The bridge seems to associate with the AP in WPA mode, but there are 0 packets in or out. The AP logs cryptic errors:

  • Apr 21 00:10:20 2007 System Log Message kern.debug Clink Reset Cause :0x1b0002 Reg:0x20000 Dbg:0xa9b
  • Apr 21 00:10:16 2007 System Log Message kern.debug Clink Device Forced reset
  • Apr 21 00:10:05 2007 System Log Message daemon.warn cLink: clink0: ioctl(DRV_GET_MY_NODE_INFO) failed, res=-1: Bad address.
  • Apr 21 00:10:00 2007 System Log Message kern.debug Clink Reset Cause :0x1b0002 Reg:0x20000 Dbg:0xa9b

Again, in WEP or unencrypted mode, the AP sees it fine. Do you think it's the bridge or the AP? Any ideas?

Beveal 09:21, 21 Apr 2007 (CEST)

The coaxial ports being active but disconnected cause those errors. Disable both coaxial ports and the errors will cease. It took me a while to discover the cause and it was staring me in the face. Good luck to you. Azpeitio

I was connecting a WRT54GS2 with dd-wrt v24 micro on it as a bridge to the Actiontec MI424-WR and the WEP was not working. Switched the Actiontec and bridge to WPA and it connected immediately as client bridge. Worked with gateway, etc. Just a standard setup under WPA Personal using AES. - William with

[edit] Brainslayer forum

The BrainSlayer forum information about 802.11 supporting one mac address is wrong. 802.11 frames carry four mac addresses:

1. Sending station MAC

2. Receiving station MAC

3. TX station MAC

4. RX station MAC

If there is a limitation in client mode wireless it's a limitation in the CLIENT or ROUTER firmwares not properly handling the frame. Some of the management frame formats only have two MAC addresses, but for data frames, four addresses are used.

802.11 Standard (see section 7)

I tried this about a year ago (don't remember which dd-wrt version), and as far as I remember it didn't work, and showed classic ARP-problems (i.e. pinging two computers on the bridged subnet alternatively from the unbridged subnet caused predictable packet losses). But with v23sp2, I have it working fine so far, including port forwarding. It may have been broken in earlier dd-wrt versions (hence BrainSlayer's warning) or it may break if you fiddle too much with it. --Tomten 10:16, 23 July 2007 (CEST)

[edit] Example works with modded Fonera routers

Just in case someone is searching for this: In the past I had problems connecting my Fonera (DD-WRT v24 Beta (04/16/07) std) with my Netgear MR814v3. Since it was slow anyway I replaced it with a Microsoft MN-700 (DD-WRT v24 Beta (05/16/07) std). I followed the example and gave my PC a DHCP IP-adress. Everything works, even port forwarding. Thanks again.

[edit] PCs connected to client cannot talk to the primary router

Help! I am new to DD-WRT, however these instruction help me successfully connect my CLIENT router WRT54G( to my primary router Trendnet(TEW-432BRP) via wireless. But I cannot access internet from the CLIENT network side, below are ip address used in my setting:

PRIMARY router Trendnet(TEW-432BRP) (connected to a cable modem to access internet); laptop A connected to the primary router, receiving a dynamic IP - DHCP ips starting from -

CLIENT router WRT54G - laptop B connected to the CLIENT router, IP manually set as

from laptop A, I can ping the CLIENT router and laptop B, even access the web interface of DD-WRT. ;From laptop B I can ping laptop a but cannot ping the PRIMARY router. When I changed laptop B to dynamic ip mode later, it couldn't receive a valid ip. It seemed that all PCs in my LAN can communicate each other, but all PCs connected to Client cannot talk to the primary router. any idea on this?

[edit] This tutorial needs a haircut and shave

This tutorial is a mess and needs to be culled. I don't mean to be rude, just frank. I agree that this page should be renamed (after trimming) from "Wireless Bridge" to "Client-bridge".

This is way too long for a "basic tutorial". Maybe we should start from the perspective of a newbie wanting to create a bridge hosting a single computer. Multiple computers (NAT issues, WDS, et cetera) could be mentioned but have the details broken down in a separate topic.