Samba filesystem

From DD-WRT Wiki

Revision as of 00:40, 1 September 2006 by AlReece45 (Talk | contribs)
Jump to: navigation, search



One of the things you might miss on the router, is writable storage. Well, if you run a Linux samba or Windows server on your LAN, the Samba file system provides a convenient solution! It adds a vast amount of writable storage to your router and even offers an automatic startup script.


  1. Create a SMB network share on the host computer.
  • On Linux, use Samba to create a SMB network share. HOWTO
  • On Windows, this is the default file sharing system. Simply right click and select "Sharing and Security" to set up sharing.
  1. Use the [Web_Interface] and go to the Administration tab.
  2. Enable the Samba FS Automount option. If new options do not appear the "Save Changes" and go back to the page.
  3. Enter the share location in the 'share' field. eg: //
  4. In 'user' and 'password' enter the user credentials of a user allowed to access the share.
  5. You may optionally enter a Startscript. For example if you have a script on your share \\lanserver\myshare\ you enter in the 'Startscript' box. This script (/tmp/smbshare/ on the router) will be executed when the router mounts your share on boot.

You can see sample of startup script on Jffs page.


You may want to manually mount a share. To do this, simply enter this command in a Telnet or SSH prompt:

  • /tmp/Path/ is the path you want it mounted
  • Don't forget that only /tmp/, /dev/ and potentially /jffs/ are writeable!
mkdir /tmp/Path/
smbmount //<IP.SE.RV.ER>/Share /tmp/Path/ -o username=<user>,password=<password_user>

Receiving errors like this seems normal:

 load_client_codepage: filename /usr/lib/codepages/codepage.850 does not exist.
 load_unicode_map: filename /usr/lib/codepages/unicode_map.850 does not exist.
 session request to failed
 Can't get /etc/mtab~ lock filesmbmnt failed: 1

To unmount a share, enter this command in a shell prompt:

 umount /tmp/Path/
 rmdir /tmp/Path/

Note for Windows users

Especially on Windows Server 2003, assert that your server accepts NTLM v1.

  1. Goto Start > Run
  2. Type "gpedit.msc" and push enter.
  3. Goto Computer Configuration / Windows Settings / Security Settings / Local Policies / Security Options.
  4. Verify that "Network security: LAN Manager authentication level" is NOT "Send NTLMv2 response only\refuse LM & NTLM"