[Split] Compiling DD-WRT

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Generic Questions
Goto page Previous  1, 2, 3 ... 22, 23, 24, 25  Next
Author Message
Mazout360
DD-WRT Novice


Joined: 21 Apr 2013
Posts: 21

PostPosted: Wed Oct 16, 2013 13:42    Post subject: Reply with quote
Fractal wrote:
kaid definatly broken:

<code>


mipsel-linux-g++ -D_REENTRANT -DPLATFORM_linux -DVERSION=\"7.0.0.7\" -DOPENWRT -DOPENWRT -g -Wall -Ipthreadcc/src -Isocketcc/src -I../../libpcap_noring -DCONFIG_FILE="\"/etc/kaid.conf\"" -Os -pipe -mips32r2 -mtune=74kc -mdspr2 -fno-caller-saves -msoft-float -mno-branch-likely -DNEED_PRINTF -c -o KaiDaemon.o KaiDaemon.cc
mipsel-linux-g++ -D_REENTRANT -DPLATFORM_linux -DVERSION=\"7.0.0.7\" -DOPENWRT -DOPENWRT -g -Wall -Ipthreadcc/src -Isocketcc/src -I../../libpcap_noring -DCONFIG_FILE="\"/etc/kaid.conf\"" -Os -pipe -mips32r2 -mtune=74kc -mdspr2 -fno-caller-saves -msoft-float -mno-branch-likely -DNEED_PRINTF -c -o Kaid.o Kaid.cc
Kaid.cc: In function 'char* tstamp()':
Kaid.cc:175:9: warning: variable 'len' set but not used [-Wunused-but-set-variable]
Kaid.cc: In function 'int main(int, char**)':
Kaid.cc:249:14: error: 'geteuid' was not declared in this scope
Kaid.cc:259:21: error: 'fork' was not declared in this scope
Kaid.cc:270:23: error: 'setsid' was not declared in this scope
Kaid.cc:275:16: error: 'STDIN_FILENO' was not declared in this scope
Kaid.cc:275:28: error: 'close' was not declared in this scope
Kaid.cc:276:16: error: 'STDOUT_FILENO' was not declared in this scope
Kaid.cc:277:16: error: 'STDERR_FILENO' was not declared in this scope
make[2]: *** [Kaid.o] Error 1
make[2]: Leaving directory `/home/compiler/DEV/DD-WRT/src/router/kaid/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/compiler/DEV/DD-WRT/src/router/kaid'
make: *** [kaid] Error 2
</code>

-Fractal


Sounds like there's something wrong with the unistd.h header. Have you tried switching :

#ifndef PLATFORM_freebsd
#include <getopt.h>
#else
#include <unistd.h>
#endif

to simply

#include <unistd.h>

in the kaid.cc file ?

Also, do you confirm that mega builds does compile with the newer openSuse distro without Kaid? and do you have a debug log for your kernel panic ?
Sponsor
Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1243

PostPosted: Fri Oct 18, 2013 17:31    Post subject: Reply with quote
it looks like there is compiled modules that are not in libpcap-noring.

</code>
./../libpcap_noring/etherent.o ../../libpcap_noring/grammar.o ../../libpcap_noring/scanner.o ../../libpcap_noring/pcap-linux.o ../../libpcap_noring/fad-gifc.o pthreadcc/obj/*.o socketcc/obj/*.o -lpthread
mipsel-linux-g++: error: ../../libpcap_noring/fad-gifc.o: No such file or directory
make[2]: *** [kaid] Error 1
make[2]: Leaving directory `/home/compiler/DEV/DD-WRT/src/router/kaid/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/compiler/DEV/DD-WRT/src/router/kaid'
make: *** [kaid] Error 2
</code>
-fractal
Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1243

PostPosted: Fri Oct 18, 2013 18:10    Post subject: Reply with quote
I have commented out KAID, and it compiles just fine. however I get kernel panic when loading on E2500.

I used kernel config .config_bcmmips
and toolchain r2-linaro-4.7

here is the kernel crash:

<code>
CFE version 1.0.37 for BCM947XX (32bit,SP,LE)
Build Date: 05/30/11 16:28:42 CST (root@GavinPC.localdomain)
Copyright (C) 2000-2008 Broadcom Corporation.

Init Arena
Init Devs.
This is a Serial Flash
Boot partition size = 262144(0x40000)
Found a 8MB ST compatible serial flash
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 5.60.127.2901 @VERSION_TYPE@
CPU type 0x19749: 300MHz
Tot mem: 65536 KBytes

CFE mem: 0x80700000 - 0x807A24D0 (664784)
Data: 0x80734FF0 - 0x80739010 (16416)
BSS: 0x80739010 - 0x8073C4D0 (13504)
Heap: 0x8073C4D0 - 0x807A04D0 (409600)
Stack: 0x807A04D0 - 0x807A24D0 (8192)
Text: 0x80700000 - 0x80734FE4 (217060)

Boot version: v4.13
The boot is CFE
Nothing...
The country is same

### CLKDIV= 0x80e0842, SFlashClkDiv=8 clkdivsf=2 ###

### Change it to 0x20e0842 (2) ###
Device eth0: hwaddr 20-AA-4B-D5-6A-65, ipaddr 192.168.1.1, mask 255.255.255.0
gateway not set, nameserver not set
Header CRC: 0xF475AE86
Calculate CRC: 0xF475AE86
Image 1 is OK
Try to load image 1.
Loader:raw Filesys:tftp Dev:eth0 File:: Options:(null)
Loading: Failed.
Could not load :: Timeout occured
Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
Loading: .. 3916 bytes read
Entry at 0x80001000
Closing network.
Starting program at 0x80001000
**Exception 8: EPC=805802FC, Cause=00008008 (TLBMissRd)
RA=805803A0, VAddr=08000000

0 ($00) = 00000000 AT ($01) = 00000000
v0 ($02) = 08000000 v1 ($03) = 80580E2C
a0 ($04) = 807A1B68 a1 ($05) = 807A1B28
a2 ($06) = 80580000 a3 ($07) = 80580000
t0 ($0Cool = 807A1B68 t1 ($09) = 20100322
t2 ($10) = 30524448 t3 ($11) = 00000044
t4 ($12) = 0000006C t5 ($13) = 80764D24
t6 ($14) = 807609E7 t7 ($15) = 000002A9
s0 ($16) = 807A1B68 s1 ($17) = 807A1B68
s2 ($1Cool = 807A1B68 s3 ($19) = 00000000
s4 ($20) = 0057FE28 s5 ($21) = 0000000A
s6 ($22) = 0000002B s7 ($23) = 00000001
t8 ($24) = 8074B044 t9 ($25) = 80580624
k0 ($26) = 00000000 k1 ($27) = 8074B044
gp ($2Cool = 8073CFF0 sp ($29) = 807A1B18
fp ($30) = 80580E30 ra ($31) = 805803A0


</code>

-Fractal
Mazout360
DD-WRT Novice


Joined: 21 Apr 2013
Posts: 21

PostPosted: Fri Oct 18, 2013 23:03    Post subject: Reply with quote
Fractal wrote:
it looks like there is compiled modules that are not in libpcap-noring.

</code>
./../libpcap_noring/etherent.o ../../libpcap_noring/grammar.o ../../libpcap_noring/scanner.o ../../libpcap_noring/pcap-linux.o ../../libpcap_noring/fad-gifc.o pthreadcc/obj/*.o socketcc/obj/*.o -lpthread
mipsel-linux-g++: error: ../../libpcap_noring/fad-gifc.o: No such file or directory
make[2]: *** [kaid] Error 1
make[2]: Leaving directory `/home/compiler/DEV/DD-WRT/src/router/kaid/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/compiler/DEV/DD-WRT/src/router/kaid'
make: *** [kaid] Error 2
</code>
-fractal


I had the same issue, even though the fad-gifc.c file does gets cross compiled. Removing it from the makefile fixed the issue and kaid compiled properly...Yet, I can't get some modules to compile because it is searching for -ljanssen in LD_LIBRARY even though the libjanssen-dev is installed on my system...any idea why ?
Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1243

PostPosted: Sat Oct 19, 2013 0:23    Post subject: Reply with quote
Mazout360 wrote:
Fractal wrote:
it looks like there is compiled modules that are not in libpcap-noring.

</code>
./../libpcap_noring/etherent.o ../../libpcap_noring/grammar.o ../../libpcap_noring/scanner.o ../../libpcap_noring/pcap-linux.o ../../libpcap_noring/fad-gifc.o pthreadcc/obj/*.o socketcc/obj/*.o -lpthread
mipsel-linux-g++: error: ../../libpcap_noring/fad-gifc.o: No such file or directory
make[2]: *** [kaid] Error 1
make[2]: Leaving directory `/home/compiler/DEV/DD-WRT/src/router/kaid/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/compiler/DEV/DD-WRT/src/router/kaid'
make: *** [kaid] Error 2
</code>
-fractal


I had the same issue, even though the fad-gifc.c file does gets cross compiled. Removing it from the makefile fixed the issue and kaid compiled properly...Yet, I can't get some modules to compile because it is searching for -ljanssen in LD_LIBRARY even though the libjanssen-dev is installed on my system...any idea why ?



post your error output..
Mazout360
DD-WRT Novice


Joined: 21 Apr 2013
Posts: 21

PostPosted: Sat Oct 19, 2013 0:40    Post subject: Reply with quote
Yes sorry, I was not home when I posted my last message...here it is :
Code:

ccache mipsel-linux-uclibc-gcc -shared -I. -I/home/***/DD-WRT/src/router/shared -I../httpd -Wall -I/home/***/DD-WRT/src/ -DNDEBUG -I/home/***/DD-WRT/src/linux/universal/linux-3.10/brcm/mipsel/include -DNDEBUG -I/home/***/DD-WRT/src/linux/universal/linux-3.10/brcm/mipsel/shared/bcmwifi/include -I/home/***/DD-WRT/src/include.v24  -minterlink-mips16 -mips16  -fPIC  -DHAVE_DROPBEAR -DHAVE_SSHD -DHAVE_HOTPLUG2 -DHAVE_OPENDPI -DHAVE_SAMBA -I/home/***/DD-WRT/src/router/jansson/src -L/home/***/DD-WRT/src/router/jansson/src/.libs -ljansson -lm -DHAVE_SAMBA3 -DHAVE_SAMBA_SERVER -I/home/***/DD-WRT/src/router/jansson/src -L/home/***/DD-WRT/src/router/jansson/src/.libs -ljansson -lm -DHAVE_SNMP -DHAVE_3G -DHAVE_UQMI -DHAVE_SYSLOG -DHAVE_BCMMODERN -DHAVE_80211AC -DARCH_broadcom -DHAVE_PPPOE -DHAVE_PPPOA -DHAVE_L2TP -DHAVE_CHILLILOCAL -DHAVE_CHILLI -DHAVE_RFLOW -DHAVE_OPENVPN -DSET_BOOT_WAIT -DHAVE_HTTPS -DHAVE_HTTPS -I/home/***/DD-WRT/src/router/matrixssl -DHAVE_MATRIXSSL -DHAVE_SPUTNIK_APD -DHAVE_UPNP -DHAVE_SVQOS -DHAVE_AQOS -DHAVE_COOVA_CHILLI -DHAVE_MATRIXSSL -Os -pipe -mips32 -mtune=mips32 -fno-caller-saves  -mno-branch-likely  -L. -o libutils.so utils.o shutils.o wl_basic.o linux_timer.o wl_linux.o gpio.o md5c.o crc.o sha1.o nvparse.o bcmutils.o linux_osl.o backup.o country.o samba3.o lib3g.o  -lcrypt -L../nvram -lnvram
/home/***/DD-WRT/current-toolchains/toolchain-mipsel_r2_gcc-4.7-linaro_uClibc-0.9.33.2/bin/../lib64/gcc/mipsel-openwrt-linux-uclibc/4.7.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: skipping incompatible /home/***/DD-WRT/src/router/jansson/src/.libs/libjansson.so when searching for -ljansson
/home/***/DD-WRT/current-toolchains/toolchain-mipsel_r2_gcc-4.7-linaro_uClibc-0.9.33.2/bin/../lib64/gcc/mipsel-openwrt-linux-uclibc/4.7.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: skipping incompatible /home/***/DD-WRT/src/router/jansson/src/.libs/libjansson.a when searching for -ljansson
/home/***/DD-WRT/current-toolchains/toolchain-mipsel_r2_gcc-4.7-linaro_uClibc-0.9.33.2/bin/../lib64/gcc/mipsel-openwrt-linux-uclibc/4.7.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: skipping incompatible /home/***/DD-WRT/src/router/jansson/src/.libs/libjansson.so when searching for -ljansson
/home/***/DD-WRT/current-toolchains/toolchain-mipsel_r2_gcc-4.7-linaro_uClibc-0.9.33.2/bin/../lib64/gcc/mipsel-openwrt-linux-uclibc/4.7.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: skipping incompatible /home/***/DD-WRT/src/router/jansson/src/.libs/libjansson.a when searching for -ljansson
/home/***/DD-WRT/current-toolchains/toolchain-mipsel_r2_gcc-4.7-linaro_uClibc-0.9.33.2/bin/../lib64/gcc/mipsel-openwrt-linux-uclibc/4.7.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: cannot find -ljansson
/home/***/DD-WRT/current-toolchains/toolchain-mipsel_r2_gcc-4.7-linaro_uClibc-0.9.33.2/bin/../lib64/gcc/mipsel-openwrt-linux-uclibc/4.7.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: skipping incompatible /home/***/DD-WRT/src/router/jansson/src/.libs/libjansson.so when searching for -ljansson
/home/***/DD-WRT/current-toolchains/toolchain-mipsel_r2_gcc-4.7-linaro_uClibc-0.9.33.2/bin/../lib64/gcc/mipsel-openwrt-linux-uclibc/4.7.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: skipping incompatible /home/***/DD-WRT/src/router/jansson/src/.libs/libjansson.a when searching for -ljansson
/home/***/DD-WRT/current-toolchains/toolchain-mipsel_r2_gcc-4.7-linaro_uClibc-0.9.33.2/bin/../lib64/gcc/mipsel-openwrt-linux-uclibc/4.7.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: skipping incompatible /home/***/DD-WRT/src/router/jansson/src/.libs/libjansson.so when searching for -ljansson
/home/***/DD-WRT/current-toolchains/toolchain-mipsel_r2_gcc-4.7-linaro_uClibc-0.9.33.2/bin/../lib64/gcc/mipsel-openwrt-linux-uclibc/4.7.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: skipping incompatible /home/***/DD-WRT/src/router/jansson/src/.libs/libjansson.a when searching for -ljansson
/home/***/DD-WRT/current-toolchains/toolchain-mipsel_r2_gcc-4.7-linaro_uClibc-0.9.33.2/bin/../lib64/gcc/mipsel-openwrt-linux-uclibc/4.7.3/../../../../mipsel-openwrt-linux-uclibc/bin/ld: cannot find -ljansson
collect2: error: ld returned 1 exit status
make[1]: *** [libutils.so] Erreur 1
make[1]: quittant le répertoire « /home/***/DD-WRT/src/router/libutils »
make: *** [libutils] Erreur 2


Thanks
Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1243

PostPosted: Thu Oct 24, 2013 22:11    Post subject: Reply with quote
Have you made any forward progress on K3x ? On your libjansen problem, it sounds to me like you need to install libjansen* on ubuntu there is a few other dependencies that it may be wanting..

I have been trying to compile 3.x for standard ea devices, I asked kong, but I don't think brains layer committed the wl drivers for the 3.10 kernel so it errors during compile on wl modules.

if I compile using standard kernel it compiles fine, but from about post it kernel panics the E2500.

-Fractal
Mazout360
DD-WRT Novice


Joined: 21 Apr 2013
Posts: 21

PostPosted: Fri Oct 25, 2013 21:59    Post subject: Reply with quote
Fractal wrote:
Have you made any forward progress on K3x ? On your libjansen problem, it sounds to me like you need to install libjansen* on ubuntu there is a few other dependencies that it may be wanting..

I have been trying to compile 3.x for standard ea devices, I asked kong, but I don't think brains layer committed the wl drivers for the 3.10 kernel so it errors during compile on wl modules.

if I compile using standard kernel it compiles fine, but from about post it kernel panics the E2500.

-Fractal


No progress yet, and I already have every libjansen* dependencies installed. Though, it seems like it's searching for some precompiled jansen librairies inside the DD-WRT source code which is strange...anyways I'm installing openSUSE now and I'll see if it fixes that issue.
Isn't the 3.10 kernel already available and working with DD-WRT ? If it's not maybe you could try using the already fixed 3.9 wireless version as I don't think there are many differences there between 3.9 and 3.10. From your debug log, usually, Exception 8 is fixed by resetting NVRAM. Does DD-WRT export a kmsg in /proc/kmsg ? This would be more informative.
Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1243

PostPosted: Sun Oct 27, 2013 15:38    Post subject: Reply with quote
Yeah I found that openSuse worked right out of the box, all the necessary libs and updated binutils were there.

I have tried 3.9 and 3.10 all lead to exception 8 kernel panics... I would be interested to hear your progress.

My other observation is some of the precompiled modules seem to be compiled with a newer version of uclibc, aka the linaro 4.8 toolchain.. I am going to look into that next, and try a AC build since the modules are already there in the kernel.

-Fractal
Mazout360
DD-WRT Novice


Joined: 21 Apr 2013
Posts: 21

PostPosted: Mon Oct 28, 2013 18:34    Post subject: Reply with quote
Retried compiling with OpenSUSE...same error message with missing -ljansson when compiling K26 big build using makefile.brcm26. libjansson* packages already installed and same error happens with every toolchain tried. Any idea why ?
If I can compile this, I'll update the wiki with up-to-date info on how to compile K26 and K3.X.
Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1243

PostPosted: Mon Oct 28, 2013 23:47    Post subject: Reply with quote
Mazout360 wrote:
Retried compiling with OpenSUSE...same error message with missing -ljansson when compiling K26 big build using makefile.brcm26. libjansson* packages already installed and same error happens with every toolchain tried. Any idea why ?
If I can compile this, I'll update the wiki with up-to-date info on how to compile K26 and K3.X.


I am running opensuse 12.3 64bit and can compile K26, and K3x however there is problems which need fixed on both.

I have up to date latest of all libs.
I am using the r2 version 4.7- linero toolchain

you need to use version 4.5- linero to compile K26, that is not labeled 4.5 but is in toolchian dir, is the only one not labeled.. I will check when I get home.

I have all these packages installed.
__________________________________________________

Code:
sudo zypper install gcc g++ binutils patch bzip2 flex bison make gettext unzip zlib1g-dev libc6 automake automake1.7 au
tomake1.9 openssl subversion libncurses5-dev
sudo zypper install ia32-libs #32bit libs so some precompiled tools will work
sudo zypper install libstdc++5 #old version that some OS's might need?
sudo zypper install dia
sudo zypper install git-core libc6-dev libc6-i386 libusbmuxd-dev libjansson gengetopt
sudo zypper install texinfo libreadline-gplv2-dev xsltproc docbook-xsl
sudo zypper install libtool doxygen
sudo zypper install autopoint rpm cbs2cl libbluetooth-dev gettext
sudo zypper install ccache cmake
sudo zypper install gperf libexplain-dev libdigest-sha-perl ntfsprogs
sudo zypper install libcurl4-openssl-dev libiconv-hook1 libiconv-ruby libpcap-dev
sudo zypper install libcrypt-openssl*
sudo zypper install texlive flip doxygen automake* aclocal*
sudo zypper install cvs uuid
sudo zypper install gawk


Maybe one of those is what you are missing,

Let me know

-Fractal
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4344
Location: Germany

PostPosted: Tue Oct 29, 2013 14:14    Post subject: Reply with quote
You never link against libs that come with the distro, that does not work and you will get errors anyways, since a distro is usually x_86_64 or X86 and the target is mipsel, arm etc., thus you would mix different architecture and probably different versions and the linker would tell you.

If it says it can't link against ljansson, then you did not configure/compile jansson in dd-wrt tree before trying to build a full fw:-)

_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
Mazout360
DD-WRT Novice


Joined: 21 Apr 2013
Posts: 21

PostPosted: Tue Oct 29, 2013 15:15    Post subject: Reply with quote
Thanks for your continued help!
I tried installing the packages, but most of them are already included in the distro or unavailable, and I kept having the same error message. I am using the 4.5 linaro toolchain with uClibc 0.9.32 for K26. Tried K3.X and same error too.

<Kong> wrote:
You never link against libs that come with the distro, that does not work and you will get errors anyways, since a distro is usually x_86_64 or X86 and the target is mipsel, arm etc., thus you would mix different architecture and probably different versions and the linker would tell you.

If it says it can't link against ljansson, then you did not configure/compile jansson in dd-wrt tree before trying to build a full fw:-)


I thought about this too...already tried the usual "./configure" "sudo make" "sudo make install" in the jansson folder and it did compile fine. Though, I still get the "skipping incompatible ..... .libs/libjansson.a when searching for -ljansson" error. Not quite sure if it's a misconfiguration within the jansson package or a toolchain issue. If I can't get this to compile, I guess I'll just skip this package and compile everything else.
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4344
Location: Germany

PostPosted: Tue Oct 29, 2013 16:14    Post subject: Reply with quote
Mazout360 wrote:
Thanks for your continued help!
I tried installing the packages, but most of them are already included in the distro or unavailable, and I kept having the same error message. I am using the 4.5 linaro toolchain with uClibc 0.9.32 for K26. Tried K3.X and same error too.

<Kong> wrote:
You never link against libs that come with the distro, that does not work and you will get errors anyways, since a distro is usually x_86_64 or X86 and the target is mipsel, arm etc., thus you would mix different architecture and probably different versions and the linker would tell you.

If it says it can't link against ljansson, then you did not configure/compile jansson in dd-wrt tree before trying to build a full fw:-)


I thought about this too...already tried the usual "./configure" "sudo make" "sudo make install" in the jansson folder and it did compile fine. Though, I still get the "skipping incompatible ..... .libs/libjansson.a when searching for -ljansson" error. Not quite sure if it's a misconfiguration within the jansson package or a toolchain issue. If I can't get this to compile, I guess I'll just skip this package and compile everything else.


skipping incompatible-> that's what I told you, you are mixing host with target libs and try to link against a lib that you compiled for opensuse not for your target.

_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1243

PostPosted: Wed Oct 30, 2013 15:28    Post subject: Reply with quote
kong,

any news on the the k26 kernel panic with 4.5 linero toolchain... I did update the ticket with kernel debugging enabled and posted the output.

-Fractal
Goto page Previous  1, 2, 3 ... 22, 23, 24, 25  Next Display posts from previous:    Page 23 of 25
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Generic Questions All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum