R7000+VPN+dd-wrt kongmod = problem

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> ARM or PPC based Hardware
Author Message
nxxo
DD-WRT Novice


Joined: 02 Feb 2014
Posts: 7

PostPosted: Sun Feb 02, 2014 19:31    Post subject: R7000+VPN+dd-wrt kongmod = problem Reply with quote
Hi guy first thx you watch my thread and sorry for my english i know im not very good Smile

i have a problem with my r7000 dd-wrt of Kong to set-up my vpn with ipvanish

i have communicate with ipvanish but this guy is not very good for this problem, my problem is i cant connect to my vpn server i have always a error message of TLS error i put the sys log here, itake the set-up guide here to the configuration of my vpn http://www.ipvanish.com/visualguides/OpenVPN/DD-WRT/

i have always this error message in the status openvpn

Server: : Local Address: Remote Address: Client: RECONNECTING: tls-error Local Address: Remote Address:

Serverlog Clientlog 19700101 00:00:32 I TCP/UDP: Preserving recently used remote address: [AF_INET]81.171.81.3:443
19700101 00:00:32 I Attempting to establish TCP connection with [AF_INET]81.171.81.3:443 [nonblock]
19700101 00:00:33 I TCP connection established with [AF_INET]81.171.81.3:443
19700101 00:00:33 I TCPv4_CLIENT link local: [undef]
19700101 00:00:33 I TCPv4_CLIENT link remote: [AF_INET]81.171.81.3:443
19700101 00:00:33 N TLS_ERROR: BIO read tls_read_plaintext error: error:140830B5:lib(20):func(131):reason(181)
19700101 00:00:33 N TLS Error: TLS object -> incoming plaintext read error
19700101 00:00:33 N TLS Error: TLS handshake failed
19700101 00:00:33 N Fatal TLS error (check_tls_errors_co) restarting
19700101 00:00:33 I SIGUSR1[soft tls-error] received process restarting
19700101 00:00:33 Restart pause 5 second(s)
20140202 14:27:59 W NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
20140202 14:27:59 Socket Buffers: R=[87380->131072] S=[16384->131072]
20140202 14:27:59 I TCP/UDP: Preserving recently used remote address: [AF_INET]81.171.81.3:443
20140202 14:27:59 I Attempting to establish TCP connection with [AF_INET]81.171.81.3:443 [nonblock]
20140202 14:28:00 I TCP connection established with [AF_INET]81.171.81.3:443
20140202 14:28:00 I TCPv4_CLIENT link local: [undef]
20140202 14:28:00 I TCPv4_CLIENT link remote: [AF_INET]81.171.81.3:443
20140202 14:28:00 N TLS_ERROR: BIO read tls_read_plaintext error: error:140830B5:lib(20):func(131):reason(181)
20140202 14:28:00 N TLS Error: TLS object -> incoming plaintext read error
20140202 14:28:00 N TLS Error: TLS handshake failed
20140202 14:28:00 N Fatal TLS error (check_tls_errors_co) restarting
20140202 14:28:00 I SIGUSR1[soft tls-error] received process restarting
20140202 14:28:00 Restart pause 5 second(s)
20140202 14:28:05 W NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
20140202 14:28:05 Socket Buffers: R=[87380->131072] S=[16384->131072]
20140202 14:28:05 I TCP/UDP: Preserving recently used remote address: [AF_INET]81.171.81.3:443
20140202 14:28:05 I Attempting to establish TCP connection with [AF_INET]81.171.81.3:443 [nonblock]
20140202 14:28:06 I TCP connection established with [AF_INET]81.171.81.3:443
20140202 14:28:06 I TCPv4_CLIENT link local: [undef]
20140202 14:28:06 I TCPv4_CLIENT link remote: [AF_INET]81.171.81.3:443
20140202 14:28:06 N TLS_ERROR: BIO read tls_read_plaintext error: error:140830B5:lib(20):func(131):reason(181)
20140202 14:28:06 N TLS Error: TLS object -> incoming plaintext read error
20140202 14:28:06 N TLS Error: TLS handshake failed
20140202 14:28:06 N Fatal TLS error (check_tls_errors_co) restarting
20140202 14:28:06 I SIGUSR1[soft tls-error] received process restarting
20140202 14:28:06 Restart pause 5 second(s)
20140202 14:28:11 W NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
20140202 14:28:11 Socket Buffers: R=[87380->131072] S=[16384->131072]
20140202 14:28:11 I TCP/UDP: Preserving recently used remote address: [AF_INET]81.171.81.3:443
20140202 14:28:11 I Attempting to establish TCP connection with [AF_INET]81.171.81.3:443 [nonblock]
20140202 14:28:12 I TCP connection established with [AF_INET]81.171.81.3:443
20140202 14:28:12 I TCPv4_CLIENT link local: [undef]
20140202 14:28:12 I TCPv4_CLIENT link remote: [AF_INET]81.171.81.3:443
20140202 14:28:12 N TLS_ERROR: BIO read tls_read_plaintext error: error:140830B5:lib(20):func(131):reason(181)
20140202 14:28:12 N TLS Error: TLS object -> incoming plaintext read error
20140202 14:28:12 N TLS Error: TLS handshake failed
20140202 14:28:12 N Fatal TLS error (check_tls_errors_co) restarting
20140202 14:28:12 I SIGUSR1[soft tls-error] received process restarting
20140202 14:28:12 Restart pause 5 second(s)
20140202 14:28:17 W NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
20140202 14:28:17 Socket Buffers: R=[87380->131072] S=[16384->131072]
20140202 14:28:17 I TCP/UDP: Preserving recently used remote address: [AF_INET]81.171.81.3:443
20140202 14:28:17 I Attempting to establish TCP connection with [AF_INET]81.171.81.3:443 [nonblock]
20140202 14:28:18 I TCP connection established with [AF_INET]81.171.81.3:443
20140202 14:28:18 I TCPv4_CLIENT link local: [undef]
20140202 14:28:18 I TCPv4_CLIENT link remote: [AF_INET]81.171.81.3:443
20140202 14:28:18 N TLS_ERROR: BIO read tls_read_plaintext error: error:140830B5:lib(20):func(131):reason(181)
20140202 14:28:18 N TLS Error: TLS object -> incoming plaintext read error
20140202 14:28:18 N TLS Error: TLS handshake failed
20140202 14:28:18 N Fatal TLS error (check_tls_errors_co) restarting
20140202 14:28:18 I SIGUSR1[soft tls-error] received process restarting
20140202 14:28:18 Restart pause 5 second(s)
20140202 14:28:23 W NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
20140202 14:28:23 Socket Buffers: R=[87380->131072] S=[16384->131072]
20140202 14:28:23 I TCP/UDP: Preserving recently used remote address: [AF_INET]81.171.81.3:443
20140202 14:28:23 I Attempting to establish TCP connection with [AF_INET]81.171.81.3:443 [nonblock]
20140202 14:28:24 I TCP connection established with [AF_INET]81.171.81.3:443
20140202 14:28:24 I TCPv4_CLIENT link local: [undef]
20140202 14:28:24 I TCPv4_CLIENT link remote: [AF_INET]81.171.81.3:443
20140202 14:28:24 N TLS_ERROR: BIO read tls_read_plaintext error: error:140830B5:lib(20):func(131):reason(181)
20140202 14:28:24 N TLS Error: TLS object -> incoming plaintext read error
20140202 14:28:24 N TLS Error: TLS handshake failed
20140202 14:28:24 N Fatal TLS error (check_tls_errors_co) restarting
20140202 14:28:24 I SIGUSR1[soft tls-error] received process restarting
20140202 14:28:24 Restart pause 5 second(s)
20140202 14:28:29 W NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
20140202 14:28:29 Socket Buffers: R=[87380->131072] S=[16384->131072]
20140202 14:28:29 I TCP/UDP: Preserving recently used remote address: [AF_INET]81.171.81.3:443
20140202 14:28:29 I Attempting to establish TCP connection with [AF_INET]81.171.81.3:443 [nonblock]
20140202 14:28:30 I TCP connection established with [AF_INET]81.171.81.3:443
20140202 14:28:30 I TCPv4_CLIENT link local: [undef]
20140202 14:28:30 I TCPv4_CLIENT link remote: [AF_INET]81.171.81.3:443
20140202 14:28:30 N TLS_ERROR: BIO read tls_read_plaintext error: error:140830B5:lib(20):func(131):reason(181)
20140202 14:28:30 N TLS Error: TLS object -> incoming plaintext read error
20140202 14:28:30 N TLS Error: TLS handshake failed
20140202 14:28:30 N Fatal TLS error (check_tls_errors_co) restarting
20140202 14:28:30 I SIGUSR1[soft tls-error] received process restarting
20140202 14:28:30 Restart pause 5 second(s)
20140202 14:28:32 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:16
20140202 14:28:32 D MANAGEMENT: CMD 'state'
20140202 14:28:32 MANAGEMENT: Client disconnected
20140202 14:28:32 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:16
20140202 14:28:32 D MANAGEMENT: CMD 'state'
20140202 14:28:32 MANAGEMENT: Client disconnected
20140202 14:28:32 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:16
20140202 14:28:32 D MANAGEMENT: CMD 'state'
20140202 14:28:32 MANAGEMENT: Client disconnected
20140202 14:28:32 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:16
20140202 14:28:32 D MANAGEMENT: CMD 'log 500'
19700101 00:00:00




i think the problem come of the firmware i dont understand that Sad


thx you so much for your help
Sponsor
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17638
Location: Hesse/Germany

PostPosted: Mon Feb 03, 2014 16:17    Post subject: Reply with quote
this is a date problem. set a correct timeserver
_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
nxxo
DD-WRT Novice


Joined: 02 Feb 2014
Posts: 7

PostPosted: Mon Feb 03, 2014 16:22    Post subject: Reply with quote
bingo thx you men
RossGould
DD-WRT Novice


Joined: 31 May 2014
Posts: 1

PostPosted: Sat May 31, 2014 15:57    Post subject: Same problem Reply with quote
I am experiencing a very similar issue though after setting the correct time server it doesn't have any effect. Please help?
retribution
DD-WRT Novice


Joined: 13 Sep 2014
Posts: 3

PostPosted: Sat Sep 13, 2014 2:19    Post subject: Reply with quote
Sash wrote:
this is a date problem. set a correct timeserver


how do you know the correct timeserver? i have mine set to my timezone and still getting error like the above post
DzLbGtMfk3
DD-WRT Novice


Joined: 09 Nov 2014
Posts: 1

PostPosted: Sun Nov 09, 2014 15:03    Post subject: Time error Reply with quote
Hello,
I am receiving the same error and have been playing with the timeserver settings and setting the date via Putty.
What I noticed is that the date seems to be fine when comparing the clock of my pc to the router (both are set to use the same timeserver) however when I do a 'cat /var/log/messages' the time shown in the log is one hour behind.

OpenVPN connection from my pc to ipvanish works fine.
I've been playing with the TLS Cipher settings (as suggested in other posts), but this simply produces different errors.
In the end when all is set as described on the IPVanish site the same error as the start of this post is displayed so I am back to the timesettings issue.

Thusfar I am not getting a successful connection so I can realy use some help.

I've added some screenshots to show my config.
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 1375
Location: Canada

PostPosted: Thu Nov 20, 2014 17:11    Post subject: Reply with quote
I'm using IPVanish and also had connection issues.

Change TLS Cipher to TLS-DHE-RSA-WITH-AES-128-CBC-SHA and all is well.

_________________
Home Network on Telus PureFibre - Wired GigaBit Backbone
| 2x DNSCrypt-Proxy V2 | DHCPv4/v6 via DNSMasq | Telus-IPv6 |
| USB Storage - Scripts Only | 7x VLANs/BRs | WiFi 5x SSIDs |
| 3x OpenVPN-Clients | QoS | SSH | Entware | YAMon3 | Ad-Blocking |

R7800 Gateway & VPN1 - KONGAT 39855M Release 2019-05-25
R7800 WiFi & VPN2 & VPN3 - KONGAT 39855M Release 2019-05-25

______________________
YAMon 3.4 | Ad-Blocking for DD-WRT | DNSCrypt-Proxy V2
DD-WRT Beta Builds | KONG Builds
CloneVince's copies of Kong's Arm Firmware
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> ARM or PPC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum