TP-link WR841ND WAP mode

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
Phunkie
DD-WRT Novice


Joined: 01 Mar 2018
Posts: 1

PostPosted: Thu Mar 01, 2018 14:15    Post subject: TP-link WR841ND WAP mode Reply with quote
Hi, I’ll try to keep it short. I have one main router that is provided by the ISP and one DDWRT router.
Situation right now:
Main router. Some devices (phones, tablet, NAS, TV box, DDWRT router etc) connected on this router. IP range 192.168.0.x
DDWRT router connected wired to the main router and set as a regular router with DHCP enabled. IP range 192.168.1.x. On this range I have my main computer connected with wire.

Situation I would like:
Same as above but everything in one subnet.

I believe I need to configure DDWRT in WAP mode so I followed this guide:
https://www.dd-wrt.com/wiki/index.php/Wireless_Access_Point#How_To_Use_DHCP_to_Set_the_WAP.27s_IP_Address

The result is strange behavior but essentially nothing works really. No internet no LAN. I’ve done it several times now and sometimes it works for a while, sometimes it works until I reboot my computer. For example yesterday evening everything was working but when I booted my computer this morning it started going bad again. And when it worked, the main router even shows all devices configured properly with the correct IP’s.

I tried 2 different variations because they are not very clear to me:

1. "Local IP Address: 192.168.1.2 (i.e. different from primary router and out of primary router's DHCP pool)"
This guide says the static IP should not be in the main router’s DHCP pool. Does it mean it should be in the same subnet but not an IP the main router COULD assign? Or does it mean it should not even be in the same subnet?
Some posts/texts say it should be in the same subnet and also should be an IP from the dhcp pool, that it just needs one that is not assigned yet. Which one is it? Right now I configured mine 192.168.0.2, which is a free IP in my main router’s LAN. But it’s not working.
I also tried 192.168.1.2 (other subnet) but that didn’t work either.

2. Use WAN port or not for the wired connection to the main router. (WAN disabled in DDWRT as suggested in guide)
Tried both and for example yesterday my last attempt was using the WAN port which worked for the rest of the evening but this morning when booting my computer nothing worked anymore.
Also using the LAN port (right now for example) it’s not working.

I should mention that when I say it's not working, really nothing works anymore. Even the main router has problems.

I’m at work right now and cannot post screenshots of my configuration, will do this evening if necessary, all though I’m probably going to reset it again cause it’s not working. But perhaps someone could clarify the 2 points and maybe give some ideas? Maybe tell me if it should be working or not under these circumstances?

Sorry for long post
Sponsor
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2135
Location: Canada

PostPosted: Thu Mar 01, 2018 23:26    Post subject: Answers Reply with quote
1. If you are assigning a static IP to the dd-wrt router, make sure it is in the same subnet as the ISP router (192.168.0.X). You need to make sure that the ISP router is only handing out so many addresses, somewhere less than 255. Some routers only, like dd-wrt start assigning DHCP addresses at *.100 for 50 addresses, others are different. Check your ISP router's DHCP settings.

In dd-wrt set your local IP to 192.168.0.X (where X is outside the DHCP range). Subnet mask 255.255.255.0. Gateway and local DNS should be set to 192.168.0.1. Disable DHCP on the dd-wrt router.

2. If the connection is set to disabled at the top of the setup page, click save or apply. Then look for a Assign WAN port to Switch tickbox, check it, click Apply. Now it does not matter what port you have it in. The WAN port will act just like any other LAN port. I plug my WAP in the WAN port still because then it is easier to trace the LAN cords back to the ISP modem/router.

_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Atheros:
Netgear R7800 - gateway, DHCP, QoS, VPN
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
UBNT loco M2 x2 - airOS

Broadcom
Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - not used
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum