How To: Unbrick Netgear WNR2000v2 easily without serial/JTAG

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3, 4  Next
Author Message
DD-WRT Novice

Joined: 18 Oct 2010
Posts: 3

PostPosted: Mon Oct 18, 2010 11:29    Post subject: How To: Unbrick Netgear WNR2000v2 easily without serial/JTAG Reply with quote
First of all I'd like to thank kosskossy from this forum who inspired the idea on my router:

Here's the story. I wanted to put Tomato firmware on my Netgear WNR2000 v2 router. I read on some forums that you need to put DD-WRT on first. I first flashed it with DD-WRT and it froze. After doing the 30/30/30 reset a dozen times the router finally kicked on. Once I was in the DD-WRT control panel I proceeded to upload the Tomato firmware. After I got the message "Flash successful" my router was BRICKED.

I didn't want to bother with a serial cable so I looked for an alternative solution. When I tried to ping the router, I would get 3 lines of a response after power on and then no response.

Here's what I did:
Download the tftp2 client (Google it)
Download the official Netgear firmware for the router.
Disconnect all wires from the router except for power and one LAN cable that connects to your computer.

Setup your computer's network adapter IPv4 settings to:
IP Address of
Subnet to
Gatway to

Open up a command prompt window and ping your router using this line:
ping -t
I only got a response for 3 lines after I powered the router on. After 2 seconds the ping went back to failing

Setup tftp2:
In the server box put
File: Browse for the Netgear firmware file

Now: Unplug the power and crack open your router (remove 2 screws on bottom and slide the cover off)
Find the two pins marked with red arrows on the picture.

Use a screwdriver and jump those 2 pins.
Power on the router (while holding the screwdriver in place). Originally my router had a solid amber power light after booting.
After around 10 seconds the power light should start to flash green. Wait another 15 seconds and you should get a ping response on your computer.

Keep the pins shorted and click the UPGRADE button on tftp2. Your router should flash successfully. Remove the screwdriver from the jumped pins. After a few minuites the power light should flash orange and you should be back in business.

I'm writing this at 4 AM so my mind isn't in tip top tutorial writing shape. If I wrote anything on here that doesn't make sense or that is wrong let me know.

That connector may be the key to easily unbricking a lot of Netgear routers. The router in the link above had a chip on that 16 pin spot. Either way, that 16 pin square was also located next to the Broadcom chip. The pins that worked for me were pins 9&10. Kosskossy used pins 15&16. For me, pins 7&8 and 15&16 caused the router to blink green but they did not give a ping response. If you have a different model, check what pair of pins works for you.

Hope this helps somebody!!

Netgear WNR20002 inside board
 Filesize:  295.61 KB
 Viewed:  111710 Time(s)


DD-WRT Novice

Joined: 03 Oct 2010
Posts: 3

PostPosted: Thu Nov 04, 2010 3:42    Post subject: IT WORKS !!! Reply with quote


Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very Very THANX !!!

UNBRICKED MY WNR2000v2 !!! ;-)

Just 1 thing was different from the tutorial: First I needed to turn on the router and then, quickly short it ! The power led was GREEN blinking, removed the short and uploaded the firmware and DONE !!! Working perfectly !!! :D

Thanx !!! Wink
DD-WRT Novice

Joined: 09 Jan 2011
Posts: 2

PostPosted: Sun Jan 09, 2011 22:46    Post subject: Worked to perfection Reply with quote
Just created an account to say Thanks, the procedure worked great. If your still interested in tomato compatible with wnr2000v2 there is victek's new version which allows bandwidth shaping. heres a the link :[/url]

First install dd-wrt, factory restart, then aply tomato raf Victek mod
DD-WRT Novice

Joined: 27 Nov 2010
Posts: 20

PostPosted: Sat Apr 02, 2011 21:57    Post subject: Reply with quote
Your sir are a god among men.
DD-WRT Novice

Joined: 10 Jun 2006
Posts: 13
Location: Syracuse Utah

PostPosted: Thu May 19, 2011 0:00    Post subject: Reply with quote
Rock and Roll! Thanks for this post... saved my WNR2000v2 from a screwed up firmware update... my fault. I thought I was screwed. Tired everything, even made up a serial cable etc...


Matthew George
DD-WRT Novice

Joined: 07 Aug 2011
Posts: 1

PostPosted: Sun Aug 07, 2011 10:34    Post subject: Reply with quote
I tried to use some beta firmware of tomato and got a brick, totally my fault.
It would not respond to anything so i tried your guide that didnt work either as you wrote it.
But after trying to connect and realese the 2 dots and power off and on several times it finally got some blinking lights and could be reached with tftp and flashed back to work!

So if it does not work then play around with connectin those 2 solders and turn it off and on then it might work for you to.

Thanks alot!
DD-WRT Novice

Joined: 14 Aug 2011
Posts: 5

PostPosted: Sun Aug 14, 2011 7:47    Post subject: Reply with quote
Just bricked mine Sad i tried this and it didnt work. Could it be that i used a precision screw driver? My brick sounds different than yous guyses. all my lights are on and i dont get ANY ping response whatsoever. The power light is amber and green. When I hit the reset button the power light goes green while the others are still on.
DD-WRT Novice

Joined: 28 Jun 2009
Posts: 40

PostPosted: Sun Aug 28, 2011 15:55    Post subject: Reply with quote
Just wanted to post a thanks to the Quasi635 and montz for the procedure. Montz's modification is essential - powering on with the pins shorted made the router even less functional than bricked. I'll just add that you want to short those pins just after the front lights change following power-on. Once the green light flashes, you can remove the screwdriver.

Now to figure out whether any recent build of K2.6 will not brick this router. The one that bricked mine was dd-wrt.v24-17084_NEWD-2_K2.6_std_nokaid_small.bin. I had previously flashed dd-wrt.v24-15943_NEWD-2_K2.6_openvpn_small.bin with success, which is slightly smaller, so maybe the one that bricked it was just too big.
DD-WRT Novice

Joined: 14 Aug 2011
Posts: 5

PostPosted: Fri Sep 09, 2011 5:43    Post subject: Reply with quote
Im back on this. I need to unbrick this router somehow. All my lights are on except the wireless and internet lights. no flashing. and the power light is both amber and green. I even tried shorting all the pins with a precision screwdriver 2 at a time.
DD-WRT Novice

Joined: 28 Jun 2009
Posts: 40

PostPosted: Fri Sep 09, 2011 6:18    Post subject: Reply with quote
You only need to short the 2 pins shown with red arrows in the picture above. Shorting every possible combination of pins when the correct pins are already known is a waste of time and could potentially damage something.

Timing is important. When power is applied, the power light is dim amber and the 4 switch lights are on. About 1/2 second later the power light goes to bright amber and the remaining lights come on briefly. You want to short the pins when that light change happens. If you short too soon, no lights will change and nothing will happen. Done properly, the power light will flash green and pings will be returned continuously.
DD-WRT Novice

Joined: 14 Aug 2011
Posts: 5

PostPosted: Fri Sep 09, 2011 7:13    Post subject: Reply with quote
but my power light isnt solid amber or dim when i first power on. i power it on and the power is both green and amber. if i hit the factory reset button on the back it goes full amber. when released, it returns to half amber half green.
DD-WRT Novice

Joined: 28 Jun 2009
Posts: 40

PostPosted: Fri Sep 09, 2011 7:50    Post subject: Reply with quote
When mine was bricked, I didn't get the green/amber power light until a few seconds after powering on.

If the power light starts out at green/amber and never changes, you're not going to fix it with this topic's method, nor likely any other method.

Another test would be to connect both computer and router LAN ports to an isolated switch, set the computer's IP to and then do a

ping -t -w 30 (assuming Windows)

as the router is powered up. There should be 1-3 ping responses from the router. No ping responses would confirm the router is worse than bricked.
DD-WRT Novice

Joined: 15 Nov 2011
Posts: 2

PostPosted: Wed Nov 16, 2011 0:56    Post subject: Reply with quote
I think this is great. It would be even better if it worked for me. I seem to have an odd variation. I flashed 15962 K26 to my WNR2000v2 and everything seemed to be fine. Odd thing is that #1 and #2 are amber all the time and #3 and #4 are green all the time. (I know that the OEM docs say that an amber # means 10Mbps and green means 100Mbps, but computer says that they're all at 100Mbps.) I've also switched the wires that I have plugged into the router and get the same thing. 1,2,amger; 3,4,green. I thought that was odd, so I figured I'd re-flash with OEM then start over, just for the experience. There-in lies the problem. Attempted to flash the firmware and after 5 seconds, got a blank screen with the message "Upgrade failed." Nothing seems to have changed. Yes, I verified that the .chk file was the one from Netgear. Router still works like before, but the flash just didn't work. So... I perused the forum and found this thread. Tried the screwdriver jumper with tftp2.exe to revert to the OEM firmware and the little app SAID IT WAS SUCCESSFUL. Figured I was good to go. Did a 30/30/30 reset and . . . . still has the 15962 firmware!! Now I'm really stumped. Tried to flash the 14929 firmware and still got "Upgrade failed." I guess I don't NEED to update the firmware at this point, but when the time comes, I think I'm screwed - unless someone has any another ideas?
Much grass,
DD-WRT Novice

Joined: 28 Jun 2009
Posts: 40

PostPosted: Wed Nov 16, 2011 1:54    Post subject: Reply with quote
Since I know that EKO's 15943 works, try one of the mini builds of that from the GUI, with "reset to default settings" selected.

If no dice, try one of the .chk builds for this router at pins-shorted boot-up with tftp. You could try the actual Netgear firmware and/or a DD-WRT .chk build.

If nothing above causes a change to the status quo, your hardware is probably damaged/broken in some way. It was already suspect for the odd switch port LED colors... and then you've confirmed it.
DD-WRT Novice

Joined: 15 Nov 2011
Posts: 2

PostPosted: Wed Nov 16, 2011 18:41    Post subject: Reply with quote

Initial problem: Upgraded OEM firmware of WNR2000v2 to K26 bld 15962, but #1 and #2 were always amber while #3 and #4 were always green (regardless of what devices I had plugged into them). Thought that was odd, so wanted to change firmware and see if another build made them all green. Then found that firmware upgrade always gave me "Upgrade failed" after just 5 seconds. Freaked me out so came to the forum to see how I could fix the firmware flash problem. Bottom line is that the fix below resolved the firmware flash issue, but not the amber #1 and #2. Have decided that is par for the course for my router.

So here's what worked for me. The first 8 steps are compiled from above, and the rest are what I discovered worked for me:
1) Disabled wireless
2) Set network IP to, subnet, gateway
3) Remove bottom cover (when reading words on back of router)
4) Connect LAN wire to computer, plug in power cord, turn router on
5) After it boots up, hold in Reset button for 30 seconds
6) Open tftp2.exe; enter, <router_password>, navigate to location of desired .chk firmware file and select it. DO NOT hit Upgrade yet.
7) Power off the router, then ready your screwdriver
8 ) Bring the tftp.exe popup up so you are ready to click, but DO NOT do it yet.
9) Follow the instructions by 'carlh' from his paragraph that starts "Timing is important" and power on the router.
10) Jump the points with your screwdriver at the right time with one hand and hold it there.
NOTE: I found that it can be difficult to bridge the points of solder on top and hold the screwdriver in place for the duration of the upgrade (about 20 seconds), so what I did was touch the green circuit board between the points of solder with the screwdriver, then at the right time, turn the screwdriver so that it contacts both points of solder.
11) After the router has booted up, and still holding the screwdriver in place, click Upgrade on the tftp2 popup. After the blue bar goes across and it says that the upgrade was successful, remove the screwdriver. The power light will blink amber, then solid amber, then blink green. This green blinking will continue indefinitely.
- Here's what made the difference for me:
12) After 30 seconds of green light blinking, I RE-RAN the SAME tftp2 process - without doing anything else! (no screwdriver jump, no reset first, nothing)
13) After that second time, the router restarted normally and finished with solid green power, blue wi-fi, lit LAN number.
14) At this point, I did a 30/30/30 hard reset.

THAT DID IT!! New flash was successfully applied! After the router rebooted, I logged in and saw that the firmware I changed to was the one listed. NICE!

I don't know if I will be able to use the DD-WRT firmware Upgrade interface in the future, but now I know what to do if the Upgrade doesn't work with this 15943 build. (The 15962 build kept giving me "Upgrade failed")

Thanks, DD-WRT Community!! Quasi635 and Carlh especially!!!
Goto page 1, 2, 3, 4  Next Display posts from previous:    Page 1 of 4
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum