E4200, 18777, issues with DHCP after router restart?

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
DD-WRT Novice

Joined: 03 Aug 2012
Posts: 16

PostPosted: Fri Aug 03, 2012 20:34    Post subject: E4200, 18777, issues with DHCP after router restart? Reply with quote
Hi guys,

I'm new here. I purchased the E4200 a few days back because of the potential it has but I have noticed that the router is kind of jacked up on crank compared to my old DIR-615, at least with the current build that I'm running. The E4200's signal is going yo-yo compared to the DIR-615's more stable signal.

I've understood that the E4200 still have some performance issues. I cannot get more than 7-9MB/s out of it on 802.11n 5GHz WIFI but that's another issue which progress I will follow here on the forum for a while.

So the issue I'm having is this. Every time I reboot the router (which I have been doing a lot to try to find the best WIFI settings) my ReadyNAS defaults to where as my LAN is set to This obviously creates a PITA for me as I have to go to the NAS and plug the ethernet cable and hook it up to eth1 and then back to eth0 in order for it to get its static DHCP address again.

I've tried to search for the problem in the forums and at Google but nothing gives me the immediate attention so I have tried a 30/30/30 without luck.

I'm using 'dd-wrt.v24-18777_NEWD-2_K2.6_mega-nv60k.bin', I got about 11 hosts with pre-defined IP's, default DHCP Server settings and I have now tried to disable DNSMasq as an attempt to see if it helped.

Without knowing why it seems as if my NAS grabs a lease before the router have loaded my subnet settings.

Any idea's to why this happens?

Update 1

I thought this could be useful.

xxxxxxxxxxxxx:~# cat /tmp/dnsmasq.leases
0 uu:vv:ww:xx:yy:zz NAS uu:vv:ww:xx:yy:zz

xxxxxxxxxxxxx:~# cat /tmp/dnsmasq.conf

After a reboot my NAS just disappears from the dnsmasq.leases. Confused

Update 2

I had to do a workaround as I could not find the issue. I configured my NAS with a static IP instead.

Update 3

This even happened on another site that I admin. After a router reboot the on site NAS got IP instead of its DHCP reserved IP.

I have worked around the problem by assigning static IP's to the NAS boxes.

Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum