WRT160N V3 Bricked

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3
Author Message
muiz
DD-WRT Novice


Joined: 27 Jan 2011
Posts: 3

PostPosted: Mon Aug 05, 2013 8:28    Post subject: Reply with quote
t2mg wrote:
I had to register and drop by to let you guys know exactly how to fix this. I just successfully unbricked my router by:

Manually assigning my ethernet adapter a
IP 192.168.1.x address,
255.255.255.0 subnet,
192.168.1.1 gateway

unplugging the router, holding the reset button in and powering it up, DO NOT RELEASE, visit http://192.168.1.1/ or http://192.168.1.1/f2.htm [don't think it matters] and upload your file, the router will now automatically reboot, NOW release the reset button as it comes back up, configure your router the way you want it and enjoy!

I intentionally bricked it 2 more times (power light turns off and stays off) and I can confirm this works for me every time.
(Please edit my post as needed for clarity, readability, sentence structure and grammar)

Whow after many attempts to unbrick and reading and soldering cables.... finaly i came to this post. it worked perfectly !!! thank you !! My WRT320 (E2000) back to life.
Sponsor
Fstrat90
DD-WRT Novice


Joined: 15 Jun 2014
Posts: 2

PostPosted: Sun Jun 15, 2014 1:28    Post subject: wrt160n v3 bricked Reply with quote
So I have been searching through these forums trying to find a solution to flashing the wrong firmware. As I have seen before there was a poster who mentioned holding down the reset for 30 seconds, disconnecting power and plugging in again while holding the reset until the power light returned. This did not work at first. However, when searching cisco's help for linksys routers that have been bricked, they suggested using the tftp utility which didn't work either. I used cmd to ping the router and of course, nothing. host unreachable yada yada. Decided to use the ping test as a monitor. Opened the browser to 192.168.1.1 which of course showed unable to display. This time I had the power plugged in, held down the reset making sure to keep it down through power cycling. Waited 60 seconds, not 30. Once the lights returned all on and the power and ethernet port one remained I continued holding the reset button. Waited, suddenly the ping in the command window was talking. All while refreshing the browser, it took a few tries and the restore screen appeared. I learned the hard way, do not release the reset. Hopefully you have a working firmware bin. Continue to hold the reset throughout the firmware upgrade and past the "reset" and "continue". It was like watching a heart monitor blip after flat lining. You are welcome if this works for you.
purefusion
DD-WRT Novice


Joined: 09 Oct 2014
Posts: 1

PostPosted: Thu Oct 09, 2014 16:28    Post subject: Bricked WRT160N V3, Unable to Access Router in Recovery Mode Reply with quote
Sadly, this trick did NOT work for me, neither lijianch's method, nor Fstrat90's.

I'm not new to flashing routers with alternate firmware. I've flashed Tomato and DD-WRT to ASUS routers with no issues. Nevertheless, here's the backstory on this Linksys WRT160N V3 router I picked up for a couple bucks at a garage sale...

This WRT160N V3 was running Linksys stock 3.0.00 firmware when I got it and I could not get it to boot into maintenance mode no matter how many times I tried the 30-30-30 restart. Some users from this thread reported eventual success getting to that elusive maintenance mode as described in these instructions, but I never could. So I decided to try just uploading from the normal "Firmware Upgrade" page located under the Administration tab. No luck flashing DD-WRT from their either. No matter what browser I tried, it always cut out halfway through the firmware bin file upload and the router would reboot, still with Linksys stock firmware and admin panel. I could not get it to take ANY version of DD-WRT bin files.

That when I stumbled upon this thread with crane's ingenious use of cURL in a unix command line to overcome the issue of browsers not being able to fully upload the firmware bin file before the router would inadvertently reboot (it would get to about 5% then the page would cut out as the router began to prematurely reboot). However, being as I couldn't get into that elusive maintenance mode, I had to change things up a bit. Instead of cURL-ing to the maintenance mode URL, I cURL'd to the standard firmware upgrade form handler URL. I tried with several versions of DD-WRT firmware bin files, and had at least been successful getting the bin files to the router successfully, as it would take a little while to upload, then it would respond with the HTML of a page with messages such as "Upgrade is successful." but this dastardly Linksys WRT1600N V3 router would still reboot back into its stock admin panel with its crappy 3.0.00 firmware! Finally I decided to take the same approach but upload another version of the stock firmware they'd been mentioning in that cURL approach thread, which I downloaded from this link I found via Google. Same unix command, but using a stock OEM firmware bin file, as opposed to DD-WRT bin files.

It worked! I was even connecting via wifi rather than ethernet at the time, as my MacBook Air has no ethernet port and I didn't want to mess with a Linux live disk nor install cgwin on my PC at the time to get access to cURL. So frankly, I was pretty stoked at this point to be getting somewhere.

Code:

curl -H "Expect:" --form "file=@WRT160Nv3_0_03_003.code1.bin;type=application/octet-stream" http://admin:admin@192.168.1.1/upgrade.cgi


So being that the above worked, I knew the cURL method was supposed to work, just no clue why it wasn't for the DD-WRT bin files.

In any case, I still couldn't get to that elusive maintenance mode, even with the new Linksys stock 3.0.03 firmware newly flashed to the WRT160N V3 router. So I decided to hit the admin panel again in my browser and try uploading a DD-WRT firmware bin file again. In my haste, I picked an older one that I'd downloaded from a thread where some other user with a Linksys WRT160N V3 had mentioned it, or maybe I grabbed it from the same Debrick NL site that I grabbed the Linksys stock firmware update file from. Can't remember where. Probably the latter. Nevertheless, it apparently uploaded via the web interface successfully, and that's what brings me to where I am now. I now have a bricked Linksys WRT160N V3. I've flashed hardware before, and I've rooted phones before. Never bricked a device before, so I initially celebrated this feat as a milestone in my hardware dabbling. But the celebration quickly ceased...

Naturally I started Googling around "Linksys WRT160N V3 bricked" and similar terms and found this thread. Tried lijianch's and Fstrat90's methods multitple times to no avail. I'm not afraid to try anything. This peice of crap was a $2 garage sale buy. I'm probably better off just buying a router that I know will easily flash DD-WRT like many others I've done.

In any case, I'm just at a loss as to what to try next. I'm up for anything if anyone has a clue what else I could try. Technology never seems to work for me the way it seems to work for everyone else, which is always disappointing, but I always try to overcome. I usually do! Shoot, I've built hackintoshes before. Now THAT was a challenge! I just haven't had much success with this Linksys WRT160N V3 router... YET. Still, the cheapskate/time-waster within me remains hopeful!

Thoughts?
t2mg
DD-WRT Novice


Joined: 10 Jun 2011
Posts: 5

PostPosted: Sun Feb 21, 2016 9:54    Post subject: Reply with quote
Since I have gotten a couple of private messages about this post I figured I would update the topic with the solution for those who TL;DR


1.) Unplug the router.

2.) Turn off wireless on your computer if it has it.

3.) Set your Wired/LAN connection to
192.168.1.10
255.255.255.0
192.168.1.1

4.) Connect directly to the router using an ethernet cable to port 1

5.) Hold the reset button in on the back of the router
using a pen, pencil, paperclip or whatever else you
can find.

6.) Plug the router in again, but do not let go of the reset button.

7.) Wait about 3 seconds then go to http://192.168.1.1/f2.htm

8.) Upload your new firmware and wait til it restarts

9.) Release the reset button


Your router should now be fully operational again.

This should also work with other routers released around the same time.
bytersweet
DD-WRT Novice


Joined: 15 Apr 2016
Posts: 32

PostPosted: Sat Apr 23, 2016 0:01    Post subject: Bricked e3000 fix? Reply with quote
Greetings,

Anyone have a fix for what appears to be a bricked linksys e3000 v1 router?...Tried to load a DDWRT bin onto it and it said "successful" but, froze after that...Stayed that way for 30+ minutes until I had to shut down the power....

Now, all I get after all resets is a pulsating/flashing power light indicator......Anyone? (even a link to ebay for the correct cable to use and associated program would be appreciated!).
Goto page Previous  1, 2, 3 Display posts from previous:    Page 3 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum