D-Link DIR-825 Rev. B - Porting DD-WRT

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3 ... 146, 147, 148, 149  Next
Author Message
Justice
DD-WRT Novice


Joined: 26 May 2017
Posts: 4

PostPosted: Mon May 29, 2017 2:25    Post subject: Reply with quote
@Wildlion: I have taken a look at the most recent 3-4 builds, but only maybe 2 or 3 people who post are posting results from the DIR-825. And the reviews seem mixed, however, I don't know if this is because of the build or because of specialized usage.

Was just hoping for a quicker response than having to put the last 20 builds in an Excel spreadsheet with all it's inherent comments.
Sponsor
Wildlion
DD-WRT User


Joined: 24 May 2016
Posts: 465

PostPosted: Mon May 29, 2017 21:16    Post subject: Reply with quote
Justice wrote:
@Wildlion: I have taken a look at the most recent 3-4 builds, but only maybe 2 or 3 people who post are posting results from the DIR-825. And the reviews seem mixed, however, I don't know if this is because of the build or because of specialized usage.

Was just hoping for a quicker response than having to put the last 20 builds in an Excel spreadsheet with all it's inherent comments.


Understood, and I have noticed that as well, a feature or thing will not work for some but it will for others. My guess is due to different usage parameters for the most part. That is why I try to at least document what/how I use. Sorry I am not of more help, but feel free to ask.
REDXIII
DD-WRT Novice


Joined: 21 Sep 2014
Posts: 10

PostPosted: Sat Oct 21, 2017 8:53    Post subject: Reply with quote
Hi

Does anyone knows if the D-Link DIR-825 DD-WRT firmware has been patched since WPA2 vulnerabilities has been found?

(I use it has range extender so it connects to an other point access through WPA2)
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7093
Location: YWG, Canada

PostPosted: Sat Oct 21, 2017 16:45    Post subject: Reply with quote
yes use latest build look below in red font
_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

[X86-64] Haswell i3-4150 ------------> DD-WRT v3.0-r41303 std
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r40270M kongat
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41303 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41303 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41303 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r40634 std

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
tedm
DD-WRT User


Joined: 13 Mar 2009
Posts: 281

PostPosted: Sat Oct 21, 2017 21:59    Post subject: Reply with quote
I can confirm the DIR-825 B1 runs the latest 33555 build. (I have not done extensive testing yet)
bedub1
DD-WRT Novice


Joined: 04 Jan 2011
Posts: 31

PostPosted: Mon Oct 23, 2017 23:17    Post subject: Reply with quote
Just installed the build (33555). I'm running it as a Client Bridge. I reset it back to factory defaults after installing the build.

I can only setup Client Bridge on 2.4ghz channel, with WPA2+AES.
When I try to setup Client Bridge on 5ghz, with WPA2+AES, it fails to connect. If I remove the encryption, it will connect.

I was most recently running 29974, so it broke somewhere in the middle there.
KariHarri
DD-WRT Novice


Joined: 01 Aug 2012
Posts: 4

PostPosted: Thu Oct 26, 2017 7:14    Post subject: Reply with quote
Build r33555 seems to be working well. I have been running my router on r33555 for a one day now.

Everything that I'm using is working:
- 2,4GHz WiFi
- DDNS
- OpenVPN server
- Firewall and startup commands
- Static Leases
Molle
DD-WRT Novice


Joined: 13 Jan 2015
Posts: 22
Location: Finland

PostPosted: Thu Oct 26, 2017 18:25    Post subject: Reply with quote
bedub1 wrote:
Just installed the build (33555). I can only setup Client Bridge on 2.4ghz channel, with WPA2+AES.

I have two DIR-825s, one as the AP and the other as a CB serving eth connections to my home theater equipment.

I'm on r33525 and the bridge on ath1/5GHz connects fine with 300/300 RX/TX. And, yes, I have WPA2+AES enabled.
bedub1
DD-WRT Novice


Joined: 04 Jan 2011
Posts: 31

PostPosted: Fri Oct 27, 2017 0:28    Post subject: Reply with quote
Molle wrote:
bedub1 wrote:
Just installed the build (33555). I can only setup Client Bridge on 2.4ghz channel, with WPA2+AES.

I have two DIR-825s, one as the AP and the other as a CB serving eth connections to my home theater equipment.

I'm on r33525 and the bridge on ath1/5GHz connects fine with 300/300 RX/TX. And, yes, I have WPA2+AES enabled.

Thanks for the info. Can you try installing 33555 and see if it still works?
Molle
DD-WRT Novice


Joined: 13 Jan 2015
Posts: 22
Location: Finland

PostPosted: Tue Oct 31, 2017 18:39    Post subject: Reply with quote
bedub1 wrote:
Can you try installing 33555 and see if it still works?

I decided to jump straight to r33607. Still works like before.


Last edited by Molle on Tue Oct 31, 2017 18:50; edited 1 time in total
bedub1
DD-WRT Novice


Joined: 04 Jan 2011
Posts: 31

PostPosted: Tue Oct 31, 2017 18:49    Post subject: Reply with quote
Molle wrote:
bedub1 wrote:
Can you try installing 33555 and see if it still works?

I decided to jump straight to r33607. Still works like before.

Thanks. So what am I doing wrong? Hmmmm
Molle
DD-WRT Novice


Joined: 13 Jan 2015
Posts: 22
Location: Finland

PostPosted: Tue Oct 31, 2017 18:52    Post subject: Reply with quote
bedub1 wrote:
Thanks. So what am I doing wrong? Hmmmm


If it helps, the basic setup I use on ath1 is: N-Only, Wide HT40 and Channel 104 w/ upper extension channel.
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2000
Location: Canada

PostPosted: Tue Oct 31, 2017 19:11    Post subject: N-only Reply with quote
N-only is broken, it is better to use NG-Mixed

See this link for a description and recommendations on wireless settings: https://www.dd-wrt.com/wiki/index.php/Atheros/ath_wireless_settings

_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Atheros:
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
Linksys WRT400N - bricked
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
TP-Link 1043nd v1, inactive, unstable hardware
UBNT loco M2 x2 - airOS

Broadcom
Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - Gateway, DHCP, QoS
bedub1
DD-WRT Novice


Joined: 04 Jan 2011
Posts: 31

PostPosted: Tue Oct 31, 2017 23:19    Post subject: Reply with quote
Settings are:

Client Bridge (Router)
NA-Mixed
Wide HT40 (40 Mhz)
SSID is correct

Wireless Security:
WPA2 Personal
AES
Password is correct

My main AP Ubiquity UniFi AP-AC-Pro is set to VHT40, Channel 48, -1.

It tries to connect, shows Legacy, then disconnects.
I perform a Site Survey, it shows up, click connect, says it connected fine.

Just switched encryption to WEP, and it connects fine. 54mbps. The DDWRT GUI is saying it's on channel 48, 5240MHz NOHT.

I can connect with no encryption, and I can connect with WEP. I cannot connect with WPA1 TKIP, nor WPA2 TKIP, nor WPA2 AES.

I have an older Linksys 2000, and it connects just fine with WPA2 AES encryption.
Molle
DD-WRT Novice


Joined: 13 Jan 2015
Posts: 22
Location: Finland

PostPosted: Wed Nov 01, 2017 5:52    Post subject: Re: N-only Reply with quote
ian5142 wrote:
N-only is broken, it is better to use NG-Mixed

There's no NG-Mixed mode on the 5GHz band. Would NA-Mixed do?

Anyway, I haven't had any problems with N-Only as the CB is the only device using 5GHz on the AP.
Goto page Previous  1, 2, 3 ... 146, 147, 148, 149  Next Display posts from previous:    Page 147 of 149
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum