OpenVPN Routing Problem

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Allgemeine Fragen
Author Message
schroedi23
DD-WRT Novice


Joined: 05 Feb 2009
Posts: 18

PostPosted: Mon Aug 24, 2009 13:09    Post subject: OpenVPN Routing Problem Reply with quote
Hallo,

kann mir wer sagen was sich zwischen der SP1 (Build 10020) und preSP2 (Build 12533)version am Netzwerk geändert hat?

Habe folgendes Problem. Hatte auf SP1 eine Konfiguration mit OpenVPN wo nach erfolgreichem Tunnelaufbau alles in den Tunnel geroutet wurde und das war gut so.

Mit der Version SP2 ist dies leider nicht mehr möglich. Die default route kann gar nicht mehr in den Tunnel gelegt werden obwohl hinter dem Tunnel eigentlich alles erreichbar ist und auch antwortet.

Bei manuellen versuch: "ip route change default via serverip" gibt es lediglich eine rüge abfuhr: RTNETLINK answers: Network is unreachable

Jemand hier ne ahnung wo ich hier ansetzen müsste oder hat sich hier so grundlegend etwas geändert dass ein default in den tunnel routen nicht mehr möglich ist?
Sponsor
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17638
Location: Hesse/Germany

PostPosted: Mon Aug 24, 2009 23:06    Post subject: Reply with quote
wie sind den deine routen?
_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
schroedi23
DD-WRT Novice


Joined: 05 Feb 2009
Posts: 18

PostPosted: Tue Aug 25, 2009 9:13    Post subject: Reply with quote
Richtig hübsch sind die, mal länger mal kürzer ;)

Nach weiteren nachforschungen gebe ich das Problem an openVPN weiter.

redirect-gateway wird da jetzt komplett ignoriert. Egal ob als startparameter in der config oder wenn es vom server als push kommt.
Weiters gibt es beim starten dess route-up scripts fehlermeldungen im log von wegen externe scripts können nicht ausgeführt werden.

Jemand ne ideee was hier geändert wurde?

Das Problem scheint schon länger zu existieren: http://www.dd-wrt.com/phpBB2/viewtopic.php?p=340488#340488
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Allgemeine Fragen All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum