Please help - Bug in PPTP VPN Server??

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
chpyeung
DD-WRT Novice


Joined: 04 Mar 2008
Posts: 42

PostPosted: Fri Jul 17, 2009 3:51    Post subject: Please help - Bug in PPTP VPN Server?? Reply with quote
Recently I flashed DD-WRT (build 12319) on my WRT54G V3.1 hoping to use it as PPTP VPN server. I followed the setup guide in Wiki to set it up successfully and VPN client PC (using XP) can connect to it successfully. However, I found the following problems.

1. Whenever the VPN establishes, the MSN on client PC disconnects and cannot re-establish connection until VPN is disconnected.

2. I cannot access to a few websites via VPN (e.g. www.gov.hk) I am sure it is not blocked.

Apart from that, the VPN client PC can access to devices on the server's intranet and access the internet through the gateway router on VPN server side. In fact this problem happens at my DD-WRT Fonera 2100 as well, and I have tested it on build 12188, 12319 and 12426 and all exhibit same problems.

At present, both routers use BrainSlayer firmwares as there are available for both Fonera and WRT54G.
Sponsor
chpyeung
DD-WRT Novice


Joined: 04 Mar 2008
Posts: 42

PostPosted: Sat Jul 18, 2009 4:14    Post subject: Re: Please help - Bug in PPTP VPN Server?? Reply with quote
chpyeung wrote:
Recently I flashed DD-WRT (build 12319) on my WRT54G V3.1 hoping to use it as PPTP VPN server. I followed the setup guide in Wiki to set it up successfully and VPN client PC (using XP) can connect to it successfully. However, I found the following problems.

1. Whenever the VPN establishes, the MSN on client PC disconnects and cannot re-establish connection until VPN is disconnected.

2. I cannot access to a few websites via VPN (e.g. www.gov.hk) I am sure it is not blocked.

Apart from that, the VPN client PC can access to devices on the server's intranet and access the internet through the gateway router on VPN server side. In fact this problem happens at my DD-WRT Fonera 2100 as well, and I have tested it on build 12188, 12319 and 12426 and all exhibit same problems.

At present, both routers use BrainSlayer firmwares as there are available for both Fonera and WRT54G.


Later I switched to Eko's firmware of build 12360 NEWD on my WRT54G V3.1 and the problem is gone. I would be grateful if BrainSlayer would look into this problem and fix it asap so that I can use the FON router for PPTP VPN as well. (as there is brainslayer firmware for FON only.)
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum