Multicast Issues with WL500W

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
Cronium
DD-WRT Novice


Joined: 11 Jul 2009
Posts: 3

PostPosted: Sat Jul 11, 2009 14:48    Post subject: Multicast Issues with WL500W Reply with quote
I am having a bit of trouble getting multicast working on my router.

I have searched and read a fair few threads, and my research leads me to believe the igmprt (the multicast routing daemon) needs to be running for multicast to do anything.

However whenever I start the daemon, WAN access dies, apparently a common bug.

(As a side note I believe igmprt reads its configuration files from /etc/igmpproxy.conf but this file doesnt exist)

Is there anything I can do to workaround the problem or otherwise fix it?

I am running DD-WRT v24-sp2 (02/18/09) mega
(SVN revision 11650M NEWD Eko) on a Asus WL-500W

Thank you.
Sponsor
Murrkf
DD-WRT Guru


Joined: 22 Sep 2008
Posts: 12680

PostPosted: Sat Jul 11, 2009 14:56    Post subject: Reply with quote
Can't help you with your problem, but if anyone tells you to upgrade to a newer build, make SURE it works with that problematic router first. It seems that the newer builds are working, but check. Some don't know the history behind the wl500w problems.

11296 was reported to be working on a wl500w, so you might wish to try that build.

_________________
SIG:
I'm trying to teach you to fish, not give you a fish. If you just want a fish, wait for a fisherman who hands them out. I'm more of a fishing instructor.
LOM: "If you show that you have not bothered to read the forum announcements or to follow the advices in them then the level of help available for you will drop substantially, also known as Murrkf's law.."
Cronium
DD-WRT Novice


Joined: 11 Jul 2009
Posts: 3

PostPosted: Sat Jul 11, 2009 15:14    Post subject: Reply with quote
Is there somewhere I can check what is working with my router? The wiki recommended the version I am currently using, but it seems a bit infrequently updated.
Murrkf
DD-WRT Guru


Joined: 22 Sep 2008
Posts: 12680

PostPosted: Sat Jul 11, 2009 21:41    Post subject: Reply with quote
Not an easy check....In the build threads, I know I saw recently that one said they were using a newer build on a WL500W.

I would try the 11296. You are aware of the filter multicast button in security. Redhawk has reported problems with at least some builds if you uncheck that. See for example, this recent post:

http://www.dd-wrt.com/phpBB2/viewtopic.php?t=41466


You will have to take a look at the build threads and see if anyone reports the build working on a wl500w. Start with 12307 and see if that one has been reported as good.

Or post a new thread entitled "Which builds are working on an Asus WL500W?" Look for consistency in the replies, not just one person answer.

_________________
SIG:
I'm trying to teach you to fish, not give you a fish. If you just want a fish, wait for a fisherman who hands them out. I'm more of a fishing instructor.
LOM: "If you show that you have not bothered to read the forum announcements or to follow the advices in them then the level of help available for you will drop substantially, also known as Murrkf's law.."
PUNiZZLE
DD-WRT User


Joined: 06 Apr 2008
Posts: 79

PostPosted: Mon Jul 13, 2009 20:09    Post subject: Reply with quote
Hey,
The newer builds are working on the WL-500W pretty stable for me. I usually throw on the newer builds within the week they come out.

The NEWD2 drivers work on the WL-500W.

I know Murrkf advocates NOT using the mega builds, but personally I use them without a problem.

I haven't used the multicast daemon so I can't help you out there.

_________________
I'll short all the pins on my router before I ever build a JTAG. Twisted Evil
Murrkf
DD-WRT Guru


Joined: 22 Sep 2008
Posts: 12680

PostPosted: Mon Jul 13, 2009 20:54    Post subject: Reply with quote
PUNiZZLE wrote:
I know Murrkf advocates NOT using the mega builds, but personally I use them without a problem.



I advocate caution in using them on that router....not NOT.

_________________
SIG:
I'm trying to teach you to fish, not give you a fish. If you just want a fish, wait for a fisherman who hands them out. I'm more of a fishing instructor.
LOM: "If you show that you have not bothered to read the forum announcements or to follow the advices in them then the level of help available for you will drop substantially, also known as Murrkf's law.."
PUNiZZLE
DD-WRT User


Joined: 06 Apr 2008
Posts: 79

PostPosted: Mon Jul 13, 2009 22:33    Post subject: Reply with quote
Murrkf wrote:
PUNiZZLE wrote:
I know Murrkf advocates NOT using the mega builds, but personally I use them without a problem.



I advocate caution in using them on that router....not NOT.

My apologies. Rolling Eyes

_________________
I'll short all the pins on my router before I ever build a JTAG. Twisted Evil
axo
DD-WRT Novice


Joined: 16 Jun 2009
Posts: 11

PostPosted: Mon Jul 13, 2009 23:19    Post subject: Reply with quote
So far, I've successfully flashed the following Eko NEWD builds on my ASUS WL-500W:
- 11650 Mega
- 12220 Mega
- 12360 Mega
- 12424 Std-nokaid_usb
I've flashed other builds as well but at least the ones above have been running fine over a longer period of time. The reason I "downgraded" from mega to the standard build was to have more memory available for the JFFS drive.
v01d
DD-WRT Novice


Joined: 05 Jul 2009
Posts: 3

PostPosted: Mon Jul 13, 2009 23:20    Post subject: Reply with quote
I'm using SVN revision 12424M NEWD Eko without problems on my WL500W. I'm not sure if the multicast issue you are having is fixed in that revision, but it certainly runs very well indeed.

I'm waiting a little longer to find out if it's safe to put the latest NEWD2 revision on it. Would there be much danger (as in more than a normal flash) trying it out seeing as there is no JTAG on WL500W's?
PUNiZZLE
DD-WRT User


Joined: 06 Apr 2008
Posts: 79

PostPosted: Tue Jul 14, 2009 0:37    Post subject: Reply with quote
v01d wrote:

I'm waiting a little longer to find out if it's safe to put the latest NEWD2 revision on it. Would there be much danger (as in more than a normal flash) trying it out seeing as there is no JTAG on WL500W's?

I'm using the NEWD2 without problems, the flash went smooth without a hitch.

Using the mega version 12476M.

You are correct in saying that there is a risk in flashing because this unit does not have a JTAG header. However, you take the same risk when flashing any build.

There is a serial connection that can be made in place of JTAG, search the forums.

_________________
I'll short all the pins on my router before I ever build a JTAG. Twisted Evil
Cronium
DD-WRT Novice


Joined: 11 Jul 2009
Posts: 3

PostPosted: Tue Jul 14, 2009 9:50    Post subject: Reply with quote
How are you upgrading? 30/30/30 then Web interface, Asus Tool? tftp? Are you clearing the nvram or loading the mini asus versions or are you doing it directly
v01d
DD-WRT Novice


Joined: 05 Jul 2009
Posts: 3

PostPosted: Tue Jul 14, 2009 14:02    Post subject: Reply with quote
Cool that there is some kind of backup. Finding a PC in my house with a serial port might be interesting though :)


I found the web interface didn't work for my WL500W (works on the "work" Linksys GL though)

I've been doing 30/30/30 > tftp nfram-clear > tfp revision > 30/30/30.

I did try other shorter methods and ended up with it not booting. (oops :-S ) Luckily trying again with the whole shebang got it back.
axo
DD-WRT Novice


Joined: 16 Jun 2009
Posts: 11

PostPosted: Tue Jul 14, 2009 16:49    Post subject: Reply with quote
For my initial flash, I followed the step-by-step instructions from the wiki using tftp.
Ever since I had DD-WRT installed, I have been using the web interface to update (30-30-30).
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum