WRT54GL - DDNS Problem [Solved]

Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3
Author Message
phuque99
DD-WRT User


Joined: 20 Oct 2008
Posts: 446

PostPosted: Thu Aug 06, 2009 1:31    Post subject: Reply with quote
I would echo rcblackwell's comment. The DDNS error in the logs probably has nothing to do with dd-wrt firmware build / versions. It has to do with inadyn encountering intermittent issues when checking for public IP updates on "checkip.dyndns.org:80"

Comparing rcblackwell's inadyn settings with my own, all the developers did was decrease the IP checking frequency from every 360s to 600s. Unfortunately, that did not help as we still see the issue on build 12601.

What I did was to customize my inadyn setting on dd-wrt to use "whatismyip.org:80" to check public IP. I've been running this for almost a day and I no longer see the error. This workaround maybe working and you're welcomed to give it a try:

Code:
DDNS Service: Custom
DYNDNS Server: members.dyndns.org
User Name: <your username>
Password: <your password>
Host Name: <your dyndns host>
URL: /nic/update?
Additional DDNS Options
--dyndns_system dyndns@dyndns.org --ip_server_name whatismyip.org:80 /


Please bear in mind that this is not a confirmed workaround. There are possible issues. "checkip.dyndns.org" has 4 IPs on around robin to service the public while "whatismyip.org" has only 1. I'm not sure if it would be able to withstand the load of many dd-wrt users querying it to check IP updates, or we'll just kill it when everyone implements this workaround.
Sponsor
revolutiontoast
DD-WRT Novice


Joined: 06 Jul 2009
Posts: 2

PostPosted: Tue Aug 18, 2009 14:09    Post subject: Reply with quote
dpp3530 wrote:
I've seen a lot of posts about DynDNS not working. I belive it's a known bug.

The workaround I ended up using was to get myself a DNS-O-MATIC account. If you already use OpenDNS, you already have an account. The other benefit is that you can update multiple Dynamic DNS services (in my case DynDNS and OpenDNS).

Go to www.dnsomatic.com and configure your services. It supports most common ones. Then configure the router as below.

DDNS Service: Custom
DYNDNS Server: updates.dnsomatic.com
User Name: your dns-o-matic username
Password: your dns-o-matic password
Host Name: all.dnsomatic.com
URL: /nic/update?



Because the country I live in routes everything thru a transparent proxy, the ONLY way I can get updates to work is by using https. I can use a URL to update dnsomatic, but this means that if the IP address on my router changes, I cant log in to open the URL that will update it (to allow me access again!)

I have tried using the above info to get updates working, and when I do it as shown above it will always update using the PROXY IP, not my router IP.

Very annoying. I tried using the small change below (where I added :443 on the end of the address so it SHOULD try to use that port instead of port 80) but it never works, it always gives the
INADYN :IP : Error 0x83 in recv()
RC_IP_RECV_ERROR (0x15) updating the IPs (it 1)


This is the settings that I tried that results in the error message
DDNS Service: Custom
DYNDNS Server: updates.dnsomatic.com:443
User Name: your dns-o-matic username
Password: your dns-o-matic password
Host Name: all.dnsomatic.com
URL: /nic/update?

So, if I do it the first way, it always gives the wrong IP address, and if I try the other way with port 443 it always gives an error.


How can I tell it to use port 443 in a way that will work????
hako
DD-WRT Novice


Joined: 04 Sep 2009
Posts: 3
Location: Shanghai, China

PostPosted: Fri Sep 04, 2009 10:14    Post subject: Reply with quote
Like revolutiontoast I also have the problem that all IP services always report another IP, not my router's IP.
This WAN IP, however, is correctly displayed and updated in the router's status screen.

I can update the DNS IP only manually, by reading my router's WAN IP (from its http interface) and paste it into a browser URL for updating.
I did not find a way within DD-WRT to send it's WAN IP to the update server.
I am using DD-WRT v23 SP2 (09/15/06) std (SVN revision 3932).
Any ideas?
phuque99
DD-WRT User


Joined: 20 Oct 2008
Posts: 446

PostPosted: Fri Sep 04, 2009 11:22    Post subject: Reply with quote
rcblackwell wrote:
rcblackwell wrote:
I'd be interested in knowing why versions of DD-WRT subsequent to build 12533 (I think this is the correct build number) present errors when 12533 doesn't?


Oh, oh! I spoke to soon! Not only did I get the build version wrong a recent check of the logs reveals it's full of errors Shocked .

The build I currently have loaded is 12188. When DDNS was configured on Sunday all was fine. Subsequent checks a few hours apart led me to believe all was well however early Monday morning the errors returned.

Looks as though the build has little if anything to do with this problem.


Unless you run your own script to capture the right header, the transparent proxy is the annoyance. You can work around it by using port 8245 of the IP checker suggested in the wiki here:

http://www.dd-wrt.com/wiki/index.php/DDNS#DynDNS
hako
DD-WRT Novice


Joined: 04 Sep 2009
Posts: 3
Location: Shanghai, China

PostPosted: Fri Sep 04, 2009 12:23    Post subject: Reply with quote
phuque99 wrote:
Quote:
....You can work around it by using port 8245 of the IP checker suggested in the wiki here:

http://www.dd-wrt.com/wiki/index.php/DDNS#DynDNS ...


That does not work, it returns the same bogus IP as the other IP checkers. Defining a port does not do the job.
We will need some better way to get the router's WAN IP in China.

Edit:
DynDNS has recommendations for developers: http://www.dyndns.com/developers/routers/hints.html,
they recommend to use the WAN IP for updating...

Where to get such a tool?

Did anyone try koshmar's IPdetect? Any experience?
granchalek
DD-WRT Novice


Joined: 20 Apr 2010
Posts: 6

PostPosted: Tue Apr 20, 2010 7:17    Post subject: Same Problem Reply with quote
Has anyone come up with a solution to update a DNS service using the WAN IP from the router?

I have tried all of the solutions and none seem to work.

Thanks
granchalek
DD-WRT Novice


Joined: 20 Apr 2010
Posts: 6

PostPosted: Sat Apr 24, 2010 7:56    Post subject: Easy Solution Reply with quote
Someone helped me out and it seems that the new firware includes an option to NOT use external IP detection. Click that and it uses the internal WAN IP.
hako
DD-WRT Novice


Joined: 04 Sep 2009
Posts: 3
Location: Shanghai, China

PostPosted: Sat Apr 24, 2010 18:21    Post subject: Easy Solution Reply with quote
granchalek:
Quote:

...the new firware includes an option to NOT use external IP detection. Click that and it uses the internal WAN IP


Which firmware did you use? Where to download?
granchalek
DD-WRT Novice


Joined: 20 Apr 2010
Posts: 6

PostPosted: Sun Apr 25, 2010 1:04    Post subject: Firmware Reply with quote
DD-WRT v24-sp2 (10/10/09) std - build 13064

I was initially using the firmware that was used for the initial flashing but I failed to upgrade to the latest version. Since then all of my problems have been solved.
granchalek
DD-WRT Novice


Joined: 20 Apr 2010
Posts: 6

PostPosted: Sun Apr 25, 2010 1:06    Post subject: Download Reply with quote
I think you just go to the router database page and find your router and select the appropriate model etc..

http://www.dd-wrt.com/site/support/router-database
appenzellois
DD-WRT Novice


Joined: 06 Mar 2013
Posts: 1

PostPosted: Wed Mar 06, 2013 22:58    Post subject: Definitely a password problem Reply with quote
Ok guys, I struggled with that "Connecting to server" too. And as Glorymajor pointed out, it definitely has to do with dd-wrt not recognizing certain characters.

I tried almost everything : now I have a dd-wrt.v24-16785_NEWD-2_K2.6_big-e2000 version on my Linksys E2000 router, even if the v24-sp2 (16785) would have been enough after all. I flashed my router, did the 30/30/30, rested everything and so on...

I had my DynDns password right that's for 110% certain. But, then I came across this post and I changed my DynDns password (also in dd-wrt) only with alphanumeric chars... and guess what ?

Yes, from that on it worked fine !

My old password contained some (or perhaps was it only one, I don't know) characters too tricky for dd-wrt, that's all! Period.

My special THANK YOU !!! to Glorymajor, I owe you one !
tonosam
DD-WRT Novice


Joined: 05 Jan 2016
Posts: 1

PostPosted: Tue Jan 05, 2016 23:14    Post subject: My problem was the special characters in passwords Reply with quote
I post my own experience for helping others...

I have a Linksys WRT54GL with DD-WRT v24-sp2. I had the same problem related to "Connecting to server": when I tried to configure DNS-O-MATIC with my Linksys I just got the "Connecting to server" message and no inadyn logs. The last made me think that may be the inadyn command could not be properly executed due to the issue related to special characters in passwords, as my password had a '#' inside (DNS-O-MATIC forces to use special characters).

I followed the inadyn instructions and I scaped my special character with a '\' and it worked (pass: xxx\#xxx). My configuration is:

Quote:
DDNS Service: Custom
Do not use external ip check: Yes
Server: updates.dnsomatic.com
User Name: [my e-mail]
Password: [my pass]
Host name: all.dnsomatic.com
URL: /nic/update?hostname=
Additional DDNS Options: [empty]


I hope this help someone. Regards.
aksingh
DD-WRT Novice


Joined: 17 Feb 2013
Posts: 26

PostPosted: Fri Dec 08, 2017 7:42    Post subject: DDNS not working on WRT54GL rel v3.0-r33555 vpn (10/20/17) Reply with quote
Can anyone help me on DDNS is not working on my router
Problem is same as discussed in this thread:
"DDNS Status Connecting to server "

My connection is PPPoE with dynamic IP and router manages PPoE and modem is configured in bridge mode.

Router: WRT54GL V1.1
dd-wrt bBuild: v3.0-r33555 vpn (10/20/17)

DDNS Service: Custom

DYNDNS Server: updates.dnsomatic.com

User Name: your dns-o-matic username.

Please note this is email address with @ symbol therefore do I need to escape @ in this files as well e.g. abc\@gmail.com or abc@gmail.com is enough?

Is there any restriction on length of email field because my email id is long one here 25 char?

Password: your dns-o-matic password.
Note: Here also we have special character because opendns enforces in its password rules.
Do I need to escape special character in password filed e.g. abcd\@123 or abcd@123 is enough?
Password length is 8 char.

Host Name: all.dnsomatic.com

URL:/nic/update?hostname=
dpp3530
DD-WRT Guru


Joined: 12 Dec 2007
Posts: 567
Location: Pittsburgh, PA USA

PostPosted: Fri Dec 08, 2017 11:34    Post subject: Re: DDNS not working on WRT54GL rel v3.0-r33555 vpn (10/20/1 Reply with quote
aksingh wrote:

Please note this is email address with @ symbol therefore do I need to escape @ in this files as well e.g. abc\@gmail.com or abc@gmail.com is enough?

When you create your DNSOMatic account, your username doesn't need to contain an @ sign. I would change it in the Account settings and try without the @. Otherwise, your settings are the same as mine.

_________________
__________________________
Linksys WRT-1900AC
DD-WRT v3.0 STD
Netgear R7000
DD-WRT v3.0 STD
Netgear R7800
DD-WRT v3.0 STD
Goto page Previous  1, 2, 3 Display posts from previous:    Page 3 of 3
Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum