I can't get bwlog working...

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3, 4  Next
Author Message
fyleow
DD-WRT Novice


Joined: 16 Jun 2006
Posts: 10

PostPosted: Sat Jun 17, 2006 4:09    Post subject: I can't get bwlog working... Reply with quote
I'm using the latest DD-WRT(5/16/06) and I can't get this to work.

When I start it with ./start.sh it gives me this error:

ftpget: Unable to connect to remote host (192.168.1.100): No route to host

When I type in PS the ./mini_httpd is running but not the other processes like backup.sh

If I try to go to the URL 192.168.1.1:8000/traffic.cgi I just get a blank page. If I enter an invalid URL I get a 404 from mini_httpd so mini_httpd is indeed running properly.

Any ideas?


Last edited by fyleow on Sat Jun 17, 2006 5:24; edited 1 time in total
Sponsor
colindean
DD-WRT User


Joined: 08 Jun 2006
Posts: 59
Location: Pittsburgh, PA

PostPosted: Sat Jun 17, 2006 4:56    Post subject: Reply with quote
I think you mean bwlog...your title threw me a loop a bit.

http://www.dd-wrt.com/wiki/index.php/BWlog

_________________
PittMesh, a Meta Mesh Wireless Communities project.
Mi parolas Esperanton.
fyleow
DD-WRT Novice


Joined: 16 Jun 2006
Posts: 10

PostPosted: Sat Jun 17, 2006 5:24    Post subject: Reply with quote
colindean wrote:
I think you mean bwlog...your title threw me a loop a bit.

http://www.dd-wrt.com/wiki/index.php/BWlog


Yeah I did, sorry about that. I followed the installation instructions and got the error.
Tornado
DD-WRT Developer/Maintainer


Joined: 07 Jun 2006
Posts: 2087
Location: Odessa, Ukraine

PostPosted: Sat Jun 17, 2006 9:12    Post subject: Reply with quote
The problem is with haserl, I recompiled this, and replaced the one distributed with the latest bwlog, and it now works fine with the current SVN.

also 192.168.1.100, is where the logs are stored, this can be changed in the configure screen of bwlog, it will not hurt anything, nor is it really an error. It is just a default that can be changed once you get bwlog started.

_________________
Want JTAG support - Donate a router
or Donate with PayPal !

My preferred parallel jtag adapter:
TIAO Parallel adapter

Tjtag website - http://tjtag.com

Compiling DD-WRT on:
AMD Phenom II X6 1090T @ 3926.667 Mhz

Aptosid X64 - Debian SID X64
Ubuntu 10.10 X64 - Arch X64
krikkit
DD-WRT User


Joined: 07 Jun 2006
Posts: 68
Location: Vienna

PostPosted: Sat Jun 17, 2006 15:06    Post subject: Reply with quote
with newer versions there is also a problem with the backup to FTP servers... just a little change of the ftpput command syntax...

you can find a working version of WRTbwlog here:
http://www.krikkit.net/download/wrtbwlog_cust_exp.tgz

...tested and fully working with Firmware: DD-WRT v23 SP1 Final (05/30/06) vpn

_________________
Using Firmware:
DD-WRT v24-sp2 (01/29/09) vpn
(SVN revision 11514) on WRT54G v3.1
colindean
DD-WRT User


Joined: 08 Jun 2006
Posts: 59
Location: Pittsburgh, PA

PostPosted: Sat Jun 17, 2006 15:39    Post subject: Reply with quote
Here, here.
I'm copying and pasting the code from the other thread so that we have it on this board, too.
Code:
#!/bin/sh
for i in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20;
do
sleep 5
cd /tmp
/usr/bin/wget http://your.domain/yoursubdirectory/wrtbwlog_cust.tgz
/bin/tar -xzf wrtbwlog_cust.tgz
rm wrtbwlog_cust.tgz
cd bwlog
rm bwdata.tgz
/usr/bin/wget http://your.domain/yoursubdirectory/bwdata.tgz
( ./start.sh & ) &
done
So here's my rc_startup now:
Code:
nvram set rc_startup="echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts;echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses;echo '600 1800 120 60 120 120 10 60 30 120' > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts;for i in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20; do sleep 5; cd /tmp; /usr/bin/wget http://www.krikkit.net/download/wrtbwlog_cust_exp.tgz; /bin/tar -xzf wrtbwlog_cust_exp.tgz; rm wrtbwlog_cust_exp.tgz; cd bwlog; ( ./start.sh & ) &  done";
Don't forget the nvram commit like I did the first three times :wink:

If you have your own server, I'm sure krikkit would appreciate it if you hosted the archive on it rather than mooching his bandwidth.

A question I have, though, is this: does that for loop really need to be 20 times?

_________________
PittMesh, a Meta Mesh Wireless Communities project.
Mi parolas Esperanton.
fyleow
DD-WRT Novice


Joined: 16 Jun 2006
Posts: 10

PostPosted: Sat Jun 17, 2006 18:25    Post subject: Reply with quote
Thank you so much Krikkit, that works perfectly now. I'll put it on my own server so I won't waste your bandwidth :)

Colindean where do you put the startup scripts?
colindean
DD-WRT User


Joined: 08 Jun 2006
Posts: 59
Location: Pittsburgh, PA

PostPosted: Sun Jun 18, 2006 1:34    Post subject: Reply with quote
I couldn't find the startup script box in the administration tab (where it's been in past versions), so I just used ssh to do it.

You could use the Administration > Diagnostics box and put that all in there with a nvram commit; after that last semicolon. I believe that that will accomplish it, too.

_________________
PittMesh, a Meta Mesh Wireless Communities project.
Mi parolas Esperanton.
SMario
DD-WRT Novice


Joined: 22 Jun 2006
Posts: 2
Location: DD

PostPosted: Thu Jun 22, 2006 21:40    Post subject: Reply with quote
I still have got 2 little problems with Krikkit's bwlog version.
When I try to upload, after configuration, the custom bwlog to my webspace, I get an error message "ftpput: CWD error: wrtbwlog_cust.tgz: No such file or directory" and no file is uploaded.

The 2nd thing, that does'nt work is reloading of the backuped logdata after a reboot of the router. Maybe there is a little mistake in my startup-script, because the backupfile is on the webspace:
Code:

#!/bin/sh
for i in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20;
do
sleep 20
cd /tmp
/usr/bin/wget http://www.mydomain.com/wrt54g/wrtbwlog_cust_exp.tgz
/bin/tar -xzf wrtbwlog_cust_exp.tgz
rm wrtbwlog_cust_exp.tgz
cd bwlog
rm bwdata.tgz
/usr/bin/wget http://www.mydomain.com/wrt54g/bwdata.tgz
( ./start.sh & ) &
done


Thanks

Mario
colindean
DD-WRT User


Joined: 08 Jun 2006
Posts: 59
Location: Pittsburgh, PA

PostPosted: Thu Jun 22, 2006 23:06    Post subject: Reply with quote
Crikey!

I left out that part.

Code:
nvram set rc_startup="echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts;echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses;echo '600 1800 120 60 120 120 10 60 30 120' > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts;for i in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20; do sleep 5; cd /tmp; /usr/bin/wget http://www.krikkit.net/download/wrtbwlog_cust_exp.tgz; /bin/tar -xzf wrtbwlog_cust_exp.tgz; rm wrtbwlog_cust_exp.tgz; cd bwlog; rm bwdata.tgz; /usr/bin/wget http://WWW.MYDOMAIN.COM/bwdata.tgz; ( ./start.sh & ) &  done";

I left it out 'cause I'm not backing it up--I don't have an FTP anywhere and I've got "Add SFTP/SCP option to bwlog" on my to-do list for the summer.

_________________
PittMesh, a Meta Mesh Wireless Communities project.
Mi parolas Esperanton.
krikkit
DD-WRT User


Joined: 07 Jun 2006
Posts: 68
Location: Vienna

PostPosted: Fri Jun 23, 2006 10:38    Post subject: Reply with quote
@mario: which version of dd-wrt are you using?

..my custom package is preconfigured to backup/reload to/from FTP server...if you don't need this, disable is under option.... btw. you can't backup to http server...

_________________
Using Firmware:
DD-WRT v24-sp2 (01/29/09) vpn
(SVN revision 11514) on WRT54G v3.1
stephen
DD-WRT User


Joined: 07 Jun 2006
Posts: 137

PostPosted: Fri Jun 23, 2006 12:18    Post subject: Reply with quote
krikkit, colin,
it would be nice if you'd contact the original author of wrtbwlog so he might revise/include
your midifications into the next release (already overdue)
At the moment I can't manage to make modifications myself, still got a real life Smile
SMario
DD-WRT Novice


Joined: 22 Jun 2006
Posts: 2
Location: DD

PostPosted: Fri Jun 23, 2006 19:22    Post subject: Reply with quote
@krikkit or other bwlog-professional: I use the v23 SP1 final on the router. Of course I use a ftp-account to backup the bwdata.tgz. The error will be shown, if i try to use this button on the config-page to upload a customized bwlog.
But my second problem is much more important for me. The bwdata.tgz is uploaded by bwlog. But the automatic download to the router doesn't work.
Maybe you can post your startup-script, which is working for you.
I tried manually my startup-script per telnet. And there was no error, but the configuration was still on default after all.
BTW Is the configuration (for ftp etc.) in the bwdata.tgz or only in the wrtbwlog_cust.tgz saved? Maybe is this the problem, because of the error while uploading the customized wrtbwlog-file.

Mario
krikkit
DD-WRT User


Joined: 07 Jun 2006
Posts: 68
Location: Vienna

PostPosted: Fri Jun 23, 2006 22:02    Post subject: Reply with quote
i can't say for shure if my customized version is working with the final build of v23 SP1 (i think not) ...i tested it on Firmware: DD-WRT v23 SP1 Final (05/30/06) vpn

but my customization was only a fix to the change syntax of ftpput... if you post teh output of your ftpput command i can say if my bwlog will work...

the output of my ftpput command:
Code:
~ # ftpput
Now DD-WRT VeryBusyBox v1.1.3 (2006.05.29-23:26+0000) multi-call binary

Usage: ftpput [options] remote-host remote-file local-file


my startup script:
Code:
#!/bin/sh
#for i in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20;
for i in 1;
do
sleep 15
cd /tmp
/usr/bin/wget ftp://192.168.1.2/wrtbwlog_cust.tgz
/bin/tar -xzf wrtbwlog_cust.tgz
rm wrtbwlog_cust.tgz
cd bwlog
( ./start.sh & ) &
done


...the config for ftp backup is stored in the wrtbwlog_cust.tgz AND the bwlog file, but to make it work on startup the conf must be in the _cust file

_________________
Using Firmware:
DD-WRT v24-sp2 (01/29/09) vpn
(SVN revision 11514) on WRT54G v3.1
rovel
DD-WRT Novice


Joined: 07 Jun 2006
Posts: 21

PostPosted: Sat Jun 24, 2006 5:44    Post subject: Reply with quote
I am using the krikket's custom version of BWLOG tool on 2 routers wrt54g v3.1 loaded with dd-wrt sp1 build 06/06/06. I have my own ftp server at 192.168.4.144, where I have installed WARFTP server. It's working beautiful with the ftp backup option. Thanks krikkit.
My rc_startup scripts on the 2 routers are:

router1:

#!/bin/sh
for i in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20;
do
sleep 5
cd /tmp
/usr/bin/wget ftp://wrtgs:wrtgs@192.168.4.144/router1/wrtbwlog_cust.tgz
/bin/tar -xzf wrtbwlog_cust.tgz
rm wrtbwlog_cust.tgz
cd bwlog
rm bwdata.tgz
/usr/bin/wget ftp://wrtgs:wrtgs@192.168.4.144/router1/bwdata.tgz
( ./start.sh & ) & done

router2:

#!/bin/sh
for i in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20;
do
sleep 5
cd /tmp
/usr/bin/wget ftp://wrtg2:wrtg2@192.168.4.144/router2/wrtbwlog_cust.tgz
/bin/tar -xzf wrtbwlog_cust.tgz
rm wrtbwlog_cust.tgz
cd bwlog
rm bwdata.tgz
/usr/bin/wget ftp://wrtg2:wrtg2@192.168.4.144/router2/bwdata.tgz
( ./start.sh & ) & done

No problems so far. Software loaded in the 2 routers and working for 5 days now.

One small problem I have is that I have configured the ftp backup option to store BWDATA.TGZ file to be saved in the /router1 and /router2 subdirectory of the ftp server at the 192.168.4.144 IP with the needed passwords. Not the root directory. But it always saves bwdata.tgz in the main root directory. When I upload wrtbwlog_cust.tgz it's also saved in the root ftp directory.

Is this a bug in the config for ftp backup or am I doing something wrong?
Thank you krikkit.
Goto page 1, 2, 3, 4  Next Display posts from previous:    Page 1 of 4
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum