WRT350n v1 How configure USB storage

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3  Next
Author Message
emersonvier
DD-WRT Novice


Joined: 16 Jun 2008
Posts: 35
Location: Sao Paulo, Brazil

PostPosted: Tue Dec 02, 2008 18:01    Post subject: Reply with quote
Now I see the Samba page Laughing

I try make a configuration Laughing


My Steps:

In the web-GUI select: tab: Services -> tab: Services --> section: USB Support
Enable all option, less 2.0


http://www.dd-wrt.com/wiki/index.php/Jffs#Directions_for_.28normal.29_users:_Web_Interface

Directions for (normal) users: using Web-GUI Interface

The steps to enable JFFS through the router web page are very specific. To avoid having to reset and reprogram your router, it's smart to make a backup here of your settings. If you follow these steps exactly, it should not lock up.

1. On the router web page click on Administration.
2. Scroll down until you see JFFS2 Support section.
3. Click Enable JFFS.
4. Click Save.
5. Wait couple seconds, then click Apply.
6. Wait again. Go back to the Enable JFFS section, and enable Clean JFFS.
7. Do not click "Save". Click Apply instead.

The router formats the available space.

8. Wait till you get the web-GUI back, then disable "Clean JFFS" again.
9. Click "Save".
10. It may be wise to Reboot the router, just to make sure

Open Putty


/bin/ipkg update

/bin/ipkg install e2fsprogs swap-utils

cd /jffs

wget http://downloads.betaserver.org/ddwrt/scripts/begin-here.startup
chmod +x begin-here.startup
wget http://downloads.betaserver.org/ddwrt/scripts/hdd-check.sh
chmod +x hdd-check.sh

sh /jffs/begin-here.startup
wait long time

cd /mnt
ls
look for a folder called lost+found

mkdir scripts
mkdir logs
mkdir share
ls
cd \scripts
wget http://downloads.betaserver.org/ddwrt/scripts/boot.startup
chmod +x boot.startup
wget http://downloads.betaserver.org/ddwrt/scripts/firewall.sh
chmod +x firewall.sh
wget http://downloads.betaserver.org/ddwrt/scripts/optware-install.sh
chmod +x optware-install.sh
wget http://downloads.betaserver.org/ddwrt/scripts/ad-block.sh
chmod +x ad-block.sh

ls /opt

sh optware-install.sh

cd /opt
ls
cd etc
wget http://downloads.betaserver.org/ddwrt/scripts/profile
/opt/bin/ipkg-opt update
/opt/bin/ipkg-opt install xinetd samba2
wait a long time

/opt/etc/init.d/S80samba start
/opt/etc/init.d/S10xinetd start


Then in the command section of the webgui (under administration), you want to enter sh /jffs/begin-here.startup and save it as a startup script.


Reboot router

Pointing you web browser to http://192.168.1.1:901
Sponsor
bzzbr
DD-WRT Novice


Joined: 03 Dec 2008
Posts: 3

PostPosted: Wed Dec 03, 2008 0:38    Post subject: Reply with quote
Hi kjbuente & emersonvier.

I tried to follow all steps here and before reboot the router, i got access to SWAT ( 192.168.1.1:901 ) but I notice in STATUS page the service was stopped. I tried several times to start the service, but without success ( I also tried to start it manually from Putty ). Then I rebooted the router and can´t access the SWAT anymore.
In the log subdirectory there is no error and the only thing I did diferent is the partions size, order and type ( i changed the scripts to reflect my configuration ).
Any clue ? Should I restart from flashing the firmware again ( I´m using the DD-WRT v24-sp2 (11/30/0Cool mega(SVN revision 11028M NEWD Eko) and my router is a Linksys 600N v1.1

Any advice is welcome.
Thank you.
kjbuente
DD-WRT User


Joined: 31 Mar 2007
Posts: 181
Location: /Earth/USA/OH/Zville

PostPosted: Wed Dec 03, 2008 6:18    Post subject: Reply with quote
With my router, I was not able to use jffs with the mega version of dd-wrt. There was just no room for it.

telnet into the router again and see if the stuff that you put in /jffs is still there. If not, then there was just not enough room for it. If this is the case, use Ekos mini-usb build so you have room for jffs. and start from scratch.

Also look in the /tmp directory. Do you see a usb.log? If so, please post it...
bzzbr
DD-WRT Novice


Joined: 03 Dec 2008
Posts: 3

PostPosted: Wed Dec 03, 2008 11:39    Post subject: Reply with quote
kjbuente,

I will start over with a smaller build but the stuff in /jffs still there. It seems N600 has enough room to hold the MEGA build. in the usb log there is one error :

root@Kamikaze:/tmp# vi usb.log
USB Device Detected, Attempting to mount and run script
Mounting Swap
/jffs/begin-here.startup: line 39: /jffs/sbin/swapon: not found
Checking and mounting /opt
tune2fs 1.38 (30-Jun-2005)
Setting maximal mount count to 20
Setting interval between checks to 0 seconds
Checking and mounting /mnt

Thank You.
emersonvier
DD-WRT Novice


Joined: 16 Jun 2008
Posts: 35
Location: Sao Paulo, Brazil

PostPosted: Wed Dec 03, 2008 21:10    Post subject: Re: WRT350n v1 How configure USB storage Reply with quote
Guys, today I make donate the 12.00Euro to DDWRT.

Thanks for kjbuente for all help.

EMERSON VIER

emersonvier wrote:
I try configure my WRT350n v1 to use my external HD, I read the
http://www.dd-wrt.com/wiki/index.php/USB_storage
But I not sucess Embarassed
I use the v24 sp2, can I help configure this..

I will donate by Paypal 15.00USD to people or to DDWRT for this help.
Sorry my bad english :oops:

Thx Laughing

EMERSON VIER
SKYPE: emersonvier
MSN: emersonvier@hotmail.com
Draconis2941
DD-WRT Novice


Joined: 07 Dec 2008
Posts: 7

PostPosted: Sun Dec 07, 2008 3:15    Post subject: Reply with quote
Apparently my first post didn't take. So... long story short this time. I also have a wrt350n and followed the steps listed by emersonvier above. Most things worked but I swapon never seemed to install and I can't access SWAT thought Samba is running (I can see the tmp directory in my win xp network). Any thoughts ?
kjbuente
DD-WRT User


Joined: 31 Mar 2007
Posts: 181
Location: /Earth/USA/OH/Zville

PostPosted: Sun Dec 07, 2008 3:54    Post subject: Reply with quote
@bzzbr
Sorry, I did not see you post till now. Good info to know that you had enough space then.

@Draconis2941 & bzzbr

The reason swap is not working is because I made a typo in the script. I am going to upload the script again with the correction. (I also got the ad-block script working, still not sure if it will update automatically. If it does not update, still worth it IMO).

As far as not getting SWAT to load. Check to see if xinetd is running. You can see it running by running top and look for "/opt/sbin/xinetd" in the right hand side. If it is running, and Samba is running then I would think that it is a browser issue. Clear you history and all that stuff and try again.

Please tell me if you have any errors in /mnt/logs/scripts.log. If you do Post it please.

_________________
WRT-350N v1.0; 128MB RAM, WPC600N, Dual USB, Mini+USB+FTP NEWD, CPU@330Mhz, Terk WF-R x3, Serial, external jtag, and working on SD Mod. Running Samba3, Lighttpd, and some Python apps.
WRT-300N v1.1; 128MB Ram, USB1.1, Bricked

ALL FOR SALE!
Draconis2941
DD-WRT Novice


Joined: 07 Dec 2008
Posts: 7

PostPosted: Sun Dec 07, 2008 4:01    Post subject: Reply with quote
Looks like it's not running. I tried starting it manually with "/opt/etc/init.d/S10xinetd start" and still no go. I've found the samba config file and have been playing with that trying to get the directory I want, but i'm having trouble getting it right.
kjbuente
DD-WRT User


Joined: 31 Mar 2007
Posts: 181
Location: /Earth/USA/OH/Zville

PostPosted: Sun Dec 07, 2008 4:33    Post subject: Reply with quote
what does "ps | grep xinetd" say after you run it? you should see something like...

Code:
root@WRT350N:~#  ps | grep xinetd
  610 root      1372 S    /opt/sbin/xinetd
root@WRT350N:~#


or do you get this...
Code:

root@WRT350N:~#  ps | grep xinetd
root@WRT350N:~#

_________________
WRT-350N v1.0; 128MB RAM, WPC600N, Dual USB, Mini+USB+FTP NEWD, CPU@330Mhz, Terk WF-R x3, Serial, external jtag, and working on SD Mod. Running Samba3, Lighttpd, and some Python apps.
WRT-300N v1.1; 128MB Ram, USB1.1, Bricked

ALL FOR SALE!
Draconis2941
DD-WRT Novice


Joined: 07 Dec 2008
Posts: 7

PostPosted: Sun Dec 07, 2008 4:39    Post subject: Reply with quote
I get:

Code:

root@WRT350N:~#  ps | grep xinetd
root@WRT350N:~#


I'm guessing that means the install didn't take right.
kjbuente
DD-WRT User


Joined: 31 Mar 2007
Posts: 181
Location: /Earth/USA/OH/Zville

PostPosted: Sun Dec 07, 2008 4:42    Post subject: Reply with quote
Quote:
I'm guessing that means the install didn't take right.


Yea, I'm thinking it did not intsall possibly. Have you tried to installing it again? (/opt/bin/ipkg-opt install xinetd) Does it say nothing to do? Or does it download and install?

_________________
WRT-350N v1.0; 128MB RAM, WPC600N, Dual USB, Mini+USB+FTP NEWD, CPU@330Mhz, Terk WF-R x3, Serial, external jtag, and working on SD Mod. Running Samba3, Lighttpd, and some Python apps.
WRT-300N v1.1; 128MB Ram, USB1.1, Bricked

ALL FOR SALE!
Draconis2941
DD-WRT Novice


Joined: 07 Dec 2008
Posts: 7

PostPosted: Sun Dec 07, 2008 5:13    Post subject: Reply with quote
The first re-install wouldn't go. I removed and reinstalled and it still doesn't show under top.

Code:

root@DD-WRT:~# /opt/bin/ipkg-opt install xinetd
Package xinetd (2.3.14-8) installed in /opt/ is up to date.
Nothing to be done
Successfully terminated.
root@DD-WRT:~# /opt/bin/ipkg-opt remove xinetd
Removing package xinetd from /opt/...
Successfully terminated.
root@DD-WRT:~# /opt/bin/ipkg-opt install xinetd
Installing xinetd (2.3.14-8) to /opt/...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/ddwrt/cross/stable/xinetd_2.3.14-8_mipsel.ipk
Configuring xinetd
Warning: the current only_from configuration in /opt/etc/xinetd.conf is
        only_from      = localhost 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16
change to your subnet accordingly and tighten security!
Successfully terminated.
root@DD-WRT:~# /opt/etc/init.d/S10xinetd start
kjbuente
DD-WRT User


Joined: 31 Mar 2007
Posts: 181
Location: /Earth/USA/OH/Zville

PostPosted: Sun Dec 07, 2008 14:08    Post subject: Reply with quote
what version of dd-wrt are you using?
_________________
WRT-350N v1.0; 128MB RAM, WPC600N, Dual USB, Mini+USB+FTP NEWD, CPU@330Mhz, Terk WF-R x3, Serial, external jtag, and working on SD Mod. Running Samba3, Lighttpd, and some Python apps.
WRT-300N v1.1; 128MB Ram, USB1.1, Bricked

ALL FOR SALE!
Draconis2941
DD-WRT Novice


Joined: 07 Dec 2008
Posts: 7

PostPosted: Sun Dec 07, 2008 18:40    Post subject: Reply with quote
I'm on "dd-wrt.v24-11028_NEWD_mini_usb". I got swapon working last night using busy box, but SWAT is still eluding me and I can't access the drive in XP.

-Update-

Ok, still no SWAT but I've managed to cobble together the settings to allow me to access and read from the attached usb drive. I've even managed to install and configure uShare and have streamed files to my ps3. Now I just have to figure out the issue with writing to the share. I can't seem to get a "chmod 777" to stick on the "/mnt" directory, I think that may be part of the problem.
kjbuente
DD-WRT User


Joined: 31 Mar 2007
Posts: 181
Location: /Earth/USA/OH/Zville

PostPosted: Mon Dec 08, 2008 4:16    Post subject: Reply with quote
Well, always been a fan of the CLI anyways. So kudos for figuring the config file. Really not that hard one you get a hang of it. As far as writing to the drive. The only way I could do that is issue a "chmod a+rw /mnt". Never had an issue since.
_________________
WRT-350N v1.0; 128MB RAM, WPC600N, Dual USB, Mini+USB+FTP NEWD, CPU@330Mhz, Terk WF-R x3, Serial, external jtag, and working on SD Mod. Running Samba3, Lighttpd, and some Python apps.
WRT-300N v1.1; 128MB Ram, USB1.1, Bricked

ALL FOR SALE!
Goto page Previous  1, 2, 3  Next Display posts from previous:    Page 2 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum