HTTP device admin not responding

Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3
Author Message
DD-WRT Developer/Maintainer

Joined: 07 Jun 2006
Posts: 5771

PostPosted: Mon Sep 25, 2006 14:44    Post subject: Reply with quote
koitsu wrote:

If there's a "hold the reset button on the back of the router for 30 seconds" solution *while the kernel is loaded*, that's news to me.

Eko, can you confirm that the "hold button for 30 seconds while unit is running" method does something other than simply reboot the unit? I imagine the reason it works is because holding down the button while the kernel is loaded results in a unit reset, then since the user is holding the button still, CFE/PMON sees this and does what I described above...

Yes, the resetbuttond checks the button, if short pressed -> reboot, if pressed more than 3 s (Yes 3s !, not 30), then erase nvram and reboot.
30 is only for people counting seconds very very fast. Very Happy
DD-WRT Novice

Joined: 25 Sep 2006
Posts: 1

PostPosted: Tue Sep 26, 2006 4:51    Post subject: v23 SP2 upgrade problem Reply with quote
I also encountered this problem in upgrading a WRT54Gv6 router to DD-WRT v23 SP2 from SP1. Bridging to a separate access point as well as Internet access worked fine after the upgrade, but I could not access the router's web UI. I tried various suggestions made in earlier postings from the DD-WRT forum, but was not able to either telnet or ssh into the router, which reduced my options. In the end, a 30-second reset followed by manual reconfiguration of all the settings did the trick.

One detail I discovered is that following the reset, I could view the DD-WRT UI via Firefox but could not save any changes to the settings. I had to switch to Internet Explorer in order to reconfigure them.

Thanks to earlier posters on this forum who saved me days of time and stress dealing with headaches like this!
DD-WRT Novice

Joined: 29 Sep 2006
Posts: 1

PostPosted: Fri Sep 29, 2006 19:30    Post subject: Reply with quote
Guys, I'm having the same problem and about to go nuts. I've bought a brand new WRT54GL, and flashed version 23 SP2 mini. I can't access the web admin. People here are talking about SSHing to the thing, but I can't. I'm using Putty to address over port 22 and it says connection refused. Could anyone give me a hint of how to solve this? Thanks a lot

PS: I'm sorry guys. I'mve missed the part about the reset, I was trying to SSH. After reseting it works. I apologize for not having read the whole thing
DD-WRT Novice

Joined: 17 Jun 2006
Posts: 5

PostPosted: Fri Sep 29, 2006 23:15    Post subject: Reply with quote
Try telnet, I think it's enabled by default.

I ran into this EXACT same problem. httpd crashed right after delivering the head tag, and telnet was the only way I could get into the router. Upon checking the "language" setting, mine was also set to "EN", and setting it to "english" fixed it.

This is a pretty serious bug, and I think it warrants spinning a new release of SP2 that properly changes the language setting after an upgrade. Even if the instructions are to restore to factory defaults after an upgrade (which is a huge annoyance when you have a lot of customized settings), if a user neglects to do this, their router is effectively bricked if they don't know how to use a linux console. They can't even log into the web ui to restore factory settings after the upgrade.
DD-WRT Novice

Joined: 02 Oct 2006
Posts: 1

PostPosted: Mon Oct 02, 2006 9:28    Post subject: Reply with quote
Hi, im quite new to 3rd party firmware upgrading.

And I have the same language bug on my linksys router upon upgrading...

so how do I implent the
nvram set language=english
nvram commit

code onto my router?

Do I just use tftp command like this: tftp [-i] put nvram set

nvram commit

if not then how?
DD-WRT Novice

Joined: 07 Nov 2006
Posts: 8

PostPosted: Sat Nov 11, 2006 18:07    Post subject: Reply with quote
I've been having this problem also lately but only happens after i save my setting using wireless. Never happen when i setup my router using CAT5 cable.

and then i turn on Frameburst and afterburner under Wireless --> advanced settings

and httpd always work. I'm guessing that when you press Save ( while using wireless ) the wireless transmission got cut-off before it finish.

using WHR-HP-G54
Goto page Previous  1, 2, 3 Display posts from previous:    Page 3 of 3
Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum