New build: DD-WRT 30805 - 2016/10/27

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
KrypteX
DD-WRT Guru


Joined: 18 Jan 2014
Posts: 2411

PostPosted: Fri Oct 28, 2016 9:33    Post subject: New build: DD-WRT 30805 - 2016/10/27 Reply with quote
DD-WRT build 30805 - 2016/10/27 has been released: ftp://ftp.dd-wrt.com/betas/2016/10-27-2016-r30805

Changelog: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=279466

Your reports for Broadcom units are greatly appreciated !
Router:
Firmware:
Kernel:
Status:
Reset:
Errors:

This build thread is for reporting successes and problem with loading this experimental test build. This is important info for developers and users. Always state your hardware and SPECIFIC build. Do not ask questions about your specific router or how to configure it in this thread; create your own thread to discuss any specific problems you have or need resolved. Please also do not respond to such questions. This thread is to report info, not to seek it. Posts that do not add to understanding this build will be deleted. Make sure you know how to flash properly and the risk before using this build. It is important to adhere to these requirements, to keep this thread from becoming impossibly long and useless. If you don't know what build to flash and how to flash properly and have a means of recovery if things should go wrong, do NOT flash this experimental test build.

_________________
THERE ARE NO STRANGERS HERE; ONLY FRIENDS YOU HAVEN'T YET MET.
________________________________________________________________________________________________________
DD-WRT CHANGELOG | DEVICES | DD-WRT BUILDS | KONG BUILDS | UNOFFICIAL BUILDS | DD-WRT in VIRTUALBOX

Testing BrainSlayer's DD-WRT build 31924 on various units:
NETGEAR : WNDR3800 WNDR3800CH WNDRMACv2 WNDRMACv1 WNR2200 WNR2000v3
TP-LINK : ArcherC7v3 WR1043NDv3 WR740Nv4 WR740Nv6 WR710Nv1 WR810Nv1 WA850REv1 WA901NDv3 WA901NDv4
D-LINK : DIR-862L DIR-615D2
ASUS : RT-N10 C1
VirtualBox : x86_64
Sponsor
smapdi
DD-WRT Novice


Joined: 11 Sep 2006
Posts: 36

PostPosted: Fri Oct 28, 2016 13:26    Post subject: Reply with quote
Router: R7000
Firmware: r30805
Previous: r30796
Kernel: Linux 4.4.28-rc1 #1537 SMP Thu Oct 27 00:31:45 CEST 2016 armv7l
Status: Working. R7000 is the main router + OpenVPN Server
Reset: No, dirty flash from previous release
Errors: None so far with uptime of 6 minutes (too short for any conclusions)




Valeriy_tc
DD-WRT User


Joined: 03 Sep 2016
Posts: 57
Location: Ukraine

PostPosted: Fri Oct 28, 2016 14:16    Post subject: Reply with quote
Router: Linksys EA6400
Firmware: DD-WRT v3.0-r30805 std (10/27/16)
Kernel: Linux 4.4.28-rc1 #1537 SMP Thu Oct 27 00:31:45 CEST 2016 armv7l
Status: Working
Reset: No. Previous release r30771
Errors: No.
Newbrain
DD-WRT User


Joined: 28 Dec 2013
Posts: 152

PostPosted: Fri Oct 28, 2016 18:17    Post subject: Asus RT-AC68U & 2 Linksys E2000 Reply with quote
Asus RT-AC68U
DD-WRT v3.0-r30805 std (10/27/16) (previous r30796)
Kernel: Linux 4.4.28-rc1 #1537 SMP Thu Oct 27 00:31:45 CEST 2016 armv7l
2.4Ghz (NG-mixed) with 40Mhz channel width: Ok
5Ghz (Mixed) with 80Mhz channel width: Ok
SSH: Ok
Telnet: Disabled but tested to work
USB 2.0 storage ext3 mount to JFFS: Ok
USB 3.0 storage EXT3 mount to /mnt: Ok
Samba shared drive: Ok
Site Survey: Ok
Wi-viz Survey 2.4Ghz & 5Ghz: Ok
Reset: No
Status: Ok
Uptime: 8 minutes
CPU Temperature: CPU 70.2 °C / WL0 47.0 °C / WL1 46.5 °C

2 x E2000
DD-WRT v3.0-r30805 mega (10/27/16) (previous r30796)
Kernel: Linux 3.10.104 #14725 Thu Oct 27 14:25:53 CEST 2016 mips
2.4Ghz (NG-mixed) with 40Mhz channel width: Ok
SSH: Ok
Telnet: Disabled but tested to work
Site Survey: Ok
Wi-viz Survey 2.4Ghz: Ok
Reset: No
Status: Ok
Uptime: 18 minutes
CPU Temperature: WL0 54.4 °C

All devices working as AP's each with individual 1Gb wired connections to main firewall
SinCalChewy
DD-WRT User


Joined: 09 Nov 2014
Posts: 311
Location: Bakersfield, CA

PostPosted: Fri Oct 28, 2016 19:37    Post subject: Reply with quote
Router: 2x Linksys e3000
Firmware: dd-wrt.v24-30805_NEWD-2_K3.x_mega-e3000.bin
Previous: dd-wrt.v24-30796_NEWD-2_K3.x_mega-e3000.bin
Kernel: Linux 3.10.104 #14725 Thu Oct 27 14:25:53 CEST 2016 mips
Status: Working as client bridges
Reset: No
Errors: None thus far



Router: Trendnet TEW811DRU
Firmware: DD-WRT v3.0-r30805 mini (10/27/16)
Previous: DD-WRT v3.0-r30796 mini (10/25/16)
Kernel: Linux 4.4.28-rc1 #1540 Thu Oct 27 08:45:29 CEST 2016 armv7l
Status: Working as a client bridge
Reset: No
Errors: None thus far

_________________

Deployed Routers:
Netgear R7000 - 5x build 44538M
- Gateway: DoT/DoH, CAKE QoS, USB /w Entware
- Second Subnet Gateway: CAKE QoS, USB /w Entware
- Client Bridge x3: USB /w Entware

Spares/Backups/Collection:
Too many to list. I have old routers, bricked routers, weird routers. You name it.
rnix
DD-WRT User


Joined: 23 Feb 2016
Posts: 131

PostPosted: Fri Oct 28, 2016 20:45    Post subject: Reply with quote
Router: Asus RT-N18U
Firmware: DD-WRT v3.0-r30805 std (10/27/16)
Kernel: Linux 4.4.28-rc1 #1541 Thu Oct 27 08:52:02 CEST 2016 armv7l
Status: Working
Reset: Yes (erase nvram)
Errors: Yes, same as always.

- LAN LED stays always off and WAN LED stays always on (even if cable is physically unplugged)
- http://svn.dd-wrt.com/ticket/5183
Bernadoe
DD-WRT User


Joined: 03 Dec 2014
Posts: 215

PostPosted: Sat Oct 29, 2016 1:40    Post subject: Reply with quote
Router : Netgear R7000
Firmware: DD-WRT v3.0-r30805 std (10/27/16)
Kernel: Linux 4.4.28-rc1 #1537 SMP Thu Oct 27 00:31:45 CEST 2016 armv7l
Status: Working
Reset: No
Previous: 30796
Errors: No

CPU 52.5 °C / WL0 44.9 °C / WL1 48.7 °C

Ah-Pin-Kor
DD-WRT User


Joined: 19 Sep 2015
Posts: 267

PostPosted: Sat Oct 29, 2016 4:45    Post subject: Reply with quote
Router: D-Link DIR-895L
Firmware: DD-WRT v3.0-r30805 (10/27/16)
Kernel: Linux 4.4.28-rc1 #1542 SMP Thu Oct 27 08:58:51 CEST 2016 armv7l
Status: LAN ports not working and wl2 not detected
Reset: Yes
Errors:

LAN/WAN ports don't work.
Tried pinging router's LAN IP with static IP on PC (wired connection), no response.
Able to connect thru wl0.
Webgui shows wl0 and wl1 detected. No configuration available for wl2.
Same symptoms as last few builds.
partial dmesg below:

et: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
et_module_init: passivemode set to 0x0
et_module_init: txworkq set to 0x0
et_module_init: et_txq_thresh set to 0x400
et_module_init: et_rxlazy_timeout set to 0x3e8
et_module_init: et_rxlazy_framecnt set to 0x20
et_module_init: et_rxlazy_dyn_thresh set to 0
ET Corerev 7
eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 7.14.89.21 (r524987)
et1: etc_attach() failed
ET Corerev 7
eth1: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 7.14.89.21 (r524987)
roboswitch: Probing device 'eth0'
roboswitch: trying a 53012! at eth0
detected CPU Port is 8
roboswitch: found a 53012! at eth0
detected CPU Port is 8
PCI: Enabling device 0001:03:00.0 (0140 -> 0142)
PCI: Enabling device 0001:04:00.0 (0140 -> 0142)
random: nonblocking pool is initialized
PCI: Enabling device 0002:01:00.0 (0140 -> 0142)
wl_module_init: passivemode set to 0x0
wl_module_init: txworkq set to 0x0
Handle DIR885 workaround
eth0: mixed HW and IP checksum settings.
eth1: mixed HW and IP checksum settings.
device br0 entered promiscuous mode
device vlan1 entered promiscuous mode
device eth0 entered promiscuous mode
device eth1 entered promiscuous mode
device eth2 entered promiscuous mode
device eth3 entered promiscuous mode
br0: port 4(eth3) entered forwarding state
br0: port 4(eth3) entered forwarding state
br0: port 3(eth2) entered forwarding state
br0: port 3(eth2) entered forwarding state
br0: port 2(eth1) entered forwarding state
br0: port 2(eth1) entered forwarding state
br0: port 1(vlan1) entered forwarding state
br0: port 1(vlan1) entered forwarding state
device br0 left promiscuous mode
device br0 entered promiscuous mode
device br0 left promiscuous mode
device vlan2 entered promiscuous mode
device vlan2 left promiscuous mode
br0: port 4(eth3) entered forwarding state
br0: port 3(eth2) entered forwarding state
br0: port 2(eth1) entered forwarding state
br0: port 1(vlan1) entered forwarding state
root@DD-WRT:~#

_________________

Netgear R7800 kongpro 19.07 20190919 || Netgear R7000 36070M kongac (Client Bridge=5GHz, AP=2.4GHz with bridged VAP)
Linksys WRT32X davidc502 OpenWrt || Linksys WRT1200ACv1 Gargoyle 1.11.x
Linksys WRT1900ACSv2 dd-wrt 39956
himbeere
DD-WRT Novice


Joined: 20 Aug 2008
Posts: 16

PostPosted: Sat Oct 29, 2016 15:05    Post subject: Reply with quote
My Netgear R7000 reboots every 5 minutes now. Had to go back to 30731.
suprnova74
DD-WRT Novice


Joined: 09 Feb 2012
Posts: 12

PostPosted: Sat Oct 29, 2016 16:54    Post subject: Reply with quote
Router: R7000
Firmware: DD-WRT v3.0-27734 STD
Kernel: Kernel 3.2.71 / 3.10.87 / 4.1.5
Status: Update successful
Reset: No, dirty flash
Errors: None during flash, short uptime so no discernible difference yet.

Previous version had sporadic network drops on some older wireless clients. I'm curious if this will resolve it. Pretty basic configuration other than some port forwarding type rules.

UPDATE: Uptime of 2D 45 minutes so far. The only thing I noticed is some clients had to be rebooted or wireless connection reset post upgrade as performance was slow. Once a connection reset was done, speeds are fine. Primarily Roku devices were affected. No detected wireless drops on the laptops yet


Last edited by suprnova74 on Mon Oct 31, 2016 17:23; edited 1 time in total
Scootcha
DD-WRT Novice


Joined: 23 May 2014
Posts: 40

PostPosted: Sun Oct 30, 2016 17:38    Post subject: Reply with quote
Router: Netgear WNDR3400v1
Firmware: dd-wrt.v24-30805_NEWD-2_K3.x_mega-nv64k.bin
Kernel: Linux 3.10.104 #14693 Tue Oct 25 15:40:04 CEST 2016 mips
Status: Failed
Reset: Yes, via 30/30/30 and serial and downrev
Errors: Software hung on boot load attempt

Reverted to DD-WRT v3.0-r30796 mega (10/25/16)
hubermania
DD-WRT User


Joined: 24 Aug 2012
Posts: 223

PostPosted: Sun Oct 30, 2016 23:21    Post subject: Reply with quote
Router: Asus RT-AC66U
Firmware: DD-WRT v3.0-r30805 giga (10/27/16)
Previous: DD-WRT v3.0-r30731 giga (10/06/16)
Kernel: Linux 3.10.104 #14709 Thu Oct 27 14:09:03 CEST 2016 mips
Status: OK
Reset: Yes via GUI
Errors: None

IPv6 DHCPv6 PD: OK
WAN/LAN ports: OK
2.4GHz 40MHz N AP: OK
5GHz 40MHz AC/N AP: OK
ISP 30/6 Bandwidth: 30.82/6.07 IPv4, 29.69/6.04 IPv6
Site Survey: OK
Wiviz Survey: OK
OpenVPN Server: OK
USB Flash Drive: OK mounting /opt, /jffs, /swap partitions
Privoxy + Easylist: OK on /jffs
CPU Temperature: WL0 50.5 °C / WL1 55.0 °C

_________________
[Broadcom] Asus rt-ac66u r35531 ('66 should only be factory reset through the DD UI)
Fix RT-AC66U "wl1 [2.4 GHz TurboQAM]". DD-WRT failsafe UI @ http|https://169.254.255.1/
M
DD-WRT User


Joined: 29 Dec 2012
Posts: 169

PostPosted: Mon Oct 31, 2016 6:56    Post subject: Re: New build: DD-WRT 30805 - 2016/10/27 Reply with quote
r30805
Netgear-R6250
factory to dd-wrt.chk

Reboot looping after the flashing

TFTP Mode does not work for recovery.

Rom Chip is Spansion. It is not Samsung so It always be unstable.

Please remind the developer.
https://wikidevi.com/wiki/Netgear_R6250

https://wikidevi.com/w/images/0/0b/R6250.jpg
labo
DD-WRT Guru


Joined: 30 Jan 2015
Posts: 675
Location: Texas, USA

PostPosted: Wed Nov 30, 2016 3:31    Post subject: Reply with quote
Ah-Pin-Kor,
So what firmware you are now using it for your D-Link DIR-895L now? I have a new DIR-895L router but not able make it work with BS builds.
The issue I see is the MAC addresses are same for all three wireless and are incorrect.
Thanks,

Ah-Pin-Kor wrote:
Router: D-Link DIR-895L
Firmware: DD-WRT v3.0-r30805 (10/27/16)
Kernel: Linux 4.4.28-rc1 #1542 SMP Thu Oct 27 08:58:51 CEST 2016 armv7l
Status: LAN ports not working and wl2 not detected
Reset: Yes
Errors:

LAN/WAN ports don't work.
Tried pinging router's LAN IP with static IP on PC (wired connection), no response.
Able to connect thru wl0.
Webgui shows wl0 and wl1 detected. No configuration available for wl2.
Same symptoms as last few builds.
partial dmesg below:

et: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
et_module_init: passivemode set to 0x0
et_module_init: txworkq set to 0x0
et_module_init: et_txq_thresh set to 0x400
et_module_init: et_rxlazy_timeout set to 0x3e8
et_module_init: et_rxlazy_framecnt set to 0x20
et_module_init: et_rxlazy_dyn_thresh set to 0
ET Corerev 7
eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 7.14.89.21 (r524987)
et1: etc_attach() failed
ET Corerev 7
eth1: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 7.14.89.21 (r524987)
roboswitch: Probing device 'eth0'
roboswitch: trying a 53012! at eth0
detected CPU Port is 8
roboswitch: found a 53012! at eth0
detected CPU Port is 8
PCI: Enabling device 0001:03:00.0 (0140 -> 0142)
PCI: Enabling device 0001:04:00.0 (0140 -> 0142)
random: nonblocking pool is initialized
PCI: Enabling device 0002:01:00.0 (0140 -> 0142)
wl_module_init: passivemode set to 0x0
wl_module_init: txworkq set to 0x0
Handle DIR885 workaround
eth0: mixed HW and IP checksum settings.
eth1: mixed HW and IP checksum settings.
device br0 entered promiscuous mode
device vlan1 entered promiscuous mode
device eth0 entered promiscuous mode
device eth1 entered promiscuous mode
device eth2 entered promiscuous mode
device eth3 entered promiscuous mode
br0: port 4(eth3) entered forwarding state
br0: port 4(eth3) entered forwarding state
br0: port 3(eth2) entered forwarding state
br0: port 3(eth2) entered forwarding state
br0: port 2(eth1) entered forwarding state
br0: port 2(eth1) entered forwarding state
br0: port 1(vlan1) entered forwarding state
br0: port 1(vlan1) entered forwarding state
device br0 left promiscuous mode
device br0 entered promiscuous mode
device br0 left promiscuous mode
device vlan2 entered promiscuous mode
device vlan2 left promiscuous mode
br0: port 4(eth3) entered forwarding state
br0: port 3(eth2) entered forwarding state
br0: port 2(eth1) entered forwarding state
br0: port 1(vlan1) entered forwarding state
root@DD-WRT:~#
Ah-Pin-Kor
DD-WRT User


Joined: 19 Sep 2015
Posts: 267

PostPosted: Wed Nov 30, 2016 6:35    Post subject: Reply with quote
labo wrote:
Ah-Pin-Kor,
So what firmware you are now using it for your D-Link DIR-895L now? I have a new DIR-895L router but not able make it work with BS builds.
The issue I see is the MAC addresses are same for all three wireless and are incorrect.
Thanks,

Ah-Pin-Kor wrote:
Router: D-Link DIR-895L
Firmware: DD-WRT v3.0-r30805 (10/27/16)
Kernel: Linux 4.4.28-rc1 #1542 SMP Thu Oct 27 08:58:51 CEST 2016 armv7l
Status: LAN ports not working and wl2 not detected
Reset: Yes
Errors:

LAN/WAN ports don't work.
Tried pinging router's LAN IP with static IP on PC (wired connection), no response.
Able to connect thru wl0.
Webgui shows wl0 and wl1 detected. No configuration available for wl2.
Same symptoms as last few builds.
partial dmesg below:

et: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
et_module_init: passivemode set to 0x0
et_module_init: txworkq set to 0x0
et_module_init: et_txq_thresh set to 0x400
et_module_init: et_rxlazy_timeout set to 0x3e8
et_module_init: et_rxlazy_framecnt set to 0x20
et_module_init: et_rxlazy_dyn_thresh set to 0
ET Corerev 7
eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 7.14.89.21 (r524987)
et1: etc_attach() failed
ET Corerev 7
eth1: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 7.14.89.21 (r524987)
roboswitch: Probing device 'eth0'
roboswitch: trying a 53012! at eth0
detected CPU Port is 8
roboswitch: found a 53012! at eth0
detected CPU Port is 8
PCI: Enabling device 0001:03:00.0 (0140 -> 0142)
PCI: Enabling device 0001:04:00.0 (0140 -> 0142)
random: nonblocking pool is initialized
PCI: Enabling device 0002:01:00.0 (0140 -> 0142)
wl_module_init: passivemode set to 0x0
wl_module_init: txworkq set to 0x0
Handle DIR885 workaround
......
root@DD-WRT:~#


I've gone back to stock v1.12 for now.

_________________

Netgear R7800 kongpro 19.07 20190919 || Netgear R7000 36070M kongac (Client Bridge=5GHz, AP=2.4GHz with bridged VAP)
Linksys WRT32X davidc502 OpenWrt || Linksys WRT1200ACv1 Gargoyle 1.11.x
Linksys WRT1900ACSv2 dd-wrt 39956
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum