Not able to enter 64bit WEP key in v24 SP1 - please help!

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
orange
DD-WRT Guru


Joined: 05 Sep 2007
Posts: 532
Location: 49.50N, 08.44E

PostPosted: Mon Jul 28, 2008 11:30    Post subject: Not able to enter 64bit WEP key in v24 SP1 - please help! Reply with quote
Folks,

I encounter the following problem with v24-sp1. I configure my f*nera in client mode and I need to define a 64bit WEP key in Wireless/Wireless Security Tab. After entering the key 1 and pressing apply, the setting changes back to blank (same happens when pressing save). therefore I'm not able to configure the network at all. I never had this problem with previous dd-wrt versions before. Anyone else? BS, if that's a bug.. could you please fix it? I tried it several times starting with factory defaults, but to no avail.

Please help!

_________________
7x La Fonera 2100, 1x NanoStation2 Loco
running bleeding edge openwrt backfire/attitude adjustment
or4n9e on irc.freenode.net
Sponsor
orange
DD-WRT Guru


Joined: 05 Sep 2007
Posts: 532
Location: 49.50N, 08.44E

PostPosted: Mon Jul 28, 2008 19:11    Post subject: Reply with quote
nobody?
if that's really a bug (and I honestly believe so) and not my personal fault, that's a big showstopper! isn't it?
could someone please test it and report if it's working?

_________________
7x La Fonera 2100, 1x NanoStation2 Loco
running bleeding edge openwrt backfire/attitude adjustment
or4n9e on irc.freenode.net
campigenus
DD-WRT Guru


Joined: 01 Apr 2007
Posts: 520

PostPosted: Mon Jul 28, 2008 19:18    Post subject: Reply with quote
Had the same problem with pre SP1 Eko built. I went back to the June 20 built. This is with micro on a V5 router.
_________________
"You think you´re real smart. But you´re not smart; you´re dumb. Very dumb. But you´ve met your match in me. "
Colonel Flagg
orange
DD-WRT Guru


Joined: 05 Sep 2007
Posts: 532
Location: 49.50N, 08.44E

PostPosted: Tue Jul 29, 2008 18:44    Post subject: Reply with quote
Glad to hear, that I'm not the only one facing this problem.
JFYI, I reflashed one of my f*neras today through redboot with an initial "fis init -f" to make sure every messed up configuration is definitely erased, BUT..
the issue remains as is!
So, as this is obviously a bug (3 f*neras behaving the same here), how to get the appropriate attention from developers? I'm willing to test if that helps. Should I open a ticket or what? If so, how to report bugs properly for dd-wrt? Is there a bugtracking system? Obviously developers are not in the loop with forum posts (I can imagine) - otherwise someone had taken care of that REAL showstopper already.
Is there anything I could do? Let me know, and please fix this problem. The f*nera is pretty useless in this configuration atm and as it seems this doesn't only affect the f*nera.

_________________
7x La Fonera 2100, 1x NanoStation2 Loco
running bleeding edge openwrt backfire/attitude adjustment
or4n9e on irc.freenode.net
ubn123
DD-WRT Novice


Joined: 29 Jul 2008
Posts: 1

PostPosted: Tue Jul 29, 2008 23:08    Post subject: Reply with quote
To modify 64bit wep key first set mode to 64bit via web interface, then telnet to your router ip, enter username: "root" and your password. Then type:
nvram set ath0_key1="YOURWEPKEY" (WITH QOUTES)
nvram commit
reboot
SonicPower
DD-WRT Novice


Joined: 10 Apr 2008
Posts: 31

PostPosted: Thu Jul 31, 2008 7:00    Post subject: Reply with quote
Same thing happens to me on 128-bit encryption, but when I try to connect to my wireless network, it works!

::shrug::
orange
DD-WRT Guru


Joined: 05 Sep 2007
Posts: 532
Location: 49.50N, 08.44E

PostPosted: Thu Jul 31, 2008 9:18    Post subject: Reply with quote
Quote:
To modify 64bit wep key first set mode to 64bit via web interface, then telnet to your router ip, enter username: "root" and your password. Then type:
nvram set ath0_key1="YOURWEPKEY" (WITH QOUTES)
nvram commit
reboot

Thanks a lot for the appropriate nvram command. I'll try that out asap. btw, does the key appear in webgui after rebooting?
Quote:
Same thing happens to me on 128-bit encryption, but when I try to connect to my wireless network, it works!

That's quite interesting. So you mean, the key does not appear in webgui but actually works, although the setting is blank after hitting apply?

_________________
7x La Fonera 2100, 1x NanoStation2 Loco
running bleeding edge openwrt backfire/attitude adjustment
or4n9e on irc.freenode.net
Simon
DD-WRT Guru


Joined: 20 Jul 2007
Posts: 612

PostPosted: Wed Aug 06, 2008 1:07    Post subject: Reply with quote
This issue has already been fixed, if you check the SVN. I updated my Broadcom routers to the latest Broadcom TNG newer than SP1 firmware for this EXACT reason and all is now fine with WEP.

We just have to "beg" BrainSlayer to compile a newer v24 SP1 build for the F*nera. :-)

Maybe next month he'll release v24 SP2, instead.

-Simon
orange
DD-WRT Guru


Joined: 05 Sep 2007
Posts: 532
Location: 49.50N, 08.44E

PostPosted: Wed Aug 06, 2008 6:53    Post subject: Reply with quote
@SonicPower
I tried your approach and it definitely works! Very confusing though.
@ubn123
I verified the nvram ath0_key1 and SonicPower's proposal sets the value accordingly.

Thanks a lot for your help!

@Simon
Thanks for the hint with the SVN.

@BrainSlayer
Would it be possible for you to release a fixed v24-sp1 for the f*nera? Please, that would be very supportive!
edit
If so, please also take this bug(?) http://dd-wrt.com/phpBB2/viewtopic.php?t=36066 into account. Thanks a lot in advance!

_________________
7x La Fonera 2100, 1x NanoStation2 Loco
running bleeding edge openwrt backfire/attitude adjustment
or4n9e on irc.freenode.net
xames
DD-WRT Novice


Joined: 09 Mar 2010
Posts: 4

PostPosted: Tue Mar 09, 2010 11:37    Post subject: wep key Reply with quote
I have to repeat router neighbour with wep key and i can't do it, always limited conection, how i can now if the trouble is in wep key or in other things? The key is good because without repeat connect perfect, but when i put in linksys in key1 with hex mode not work, how i have to put there.

Sorry my english.

Thanks.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum