20080726 - v24 sp1 special - build ~10020 (updated)

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom Customer Downloads & Updates
Goto page 1, 2, 3, 4  Next
Author Message
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7027
Location: Dresden, Germany

PostPosted: Sat Jul 26, 2008 11:38    Post subject: 20080726 - v24 sp1 special - build ~10020 (updated) Reply with quote
Hello after some long nights of development i'm happy to anounce the release of v24-sp1. i will post the special edition a little bit earlier than the official release since i still have to collect some changelog and anouncement informations.

here are the most important changes: (special changes included)

special enhancements:
ZeroIP in Services->Hotspot added (mini,std special only)
UP/DOWN shaping for ip and mac finally working

overall enhancements:
DNS security fix for dnsmasq
Site Survey security fix
Passwords longer chan 8 characters are now supported
forced password change on first installation
support for WRT300 v1.1
support for WRT310N
support for WRT600N v1.1
support for new Netgear, Belkin and USR devices
support for Tonze AP42X (Xscale)
support for Pronghorn SBC (Xscale)
support for Ubiquiti LSX devices
Noise Immunity configuration for atheros cards
RTS/CTS configuration for atheros based cards
performance increase and fixes for atheros cards
VAP bssid fix for Broadcom devices (fixes various wpa issues)
chillispot key server update to key.chillispot.info
(change on request by chillispot.info since chillispot.org is not available anymore)
support for swedish language
enhanced italian language
mac address correction for DIR-400 devices
decrease memory footprint for micro distribution
reintroduce sputnik in micro
sputnik fix for server type
more flexible openvpn configuration
TX PA detection for some atheros cards (to adjust displayed output power and to correct power setting)
work around for chillispot crashes, caused by a mikrotik bug
allow more flexible vlan configurations
support for vlan trunking on broadcom switches (except gigabit)

and some other hidden, invisible, forgotten enhancements

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s


Last edited by BrainSlayer on Sun Jul 27, 2008 18:21; edited 2 times in total
Sponsor
Tuurbo
DD-WRT Novice


Joined: 20 May 2008
Posts: 14

PostPosted: Sat Jul 26, 2008 16:05    Post subject: Reply with quote
Thank you voor this fine release!
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7027
Location: Dresden, Germany

PostPosted: Sat Jul 26, 2008 17:21    Post subject: Reply with quote
i hope it solves the most problems. if not, just post it and i will try to solve it as soon as possible
_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
shizuo
DD-WRT User


Joined: 10 Feb 2008
Posts: 72

PostPosted: Sun Jul 27, 2008 2:09    Post subject: Reply with quote
Thanks! Will try it out later tonight.
MikeP lowman
DD-WRT Novice


Joined: 22 Jun 2008
Posts: 28

PostPosted: Sun Jul 27, 2008 7:12    Post subject: Reply with quote
Upgraded my WRT54GL from v23 sp2 to the new v24 micro special, not changing any settings, and when it rebooted I had no internet access and other devices could not connect to the wlan. I checked all my settings and they seemed the same as I had on v23.

I connect via PPOE and had DHCP enabled but nothing. I flashed back to v23 and it worked fine again.

I'm sure it's just me missing something obvious but I have no idea what?

Any ideas anyone.

Thanks for the update BS
manu
DD-WRT User


Joined: 17 Feb 2007
Posts: 136
Location: Giesen b. Hildesheim

PostPosted: Sun Jul 27, 2008 11:31    Post subject: Reply with quote
under Services the Tab :My Ad Network kills my Webinterface in Std Version and in Std Mega Version testet on 2 different Router.
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7027
Location: Dresden, Germany

PostPosted: Sun Jul 27, 2008 13:30    Post subject: Reply with quote
MikeP lowman wrote:
Upgraded my WRT54GL from v23 sp2 to the new v24 micro special, not changing any settings, and when it rebooted I had no internet access and other devices could not connect to the wlan. I checked all my settings and they seemed the same as I had on v23.

I connect via PPOE and had DHCP enabled but nothing. I flashed back to v23 and it worked fine again.

I'm sure it's just me missing something obvious but I have no idea what?

Any ideas anyone.

Thanks for the update BS


why do you flash micro on a GL?

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7027
Location: Dresden, Germany

PostPosted: Sun Jul 27, 2008 13:33    Post subject: Reply with quote
manu wrote:
under Services the Tab :My Ad Network kills my Webinterface in Std Version and in Std Mega Version testet on 2 different Router.


okay, found and fixed. will reupload as soon as all is recompiled. (takes some hours)

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
dahuafschmied
DD-WRT Novice


Joined: 07 Jun 2006
Posts: 20
Location: UpperAustria

PostPosted: Sun Jul 27, 2008 17:01    Post subject: Reply with quote
hi bs
i have found a little typo bug in "Multiple DHCP Server"

Code:

press add:
leasetime is called Max.

then press apply:
leasetime is called leasetime.


and perhaps you set the default settings (lease time) to the same values as in the defalt dhcp server.


dahuafschmied

_________________
Alles ist schon einmal gesagt worden, aber da niemand zuhört, muß man es immer wieder sagen.
MikeP lowman
DD-WRT Novice


Joined: 22 Jun 2008
Posts: 28

PostPosted: Sun Jul 27, 2008 17:20    Post subject: Reply with quote
BrainSlayer wrote:
MikeP lowman wrote:
Upgraded my WRT54GL from v23 sp2 to the new v24 micro special, not changing any settings, and when it rebooted I had no internet access and other devices could not connect to the wlan. I checked all my settings and they seemed the same as I had on v23.

I connect via PPOE and had DHCP enabled but nothing. I flashed back to v23 and it worked fine again.

I'm sure it's just me missing something obvious but I have no idea what?

Any ideas anyone.

Thanks for the update BS


why do you flash micro on a GL?


Because I'm stupid/uninformed/a dick. Delete as applicable. :-)

That's the version of v23 sp2 that I downloaded and flashed to it and that worked so I got the micro version of v24 as well. And to be honest, I don't know what the differences are. The micro version of v23 sp2 does everything I want (apart from upload limit) si I assumes the other version would have extra things in that I probably don't need?

What version should I be using?
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7027
Location: Dresden, Germany

PostPosted: Sun Jul 27, 2008 18:15    Post subject: Reply with quote
MikeP lowman wrote:
BrainSlayer wrote:
MikeP lowman wrote:
Upgraded my WRT54GL from v23 sp2 to the new v24 micro special, not changing any settings, and when it rebooted I had no internet access and other devices could not connect to the wlan. I checked all my settings and they seemed the same as I had on v23.

I connect via PPOE and had DHCP enabled but nothing. I flashed back to v23 and it worked fine again.

I'm sure it's just me missing something obvious but I have no idea what?

Any ideas anyone.

Thanks for the update BS


why do you flash micro on a GL?


Because I'm stupid/uninformed/a dick. Delete as applicable. :-)

That's the version of v23 sp2 that I downloaded and flashed to it and that worked so I got the micro version of v24 as well. And to be honest, I don't know what the differences are. The micro version of v23 sp2 does everything I want (apart from upload limit) si I assumes the other version would have extra things in that I probably don't need?

What version should I be using?


on the GL alot of people would choose std or mini. the micro is really reduced at many points. if it works, its okay

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7027
Location: Dresden, Germany

PostPosted: Sun Jul 27, 2008 18:15    Post subject: Reply with quote
all files are now reuploaded
_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7027
Location: Dresden, Germany

PostPosted: Sun Jul 27, 2008 18:22    Post subject: Reply with quote
dahuafschmied wrote:
hi bs
i have found a little typo bug in "Multiple DHCP Server"

Code:

press add:
leasetime is called Max.

then press apply:
leasetime is called leasetime.


and perhaps you set the default settings (lease time) to the same values as in the defalt dhcp server.


dahuafschmied


if you press save, it will be correctly displayed. i fixed this small typo now. the last one should be "leasetime"

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
shaad
DD-WRT User


Joined: 19 May 2008
Posts: 78

PostPosted: Mon Jul 28, 2008 7:15    Post subject: Reply with quote
Thanks BS, you're the best :D

Cheers
Demonicos
DD-WRT Novice


Joined: 10 Jul 2008
Posts: 4

PostPosted: Mon Jul 28, 2008 13:17    Post subject: Reply with quote
W00T, Thanks brainslayer QoS now seems to be working and IP/MAC shaping is also working well.

One question though MAC shaping seemed to limit the local LAN side not just the WAN, is this normal?, if not it does not matter they can suffer slow LAN speeds as punishment.
Goto page 1, 2, 3, 4  Next Display posts from previous:    Page 1 of 4
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom Customer Downloads & Updates All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum