Posted: Sun Aug 09, 2026 17:52 Post subject: New Build - 08/09/2026 - r65908
Welcome to x86 / x64 r65908 beta release thread for reporting, feedback to developers & community benefit.
Please do not flash builds until installation is understood, risks involved and device specificrecovery methods.
Avoid discussions, create threads for questions, general problems or use search; this thread is not for support.
List router model & version or revision, operating & wireless modes & exact filename/firmware image flashed.
CLI Flash: 'cd /tmp' then 'wget {file URL}' (httponly) or 'curl -O {file URL}' (http, https, ftp) 'write {file} linux' then 'reboot'.
Issues, observations, and/or workarounds reported:
• WebUI: Clear history or use a portable. Temporary cache bypass: Ctrl+F5, Cmd+Shift+R or new private window/incognito.
• Please report findings with steps needed to reproduce, configuration, clients, output, logs and important information below!
Important:
• Detail issues & relevant configs, logs: syslog klog 'dmesg' 'cat /tmp/var/log/messages' nvram set console_debug=1, serial.
• Firewall NAT: 'iptables -vnL' 'iptables -t nat -vnL' 'iptables -t mangle -vnL' & 'cat /tmp/.ipt'. Debug Analyze: stracetcpdump.
• Gremlins: reboot. cold boot. Reset & reconfigure not restore backup. Search Trac & discuss in forum before opening tickets.
• Include operating & wireless modes (e.g. Gateway, Router, AP, SB, WDS, Mesh) and applicable configurations to reproduce.
Router/Version: industrial PC N4000 4GB RAM, 2*intel i226-v, running dd-wrt_x64_full_vga_2GB.image
File: /x86-64/web/dd-wrt_x64-webupgrade_full_vga.bin
Firmware: DD-WRT v3.0-r65908 std (08/09/26) (prev. DD-WRT v3.0-r65876 std (08/05/26))
Kernel: Linux 6.12.102 #1251 SMP Sun Aug 9 05:13:26 +06 2026 x86_64
Mode: Gateway, SFE disabled, Wireguard for external access, WAN (ETH0, ethernet) to Docsis Router (exposed host, since no bridge available), ETH1 to LAN, Automatic Drive Mount disabled - using own mount script for USB Disk, nfs to access USB3-ext4 SSD, using my own local NTP, CPU governour set to ondemand by script, Ignore WAN DNS, Recursive DNS Resolving (Unbound), using NAT66, DHCP disabled.
Reset: No
Status: Installed yesterday, on several reboots unbound was there but didnt do anything. No Nameresolution until I killed and restarted the process "killall -HUP unbound".
Did not observe any unbound related segfaults like in previous older reports.
cat /var/log/messages |grep -i unbound -B2 -A2
Code:
Aug 10 23:25:59.622 N4000 user.info : [rpc.mountd] : successfully started
Aug 10 23:25:59.675 N4000 user.info root: Enable WireGuard interface oet1 on port 35087
Aug 10 23:25:59.751 N4000 user.info : [unbound] : successfully started
Aug 10 23:25:59.763 N4000 daemon.notice unbound: [3530:0] notice: init module 0: validator
Aug 10 23:25:59.763 N4000 daemon.notice unbound: [3530:0] notice: init module 1: iterator
Aug 10 23:25:59.790 N4000 daemon.info unbound: [3530:0] info: start of service (unbound 1.26.0).
Aug 10 23:25:59.790 N4000 kern.info kernel: [ 34.088721] oet1: entered promiscuous mode
Aug 10 23:25:59.834 N4000 kern.warn kernel: [ 34.127237] ksmbd: unknown parameter 'connlimit' ignored
--
Aug 10 23:26:00.883 N4000 daemon.crit dnsmasq[3933]: FAILED to start up
Aug 10 23:26:00.889 N4000 user.info : [dnsmasq] : Error on startup, returncode 2
Aug 10 23:26:00.908 N4000 daemon.info unbound: [3530:0] info: service stopped (unbound 1.26.0).
Aug 10 23:26:00.908 N4000 daemon.info unbound: [3530:0] info: server stats for thread 0: 6 queries, 0 answers from cache, 6 recursions, 0 prefetch, 0 rejected by ip ratelimiting
Aug 10 23:26:00.908 N4000 daemon.info unbound: [3530:0] info: server stats for thread 0: requestlist max 7 avg 4.5 exceeded 0 jostled 0
Aug 10 23:26:00.909 N4000 daemon.info unbound: [3530:0] info: server stats for thread 1: 7 queries, 0 answers from cache, 7 recursions, 0 prefetch, 0 rejected by ip ratelimiting
Aug 10 23:26:00.909 N4000 daemon.info unbound: [3530:0] info: server stats for thread 1: requestlist max 7 avg 3.85714 exceeded 0 jostled 0
Aug 10 23:26:00.913 N4000 user.info : [unbound] : daemon successfully stopped
Aug 10 23:26:00.927 N4000 daemon.notice unbound: [3937:0] notice: init module 0: validator
Aug 10 23:26:00.929 N4000 user.info : [unbound] : successfully started
Aug 10 23:26:00.929 N4000 daemon.notice unbound: [3937:0] notice: init module 1: iterator
Aug 10 23:26:00.951 N4000 daemon.info unbound: [3937:0] info: start of service (unbound 1.26.0).
Aug 10 23:26:00.997 N4000 user.info root: WireGuard acquiring /tmp/oet-tunnels.lock for prewall 3943
Aug 10 23:26:01.053 N4000 user.info root: WireGuard NAT via oet1 for 192.168.90.1 enabled
--
killed unbound and namresolution became working instantly:
Code:
Aug 10 21:25:52.090 N4000 user.info root: WireGuard firewall removing temporary killswitch for IPv4
Aug 10 21:25:52.092 N4000 user.info root: WireGuard firewall removing temporary killswitch for IPv6
Aug 10 21:26:52.221 N4000 daemon.info unbound: [3937:0] info: service stopped (unbound 1.26.0).
Aug 10 21:26:52.222 N4000 daemon.info unbound: [3937:0] info: server stats for thread 0: 285 queries, 0 answers from cache, 285 recursions, 0 prefetch, 0 rejected by ip ratelimiting
Aug 10 21:26:52.222 N4000 daemon.info unbound: [3937:0] info: server stats for thread 0: requestlist max 27 avg 21.0386 exceeded 0 jostled 0
Aug 10 21:26:52.223 N4000 daemon.info unbound: [3937:0] info: server stats for thread 1: 213 queries, 0 answers from cache, 213 recursions, 0 prefetch, 0 rejected by ip ratelimiting
Aug 10 21:26:52.223 N4000 daemon.info unbound: [3937:0] info: server stats for thread 1: requestlist max 26 avg 19.6479 exceeded 0 jostled 0
Aug 10 21:26:52.224 N4000 daemon.notice unbound: [3937:0] notice: Restart of unbound 1.26.0.
Aug 10 21:26:52.229 N4000 daemon.notice unbound: [3937:0] notice: init module 0: validator
Aug 10 21:26:52.229 N4000 daemon.notice unbound: [3937:0] notice: init module 1: iterator
Aug 10 21:26:52.244 N4000 daemon.info unbound: [3937:0] info: start of service (unbound 1.26.0).
Aug 10 21:26:52.279 N4000 daemon.info unbound: [3937:0] info: generate keytag query _ta-4a5c-4f66. NULL IN
Aug 10 21:27:27.874 N4000 authpriv.info dropbear[3829]: Exit (root) from <192.168.1.204:45430>: Disconnect received
Aug 10 21:36:02.949 N4000 daemon.info httpd[4272]: [httpd] : Authentication fail for ::ffff:192.168.1.223
--
Aug 11 07:25:49.906 N4000 daemon.info process_monitor[4260]: [ntp] : Cyclic NTP Update success (servers 192.168.1.254)
Aug 11 07:25:49.906 N4000 daemon.info process_monitor[4260]: [ntp] : Local timer delta is 0
Aug 11 08:25:29.317 N4000 daemon.info unbound: [3937:0] info: generate keytag query _ta-4f66. NULL IN
Aug 11 08:25:49.934 N4000 daemon.debug ntpclient[7631]: Connecting to 192.168.1.254 [192.168.1.254] ...
Aug 11 08:25:49.936 N4000 daemon.info ntpclient[7631]: Time set from 192.168.1.254 [192.168.1.254].
Running php scripts gives an error on first line, but works:
Code:
Warning: Failed loading Zend extension 'opcache.so' (tried: /etc/php/modules/opcache.so (Error loading shared library /etc/php/modules/opcache.so: No such file or directory), /etc/php/modules/opcache.so.so (Error loading shared library /etc/php/modules/opcache.so.so: No such file or directory)) in Unknown on line 0