New Build - 03/03/2024 - r55262

Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 5780

PostPosted: Sun Mar 03, 2024 17:15    Post subject: New Build - 03/03/2024 - r55262 Reply with quote
Welcome to Atheros r55262 beta release thread for reporting, feedback to developers and community benefit.
Please do not flash builds until installation is understood, risks involved and device specific recovery methods.
Avoid discussions, create threads for questions, general problems or use search; this thread is not for support.
List router model & version or revision, operating & wireless modes & exact filename/firmware image flashed.


CLI Flash: 'cd /tmp' then 'wget {file URL}' (http only) or 'curl -O {file URL}' (http, https, ftp) 'write {file} linux' then 'reboot'.

Downloads: HTTPS, FTP

Trac SVN: repository since last build 55209 (mirror)

OpenVPN 2.6.8: Changelog, Guides, Server, PBR, DNS, Kill Switch, Watchdog, Reverse PBR, Client, Multiple, tips & scripts.
WireGuard 1.0.20211208/Tools: Changelog, Guides, Client, Server, Adv, PBR, KS, tips & scripts. Thanks BS egc & eibgrad!

Notes:
r54203 r54248 r54420 r54475 r54517 r54545 r54569 r54604 r54637 r54652 r54682 r54905 r54914 r55003 r55009 r55033
r55052 r55109 r55179 r55209 r55262

Issues, observations, and/or workarounds reported:
WebUI: Clear history or use a portable. Temporary cache bypass: Ctrl+F5, Cmd+Shift+R or new private window/incognito.
Please report findings with steps needed to reproduce, configuration, clients, output, logs and important information below!

Important:
Detail issues & relevant configs, logs: syslog klog 'dmesg' 'cat /tmp/var/log/messages' nvram set console_debug=1, serial.
• Firewall NAT: 'iptables -vnL' 'iptables -t nat -vnL' 'iptables -t mangle -vnL' & 'cat /tmp/.ipt'. Debug Analyze: strace tcpdump.
• Gremlins: reboot. cold boot. Reset & reconfigure not restore backup. Search Trac & discuss in forum before opening tickets.
• Include operating & wireless modes (e.g. Gateway, Router, AP, SB, WDS, Mesh) and applicable configurations to reproduce.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
whitebeard
DD-WRT User


Joined: 26 Jul 2013
Posts: 127
Location: Canada

PostPosted: Sun Mar 03, 2024 18:06    Post subject: Reply with quote
Router/Version: Netgear R7500v2
Kernel: Linux 6.1.80 #113 SMP Sun Mar 3 03:42:19 +07 2024 armv7l
Previous/Reset: 55179 / No Reset
Mode: Gateway+AP, SFE Disabled, STP Disabled, Wifi 5(VANILLA)/2.4(VANILLA) Main+Guest(VAP), DNSMasq, USB(3.2, Ext2)/Entware, DNSCrypt, NAS/Samba, Static & DHCP, SSH, FTP, QoS (WAN) using MAC.
Issues/Errors: Upgraded Ok. SMB still crashes the router on saves to router mounted USB Drive. Otherwise everything else seems Ok.

Thanks to BS and crew for all your good work.

To test the SMB I read a test.txt file from the USB and save an edit. To repair the drive corruption I perform an fsck which appears to consistently detect damage in the same filesystem structures.
Code:

# fsck -v /dev/sda1
fsck 1.47.0 (5-Feb-2023)
e2fsck 1.47.0 (5-Feb-2023)
opt was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Inode 56 has a bad extended attribute block 1006.  Clear<y>? yes
Inode 56, i_blocks is 8, should be 4.  Fix<y>? yes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Block bitmap differences:  +14848 -14849
Fix<y>? yes
opt: ***** FILE SYSTEM WAS MODIFIED *****

        7117 inodes used (0.15%, out of 4890624)
         823 non-contiguous files (11.6%)
           7 non-contiguous directories (0.1%)
             # of inodes with ind/dind/tind blocks: 823/14/0
      379997 blocks used (3.89%, out of 9778688)
           0 bad blocks
           0 large files

        6301 regular files
         696 directories
           0 character device files
           0 block device files
           0 fifos
           0 links
         111 symbolic links (111 fast symbolic links)
           0 sockets
------------
        7108 files

jrscs
DD-WRT User


Joined: 09 Aug 2010
Posts: 444

PostPosted: Sun Mar 03, 2024 18:58    Post subject: Reply with quote
Router/Version: Netgear XR500 Nighthawk Pro Gaming (Install guide by egc)
Firmware: DD-WRT v3.0-r55262 std (03/03/24)
Kernel: Linux 6.1.80 #113 SMP Sun Mar 3 03:42:19 +07 2024 armv7l
Previous: DD-WRT v3.0-r55209 std (02/27/24)
Update Method: SSH / CLI using PuTTY with ‘firmware.bin’ install
Mode/Status: Gateway / Ok
Reset: No
Setup:
2.4 GHz N/G Mixed 20 MHz WPA2 - Vanilla, 2.4 GHz guest (VAP) WPA2
5.0 GHz AC/N Mixed 80 MHz WPA2 - Vanilla
IPv4, DHCP, DNSMasq, Static Leases, Port Forwarding
USB 3.2 Gen 1 (USB 3.0) Seagate One Touch 2TB STKB2000400 (exFAT), NAS, Samba (Restricted User/Password)
NTP Client
Wireguard Server
Wake-on-WAN (Internet)
SFE Disabled, QoS Disabled
Issues/Errors: Router crashes and reboots immediately when trying to upload a file using SMB Windows 10, File Explorer, to USB drive attached to router

Thanks B.S.

_________________
Netgear XR500, R7800
Asus AC87Ua1
Repeater Bridge
Netgear R6400v2otp
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 6910
Location: Romerike, Norway

PostPosted: Sun Mar 03, 2024 19:09    Post subject: Reply with quote
Router/Version: Netgear R7800
File/Kernel: 6.1.80 #113 SMP Sun Mar 3 03:42:19 +07 2024 armv7l
Previous/Reset: No Reset
Mode/Status: Working
Issues/Errors:
MLandi
DD-WRT Guru


Joined: 04 Dec 2007
Posts: 1055

PostPosted: Sun Mar 03, 2024 19:25    Post subject: Reply with quote
Update method: SSH / CLI using PuTTY
Router/Version: Netgear R9000
File/Kernel: DD-WRT v3.0-r55262 std (03/03/24)
Previous/Reset: DD-WRT v3.0-r55209 std (02/27/24)
Mode/Status: Gateway / Working Normally
Issues/Errors: None

_________________
Netgear R9000
DD-WRT v3.0-r57447 std (07/17/24)
Linux 4.9.337 #745 SMP Wed Jul 10 04:29:39 +07 2024 armv7l
Gateway, AP, DNSMasq, Clock 2000MHz
VAP on wlan1 for internet devices
IPv4 & IPv6 (Prefix Delegation)
Static Leases & DHCP
SmartDNS (using Cloudflare, Quad9 and Google), no QoS, no SFE
2.4GHz: Vanilla, Airtime Fairness, NG-Mixed, ACK Timing 3150, WPA2 w=4/>/AES & WPA3
5GHz: Vanilla, Airtime Fairness, AC/N Mixed, ACK Timing 3150, WPA2 w/AES & WPA3
2 Netgear AX1800 WiFi Mesh Extenders
Xfinity 1.2Gbps/35Mbps
IONK
DD-WRT Guru


Joined: 19 Aug 2011
Posts: 1012

PostPosted: Sun Mar 03, 2024 19:38    Post subject: Reply with quote
Router/Version: Netgear XR500 (Install guide by egc)
File/Kernel: dd-wrt-webupgrade.bin (r55262) / Linux 6.1.80 #113 SMP Sun Mar 3 03:42:19 +07 2024 armv7l
Previous/Reset: DD-WRT v3.0-r55209 std (02/27/24) / no
Mode/Status: AP, SFE, AP 5GHz Mixed 80MHz + AP 2.4GHz NG-Mixed 20MHz, WPA2/WPA3-Personal, 802.11r (FT), SSH (public key), DDNS (Dynu.com), 802.11 encapsulation offloading, ondemand CPU governor at night, SuperSpeed USB Storage (guide by egc), lighttpd (using Entware’s php8), WireGuard server, Cron / working
Issues/Errors: none

_________________
▫ RSS feed for DD-WRT releases (2024): https://rsseverything.com/feed/7d36ab68-7733-46c3-bd8a-9c54c5cef08c.xml
easyddup - A simple upgrade/downgrade utility by yoyoma2 --- as featured in 📌 Reference Links, stickies retired back to forum (Moderator's Pick 🌟)
KACTET
DD-WRT User


Joined: 01 May 2022
Posts: 287

PostPosted: Sun Mar 03, 2024 23:03    Post subject: Reply with quote
Router/Version: TP-Link TL-WR841ND v11
Update method: WebUpgrade
File/Kernel: tl-wr841nd-webflash.bin_r55262 / Linux 3.18.140-d6 #194452 Sun Mar 3 07:57:19 +06 2024 mips
Previous/Reset: r55209 / no
Mode/Status: AP wired and wireless / Up and running for 4:12 hours
Issues/Errors: Nothing significant

The fact is that the router connected to the Internet (to the Internet provider). And it reports an error, the orange WAN indicator flashes (the icon in the form of a planet). Internet is working, I just think it's a glitch

Thank you BS and gurus!

_________________
Atheros
Netgear XR500 Nighthawk - DD-WRT 56409
Tp-Link TL-WDR4900 v1.3 - DD-WRT 53133
TP-Link WR1043ND v4 - DD-WRT 51838
TP-Link WR1043ND v2 - Gargoyle OS 1.13.0
TP-Link WR841ND v11 - DD-WRT 57200
Broadcom
Asus RT-AC87U R - DD-WRT 56941
Asus RT-N66U - DD-WRT 57200
Linksys WRT54GL v1.1 - DD-WRT 54517M
Linksys WRT54GL v1.1 - FreshTomato 2023.4_MIPS_K26
Linksys WRT54GL v1.1 - Gargoyle OS 1.6.2
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 6327
Location: Texas

PostPosted: Mon Mar 04, 2024 4:40    Post subject: Reply with quote
Netgear WNDR3700 V4
DD-WRT v3.0-r55262 std (03/03/24)
Linux 3.18.140-d6 #194494 Sun Mar 3 09:42:18 +06 2024 mips
scp 'firmware.bin' install over r55209
WAP + OVPN server -- all ok

#

Linksys WRT160NL
DD-WRT v3.0-r55262 std (03/03/24)
Linux 3.10.108-d11 #154240 Sun Mar 3 06:10:00 +06 2024 mips
GUI install over r55209
WAP + OVPN server -- all ok

EDIT:
and this is all worky ok also ...I VPNed to it & done the upgrade
...just have to disconnect soon as it starts the reboot
Twisted Evil
Linksys E2100L
DD-WRT v3.0-r55262 std (03/03/24)
Linux 3.10.108-d11 #154244 Sun Mar 3 06:15:25 +06 2024 mips
GUI install over r55209
WAP + OVPN server
dpp3530
DD-WRT Guru


Joined: 12 Dec 2007
Posts: 829
Location: Pittsburgh, PA USA

PostPosted: Mon Mar 04, 2024 16:01    Post subject: Reply with quote
Router/Version: Netgear R7800 x 3
File/Kernel: DD-WRT v3.0-r55262 std (03/03/24)
Previous/Reset: DD-WRT v3.0-r55209 std (02/27/24), last reset at 54905
Mode/Status: Gateway (SFE disabled), Access Point (VANILLA firmware,2.4GHz, 5GHZ, WPA2/WPA3, 802.11r/v/k), IPV6 (DHCP6 w/ prefix delegation), Entware, DOT via SmartDNS/DNSMasq, OpenVPN server, Wireguard Server + 2 wired access points (VANILLA firmware,2.4GHz, 5GHZ, WPA2/WPA3, 802.11r/v/k)
Issues/Errors:
Up 19 hours. USB 3.0 working properly for Entware and "jffs" partitions. Wireguard and OpenVPN servers working as expected and throughput sufficient to open video files on network shares. Speed (tested via nPerf.com) is very close to published, both wired and wireless, which is equal or favorable to the ISP router. SFE remains disabled due to random reboots. Router LAN lights are working.

I almost feel bad that I have nothing to report. Everything I use in the firmware works fine (except SFE but that seems like a K6 thing, and I don't really need it).

Thanks Brainslayer and Devs

_________________
__________________________
Netgear R7800
DD-WRT v3.0 STD
Linksys WRT1900AC
DD-WRT v3.0 STD
nkaufman
DD-WRT User


Joined: 21 Jun 2015
Posts: 268

PostPosted: Sat Mar 09, 2024 23:00    Post subject: Issue Reply with quote
Router/Version: R7800
File/Kernel: DD-WRT v3.0-r55262 std (03/03/24)
Previous/Reset: 02-02-2024-r55052
Mode/Status:

Issues/Errors: Lost 5GHz connection after Radio Time scheduling

Installed r55262, made changes to radio time scheduling, hit 'Save', then 'Apply Settings'.
Lost 5GHz connection, could connect w/2.4GHz. Hard reboot also didn't fix it.

Went back to r55052 and restored settings from backup file I had for that version. everything worked fine.
Then installed r55262 again, made a backup of settings.
Went back to radio scheduling to check how it behaves.
made changes to radio time scheduling, hit 'Save', then 'Apply Settings'.
Lost 5GHz connection again, could connect w/2.4GHz. Hard reboot also didn't fix it.

I reverted settings from backup that I made and everything is working fine.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum