Openvpn has stopped working-new setup didn't help

Post new topic   Reply to topic    DD-WRT Forum Index -> Advanced Networking
Goto page 1, 2  Next
Author Message
bobby121418
DD-WRT Novice


Joined: 17 Jan 2022
Posts: 32

PostPosted: Mon Nov 20, 2023 18:52    Post subject: Openvpn has stopped working-new setup didn't help Reply with quote
Hi,
I have a Netgear R8000 running DD-WRT v3.0-r50500 std (10/13/22)
I had Openvpn configured and was working well until a short time ago, and I used the OpenVPN on Andoid.
Recently, however, the app no longer connects.
For this I follwed the newer guide from link below and setup all the certificates again.

https://forum.dd-wrt.com/forum/viewtopic.php?p=1247444&sid=e12a4d916676079882140826b9f1aa88

I used OpenVPN-2.6.8-I001-amd64 and EasyRSA-3.1.7-win64 to create the certificates.

However, I am still not having any luck connecting to the Netgear server.

According to Status tab on Netgear, the Server is up and running.

Is there anything I should look for?
Any help would be greatly appreciated.

Many thanks
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12795
Location: Netherlands

PostPosted: Mon Nov 20, 2023 19:05    Post subject: Reply with quote
You need the OpenVPN server setup guide see https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398

Note the minimum required version.

But you might consider using WireGuard also a sticky (first few threads) in this forum.
Much faster and easier to setup.

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087


Last edited by egc on Tue Nov 21, 2023 6:29; edited 1 time in total
dale_gribble39
DD-WRT Guru


Joined: 11 Jun 2022
Posts: 1856

PostPosted: Tue Nov 21, 2023 2:56    Post subject: Reply with quote
You should be aware that the guide linked in that thread by sir egc is the same guide that he linked in this one and is constantly updated </PSA>

bobby121418 wrote:
For this I followed the newer guide from link below and setup all the certificates again.

https://forum.dd-wrt.com/forum/viewtopic.php?p=1247444&sid=e12a4d916676079882140826b9f1aa88
Code:
Posted: Sun Oct 03, 2021 11:08    Post subject: [SOLVED]How to setup an OpenVPN server on DDWRT
egc wrote:
You need the open vpn server setup guide see https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
Code:
Last edited by egc on Mon Nov 20, 2023 14:01; edited 107 times in total

_________________
"The woods are lovely, dark and deep,
But I have promises to keep,
And miles to go before I sleep,
And miles to go before I sleep." - Robert Frost

"I am one of the noticeable ones - notice me" - Dale Frances McKenzie Bozzio

<fact>code knows no gender</fact>

This is me, knowing I've ruffled your feathers, and not giving a ****
Some people are still hard-headed.

--------------------------------------
Mac Pro (Mid 2012) - Two 2.4GHz 6-Core Intel Xeon E5645 processors 64GB 1333MHz DDR3 ECC SDRAM OpenSUSE Leap 15.5
bobby121418
DD-WRT Novice


Joined: 17 Jan 2022
Posts: 32

PostPosted: Fri Nov 24, 2023 21:16    Post subject: Reply with quote
dale_gribble39 wrote:
You should be aware that the guide linked in that thread by sir egc is the same guide that he linked in this one and is constantly updated </PSA>

bobby121418 wrote:
For this I followed the newer guide from link below and setup all the certificates again.

https://forum.dd-wrt.com/forum/viewtopic.php?p=1247444&sid=e12a4d916676079882140826b9f1aa88
Code:
Posted: Sun Oct 03, 2021 11:08    Post subject: [SOLVED]How to setup an OpenVPN server on DDWRT
egc wrote:
You need the open vpn server setup guide see https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
Code:
Last edited by egc on Mon Nov 20, 2023 14:01; edited 107 times in total


Thank you dale_gribble39.

I want to upgrade my Netgear firmware from 10-13-2022-r50500 to 11-24-2023-r54109.
Just wondering if you might be aware of any issues?

Thanks again
Best
bobby121418
DD-WRT Novice


Joined: 17 Jan 2022
Posts: 32

PostPosted: Sun Nov 26, 2023 11:32    Post subject: Reply with quote
Hi,
I have updated the firmware to the latest
Firmware: DD-WRT v3.0-r54109 std (11/24/23)

and also checked the openvpn configuration in Services/VPN according to
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398

however while I get server: :CONNECTED SUCCESS
I still cannot get the client to connect to the server.
I have attached the log as I see it and ask if any one can help tell me what could be wrong.

Many thanks
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12795
Location: Netherlands

PostPosted: Mon Nov 27, 2023 10:46    Post subject: Reply with quote
On the server side set in the Additional Config:
verb 5
disable-dco

Show a screenshot of the server side: OpenVPN setup page and OpenVPN status page.

Show the log of the Client.

I noticed your WAN IP is 192.168.X.X so this router is not facing the internet.

Do you port forward from the primary router to the OpenVPN server router?

Does the primary router has a Public IP address (check if the WAN address is the same as the one from ipleak.net).
Please show the first octet (first three digits before the dot of the WAN address to check)

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
bobby121418
DD-WRT Novice


Joined: 17 Jan 2022
Posts: 32

PostPosted: Tue Nov 28, 2023 20:12    Post subject: Reply with quote
egc wrote:
On the server side set in the Additional Config:
verb 5
disable-dco

Show a screenshot of the server side: OpenVPN setup page and OpenVPN status page.

Show the log of the Client.

I noticed your WAN IP is 192.168.X.X so this router is not facing the internet.

Do you port forward from the primary router to the OpenVPN server router?

Does the primary router has a Public IP address (check if the WAN address is the same as the one from ipleak.net).
Please show the first octet (first three digits before the dot of the WAN address to check)


Thanks for your response.

I am attaching the files from server side, setup + status and client log.

I had port forwarding to the second router. To be sure, I deleted and added again, but still the same result.

The client log shows one attempt post re adding the port forwarding and additional config.

Checked WAN IP and it is the same as ipleak.net

The first octet is 95

Many thanks for your help.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12795
Location: Netherlands

PostPosted: Tue Nov 28, 2023 20:31    Post subject: Reply with quote
On the server you have specified to use a tls-auth key but the key box is empty.
That will not work.

So if you do not use a tls-auth key set tls key to none.

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
bobby121418
DD-WRT Novice


Joined: 17 Jan 2022
Posts: 32

PostPosted: Tue Nov 28, 2023 21:07    Post subject: Reply with quote
Not sure I fully understand this, but I set Hash algorithm in the dropdown menu to none.
I tried both with client.ovpn file with auth none and # auth none to have it removed.
Neither case produced a connection.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12795
Location: Netherlands

PostPosted: Tue Nov 28, 2023 21:15    Post subject: Reply with quote
No you have set TLS / Static key choice to tls auth.

But there is no key specified, the box is empty.

That is wrong either add a static key or set to "none" which is probably what you want.

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
bobby121418
DD-WRT Novice


Joined: 17 Jan 2022
Posts: 32

PostPosted: Tue Nov 28, 2023 21:47    Post subject: Reply with quote
I set TLS / Static key to none and rebooted.
However, still no connection.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12795
Location: Netherlands

PostPosted: Wed Nov 29, 2023 9:30    Post subject: Reply with quote
bobby121418 wrote:
I set TLS / Static key to none and rebooted.
However, still no connection.


Then show again your OpenVPN Setup page, the OpenVPN Status page and OpenVPN client log

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
bobby121418
DD-WRT Novice


Joined: 17 Jan 2022
Posts: 32

PostPosted: Wed Nov 29, 2023 21:37    Post subject: Reply with quote
Please see attached.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12795
Location: Netherlands

PostPosted: Thu Nov 30, 2023 7:03    Post subject: Reply with quote
Your server log shows:
Quote:
Connection Attempt read UDPv4 [ECONNREFUSED]: Connection refused (fd=6 code=111)


That can mean the following:
Quote:
ECONNREFUSED means that the port you are trying to connect to is not open on the IP you are trying to connect to. This implies that either you are connecting to the wrong IP, you did not open the port on your firewalls successfully, the server did not launch successfully, or the server is using a different port. Try this:


Sometimes using TCP4 instead if UDP4 will work

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
bobby121418
DD-WRT Novice


Joined: 17 Jan 2022
Posts: 32

PostPosted: Thu Nov 30, 2023 22:25    Post subject: Reply with quote
I am having some issue with the router's DDNS which was working before. In this firmware version the path is missing so I am not sure where to put the URL.

Any suggestions please?
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Index -> Advanced Networking All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum