USB mount problem / EX6200 memory stuck at 400MHz bug

Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
ZuluZebra
DD-WRT Novice


Joined: 16 Oct 2023
Posts: 14

PostPosted: Mon Oct 16, 2023 16:52    Post subject: USB mount problem / EX6200 memory stuck at 400MHz bug Reply with quote
Hi

I'm a new DD-WRT user with two questions for you.

I tested r53662 mini on my EX6200 and I can't figure out how to mount a usb drive, first I formatted it to fat32 on a linux computer using GParted - copied a file to it from win10 machine and when I choose 'Automatic Drive Mount', using ssh I can't see the file when I connect using Winscp.

I can copy the same file over using winscp, I can run it perfectly fine, I can see it active using 'PS' but if I shut down router and restart it file is gone from sda1.

I also tried turing off automount and added a startup command for mounting drive using UUID but file is still missing after a reboot.

mkdir -p /mnt/data
mount -t vfat $(findfs UUID="3D73-1EBC") /mnt/data

As you might have guessed I'm not not very well known in the linux world.
Any ideas for the correct way to make this work ?

Also this is more a bug, under Administration/Management there is an option to choose between 800MHz and 600MHz clock, standard is 800MHz cpu / 533MHz memory clock.

CFE for Foxconn Repeater EX6200 version: v2.0.8
Build Date: Thu Apr 17 18:30:49 CST 2014
Init Arena
Init Devs.
Boot up from NOR flash...
Boot partition size = 262144(0x40000)
DDR Clock: 533 MHz
Info: DDR frequency set from clkfreq=800,*533*
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.37.15.9 (r456593)
et1: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.37.15.9 (r456593)
CPU type 0x0: 800MHz
Tot mem: 131072 KBytes

If you set cpu to 600MHz memory is set at 400MHz.

CFE for Foxconn Repeater EX6200 version: v2.0.8
Build Date: Thu Apr 17 18:30:49 CST 2014
Init Arena
Init Devs.
Boot up from NOR flash...
Boot partition size = 262144(0x40000)
DDR Clock: 400 MHz
Warning: invalid DDR setting of 0 MHz ignored. DDR frequency will be set to 400 MHz.
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.37.15.9 (r456593)
et1: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.37.15.9 (r456593)
CPU type 0x0: 600MHz
Tot mem: 131072 KBytes

But if you now set it back to 800MHz memory clock is still 400MHz

CFE for Foxconn Repeater EX6200 version: v2.0.8
Build Date: Thu Apr 17 18:30:49 CST 2014
Init Arena
Init Devs.
Boot up from NOR flash...
Boot partition size = 262144(0x40000)
DDR Clock: 400 MHz
Warning: invalid DDR setting of 0 MHz ignored. DDR frequency will be set to 400 MHz.
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.37.15.9 (r456593)
et1: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.37.15.9 (r456593)
CPU type 0x0: 800MHz
Tot mem: 131072 KBytes

Factory Defaults via gui won't get it back to 533MHz, reset button on the back won't help either but 'nvram erase' from the command shell and a reboot will set memory at proper 533MHz.


Sorry for the wall of text.
Thanks



USB DD-WRT v3.0-r53662 mini.JPG
 Description:
 Filesize:  135.03 KB
 Viewed:  6328 Time(s)

USB DD-WRT v3.0-r53662 mini.JPG



Startup.JPG
 Description:
 Filesize:  24.78 KB
 Viewed:  6328 Time(s)

Startup.JPG



WinSCP.JPG
 Description:
 Filesize:  25.97 KB
 Viewed:  6328 Time(s)

WinSCP.JPG


Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12770
Location: Netherlands

PostPosted: Mon Oct 16, 2023 17:18    Post subject: Reply with quote
You can manually overclock: https://wiki.dd-wrt.com/wiki/index.php/Overclocking

for USB see: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=335183&start=4

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
ZuluZebra
DD-WRT Novice


Joined: 16 Oct 2023
Posts: 14

PostPosted: Mon Oct 16, 2023 21:30    Post subject: Reply with quote
Thanks, I now formatted the drive with free-partition manager and following the example with 3 partitions with fat32, opt and jffs.

All 3 partitons now is automounted during boot but files I write to any of those partitions using winscp is gone after a reboot of the router - I can't understand why that happens, anyone know why ?

Also, having a look at cpu and memory frequency using 'nvram get clkfreq' only shows cpu frequency but setting cpu/mem clock using 'nvram set clkfreq=800,533 nvram commit' fixes that - Thanks
I don't know if backplane frequency is altered, its not listed.



sda1-sda3 mounted.JPG
 Description:
 Filesize:  128.24 KB
 Viewed:  6286 Time(s)

sda1-sda3 mounted.JPG



blkid-UUID.JPG
 Description:
 Filesize:  39.42 KB
 Viewed:  6286 Time(s)

blkid-UUID.JPG



800,533.JPG
 Description:
 Filesize:  28.49 KB
 Viewed:  6286 Time(s)

800,533.JPG


egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12770
Location: Netherlands

PostPosted: Tue Oct 17, 2023 7:46    Post subject: Reply with quote
First of all do not use the Commands box to execute commands, use a proper telnet/SSH client e.g Putty.

Not sure what you did wrong you can use WinSCP to write to your USB stick, maybe you did not write to the USB stick but to the router?

Most of us use Samba (SMB) to write directly from our clients to the USB stick.
But WinSCP should also work.

The GUI to overclock CPU and RAM speed has been stripped as people tend to brick their routers with it. So you must set it manually

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
ZuluZebra
DD-WRT Novice


Joined: 16 Oct 2023
Posts: 14

PostPosted: Tue Oct 17, 2023 13:22    Post subject: Reply with quote
Very likely your on to something, if I copy my file to /tmp/mnt/sda1 will the file not be copied to the usb pendrive ?


tmp mnt.JPG
 Description:
 Filesize:  45.84 KB
 Viewed:  6245 Time(s)

tmp mnt.JPG


egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12770
Location: Netherlands

PostPosted: Tue Oct 17, 2023 13:49    Post subject: Reply with quote
If that is the mount point you can copy to it.

You can view your mount points with mount:
Quote:
root@EA6900:~# mount
/dev/root on / type squashfs (ro,relatime)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
ramfs on /tmp type ramfs (rw,relatime)
none on /dev type tmpfs (rw,relatime,size=512k)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
devpts on /proc/bus/usb type usbfs (rw,relatime)
/dev/sda3 on /jffs type ext4 (rw,noatime,nodiratime,nobarrier,init_itable=0)
/dev/sda4 on /opt type ext4 (rw,noatime,nodiratime,nobarrier,init_itable=0)
/dev/sda1 on /tmp/mnt/sda1 type vfat


note that for sda3 mount point is /jfss and for sda4 it is /opt.
but for sda1 it is /tmp/mnt/sda1 so with winscp I can write to /tmp/mnt/sdda1 but for sda3 I have to write to /jffs and for sda4 I have to write to /opt

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
ZuluZebra
DD-WRT Novice


Joined: 16 Oct 2023
Posts: 14

PostPosted: Tue Oct 17, 2023 14:13    Post subject: Reply with quote
My mount points is missing even if sda1,2,3 is visible in WinSCP - I have tried writing to jffs and opt but both are read only file systems.


DiskInfo.JPG
 Description:
 Filesize:  70.02 KB
 Viewed:  6231 Time(s)

DiskInfo.JPG



mount.JPG
 Description:
 Filesize:  56.28 KB
 Viewed:  6231 Time(s)

mount.JPG


egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12770
Location: Netherlands

PostPosted: Tue Oct 17, 2023 14:22    Post subject: Reply with quote
That is odd Question

Have you tried a reboot?

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
ZuluZebra
DD-WRT Novice


Joined: 16 Oct 2023
Posts: 14

PostPosted: Tue Oct 17, 2023 14:24    Post subject: Reply with quote
Oh yes, several times - also tried 2 other usbpens, I will try a full reset just to see if anything I did earlier perhaps messed something up.
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 2001

PostPosted: Tue Oct 17, 2023 14:33    Post subject: Reply with quote
ZuluZebra wrote:
I tested r53662 mini on my EX6200


Not sure you have flashed your router with the correct file.

https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2023/10-16-2023-r53662/netgear-ex6200/

_________________
Forum Guide Lines (with helpful pointers about how to research your router, where and what firmware to download, where and how to post and many other helpful tips!)
How to get help the right way

Before asking for help - Read the forum guidelines AND Upgrade DD-WRT!
ZuluZebra
DD-WRT Novice


Joined: 16 Oct 2023
Posts: 14

PostPosted: Tue Oct 17, 2023 14:50    Post subject: Reply with quote
I'm using the correct one, the mini is the only one for this extender.
I made sure I did't use the Router Database Smile



EX6200 53662.JPG
 Description:
 Filesize:  83.35 KB
 Viewed:  6210 Time(s)

EX6200 53662.JPG


ZuluZebra
DD-WRT Novice


Joined: 16 Oct 2023
Posts: 14

PostPosted: Tue Oct 17, 2023 22:10    Post subject: Reply with quote
I tested a few older ddwrt versions, could not make usb mount.

I flashed Netgear's EX6200_V1.0.0.38_1.1.52 and the same usbpen mounted all 3 partitions and I could see and download a file I wrote to the fat32 partition so now I know the extender hardware is ok and same with usb pen.

I will test r53662 more tomorrow.



Netgear USB setup.jpg
 Description:
 Filesize:  204.35 KB
 Viewed:  6165 Time(s)

Netgear USB setup.jpg



Netgear USB http.JPG
 Description:
 Filesize:  44.71 KB
 Viewed:  6165 Time(s)

Netgear USB http.JPG


kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 14038
Location: Texas, USA

PostPosted: Wed Oct 18, 2023 0:11    Post subject: Reply with quote
@bushant:

I presume that since the files are ~6.9MB in size and the hardware is Broadcom Northstar, it's considered a "mini" vs. "std" on similar hardware with larger flash space.

https://wikidevi.wi-cat.ru/Netgear_EX6200

I can always look through the code repo or annoy the head master, but that is my best presumption given the information in hand without further research.

_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Contribute To DD-WRT
Pogo - A minimal level of ability is expected and needed...
DD-WRT Releases 2023 (PolitePol)
DD-WRT Releases 2023 (RSS Everything)

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
ZuluZebra
DD-WRT Novice


Joined: 16 Oct 2023
Posts: 14

PostPosted: Wed Oct 18, 2023 13:32    Post subject: Reply with quote
Thanks any help will do and let me know if you need me to try something on my end.


I updated to r53694, erased NVRAM , started router and activated Core USB Support ,USB Storage Support and Automatic Drive Mount.

If it helps you this is the serial connection log after enabling usb support using same usbpen as I used with Netgear V1.0.0.38_1.1.52 fw.

Code:
[  201.800746] usbcore: registered new interface driver usbfs
[  201.806473] usbcore: registered new interface driver hub
[  201.811911] usbcore: registered new device driver usb
[  201.859071] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[  201.902886] ehci-pci: EHCI PCI platform driver
[  201.907650] ehci-pci 0000:00:0b.1: EHCI Host Controller
[  201.912984] ehci-pci 0000:00:0b.1: new USB bus registered, assigned bus number 1
[  201.920669] ehci-pci 0000:00:0b.1: irq 111, io mem 0x18021000
[  201.943968] ehci-pci 0000:00:0b.1: USB 0.0 started, EHCI 1.00
[  201.950625] hub 1-0:1.0: USB hub found
[  201.954520] hub 1-0:1.0: 2 ports detected
[  202.094231] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[  202.110766] ohci-pci: OHCI PCI platform driver
[  202.115396] ohci-pci 0000:00:0b.0: OHCI PCI host controller
[  202.121061] ohci-pci 0000:00:0b.0: new USB bus registered, assigned bus number 2
[  202.128639] ohci-pci 0000:00:0b.0: irq 111, io mem 0x18022000
[  202.198730] hub 2-0:1.0: USB hub found
[  202.202651] hub 2-0:1.0: 2 ports detected
[  202.208878] usb 1-1: new high-speed USB device number 2 using ehci-pci
[  202.278528] xhci_hcd 0000:00:0c.0: xHCI Host Controller
[  202.283898] xhci_hcd 0000:00:0c.0: new USB bus registered, assigned bus number 3
[  202.291629] xhci_hcd 0000:00:0c.0: hcc params 0x02501164 hci version 0x100 quirks 0x00000010
[  202.301090] hub 3-0:1.0: USB hub found
[  202.304971] hub 3-0:1.0: config failed, hub doesn't have any ports! (err -19)
[  202.312689] xhci_hcd 0000:00:0c.0: xHCI Host Controller
[  202.317992] xhci_hcd 0000:00:0c.0: new USB bus registered, assigned bus number 4
[  202.327932] usb usb4: We don't know the algorithms for LPM for this host, disabling LPM.
[  202.336898] hub 4-0:1.0: USB hub found
[  202.340856] hub 4-0:1.0: 1 port detected
[  202.731300] SCSI subsystem initialized
[  202.905794] sr_mod: Unknown symbol register_cdrom (err 0)
[  202.911300] sr_mod: Unknown symbol cdrom_ioctl (err 0)
[  202.916478] sr_mod: Unknown symbol cdrom_get_last_written (err 0)
[  202.922582] sr_mod: Unknown symbol cdrom_check_events (err 0)
[  202.928333] sr_mod: Unknown symbol cdrom_get_media_event (err 0)
[  202.934348] sr_mod: Unknown symbol cdrom_release (err 0)
[  202.939690] sr_mod: Unknown symbol cdrom_open (err 0)
[  202.944750] sr_mod: Unknown symbol unregister_cdrom (err 0)
[  202.950331] sr_mod: Unknown symbol cdrom_number_of_slots (err 0)
[  203.021186] usb-storage 1-1:1.0: USB Mass Storage device detected
[  203.027769] scsi host0: usb-storage 1-1:1.0
[  203.032482] usbcore: registered new interface driver usb-storage
[  204.024091] scsi 0:0:0:0: Direct-Access     Corsair  Flash Voyager    1100 PQ: 0 ANSI: 0 CCS
[  204.035758] sd 0:0:0:0: [sda] 3932160 512-byte logical blocks: (2.01 GB/1.88 GiB)
[  204.044249] sd 0:0:0:0: [sda] Write Protect is off
[  204.050113] sd 0:0:0:0: [sda] No Caching mode page found
[  204.055404] sd 0:0:0:0: [sda] Assuming drive cache: write through
[  204.164608]  sda: sda1 sda2 sda3
[  204.173209] sd 0:0:0:0: [sda] Attached SCSI removable disk
[cron] : daemon successfully stopped
sh: can't create /sys/class/ksmbd-control/kill_server: nonexistent directory
method nfs not found
method rsync not found
method dlna not found

--- /dev/sda

--- /dev/sda1


--- /dev/sda3--- /dev/sda2

Block device, size 1.875 GiB (2013265920 bytes)
Block device, size 99 MiB (103809024 bytes)
Block device, size 107 MiB (112197632 bytes)
Block device, size 117 MiB (122683392 bytes)
DOS/MBR partition map
Partition 1: 2.000 TiB (2199023255040 bytes, 4294967295 sectors from 1)
  Type 0xEE (EFI GPT Protective)
GPT partition map, block size 512 bytes, 128 entries
  Disk size 1.875 GiB (2013265920 bytes, 3932160 blocks of 512 bytes)
  Disk GUID 475642A5-BF61-1648-ADA4-DB4D925103FE
Partition 1: 99 MiB (103809024 bytes, 202752 blocks of 512 bytes from 2048)
  Type Basic Data (GUID A2A0D0EB-E5B9-3344-87C0-68B6B72699C7)
  Partition Name "Basic data partition"
  Partition GUID 15960700-B0C0-1702-6C08-DA012A2C0F00
Windows NTLDR boot loader
FAT32 file system (hints score 5 of 5)
  Volume size 97.44 MiB (102170624 bytes, 199552 clusters of 512 bytes)
  Windows NTLDR boot loader
Ext2 file system
  Volume name "opt"
  UUID BDDAC702-6C00-DA01-3050-C6026C00DA01 (NCS)
  Volume size 107 MiB (112197632 bytes, 109568 blocks of 1 KiB)
Ext2 file system
  Volume name "jffs"
  UUID DFFF1705-6C00-DA01-50FF-12056C00DA01 (NCS)
  Volume size 117 MiB (122683392 bytes, 119808 blocks of 1 KiB)
  FAT32 file system (hints score 5 of 5)
    Volume size 97.44 MiB (102170624 bytes, 199552 clusters of 512 bytes)


/dev/sda1:
 setting standby to 242 (1 hours)

SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 00 00 00 00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
blockdev: No such file or directory

/dev/sda3:
 setting standby to 242 (1 hours)


/dev/sda2:
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 00 00 00 00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
blockdev: No such file or directory
 setting standby to 242 (1 hours)
Partition 2: 107 MiB (112197632 bytes, 219136 blocks of 512 bytes from 204800)
  Type Basic Data (GUID A2A0D0EB-E5B9-3344-87C0-68B6B72699C7)
  Partition Name "Basic data partition"
  Partition GUID 8D9A0700-3050-C602-6C20-DB011A350F00
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 00 00 00 00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
blockdev: No such file or directory
  Ext2 file system
    Volume name "opt"
    UUID BDDAC702-6C00-DA01-3050-C6026C00DA01 (NCS)
    Volume size 107 MiB (112197632 bytes, 109568 blocks of 1 KiB)
Partition 3: 117 MiB (122683392 bytes, 239616 blocks of 512 bytes from 423936)
  Type Basic Data (GUID A2A0D0EB-E5B9-3344-87C0-68B6B72699C7)
  Partition Name "Basic data partition"
  Partition GUID 9FA90700-50FF-1205-6C78-DE013E530F00
  Ext2 file system
    Volume name "jffs"
    UUID DFFF1705-6C00-DA01-50FF-12056C00DA01 (NCS)
    Volume size 117 MiB (122683392 bytes, 119808 blocks of 1 KiB)
Partition 4: unused
mount: mounting /dev/sda1 on /tmp/mnt/sda1 failed: No such device
mount: mounting /dev/sda1 on /tmp/mnt/sda1 failed: Invalid argument
mount: mounting /dev/sda3 on /jffs failed: No such device
mount: mounting /dev/sda2 on /opt failed: No such device
mount: mounting /dev/sda3 on /jffs failed: Invalid argument
mount: mounting /dev/sda2 on /opt failed: Invalid argument


/dev/sda:
cp: can't stat '/tmp/mycron.d/*': No such file or directory
 setting standby to 242 (1 hours)
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 00 00 00 00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
cp: can't stat '/jffs/mycron.d/*': No such file or directory
blockdev: No such file or directory
cp: can't stat '/mmc/mycron.d/*': No such file or directory
[cron] : successfully started/opt/etc/init.d/rcS: No such file or directory
[cron] : daemon successfully stopped
cp: can't stat '/tmp/mycron.d/*': No such file or directory
cp: can't stat '/jffs/mycron.d/*': No such file or directory
cp: can't stat '/mmc/mycron.d/*': No such file or directory
[cron] : successfully started[cron] : daemon successfully stopped
sh: can't create /sys/class/ksmbd-control/kill_server: nonexistent directory
cp: can't stat '/tmp/mycron.d/*': No such file or directory
cp: can't stat '/jffs/mycron.d/*': No such file or directory
sh: can't create /sys/class/ksmbd-control/kill_server: nonexistent directory
cp: can't stat '/mmc/mycron.d/*': No such file or directory
method nfs not found
[cron] : successfully startedmethod rsync not found
method dlna not found
method nfs not found
method rsync not found
sh: can't create /sys/class/ksmbd-control/kill_server: nonexistent directory
method dlna not found
method nfs not found
method rsync not found
method dlna not found
[cron] : daemon successfully stopped
cp: can't stat '/tmp/mycron.d/*': No such file or directory
cp: can't stat '/jffs/mycron.d/*': No such file or directory
cp: can't stat '/mmc/mycron.d/*': No such file or directory
[cron] : successfully startedsh: can't create /sys/class/ksmbd-control/kill_server: nonexistent directory
method nfs not found
method rsync not found
method dlna not found


As you see I get some invalid arguments during mounting:

Code:
mount: mounting /dev/sda1 on /tmp/mnt/sda1 failed: No such device
mount: mounting /dev/sda1 on /tmp/mnt/sda1 failed: Invalid argument
mount: mounting /dev/sda3 on /jffs failed: No such device
mount: mounting /dev/sda2 on /opt failed: No such device
mount: mounting /dev/sda3 on /jffs failed: Invalid argument
mount: mounting /dev/sda2 on /opt failed: Invalid argument


Is this because of the hub does not find any usb ports ?

Code:
hub 3-0:1.0: config failed, hub doesn't have any ports! (err -19)
ZuluZebra
DD-WRT Novice


Joined: 16 Oct 2023
Posts: 14

PostPosted: Thu Oct 19, 2023 18:33    Post subject: Reply with quote
Ok, I finally got it working - according to this user and his ticket usb was working using r45767 the very first release where usb support was added for the ex6200 - ticket 7345

I flashed it and my drives did not mount, I then tried ntfs and for the first time it worked fine and gui shows the used diskspace too but I could not write to the drive as winscp gave a 'Broken pipe' error.

I updated to r53708 and 'Broken pipe' error was gone, rereading BrainSlayer's post he writes that he added 'samba,exfat and ntfs3' - there is not a word about supporting ext2,3, or 4 filesystems.

Perhaps other filesystems was not added because the ex6200 only has 8MB flash memory.

I also tried exfat and it works just as fine as ntfs, files now does not disappear after a reboot and everything seems just fine.


Hehe I'm a happy camper even if I spent over a week looking for a solution for this usb problem - hope this post is helpful for others with same problem.

I'm going to treat myself to a beer.

Thanks



Disk Info ok r45767.JPG
 Description:
 Filesize:  19.84 KB
 Viewed:  6043 Time(s)

Disk Info ok r45767.JPG



Mount NTFS ok r45767.JPG
 Description:
 Filesize:  70.23 KB
 Viewed:  6043 Time(s)

Mount NTFS ok r45767.JPG


Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum