New Build - 03/01/2022 - r48432

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2, 3  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 4025

PostPosted: Tue Mar 01, 2022 11:59    Post subject: New Build - 03/01/2022 - r48432 Reply with quote
Welcome to Atheros r48432 beta release thread for reporting, feedback to developers and community benefit.
Please do not flash builds until installation is understood, risks involved and device specific recovery methods.
Avoid discussions, create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: HTTPS, FTP

CLI Flash: 'cd /tmp' then 'wget {file URL}' (http only) or 'curl -O {file URL}' (http, https, ftp). 'write {file} linux' then 'reboot'.

Trac SVN: repository since last build r48425 (mirror)

OpenVPN 2.5.5: Changelog, Guides, Server, PBR, DNS, Kill Switch, Watchdog, Reverse PBR, Client, Multiple, tips & scripts.
WireGuard 1.0.20211208/Tools: Changelog, Guides, Client, Server, Advanced, PBR, KS, tips & scripts. Thanks to BS & egc!

Notes:
Select ath10k radios now feature on-the-fly firmware type switching between customized DD-WRT and vanilla QCA binaries!
iperf3 cake SmartDNS ProFTPD BusyBox OpenSSL FreeRADIUS Unbound Squid SoftEther Zstd Asterisk Tor nginx apfs SiS-PM dnsmasq MC Nmap ZFS FRR mac80211 PHP
In-kernel Samba (ksmbd 3.4.4++) guest behavior now selectable. • WSD updateANTFS/NTFS3 kernel mode driver++++
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 fragattack fixed. • 47032 #3002 TL-WA901NDv2
• 'Assign WAN port to Switch' gone, set Connection Type Disabled. • WebUI MAC Filtering (47184-47205). • Sputnik removed.
• 'Ignore WAN DNS' also ignores WAN domain. • Milkfish removed. • TL-WR841HPv3 support. • R9000 PPPoE fixed (#7491).
New DD-WRT inspired themes conversion by the-joker & BrainSlayer, micro builds excluded, see UI theme test info thread.
• 401 bad request: Ethernet WebUI -> Wireless -> Basic Settings -> Advanced Settings -> Wireless GUI Access Enable, Save
Add static, delete DHCP lease from clients table in Status -> LAN, upgrades to forwarding delete, NAT / QoS tabs and more.
Fixes,enhancements,features: DTAG, Tagging, Switch Config, Dynamic WDS, Stations, Site Survey, RadioName, 802.11r etc.

Issues, observations, and/or workarounds reported:
WebUI: Clear history or use a portable. Temporary cache bypass: Ctrl+F5, Cmd+Shift+R or new private window/incognito.
Please report findings with steps needed to reproduce, configuration, clients, output, logs and important information below!

Important:
Detail issues & relevant configs, logs: syslog klog 'dmesg' 'cat /tmp/var/log/messages' nvram set console_debug=1, serial.
• Firewall NAT WAN: 'iptables -vnL' 'iptables -t nat -vnL' 'iptables -t mangle -vnL' & /tmp/.ipt. Misc: strace tcpdump wireshark.
• Gremlins: reset & configure manually, not restore a backup. Reboot. Search Trac & discuss in forum before opening tickets.
• Include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) and applicable configurations to reproduce.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
MLandi
DD-WRT Guru


Joined: 04 Dec 2007
Posts: 713

PostPosted: Tue Mar 01, 2022 13:32    Post subject: Reply with quote
Update method: SSH / CLI
Router/Version: Netgear R9000 Nighthawk X10
File/Kernel: DD-WRT v3.0-r48432 std (03/01/22)
Previous/Reset: DD-WRT v3.0-r48425 std (02/24/22) / No
Mode/Status: Gateway / Working Normally
Issues/Errors: No issues

_________________
Netgear R9000 X10
DD-WRT v3.0-r49392 std (06/29/22)
Gateway, AP, DNSMasq, Clock 2000MHz
VAP on wlan1 for internet devices
IPv4 & IPv6 (Prefix Delegation)
Static Leases & DHCP
CloudFlare, QoS Disabled, SmartDNS Disabled
2.4GHz: DD-WRT Firmware, Airtime Fairness Enabled, NG-Mixed, 10 + 6 (2457 MHz HT40), ACK Timing 0 (Auto), WPA2 w/AES
5GHz: DD-WRT Firmware, Airtime Fairness Enabled, AC/N Mixed, 100 + 114 (5500 MHz VHT160), ACK Timing 0 (Auto), WPA2 w/AES
Xfinity 1.2Gbps/42Mbps
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5815
Location: Texas

PostPosted: Tue Mar 01, 2022 14:37    Post subject: Reply with quote
Linksys EA8500 ... main gateway
DD-WRT v3.0-r48432 std (03/01/22)
Linux 4.9.303 #826 SMP Sat Feb 26 09:03:17 +07 2022 armv7l
GUI install over r48428
uptime 12:31
she is very fine Cool

-----
EDIT:
enabled 'unbound' a bit ago and tis seems worky good.


Last edited by mrjcd on Tue Mar 01, 2022 22:14; edited 1 time in total
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5815
Location: Texas

PostPosted: Tue Mar 01, 2022 14:51    Post subject: Reply with quote
Netgear WNDR3700 V4
DD-WRT v3.0-r48432 std (03/01/22)
Linux 3.18.140-d6 #138453 Tue Mar 1 11:46:52 +07 2022 mips
scp firmware.bin over r48425
he worky ok
RobrPatty
DD-WRT User


Joined: 06 Jun 2016
Posts: 94

PostPosted: Tue Mar 01, 2022 15:45    Post subject: 48432 Reply with quote
Netgear Nighthawk X10 R9000
Firmware Version DD-WRT v3.0-r48432 std (03/01/22)
Kernel Version Linux 4.9.303 #617 SMP Thu Feb 24 06:11:46 +07 2022 armv7l
Current Time Tue, 01 Mar 2022 03:34:54
Uptime 1 min
GUI over 48425
Reset: no
Issues: none

Thank you BS & devs
urkel
DD-WRT User


Joined: 17 Aug 2008
Posts: 114

PostPosted: Tue Mar 01, 2022 18:47    Post subject: Reply with quote
Router/Version: TP-Link WDR4900 v1.3
File/Kernel: Linux 4.4.302 #2607 Tue Mar 1 06:48:40 +07 2022 ppc
Previous/Reset: r48402 / No
Mode/Status: AP, WAN disabled, static IP, several VLANs on switch ports with DHCP per VLAN / Up and running for 10 minutes
Issues/Errors: None so far

The Wireless menu has been fixed which was broken in r48425

Thanks BS for fixing the Wireless menu for this router and all who contributed

_________________

1x TP-Link Archer C7 V2.0 r48432 (Primary router at primary location. Former Ziggo repeater)
1x TP-Link Archer C7 V2.0 OpenWrt 21.02.3 (Testing at primary location. Former Ziggo repeater)
1x TP-Link Archer C7 V5.0 r48540 (Secondary router at primary location)
1x TP-Link Archer C7 V5.0 OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WR1043ND V4.0 OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (green leds) r48646 (Primary router at secondary location)
1x TP-Link WDR4900 V1.3 (blue leds) OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (green leds) OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (green leds) OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (blue leds) r47925 (Testing at secondary location)
1x Linksys WRT160NL r48494 (Guest network with QoS at secondary location)
1x Linksys WRT54G V2.0 r14929 (Switched off at secondary location)
1x Linksys WRT54GL V1.1 r14929
giuliomagnifico
DD-WRT User


Joined: 11 Apr 2016
Posts: 448
Location: Italy

PostPosted: Wed Mar 02, 2022 7:04    Post subject: Reply with quote
Router/Version: Netgear R7800
Previous/Reset: CLI updated from previous / No reset
Mode/Status: Gateway / Working
Setup/Using: Vanilla on 2.4 and DD-WRT on 5GHz, WAN, QoS, Wireguard tunnel, DDNS, DNSmasq.
Issues/Errors: Works fine
MLandi
DD-WRT Guru


Joined: 04 Dec 2007
Posts: 713

PostPosted: Wed Mar 02, 2022 13:13    Post subject: Reply with quote
Up and stable for 24 hours. No hiccups or issues. Thank you, BrainSlayer and Team.
_________________
Netgear R9000 X10
DD-WRT v3.0-r49392 std (06/29/22)
Gateway, AP, DNSMasq, Clock 2000MHz
VAP on wlan1 for internet devices
IPv4 & IPv6 (Prefix Delegation)
Static Leases & DHCP
CloudFlare, QoS Disabled, SmartDNS Disabled
2.4GHz: DD-WRT Firmware, Airtime Fairness Enabled, NG-Mixed, 10 + 6 (2457 MHz HT40), ACK Timing 0 (Auto), WPA2 w/AES
5GHz: DD-WRT Firmware, Airtime Fairness Enabled, AC/N Mixed, 100 + 114 (5500 MHz VHT160), ACK Timing 0 (Auto), WPA2 w/AES
Xfinity 1.2Gbps/42Mbps
nyddwrtuser330
DD-WRT User


Joined: 05 Mar 2018
Posts: 153

PostPosted: Wed Mar 02, 2022 21:11    Post subject: Reply with quote
Nighthawk x10
previous: 47695
vanilla, vht80 5GHz WDS AP, ht40 2.4, SMB Dnscrypt, QOS HTB/Cake, CC=Cubic

Errors none.

performance vs previous, this build is higher in latency than 695 - on a straight compare of wired interfaces (taking wireless out of picture). Latency has even more variance on wireless.

rolling back to 47695 - Gaming latency problematic, zoom and teams audio quality partially degraded. General web browsing and streaming is fine.
strange
DD-WRT User


Joined: 18 Jun 2006
Posts: 87

PostPosted: Thu Mar 03, 2022 2:35    Post subject: Reply with quote
Netgear XR500 - Gateway
Firmware Version: DD-WRT v3.0-r48432 std (03/01/22)
Kernel Version: Linux 4.9.303 #828 SMP Tue Mar 1 06:48:31 +07 2022 armv7l
Temperatures: CPU 54.927 °C / wlan0 59 °C / wlan1 63 °C
Current Time: Wed, 02 Mar 2022 18:31:32
Uptime: 1 day, 6 min
Reset: No
GUI install over 48402
Installed using Brave browser over wireless
No issues

Thank you BS and thanks you gurus for your guides and wisdom

_________________
Netgear XR500 - Gateway
R6700 v3 - Client Bridge
husky55
DD-WRT User


Joined: 19 Nov 2008
Posts: 271
Location: Madison, CT, US

PostPosted: Thu Mar 03, 2022 14:10    Post subject: Reply with quote
Update method: Pale moon
Router/Version: Netgear r7800
File/Kernel: DD-WRT v3.0-r48432 std (03/01/22)
Previous/Reset: DD-WRT v3.0-r48393 / No
Mode/Status: WDS Main / No wifi
Issues/Errors: Lost wifi both 2.4 and 5 GHz with no reset. Reboot modem and router did not help. Not able to restore so reverted back to 48393.

_________________
Netgear R7800(2) WDS, Asus RT-AC68R (2)
DD-WRT-Nub
DD-WRT Novice


Joined: 26 Sep 2016
Posts: 22

PostPosted: Thu Mar 03, 2022 15:18    Post subject: Reply with quote
nyddwrtuser330 wrote:
Nighthawk x10
previous: 47695
vanilla, vht80 5GHz WDS AP, ht40 2.4, SMB Dnscrypt, QOS HTB/Cake, CC=Cubic

Errors none.

performance vs previous, this build is higher in latency than 695 - on a straight compare of wired interfaces (taking wireless out of picture). Latency has even more variance on wireless.

rolling back to 47695 - Gaming latency problematic, zoom and teams audio quality partially degraded. General web browsing and streaming is fine.


Hi:

Can you please describe how are you testing this? Have you tried disabling Dnscrypt or QoS? Can you test while using Westwood and later with BBR congestion control? Shortcut Forwarding Engine is enabled or disabled? Have you done a nvram erase and entered settings from scratch? Can you take a screenshot of your QoS section?


Does anyone else experience issues while on video conference calls after build 47695?

Thanks!
iMAK
DD-WRT User


Joined: 06 Nov 2011
Posts: 75

PostPosted: Thu Mar 03, 2022 15:27    Post subject: Reply with quote
Update method: WebUI over LAN
Router/Version: Buffalo WZR-HP-G300NH
File/Kernel: DD-WRT v3.0-r48432 std (03/01/22) / Linux 3.10.108-d11 #103192 Tue Mar 1 06:57:42 +07 2022 mips
Previous/Reset: DD-WRT v3.0-r48402 std (02/20/22) / No
Mode/Status: AP connected to Huawei CPE Pro 5G Router / Working
Issues/Errors: None so far

_________________
Buffalo WZR-HP-G300NH
ho1Aetoo
DD-WRT Guru


Joined: 19 Feb 2019
Posts: 1370
Location: Germany

PostPosted: Thu Mar 03, 2022 16:19    Post subject: Reply with quote
DD-WRT-Nub wrote:
Can you test while using Westwood and later with BBR congestion control?


the congestion control on the router has no effect on forwarded internet traffic

https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1255988#1255988

So it's pretty pointless to test it
nyddwrtuser330
DD-WRT User


Joined: 05 Mar 2018
Posts: 153

PostPosted: Thu Mar 03, 2022 16:29    Post subject: Reply with quote
Congestion control shouldnt do anything unless my router has contention on a link, Wired testing only had a single node so unlikely that has anything to with anything. these problems occur with pleanty of headroom, cpu not maxed memory fine etc.

As soon as i revert to 47695 all problems disappear across all platforms.

it shoudlnt be dnscrypt unless the modules loaded are conflicting, but syslog is clean so doubt it. and its not name resolution i have issues with.

testing with waveform only confirms the issues are inconsistencies in latency that just dont occur on 47695. Though you may have to run a bunch of tests back to back to see it, but it will eventually show up and you cant replicate the behavior on 47695. the items im having trouble with over time are latency sensistive.

i havent tested every build since 47695 but have doena bunch including those immediately after and problems begin following that known good build for me and persist.

i am currently using HTB/CAKE, but problems occur with multiple combos including the tried and true HTB/FQ_codel. My QOS is simplistic its jus bandwidth setting(100m/30M) and ack and RST checked, i keep it that way since i saw no difference when i started to add specific selections and accelerations
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum