New Build - 02/02/2022 - r48261

Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 4580

PostPosted: Wed Feb 02, 2022 9:12    Post subject: New Build - 02/02/2022 - r48261 Reply with quote
Welcome to Marvell r48261 beta release thread for reporting, feedback to developers and community benefit.
Please do not flash builds until installation is understood, risks involved and device specific recovery methods.
Avoid discussions, create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: HTTPS, FTP

CLI Flash: 'cd /tmp' then 'wget {file URL}' (http only) or 'curl -O {file URL}' (http, https, ftp). 'write {file} linux' then 'reboot'.

Trac SVN: repository since last build r48255 (mirror)

OpenVPN 2.5.5: Changelog, Guides, Server, PBR, DNS, Kill Switch, Watchdog, Reverse PBR, Client, Multiple, tips & scripts.
WireGuard 1.0.20211208/Tools: Changelog, Guides, Client, Server, Advanced, PBR, KS, tips & scripts. Thanks to BS & egc!

Notes:
• WRT1200AC, WRT1200AC V2, WRT1900AC, WRT1900AC V2, WRT1900ACS, WRT1900ACS V2, WRT3200ACM and WRT32X.
Privoxy, iperf3, CAKE, Asterisk, SmartDNS, curl, ProFTPD, BusyBox, OpenSSL, mac80211, FreeRADIUS, dnsmasq, Unbound, zfs, SoftEther, Squid, zstd, Tor
In-kernel Samba (ksmbd 3.4.4+): guest behavior now selectable. • WSD updateANTFS/NTFS3 kernel mode driver++++
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 fragattack fixed.
• 'Assign WAN port to Switch' gone, set Connection Type Disabled. • WebUI MAC Filtering (47184-47205). • Sputnik removed.
• 'Ignore WAN DNS' also ignores WAN domain. • Milkfish removed.
New DD-WRT inspired themes conversion by the-joker & BrainSlayer, micro builds excluded, see UI theme test info thread.
• 401 bad request: Ethernet WebUI -> Wireless -> Basic Settings -> Advanced Settings -> Wireless GUI Access Enable, Save
Add static, delete DHCP lease from clients table in Status -> LAN. Upgrades to forwarding delete, NAT / QoS tabs and more.
• Fixes,enhancements,features: DTAG, Tagging, Switch Config, Dynamic WDS, Stations, Site Survey, RadioName, 802.11r etc.

Issues, observations, and/or workarounds reported:
WebUI: Clear history or use a portable. Temporary cache bypass: Ctrl+F5, Cmd+Shift+R or new private window/incognito.
Please report findings with steps needed to reproduce, configuration, clients, output, logs and important information below!

Important:
Detail issues & relevant configs. Logs: 'dmesg' 'cat /tmp/var/log/messages' syslog klog, serial, strace, tcpdump, wireshark.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL' 'iptables -t nat -vnL' 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Gremlins: reset & configure manually, not restore a backup. Reboot. Search Trac & discuss in forum before opening tickets.
• Include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) and applicable configurations to reproduce.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Justanotherbrokenrouter
DD-WRT User


Joined: 27 Apr 2019
Posts: 166

PostPosted: Wed Feb 02, 2022 17:53    Post subject: Reply with quote
Router/Version: Linksys WRT3200ACM, DD-WRT v3.0-r48141 std (01/21/22)
File/Kernel: Linux 4.9.297 #3035 SMP Fri Jan 21 03:12:25 +07 2022 armv7l
Previous/Reset: r48141 Reset to Default settings
Mode/Status: DHCP/AP/Ignore WAN DNS/Dnsmasq/OpenVPN Client NordVPN/Uptime:
Browser: Firefox Version 96.0.2 (64-bit)
Load Average: 0.00, 0.00, 0.00 0%
Temperatures: CPU 51.3 °C / WL0 28.5 °C / WL1 29.5 °C (USB cooling fan)
Clients: Only PC at this moment
wlan0: 5GHz 40MHz Mixed 100 + 104 (5500 MHz HT40) Upper, WPA2 CCMP-128 (AES)
wlan1: 2.4GHz 20MHz Mixed Auto, WPA2 CCMP-128 (AES)
wlan2: Disabled Always

Issues/Errors:
I have always used Firefox web browser, deleted cache, and use CCleaner to delete anything browser before flashing dd-wrt firmware. I also use private browsing window before 192.168.1.1 to GUI with internet disconneced, and all other Lan devices diconnected, except PC.

After installing Build r48141 connecting to routers GUI is fine after any kind of reset. After password reset I do occasionally get the red page message (400 file not found), but if I wait for a moment, and then re-type 192.168.1.1 the routers GUI will display fine.

All builds after r48141 GUI is lost after reset of any kind. Builds after r48141 work fine if flashed without reset from r48141. I have not tried any other combination of installs.

If its Syslogd, and/or Klogd downloads that you need for me to prove the errors that other users are also obviously having to. Then its probably best to get another user that better equipped to do so. I don't mind copying, and pasting. Sharing downloaded logs seems more router personal when it comes to IP addresses, etc. Sorry for the inconveniences if my post are not reliable then let me know, and I will stop posting to this site.

Will update if issues return.

Update: 1

wlan0: 5GHz 40MHz Mixed 100 + 104 (5500 MHz HT40) Upper, WPA2 CCMP-128 (AES)
** Are the only changes from default
Advanced Settings
TX Power 30 dBm
Antenna Gain 0 dBi
**U-APSD (Automatic Power Save) Enabled
Disassoc Low Ack Disabled
Protection Mode None
RTS Threshold Disabled
Short Preamble Disabled
Short GI Enabled
**Single User Beamforming Enabled
**Multi User Beamforming Enabled
AP Isolation Disabled
Beacon Interval 100
DTIM Interval 2
WMM Support Enabled
Radar Detection Disabled
ScanList default
Sensitivity Range (ACK Timing) 500 (Default: 500 meters)
Max Associated Clients 256 (Default: 256 Clients)
Minimum Signal for authenticate -128
Minimum Signal for connection -128
Poll Time for signal lookup 10
Amount of allowed low signals 3
Other settings
Allow Channel Overlapping Disable

wlan1: 2.4GHz 20MHz Mixed Auto, WPA2 CCMP-128 (AES)
** Are the only changes from default
Advanced Settings
TX Power 30 dBm
Antenna Gain 0 dBi
U-APSD (Automatic Power Save) Disabled
Disassoc Low Ack Disabled
Protection Mode None
RTS Threshold Disabled
Short Preamble Disabled
Short GI Enabled
AP Isolation Disabled
Beacon Interval 100
DTIM Interval 2
WMM Support Enabled
Radar Detection Disabled
ScanList default
Sensitivity Range (ACK Timing) 500 (Default: 500 meters)
Max Associated Clients 256 (Default: 256 Clients)
Minimum Signal for authenticate -128
Minimum Signal for connection -128
Poll Time for signal lookup 10
Amount of allowed low signals 3
Other Settings
TurboQAM (QAM256) support Disable

wlan2: Disabled
raywan
DD-WRT User


Joined: 16 Jun 2020
Posts: 58

PostPosted: Thu Feb 03, 2022 5:50    Post subject: Reply with quote
Router/Version: wrt32x
File/Kernel: 02-02-2022-r48261/
Previous/Reset: DD-WRT v3.0-r48141 std (01/21/22)
Mode/Status: AP only
Issues/Errors: Upgrade from r48141 using firefox without reset. Everything looks fine and index.asp display correctly after reboot. I try to test WPA2/WPA3 wifi security with no luck. When Android device connected to WRT32x, it can transfer data just few seconds then stop working and disconnected. I am pretty sure that the wrt32x is working after disconnection because i can still using putty login into wrt32x and able to restart by SSH but http is not working.
Another problem is that, i try to hard reset wrt32x with reset bottom then using r48141 config backup to restore all the settings. After bootup, the same problem happens again https://svn.dd-wrt.com/ticket/7531#comment:6. Nothing can be displayed after passing user/password credentials. The simplest way to solve this problem is manually input http://192.168.1.1/Management.asp in the firefox or palemoon browsers then everything turns back to normal.
Finally, i rollback to DD-WRT v3.0-r48141 std (01/21/22) and keep looking these problems can be solved in the future.
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 350
Location: South Carolina

PostPosted: Thu Feb 03, 2022 19:43    Post subject: Update from r48255 to r48261 wrt3200acm V1 Reply with quote
Upgraded r48255 to r48261. Performed a hard power off reboot. About 30 mins later the router began, what seems as, random reboots about every 5 mins of recovering. Went back to r48255. I had real concern about being able to recover from this version. I think I'm going to just let this one expire.

Configuration is vpn client (nordvpn, and 5GHz N 40MHz only. No 2GHz used).


Last edited by scar1943 on Fri Feb 04, 2022 19:58; edited 1 time in total
Argenis
DD-WRT User


Joined: 18 Feb 2019
Posts: 159

PostPosted: Fri Feb 04, 2022 0:51    Post subject: Reply with quote
Model: WRT3200ACM v1
Reset: Yes

Solid release, no stability or CPU issues, nor any syslog events.

I love that the VPN client now has (maybe I did not notice this before?) a killswitch setting so I don't need the firewall script.

This build has an interesting thing, though I don't know if it's the build or my VPN provider doing a recent change, but the VPN client no longer accepts IPs, and instead only connects with a server FQDN, which is better practice I guess.

If this can be replicated great, if not I'll claim it's my VPN provider.

_________________
Router: Linksys WRT3200ACM WLAN0 and 1 have same SSID
88W8964 802.11ac WLAN0 Mode AP VHT80 80MHz Mixed Mode Channel and Extension Channel Auto Extension LL-6
88W8964 802.11ac WLAN1 Mode AP 20 MHz Mixed Mode Channel Auto
SD8887 802.11ac disabled but visible on GUI and CLI
TX Power 18 dBm
Antenna Gain 0 dBi
U-APSD (Automatic Power Save)Enabled 
Protection Mode None
RTS Threshold Disabled
Short Preamble Disabled 
Short GI Enabled
Single User Beamforming Enabled
Multi User Beamforming Enabled 
AP Isolation Disabled
Beacon Interval 100
DTIM Interval 2
WMM Support Enabled 
Radar Detection Disabled 
ScanList default
Sensitivity Range (ACK Timing) 500 (Default: 500 meters)
Max Associated Clients 256 (Default: 256 Clients)
Minimum Signal for authenticate -128
Minimum Signal for connection -128
Poll Time for signal lookup 10
Amount of allowed low signals 3
Wireless security is WPA2 Personal CCMP-128 only
QAM256 is on
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum