New Build - 01/11/2022 - r48081

Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2, 3  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 4585

PostPosted: Tue Jan 11, 2022 8:28    Post subject: New Build - 01/11/2022 - r48081 Reply with quote
Welcome to Atheros r48081 beta release thread for reporting, feedback to developers and community benefit.
Please do not flash builds until installation is understood, risks involved and device specific recovery methods.
Avoid discussions, create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: HTTPS, FTP

CLI Flash: 'cd /tmp' then 'wget {file URL}' (http only) or 'curl -O {file URL}' (http, https, ftp). 'write {file} linux' then 'reboot'.

Trac SVN: repository since last build r48075 (mirror)

OpenVPN 2.5.5: Changelog, Guides, Server, PBR, DNS, Kill Switch, Watchdog, Reverse PBR, Client, Multiple, tips & scripts.
WireGuard 1.0.20211208/Tools: Changelog, Guides, Client, Server, Advanced, PBR, KS, tips and scripts. Thanks BS & egc!

Notes:
Select ath10k radios now feature on-the-fly firmware type switching between customized DD-WRT and vanilla QCA binaries!
CoovaChilli, Privoxy, iperf3, CAKE, FreeRADIUS, dnsmasq, Unbound, Squid, Asterisk, SmartDNS, curl, ProFTPD, Tor, BusyBox, OpenSSL, mac80211, NASWebUI
In-kernel Samba (ksmbd 3.4.3+): guest behavior is now selectable. • WSD updateANTFS/NTFS3 kernel mode driver+++
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 fragattack fixed. • 47032 #3002 TL-WA901NDv2
• 'Assign WAN port to Switch' gone, set Connection Type Disabled. • WebUI MAC Filtering (47184-47205). • Sputnik removed.
• 'Ignore WAN DNS' also ignores WAN domain. • Milkfish removed. • TL-WR841HPv3 support. • R9000 PPPoE fixed (#7491).
New DD-WRT inspired themes conversion by the-joker & BrainSlayer, micro builds excluded, see UI theme test info thread.
• 401 bad request: Ethernet WebUI -> Wireless -> Basic Settings -> Advanced Settings -> Wireless GUI Access Enable, Save
• Add static or delete DHCP lease from DHCP clients table in Status -> LAN. Upgrades to forwarding delete in NAT / QoS tabs.

Issues, observations, and/or workarounds reported:
WebUI: Clear history or use a portable. Temporary cache bypass: Ctrl+F5, Cmd+Shift+R or new private window/incognito.
Please report findings with steps needed to reproduce, configuration, clients, output, logs and important information below!

Important:
Detail issues & relevant configs. Logs: 'dmesg' 'cat /tmp/var/log/messages' syslog klog, serial, strace, tcpdump, wireshark.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL' 'iptables -t nat -vnL' 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Gremlins: reset & configure manually, not restore a backup. Reboot. Search Trac & discuss in forum before opening tickets.
• Include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) and applicable configurations to reproduce.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Be Inspired
DD-WRT Novice


Joined: 20 Nov 2019
Posts: 4

PostPosted: Tue Jan 11, 2022 9:08    Post subject: Reply with quote
Hello,

I have a TP-LINK TL-WR1043ND v2 (r48081) configured as access point and when i want to log in in webui and type wrong username or password it doesnt ask again for username or password but the page freezes and doesnt show (401 unathorized page).

Thanks in advance and sorry for my english.

_________________
TP-LINK TL-WR1043ND v2 Wireless access point
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5946
Location: Texas

PostPosted: Tue Jan 11, 2022 11:50    Post subject: Reply with quote
Linksys EA8500 ...main gateway
DD-WRT v3.0-r48081 std (01/11/22)
Linux 4.9.296 #661 SMP Tue Jan 11 02:30:42 +07 2022 armv7l
GUI install over r48075
all my stuff works good

#

Netgear WNDR3700 V4
DD-WRT v3.0-r48081 std (01/11/22)
Linux 3.18.140-d6 #133904 Tue Jan 11 07:32:46 +07 2022 mips
GUI install over r48075
all good
RobrPatty
DD-WRT User


Joined: 06 Jun 2016
Posts: 174

PostPosted: Tue Jan 11, 2022 12:36    Post subject: r48081 Reply with quote
Netgear Nighthawk X10
Firmware VersionDD-WRT v3.0-r48081 std (01/11/22)
Kernel VersionLinux 4.9.296 #606 SMP Fri Jan 7 02:15:56 +07 2022 armv7l
Current TimeTue, 11 Jan 2022 05:33:13
Uptime1 min
Reset: No
GUI install over 48075
No issues

Thanks BS & devs
nyddwrtuser330
DD-WRT User


Joined: 05 Mar 2018
Posts: 157

PostPosted: Tue Jan 11, 2022 13:59    Post subject: Reply with quote
upgrade from 47692/5
no reset

Primary r9000
SMB, Inadyn, DNSCrypt, SMB, Vanilla, 2.4Ghz wide 40 AP, 5GHZ wide 80 WDS AP

Secondary
Archer C7v2 - 5GHz WDS STA, 2.4 GHz AP

All configured and verified best practice

Issues/Errors: Connections going directly through the r9000 all appear to be fine, services are ok too. Connections going through the wds STA are extremely inconsistent with both latency and throughput. This was the same issue on all december builds and does not occur on 47692. This may be router combo specific, as the archer uses an older radio combo that does not allow for an all vanilla config nor does it support Su-mimo. I will repurpose the 7800 as wds sta later and report back (the 7800 has same radios as 9k)

Update: WDS seems borked - even with matching radios 7800->9000. everything since 47695 is broken. Even if i hardwire to wds STA from an endpoint, the result is teh same. th actual 5ghz sta-WDS AP link is not functioning right
MLandi
DD-WRT Guru


Joined: 04 Dec 2007
Posts: 805

PostPosted: Tue Jan 11, 2022 13:59    Post subject: Reply with quote
Update method: SSH / CLI
Router/Version: Netgear R9000 Nighthawk X10
File/Kernel: DD-WRT v3.0-r48081 std (01/11/22)
Previous/Reset: DD-WRT v3.0-r48075 std (01/10/22) / No
Mode/Status: Gateway / Working Normally
Issues/Errors: Although the build did load the leases file on reboot, and the Use JFFS2 for client lease DB option was checked, I had to click Apply on the page to get the dnsmasq.leases file to start updating on /jffs. Also, the Active Clients table on the Status, LAN tab had many Hostnames as * until I erased /tmp/dnsmasq.leases.

_________________
Netgear R9000 X10
DD-WRT v3.0-r50963 std (11/28/22)
Gateway, AP, DNSMasq, Clock 2000MHz
VAP on wlan1 for internet devices
IPv4 & IPv6 (Prefix Delegation)
Static Leases & DHCP
CloudFlare, QoS Disabled, SmartDNS Disabled
2.4GHz: VANILLA Firmware, Airtime Fairness Enabled, NG-Mixed, ACK Timing 3150, WPA2 w/AES
5GHz: VANILLA Firmware, Airtime Fairness Enabled, AC/N Mixed, ACK Timing 3150, WPA2 w/AES
Xfinity 1.2Gbps/42Mbps
nickant
DD-WRT User


Joined: 09 Feb 2016
Posts: 191

PostPosted: Tue Jan 11, 2022 20:50    Post subject: Reply with quote
Linksys EA8500 ...main gateway
DD-WRT v3.0-r48081 std (01/11/22)
Linux 4.9.296 #661 SMP Tue Jan 11 02:30:42 +07 2022 armv7l
GUI install over r48075
Weird.
My partner's HP laptop refused to connect to the EA8500 wifi on this built - it was fine on r48075.
It connected to the WRT1900ACv1 (on r48081) at the far end of the house.
Once I rebooted the HP, it was ok.
My Dell laptop had no issues.
So, router good, devices bad!

_________________
------------------------------------
Linksys EA8500 DD-WRT r50963 (Gateway)
Linksys WRT1900ACv1 DD-WRT r50963 (AP)
Netgear WNDR3700v4 DD-WRT r50841 (spare Gateway)
Photos: https://www.flickr.com/photos/nickant44/albums
MLandi
DD-WRT Guru


Joined: 04 Dec 2007
Posts: 805

PostPosted: Wed Jan 12, 2022 13:25    Post subject: Reply with quote
24 hours up and stable, no issues. Thanks, BrainSlayer and Team!
_________________
Netgear R9000 X10
DD-WRT v3.0-r50963 std (11/28/22)
Gateway, AP, DNSMasq, Clock 2000MHz
VAP on wlan1 for internet devices
IPv4 & IPv6 (Prefix Delegation)
Static Leases & DHCP
CloudFlare, QoS Disabled, SmartDNS Disabled
2.4GHz: VANILLA Firmware, Airtime Fairness Enabled, NG-Mixed, ACK Timing 3150, WPA2 w/AES
5GHz: VANILLA Firmware, Airtime Fairness Enabled, AC/N Mixed, ACK Timing 3150, WPA2 w/AES
Xfinity 1.2Gbps/42Mbps
Flappjakk
DD-WRT Novice


Joined: 11 Sep 2008
Posts: 43
Location: Baltimore, MD

PostPosted: Wed Jan 12, 2022 20:07    Post subject: Reply with quote
Router/Version: Buffalo WZR-600DHP
File/Kernel: DD-WRT v3.0-r48081 std (01/11/22)
Previous/Reset: r36808M (08/30/1Cool / No
Mode/Status: Gateway / Seems OK
Issues/Errors: Unbelievably OK even though flash over a 3+ year old version with no reset.

I'm going to reset this and reconfigure it as an Access Point / Switch.
giuliomagnifico
DD-WRT User


Joined: 11 Apr 2016
Posts: 454
Location: Italy

PostPosted: Wed Jan 12, 2022 21:17    Post subject: Reply with quote
R7800 here, all perfect! Cool
mwbuss8
DD-WRT Guru


Joined: 23 Feb 2015
Posts: 743

PostPosted: Thu Jan 13, 2022 7:15    Post subject: Reply with quote
GUI upgrade for signature routers from r48075

Errors: None

_________________
Current devices:
XR500 - gateway
EA8500 - AP
EA8500 - AP
R7500v2 - AP
R7500v2 - AP
EA8500 - AP & OpenVPN client
OpenMediaVault box for SMB & Emby
mitchd123
DD-WRT Novice


Joined: 20 Jun 2010
Posts: 25

PostPosted: Thu Jan 13, 2022 8:07    Post subject: Reply with quote
Router/Version: Linksys EA8500
File/Kernel: r48081 Linux 4.9.296 #661 SMP Tue Jan 11 02:30:42 +07 2022 armv7l
Previous/Reset: Yes
Mode/Status: Failing
Issues/Errors: NTP/Time issues

This is a really strange issue. When the EA8500 reboots it loses it's time and date settings. This has happened on two different EA8500 routers. One was upgraded from r43720, the other was a fresh install onto 01-06-2022-r47976, then upgraded with a reset. I tried pointing it at a time server on the same subnet.

NPT did nothing, so I turned ntp off. When I SSH in and manually set the date, on I reboot it shows a year of 1969. Example below:

root@virtual:/home/# ssh -l root 10.10.10.4
DD-WRT v3.0-r48081 std (c) 2022 NewMedia-NET GmbH
Release: 01/11/22
Board: Linksys EA8500
root@10.10.10.4's password:
==========================================================

___ ___ _ _____ ______ ____ ___
/ _ \/ _ \___| | /| / / _ \/_ __/ _ __|_ / / _ \
/ // / // /___/ |/ |/ / , _/ / / | |/ //_ <_/ // /
/____/____/ |__/|__/_/|_| /_/ |___/____(_)___/

DD-WRT v3.0
https://www.dd-wrt.com


==========================================================


BusyBox v1.35.0 (2022-01-11 02:32:45 +07) built-in shell (ash)

root@ea8500_elijah:~# date
Wed Dec 31 19:18:21 EST 1969
root@ea8500_elijah:~# date -s 2022.01.13-07:14
Thu Jan 13 07:14:00 EST 2022
root@ea8500_elijah:~# date
Thu Jan 13 07:14:15 EST 2022
root@ea8500_elijah:~# reboot
root@ea8500_elijah:~# client_loop: send disconnect: Broken pipe
root@virtual:/home/# ssh -l root 10.10.10.4
DD-WRT v3.0-r48081 std (c) 2022 NewMedia-NET GmbH
Release: 01/11/22
Board: Linksys EA8500
root@10.10.10.4's password:
==========================================================

___ ___ _ _____ ______ ____ ___
/ _ \/ _ \___| | /| / / _ \/_ __/ _ __|_ / / _ \
/ // / // /___/ |/ |/ / , _/ / / | |/ //_ <_/ // /
/____/____/ |__/|__/_/|_| /_/ |___/____(_)___/

DD-WRT v3.0
https://www.dd-wrt.com


==========================================================


BusyBox v1.35.0 (2022-01-11 02:32:45 +07) built-in shell (ash)

root@ea8500_elijah:~# date
Wed Dec 31 19:01:10 EST 1969
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 10775
Location: Netherlands

PostPosted: Thu Jan 13, 2022 8:51    Post subject: Reply with quote
The router has no RTC (real time clock) so after a reboot it needs a time server.

If you have setup right then leaving the "Server IP/Name" field empty works best.
Only choose your time zone.

Otherwise open a new thread and give more details of your setup and post screenshots of your settings

_________________
Routers:Netgear R7800, R7000, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Molle
DD-WRT User


Joined: 13 Jan 2015
Posts: 87
Location: Finland

PostPosted: Thu Jan 13, 2022 14:17    Post subject: Reply with quote
Router/Version: Netgear R7800
Previous/Reset: r47942 (CLI update) / No
Status: OK

DD-WRT firmware on 5 GHz (WDS AP, AC/N-Mixed, VHT80), Vanilla on 2.4 GHz (AP, NG-Mixed, Wide HT40).
IPv4, DHCP Server, DNSMasq, Static Leases, NTP Client, Ondemand Governor.

Router/Version: Linksys EA8500
Previous/Reset: r47942 (CLI update) / No
Status: OK

DD-WRT firmware on 5 GHz (WDS Station, AC/N-Mixed, VHT80), 2.4 GHz disabled.
IPv4, NTP Client, Ondemand Governor.

Thanks BS!
mcchary
DD-WRT Novice


Joined: 14 Jan 2019
Posts: 10

PostPosted: Thu Jan 13, 2022 16:03    Post subject: Reply with quote
Router / Version: TL-WR841ND V8.
Kernel: Linux 3.18.140-d6 #133858 Tue Jan 11 06:20:52 +07 2022 mips
Firmware: DD-WRT v3.0-r48081 std (01/11/22).
Previous: DD-WRT v3.0-r47822 std (11/18/21).
Mode: AP
channel: 13 + 14 (2472 MHz HT40).
Power TX: 21 dBm
Reset: Yes.
State : Excellent.
Problems / Errors: None Until Now.

edit:
I have a little doubt, if this router does not have WireGuard, because this usually appears in syslog

Jan 13 16:53:05 DD-WRT user.info root: WireGuard number of non failed tunnels in fail set: 0
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum