[Don't Install] New Build - 12/19/2021 - r47893

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 4373

PostPosted: Sun Dec 19, 2021 11:23    Post subject: [Don't Install] New Build - 12/19/2021 - r47893 Reply with quote
Welcome to Marvell r47893 beta release thread for reporting, feedback to developers and community benefit.
Please do not flash builds until installation is understood, risks involved and device specific recovery methods.
Avoid discussions, create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: HTTPS, FTP

CLI Flash: 'cd /tmp' then 'wget {file URL}' (http only) or 'curl -O {file URL}' (http, https, ftp). 'write {file} linux' then 'reboot'.

Trac SVN: repository since last build r47874 (mirror)

OpenVPN 2.5.5: Changelog, Guides, Server, PBR, DNS, Kill Switch, Watchdog, Reverse PBR, Client, Multiple, tips & scripts.
WireGuard 1.0.20211208/Tools: Changelog, Guides, Client, Server, Advanced, PBR, KS, tips and scripts. Thanks BS & egc!

Notes:
• WRT1200AC, WRT1200AC V2, WRT1900AC, WRT1900AC V2, WRT1900ACS, WRT1900ACS V2, WRT3200ACM and WRT32X.
MiniDLNA, CoovaChilli, Privoxy, iperf3, CAKE, FreeRADIUS, dnsmasq, Unbound, Tor, Squid, Asterisk, OpenSSL, BusyBox, SmartDNS, mac80211, curl, ProFTPD
In-kernel Samba (ksmbd 3.4.2+++) guest behavior now selectable. • WSD updateANTFS/NTFS3 kernel mode driver+++
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 fragattack fixed.
• 'Assign WAN port to Switch' gone, set Connection Type Disabled. • WebUI MAC Filtering (47184-47205). • Sputnik removed.
• 'Ignore WAN DNS' also ignores WAN domain. • Milkfish removed.
New DD-WRT inspired themes conversion by the-joker & BrainSlayer, micro builds excluded, see UI theme test info thread.

Issues, observations, and/or workarounds reported:
WebUI: Clear history or use a portable. Temporary cache bypass: Ctrl+F5, Cmd+Shift+R or new private window/incognito.
Please report findings with steps needed to reproduce, configuration, clients, output, logs and important information below!

Important:
• For issues provide applicable info: 'dmesg' 'cat /tmp/var/log/messages', syslog klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL' 'iptables -t nat -vnL' 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Gremlins: reset & configure manually, not restore a backup. Reboot. Search Trac & discuss in forum before opening tickets.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Monza
DD-WRT User


Joined: 01 Jul 2018
Posts: 374

PostPosted: Sun Dec 19, 2021 12:59    Post subject: Reply with quote
Upgraded WRT1200AC v1's from r47874 to r47893 using Brave 1.10.97 (64-bit) running on Linux Mint 20.2 OS hardwired via Cat6.

Kernel Version Linux 4.9.292 #2973 SMP Sun Dec 19 06:03:30 +07 2021 armv7l

Update was routine and appeared successful. When I started going tab to tab the Wireless tab froze with partial data displayed. It then immediately lost connection to the GUI with a warning about unable to connect.

Did a manual router reboot which brought the connection/GUI back up and working with r47893 as expected. When I clicked the Wireless tab again it appeared with partial data and connection was lost again.

I reverted to r47874 and all tabs are working as expected. The issue for me is specific to the Wireless tab on r47893 which instantly breaks the connection when I try to open it.

Could be my setup but thought I would share the event as a possibility to occur for other community members.
roland90
DD-WRT User


Joined: 22 Oct 2015
Posts: 118

PostPosted: Sun Dec 19, 2021 19:31    Post subject: Reply with quote
Monza wrote:
When I started going tab to tab the Wireless tab froze with partial data displayed. It then immediately lost connection to the GUI with a warning about unable to connect.

Fixed, https://svn.dd-wrt.com/changeset/47897
Display posts from previous:    Page 1 of 1
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum