New Build - 12/02/2021 - r47720

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 4020

PostPosted: Thu Dec 02, 2021 8:38    Post subject: New Build - 12/02/2021 - r47720 Reply with quote
Welcome to Atheros r47720 beta release thread for reporting, feedback to developers and community benefit.
Please do not flash builds until installation is understood, risks involved and device specific recovery methods.
Avoid discussions, create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: HTTPS, FTP

CLI Flash: 'cd /tmp' then 'wget {file URL}' (http only) or 'curl -O {file URL}' (http, https, ftp). 'write {file} linux' then 'reboot'.

Trac SVN: repository since last build r47695 (mirror)

OpenVPN 2.5.4: Changelog, Guides, Server, PBR, DNS, Kill Switch, Watchdog, Reverse PBR, Client, Multiple, tips & scripts.
WireGuard 1.0.20210606/Tools: Changelog, Guides, Client, Server, Advanced, PBR, KS, tips and scripts. Thanks BS & egc!

Notes:
Select ath10k radios now feature on-the-fly firmware type switching between customized DD-WRT and vanilla QCA binaries!
MiniDLNACoovaChilliPrivoxyiperf3cakeFreeRADIUSOpenSSLdnsmasqUnboundTorAsteriskBusyBoxSquid SmartDNS mac80211
In-kernel Samba ksmbd 3.4.2++: default min/max versions revised. WSD updateANTFS/NTFS3 kernel mode driver+++
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 Fragattack fixed. • r47032 #3002 TL-WA901NDv2
• 'Assign WAN port to Switch' gone, set Connection Type Disabled. • WebUI MAC Filtering (47184-47205). • Sputnik removed.
• 'Ignore WAN DNS' also ignores WAN domain. • Milkfish removed. • TL-WR841HPv3 support. • R9000 PPPoE fixed (#7491).
New DD-WRT inspired themes conversion by the-joker & BrainSlayer, micro builds excluded.

Issues, observations, and/or workarounds reported:
WebUI: Clear history or use a portable. Temporary cache bypass: Ctrl+F5, Cmd+Shift+R or new private window/incognito.
Please report findings with steps needed to reproduce, configuration, clients, output, logs and important information below!

Important:
• For issues provide applicable info: 'dmesg' 'cat /tmp/var/log/messages', syslog klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL' 'iptables -t nat -vnL' 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Gremlins: reset & configure manually, not restore a backup. Reboot. Search Trac & discuss in forum before opening tickets.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
ho1Aetoo
DD-WRT Guru


Joined: 19 Feb 2019
Posts: 1366
Location: Germany

PostPosted: Thu Dec 02, 2021 9:37    Post subject: Reply with quote
Router/Version: R7800
File/Kernel: Linux 4.9.291 #555 SMP Thu Dec 2 04:36:07 +07 2021 armv7l
Previous/Reset: r47665 / no
Mode/Status: Gateway / working
Services Used: PPPoE,DHCP,DHCP-Reservation,Dnsmasq + PiHole,DDNS,SSH,WiFi 2,4Ghz + 5Ghz AP's + VAP's Vanilla,USB,Port forwarding,QoS
Issues/Errors: nothing so far


The bandwidth graph is now very pretty
the-joker
DD-WRT Developer/Maintainer


Joined: 31 Jul 2021
Posts: 1185
Location: All over YOUR webs

PostPosted: Thu Dec 02, 2021 10:24    Post subject: Reply with quote
ho1Aetoo wrote:
The bandwidth graph is now very pretty

Not my doing, the filled lines was BS idea/implementation, all though Ive made some fixes to it and a couple more improvements to come in this area.
Previous builds would have broken out of bounds depending on browser font size set.

Take care.

_________________
Saving your retinas from the burn!🔥
DD-WRT Inspired themes for routers
DD-WRT Inspired themes for the phpBB Forum
DD-WRT Inspired themes for the SVN Trac & FTP site
Join in for a chat @ #style_it_themes_public:matrix.org or #style_it_themes:discord

DD-WRT UI Themes Bug Reporting and Discussion thread

Router: ANus RT-AC68U E1 (recognized as C1)
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5811
Location: Texas

PostPosted: Thu Dec 02, 2021 10:27    Post subject: Reply with quote
Linksys EA8500 ...main gateway
DD-WRT v3.0-r47720 std (12/02/21)
Linux 4.9.291 #553 SMP Wed Dec 1 18:24:58 +07 2021 armv7l
GUI install over r47692
static DHCP
local DNS
OVPN server
ext4 samba share encryption required user/PW only
port range forwarding
unbound
both radios good using VANILLA FW
isolated guest net (using target DNS) for wlan0.1 wlan1.1 VLAN on wired port 4 ---> all via br1
HFSC CAKE
All is very good -- uptime 9:40

#

EA8500 ...switch / OVPN server / samba share
renamed 'dd-wrt-webupgrade.bin' to 'firmware.bin' & placed in its /tmp directory
flashed itself over r47695
all good --- uptime 5:03

#

Netgear WNDR3700 V4
DD-WRT v3.0-r47720 std (12/02/21)
Linux 3.18.140-d6 #130412 Thu Dec 2 08:49:31 +07 2021 mips
all ok
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 5104
Location: UK, London, just across the river..

PostPosted: Thu Dec 02, 2021 11:02    Post subject: Reply with quote
Router Model TP-Link WR1043ND V2
Firmware Version DD-WRT v3.0-r47720 std (12/02/21)
Kernel Version Linux 3.18.140-d6 #130384 Thu Dec 2 07:54:51 +07 2021 mips

update: CLI r47692 > r47720
reset: NO
mode: Gateway
status: Operational 3h+
errors: Nothing new, yet...Thanks BS !

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 48646 WAP
TP-Link WR1043NDv2 -DD-WRT 49326 Gateway,DNS,AP Isolation,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -DD-WRT 48971 Gateway,DNS,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -Gargoyle OS 1.13.0b AP,DNS,QoS,Quotas
Qualcomm-Atheros
Netgear R7800 --DD-WRT 49326 Gateway,DNS,AD-Block,AP&Net Isolation,VLAN's,Firewall,DoT,Vanilla
Netgear R9000 --DD-WRT 49049 Gateway,DNS,AD-Block,AP Isolation,Firewall,Forced DNS,DoT,2,4Ghz only,Vanilla
Broadcom
Netgear R7000 ---DD-WRT 49059 Gateway,DNS,AD-Block,Firewall,Forced DNS,VLAN's,DoT,VPN
NOT USING 5Ghz ANYWHERE
------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
urkel
DD-WRT User


Joined: 17 Aug 2008
Posts: 114

PostPosted: Thu Dec 02, 2021 11:38    Post subject: Reply with quote
Router/Version: TP-Link Archer C7 v2
File/Kernel: Linux 3.18.140-d6 #130390 Thu Dec 2 08:05:16 +07 2021 mips
Previous/Reset: r47665 / no
Mode/Status: Gateway / working
Issues/Errors: The bandwidth graph is still the same as it used to be.

Just flashed the unit a couple of minutes ago. Will do some more testing the coming days and report issues.

Thanks BS and to everyone who contributed.

_________________

1x TP-Link Archer C7 V2.0 r48432 (Primary router at primary location. Former Ziggo repeater)
1x TP-Link Archer C7 V2.0 OpenWrt 21.02.3 (Testing at primary location. Former Ziggo repeater)
1x TP-Link Archer C7 V5.0 r48540 (Secondary router at primary location)
1x TP-Link Archer C7 V5.0 OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WR1043ND V4.0 OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (green leds) r48646 (Primary router at secondary location)
1x TP-Link WDR4900 V1.3 (blue leds) OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (green leds) OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (green leds) OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (blue leds) r47925 (Testing at secondary location)
1x Linksys WRT160NL r48494 (Guest network with QoS at secondary location)
1x Linksys WRT54G V2.0 r14929 (Switched off at secondary location)
1x Linksys WRT54GL V1.1 r14929
jrscs
DD-WRT User


Joined: 09 Aug 2010
Posts: 321

PostPosted: Thu Dec 02, 2021 12:33    Post subject: Reply with quote
Router/Version: Netgear XR500 Nighthawk Pro Gaming
Firmware: DD-WRT v3.0-r47720 std (12/02/21)
Kernel: Linux 4.9.291 #555 SMP Thu Dec 2 04:36:07 +07 2021 armv7l
Previous: DD-WRT v3.0-r47692 std (11/28/21)
Update Method: CLI/SSH/Putty
Mode/Status: Gateway/AP/Ok
Reset: No
Setup Using: 2.4 GHz - Vanilla , 2.4 GHz guest (VAP), 5.0 GHz - Vanilla, IPv4, DHCP, DNSMasq, Static Leases, Port Forwarding, USB, NAS, Samba NTFS (User/Password required), NTP Client, Wireguard Server, and Wake-on-WAN (Internet)
Issues/Errors: Yes & No. Not able to find the NAS storage device through File Explorer, but able to map the device/drive for access.

_________________
Netgear XR500, R7800
Asus AC87Ua1
Repeater Bridges(s)
Netgear R6400v2otp
Asus AC68Ra1, AC66Ua1
urkel
DD-WRT User


Joined: 17 Aug 2008
Posts: 114

PostPosted: Thu Dec 02, 2021 13:02    Post subject: Reply with quote
Quote:
Issues/Errors: The bandwidth graph is still the same as it used to be.


I feel stupid. After a browser shutdown the bandwidth graph is new and improved on the Archer C7 v2.

_________________

1x TP-Link Archer C7 V2.0 r48432 (Primary router at primary location. Former Ziggo repeater)
1x TP-Link Archer C7 V2.0 OpenWrt 21.02.3 (Testing at primary location. Former Ziggo repeater)
1x TP-Link Archer C7 V5.0 r48540 (Secondary router at primary location)
1x TP-Link Archer C7 V5.0 OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WR1043ND V4.0 OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (green leds) r48646 (Primary router at secondary location)
1x TP-Link WDR4900 V1.3 (blue leds) OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (green leds) OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (green leds) OpenWrt 21.02.3 (Testing at primary location)
1x TP-Link WDR4900 V1.3 (blue leds) r47925 (Testing at secondary location)
1x Linksys WRT160NL r48494 (Guest network with QoS at secondary location)
1x Linksys WRT54G V2.0 r14929 (Switched off at secondary location)
1x Linksys WRT54GL V1.1 r14929
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 9761
Location: Netherlands

PostPosted: Thu Dec 02, 2021 13:14    Post subject: Reply with quote
jrscs wrote:
Router/Version: Netgear XR500 Nighthawk Pro Gaming
Firmware: DD-WRT v3.0-r47720 std (12/02/21)
Kernel: Linux 4.9.291 #555 SMP Thu Dec 2 04:36:07 +07 2021 armv7l
Previous: DD-WRT v3.0-r47692 std (11/28/21)
Update Method: CLI/SSH/Putty
Mode/Status: Gateway/AP/Ok
Reset: No
Setup Using: 2.4 GHz - Vanilla , 2.4 GHz guest (VAP), 5.0 GHz - Vanilla, IPv4, DHCP, DNSMasq, Static Leases, Port Forwarding, USB, NAS, Samba NTFS (User/Password required), NTP Client, Wireguard Server, and Wake-on-WAN (Internet)
Issues/Errors: Yes & No. Not able to find the NAS storage device through File Explorer, but able to map the device/drive for access.


I am researching a wsdd2 compile error, can you check if wsdd2 is running?
from CLI:
Code:
ps | grep wsdd2

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
jrscs
DD-WRT User


Joined: 09 Aug 2010
Posts: 321

PostPosted: Thu Dec 02, 2021 13:21    Post subject: Reply with quote
egc wrote:
jrscs wrote:
Router/Version: Netgear XR500 Nighthawk Pro Gaming
Firmware: DD-WRT v3.0-r47720 std (12/02/21)
Kernel: Linux 4.9.291 #555 SMP Thu Dec 2 04:36:07 +07 2021 armv7l
Previous: DD-WRT v3.0-r47692 std (11/28/21)
Update Method: CLI/SSH/Putty
Mode/Status: Gateway/AP/Ok
Reset: No
Setup Using: 2.4 GHz - Vanilla , 2.4 GHz guest (VAP), 5.0 GHz - Vanilla, IPv4, DHCP, DNSMasq, Static Leases, Port Forwarding, USB, NAS, Samba NTFS (User/Password required), NTP Client, Wireguard Server, and Wake-on-WAN (Internet)
Issues/Errors: Yes & No. Not able to find the NAS storage device through File Explorer, but able to map the device/drive for access.


I am researching a wsdd2 compile error, can you check if wsdd2 is running?
from CLI:
Code:
ps | grep wsdd2


CLI command entered, but nothing returned

_________________
Netgear XR500, R7800
Asus AC87Ua1
Repeater Bridges(s)
Netgear R6400v2otp
Asus AC68Ra1, AC66Ua1
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1549
Location: Belgrade

PostPosted: Thu Dec 02, 2021 13:31    Post subject: Reply with quote
there is something else interesting too... New updated wsdd2 supports "network shares on UNIX platforms to apear in Windows File Explorer / Network" but needs 239.255.255.250 and ff02::c, protocol UDP port 3702 to be opened? https://svn.dd-wrt.com/browser/src/router/wsdd2/README.md
MLandi
DD-WRT Guru


Joined: 04 Dec 2007
Posts: 711

PostPosted: Thu Dec 02, 2021 13:42    Post subject: Reply with quote
Update method: SSH / CLI
Router/Version: Netgear R9000 Nighthawk X10
File/Kernel: DD-WRT v3.0-r47720 std (12/02/21)
Previous/Reset: DD-WRT v3.0-r47695 std (11/29/21) / No
Mode/Status: Gateway / Working Normally
Issues/Errors:
    (1) Incoming & Outgoing logs show nothing (not a new issue)
    (2) Although the build did load the leases file on reboot, I had to uncheck Use JFFS2 for client lease DB, Apply, re-check and Apply, then delete lete /tmp/dnsmasq.leases to get leases to start updating to /jffs.

_________________
Netgear R9000 X10
DD-WRT v3.0-r49361 std (06/26/22)
Gateway, AP, DNSMasq, Clock 2000MHz
VAP on wlan1 for internet devices
IPv4 & IPv6 (Prefix Delegation)
Static Leases & DHCP
CloudFlare, QoS Disabled, SmartDNS Disabled
2.4GHz: DD-WRT Firmware, Airtime Fairness Enabled, NG-Mixed, 10 + 6 (2457 MHz HT40), ACK Timing 0 (Auto), WPA2 w/AES
5GHz: DD-WRT Firmware, Airtime Fairness Enabled, AC/N Mixed, 100 + 114 (5500 MHz VHT160), ACK Timing 0 (Auto), WPA2 w/AES
Xfinity 1.2Gbps/42Mbps
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 9761
Location: Netherlands

PostPosted: Thu Dec 02, 2021 15:51    Post subject: Reply with quote
jrscs wrote:
egc wrote:
jrscs wrote:
Router/Version: Netgear XR500 Nighthawk Pro Gaming
Firmware: DD-WRT v3.0-r47720 std (12/02/21)
Kernel: Linux 4.9.291 #555 SMP Thu Dec 2 04:36:07 +07 2021 armv7l
Previous: DD-WRT v3.0-r47692 std (11/28/21)
Update Method: CLI/SSH/Putty
Mode/Status: Gateway/AP/Ok
Reset: No
Setup Using: 2.4 GHz - Vanilla , 2.4 GHz guest (VAP), 5.0 GHz - Vanilla, IPv4, DHCP, DNSMasq, Static Leases, Port Forwarding, USB, NAS, Samba NTFS (User/Password required), NTP Client, Wireguard Server, and Wake-on-WAN (Internet)
Issues/Errors: Yes & No. Not able to find the NAS storage device through File Explorer, but able to map the device/drive for access.


I am researching a wsdd2 compile error, can you check if wsdd2 is running?
from CLI:
Code:
ps | grep wsdd2


CLI command entered, but nothing returned


It looks like wsdd2 is not installed (should be in /usr/sbin ).
I could be that there is a missing line in the makefile:
Code:
DESTDIR = $(INSTALLDIR)


But I am not the greatest compiler expert.

Will contact BS

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
yoyoma2
DD-WRT User


Joined: 24 Sep 2016
Posts: 278

PostPosted: Thu Dec 02, 2021 21:39    Post subject: Reply with quote
Our wsdd2 northstar build breaks after changeset 47696 deleted the initialization of DESTDIR which is now empty and still being used. Thanks @egc for finding this. Restoring that line as below fixed it.
Code:
$ svn diff src/router/wsdd2/Makefile
Index: src/router/wsdd2/Makefile
===================================================================
--- src/router/wsdd2/Makefile   (revision 47720)
+++ src/router/wsdd2/Makefile   (working copy)
@@ -10,6 +10,7 @@
 
 OBJFILES      = wsdd2.o wsd.o llmnr.o
 HEADERS       = wsdd.h wsd.h
+DESTDIR       = $(INSTALLDIR)
 
 PREFIX  ?= /usr
 SBINDIR ?= $(PREFIX)/sbin
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 481

PostPosted: Fri Dec 03, 2021 15:52    Post subject: Reply with quote
Router/Version: Netgear R7800
File: dd-wrt-webupgrade.bin
Firmware: DD-WRT v3.0-r47720 std (12/02/21) (prev. DD-WRT v3.0-r47692 std (11/28/21))
Kernel: Linux 4.9.291 #555 SMP Thu Dec 2 04:36:07 +07 2021 armv7l
Mode: Gateway, SFE disabled, 2.4G and 5G wifi, Wireguard for external access, WAN to 4G, Keep Alive reboot 6:02 in the morning
Reset: No
Status: Ok, installed 1h ago.

Is it me or does the default font size at router_status.asp looks bigger than before?
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum