New Build - 12/02/2021 - r47720

Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 10056
Location: Netherlands

PostPosted: Thu Dec 02, 2021 13:14    Post subject: Reply with quote
jrscs wrote:
Router/Version: Netgear XR500 Nighthawk Pro Gaming
Firmware: DD-WRT v3.0-r47720 std (12/02/21)
Kernel: Linux 4.9.291 #555 SMP Thu Dec 2 04:36:07 +07 2021 armv7l
Previous: DD-WRT v3.0-r47692 std (11/28/21)
Update Method: CLI/SSH/Putty
Mode/Status: Gateway/AP/Ok
Reset: No
Setup Using: 2.4 GHz - Vanilla , 2.4 GHz guest (VAP), 5.0 GHz - Vanilla, IPv4, DHCP, DNSMasq, Static Leases, Port Forwarding, USB, NAS, Samba NTFS (User/Password required), NTP Client, Wireguard Server, and Wake-on-WAN (Internet)
Issues/Errors: Yes & No. Not able to find the NAS storage device through File Explorer, but able to map the device/drive for access.


I am researching a wsdd2 compile error, can you check if wsdd2 is running?
from CLI:
Code:
ps | grep wsdd2

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Sponsor
jrscs
DD-WRT User


Joined: 09 Aug 2010
Posts: 321

PostPosted: Thu Dec 02, 2021 13:21    Post subject: Reply with quote
egc wrote:
jrscs wrote:
Router/Version: Netgear XR500 Nighthawk Pro Gaming
Firmware: DD-WRT v3.0-r47720 std (12/02/21)
Kernel: Linux 4.9.291 #555 SMP Thu Dec 2 04:36:07 +07 2021 armv7l
Previous: DD-WRT v3.0-r47692 std (11/28/21)
Update Method: CLI/SSH/Putty
Mode/Status: Gateway/AP/Ok
Reset: No
Setup Using: 2.4 GHz - Vanilla , 2.4 GHz guest (VAP), 5.0 GHz - Vanilla, IPv4, DHCP, DNSMasq, Static Leases, Port Forwarding, USB, NAS, Samba NTFS (User/Password required), NTP Client, Wireguard Server, and Wake-on-WAN (Internet)
Issues/Errors: Yes & No. Not able to find the NAS storage device through File Explorer, but able to map the device/drive for access.


I am researching a wsdd2 compile error, can you check if wsdd2 is running?
from CLI:
Code:
ps | grep wsdd2


CLI command entered, but nothing returned

_________________
Netgear XR500, R7800
Asus AC87Ua1
Repeater Bridges(s)
Netgear R6400v2otp
Asus AC68Ra1, AC66Ua1
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1554
Location: Belgrade

PostPosted: Thu Dec 02, 2021 13:31    Post subject: Reply with quote
there is something else interesting too... New updated wsdd2 supports "network shares on UNIX platforms to apear in Windows File Explorer / Network" but needs 239.255.255.250 and ff02::c, protocol UDP port 3702 to be opened? https://svn.dd-wrt.com/browser/src/router/wsdd2/README.md
MLandi
DD-WRT Guru


Joined: 04 Dec 2007
Posts: 739

PostPosted: Thu Dec 02, 2021 13:42    Post subject: Reply with quote
Update method: SSH / CLI
Router/Version: Netgear R9000 Nighthawk X10
File/Kernel: DD-WRT v3.0-r47720 std (12/02/21)
Previous/Reset: DD-WRT v3.0-r47695 std (11/29/21) / No
Mode/Status: Gateway / Working Normally
Issues/Errors:
    (1) Incoming & Outgoing logs show nothing (not a new issue)
    (2) Although the build did load the leases file on reboot, I had to uncheck Use JFFS2 for client lease DB, Apply, re-check and Apply, then delete lete /tmp/dnsmasq.leases to get leases to start updating to /jffs.

_________________
Netgear R9000 X10
DD-WRT v3.0-r49677 std (08/10/22)
Gateway, AP, DNSMasq, Clock 2000MHz
VAP on wlan1 for internet devices
IPv4 & IPv6 (Prefix Delegation)
Static Leases & DHCP
CloudFlare, QoS Disabled, SmartDNS Disabled
2.4GHz: VANILLA Firmware, Airtime Fairness Enabled, NG-Mixed, 10 + 6 (2457 MHz HT40), ACK Timing 450, WPA2 w/AES
5GHz: VANILLA Firmware, Airtime Fairness Enabled, AC/N Mixed, 100 + 106 (5500 MHz VHT80), ACK Timing 450, WPA2 w/AES
Xfinity 1.2Gbps/42Mbps
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 10056
Location: Netherlands

PostPosted: Thu Dec 02, 2021 15:51    Post subject: Reply with quote
jrscs wrote:
egc wrote:
jrscs wrote:
Router/Version: Netgear XR500 Nighthawk Pro Gaming
Firmware: DD-WRT v3.0-r47720 std (12/02/21)
Kernel: Linux 4.9.291 #555 SMP Thu Dec 2 04:36:07 +07 2021 armv7l
Previous: DD-WRT v3.0-r47692 std (11/28/21)
Update Method: CLI/SSH/Putty
Mode/Status: Gateway/AP/Ok
Reset: No
Setup Using: 2.4 GHz - Vanilla , 2.4 GHz guest (VAP), 5.0 GHz - Vanilla, IPv4, DHCP, DNSMasq, Static Leases, Port Forwarding, USB, NAS, Samba NTFS (User/Password required), NTP Client, Wireguard Server, and Wake-on-WAN (Internet)
Issues/Errors: Yes & No. Not able to find the NAS storage device through File Explorer, but able to map the device/drive for access.


I am researching a wsdd2 compile error, can you check if wsdd2 is running?
from CLI:
Code:
ps | grep wsdd2


CLI command entered, but nothing returned


It looks like wsdd2 is not installed (should be in /usr/sbin ).
I could be that there is a missing line in the makefile:
Code:
DESTDIR = $(INSTALLDIR)


But I am not the greatest compiler expert.

Will contact BS

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
yoyoma2
DD-WRT User


Joined: 24 Sep 2016
Posts: 286

PostPosted: Thu Dec 02, 2021 21:39    Post subject: Reply with quote
Our wsdd2 northstar build breaks after changeset 47696 deleted the initialization of DESTDIR which is now empty and still being used. Thanks @egc for finding this. Restoring that line as below fixed it.
Code:
$ svn diff src/router/wsdd2/Makefile
Index: src/router/wsdd2/Makefile
===================================================================
--- src/router/wsdd2/Makefile   (revision 47720)
+++ src/router/wsdd2/Makefile   (working copy)
@@ -10,6 +10,7 @@
 
 OBJFILES      = wsdd2.o wsd.o llmnr.o
 HEADERS       = wsdd.h wsd.h
+DESTDIR       = $(INSTALLDIR)
 
 PREFIX  ?= /usr
 SBINDIR ?= $(PREFIX)/sbin
Zyxx
DD-WRT Guru


Joined: 28 Dec 2018
Posts: 512

PostPosted: Fri Dec 03, 2021 15:52    Post subject: Reply with quote
Router/Version: Netgear R7800
File: dd-wrt-webupgrade.bin
Firmware: DD-WRT v3.0-r47720 std (12/02/21) (prev. DD-WRT v3.0-r47692 std (11/28/21))
Kernel: Linux 4.9.291 #555 SMP Thu Dec 2 04:36:07 +07 2021 armv7l
Mode: Gateway, SFE disabled, 2.4G and 5G wifi, Wireguard for external access, WAN to 4G, Keep Alive reboot 6:02 in the morning
Reset: No
Status: Ok, installed 1h ago.

Is it me or does the default font size at router_status.asp looks bigger than before?
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5842
Location: Texas

PostPosted: Fri Dec 03, 2021 18:04    Post subject: Reply with quote
Zyxx wrote:
Is it me or does the default font size at router_status.asp looks bigger than before?

looky 'bout same to me
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 4123

PostPosted: Fri Dec 03, 2021 18:23    Post subject: Reply with quote
Zyxx wrote:
Is it me or does the default font size at router_status.asp looks bigger than before?

Yes, I zoomed out to 90% and appearance is close to before but do not know when (r47695 or r47720)?

Edit (among ninjas): https://svn.dd-wrt.com/changeset/47700
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12837
Location: Texas, USA

PostPosted: Fri Dec 03, 2021 19:46    Post subject: Reply with quote
@egc, @yoyoma2, @jrscs - it should be fixed in next release:
https://svn.dd-wrt.com/changeset/47739

_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Pogo - A minimal level of ability is expected and needed...
At some point, people just get plain tired of this place.

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 10056
Location: Netherlands

PostPosted: Fri Dec 03, 2021 20:17    Post subject: Reply with quote
:thumbsup: Smile
_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Zyxx
DD-WRT Guru


Joined: 28 Dec 2018
Posts: 512

PostPosted: Sat Dec 04, 2021 9:34    Post subject: Reply with quote
Ha! Knew it Wink

Spend some time after installation in the webinterface and this was messing with me...
pbphoto
DD-WRT User


Joined: 29 Oct 2017
Posts: 245

PostPosted: Mon Dec 06, 2021 1:16    Post subject: Reply with quote
Router Model & Version: two Netgear R7800's
Firmware: DD-WRT v3.0-r47720 std (12/02/21)
File: dd-wrt-webupgrade.bin
Kernel: Linux 4.9.291 #555 SMP Thu Dec 2 04:36:07 +07 2021 armv7l
Previous: DD-WRT v3.0-r47692 std (11/28/21)
Reset: No
Mode: AP / Router mode - vanilla wifi firmware
Uptime: ~3+ days
Status: Excellent release. No iphone wifi hang-ups. roaming working great. 47692 was great too.
Issues/Errors: I had to restart httpd the first day- been fine since
Environment:
Two Netgear r7800s - as hardwired WAPs in router-mode, SFE enabled, DNSmasq disabled, NAS disabled, firewall disabled, QoS disabled. WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 11, BI=400, DTIM=1. 5ghz: AC/N mixed, 80mhz channel width, channel 149+U6, BI=300, DTIM=1. Both radios: Vanilla FW, WPA2-CCMP-128, strict rekey enabled, 802.11r enabled, 802.11w disabled, disable eapol retries disabled.
Clients: Apple MACOS x 4, IOS x 4, Apple TV, Chromecast Audio x 2, Eufy doorbells, Lutron Caseta, Axis Camera, Samsung TV, Nest thermostat, EtekCity outlets (Espressif), BlueSound/BlueOS devices...
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum