(SOLVED) Brcked TP-Link 1043v2 after uploading 47656

Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware
Author Message
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 5180
Location: UK, London, just across the river..

PostPosted: Wed Nov 24, 2021 17:45    Post subject: (SOLVED) Brcked TP-Link 1043v2 after uploading 47656 Reply with quote
Bricked my TP-Link-1043v2
I was updating via CLI 47528 > 47656 when suddenly halfway trough the CLI flashing hanged and router bricked...

connected serial tx to rx, rx to tx and grd...powered the router serial output hangs and unit reboots

Code:
U-Boot 1.1.4 (Jun 13 2014 - 15:14:01)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(178): (16bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x0, 0x1b)
Tap values = (0xd, 0xd, 0xd, 0xd)
64 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x17
flash size 8MB, sector count = 128
Flash:  8 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0xe
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7114
eth0: ba:bc:ca:fe:01:49
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:bc:ca:fe:01:49
eth1 up
eth0, eth1
Setting 0x18116290 to 0x50a1a14f
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

[    0.000000] Linux version 3.18.140-d6 (root@linux) (gcc version 11.1.0 (OpenWrt GCC 11.1.0 r16592-aabc632023) ) #129608 Thu Nov 18 05:15:03 +07 2021
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019750 (MIPS 74Kc)
[    0.000000] cpu apb ddr apb cpu 720 ddr 600 ahb 200
QCA9558
detect mem size
Uart Init
Booting WASP !!! -:) ...
[    0.000000] sys id = 1130 Qualcomm Atheros QCA9558 ver 1 rev 1.0 (0x1130)
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x03ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x03ffffff]
[    0.000000] Initmem setup node 0 [mem 0x00000000-0x03ffffff]
[    0.000000] Primary instruction cache 64kB, 4-way, VIPT, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line: console=ttyS0,115200 root=1f02 rootfstype=squashfs noinitrd init=/sbin/init
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 61580K/65536K available (2228K kernel code, 148K rwdata, 236K rodata, 192K init, 144K bss, 3956K reserved, 0K cma-reserved)
[    0.000000] NR_IRQS:83
[    0.000000] Calibrating delay loop... 358.80 BogoMIPS (lpj=1794048)
[    0.060000] pid_max: default: 32768 minimum: 301
[    0.060000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.070000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.070000] NET: Registered protocol family 16
[    0.490000] ar724x-pci ar724x-pci.0: PCIe link is down
[    0.500000] registering PCI controller with io_map_base unset
[    0.500000] ar724x-pci ar724x-pci.1: PCIe link is down
[    0.510000] registering PCI controller with io_map_base unset
[    0.520000] PCI host bridge to bus 0000:00
[    0.530000] pci_bus 0000:00: root bus resource [mem 0x10000000-0x11ffffff]
[    0.530000] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.540000] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.540000] PCI host bridge to bus 0000:01
[    0.550000] pci_bus 0000:01: root bus resource [mem 0x12000000-0x13ffffff]
[    0.550000] pci_bus 0000:01: root bus resource [io  0x0001]
[    0.560000] pci_bus 0000:01: No busn resource found for root bus, will use [bus 01-ff]
[    0.560000] Switched to clocksource MIPS
[    0.570000] NET: Registered protocol family 2
[    0.570000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.570000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.580000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.580000] TCP: reno registered
[    0.590000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.590000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.600000] NET: Registered protocol family 1
[    0.600000] gpio_proc: module loaded and /proc/gpio/ created (cool)
[    0.610000] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.620000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.630000] msgmni has been set to 120
[    0.630000] io scheduler noop registered
[    0.630000] io scheduler deadline registered (default)
[    0.640000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
-[    0.670000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 2500000) is a 16550A
[    0.680000] console [ttyS0] enabled
[    0.680000] console [ttyS0] enabled
[    0.680000] bootconsole [early0] disabled
[    0.680000] bootconsole [early0] disabled
[    0.690000] jedec ID EF4017
[    0.700000] flash size 8388608B, sector count = 128
[    0.700000] scanning for root partition
[    0.700000] tplink uboot detected
[    0.710000] guessed bootloader size = 20000
[    0.730000]
[    0.730000] found squashfs at 10A000
[    0.730000] adjusted length 6D0000, original length 6CA5EA
[    0.740000] Creating 9 MTD partitions on "ar7240-nor0":
[    0.750000] 0x000000000000-0x000000020000 : "RedBoot"
[    0.750000] 0x000000020000-0x0000007e0000 : "linux"
[    0.760000] 0x00000010a000-0x0000006d0000 : "rootfs"
[    0.760000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.780000] mtd: partition "rootfs" set to be root filesystem
[    0.780000] 0x0000006d0000-0x0000007e0000 : "ddwrt"
[    0.790000] 0x0000007e0000-0x0000007f0000 : "nvram"
[    0.790000] 0x0000007f0000-0x000000800000 : "board_config"
[    0.800000] 0x000000000000-0x000000800000 : "fullflash"
[    0.800000] 0x000000000000-0x000000020000 : "fullboot"
[    0.810000] 0x000000010000-0x000000020000 : "uboot-env"
[    0.820000] libphy: Fixed MDIO Bus: probed
[    0.830000] u32 classifier
[    0.830000]     Performance counters on
[    0.830000]     input device check on
[    0.840000]     Actions configured
[    0.840000] Netfilter messages via NETLINK v0.30.
[    0.840000] nf_conntrack version 0.5.0 (962 buckets, 3848 max)
[    0.850000] nf_conntrack_rtsp v0.7 loading
[    0.850000] nf_nat_rtsp v0.7 loading
[    0.860000] ip_tables: (C) 2000-2006 Netfilter Core Team
[    0.860000] TCP: bic registered
[    0.870000] TCP: cubic registered
[    0.870000] TCP: westwood registered
[    0.870000] TCP: hybla registered
[    0.880000] TCP: vegas registered
[    0.880000] NET: Registered protocol family 17
[    0.890000] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    0.900000] Bridge firewalling registered
[    0.900000] 8021q: 802.1Q VLAN Support v1.8
[    0.910000] searching for nvram
[    0.910000] nvram size = 65536
[    0.960000] Atheros AR71xx hardware watchdog driver version 0.1.0
[    0.970000] ar71xx-wdt: timeout=15 secs (max=107) ref freq=40000000
[    0.990000] squashfs: SQUASHFS error: unable to read id index table
[    0.990000] List of all partitions:
[    1.000000] 1f00             128 mtdblock0  (driver?)
[    1.000000] 1f01            7936 mtdblock1  (driver?)
[    1.010000] 1f02            5912 mtdblock2  (driver?)
[    1.010000] 1f03            1088 mtdblock3  (driver?)
[    1.020000] 1f04              64 mtdblock4  (driver?)
[    1.020000] 1f05              64 mtdblock5  (driver?)
[    1.030000] 1f06            8192 mtdblock6  (driver?)
[    1.030000] 1f07             128 mtdblock7  (driver?)
[    1.040000] 1f08              64 mtdblock8  (driver?)
[    1.040000] No filesystem could mount root, tried:  squashfs
[    1.050000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)
[    1.050000] Rebooting in 1 seconds..


so, i couldn't find any info for serial recovery, apart that one in openwrt...
not sure shall i use those commands if they are correct for DDWRT:

Code:
tftp 0x80060000 firmware.bin
erase 0x9f020000 +${filesize}
cp.b 0x80060000 0x9f020000 ${filesize}
boot.m 0x9f020000


in my case new recovery file size is 8060928 - 7B0000
but dont know the old one that was flashed or whatever was flashed..
any help ?

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 49599 WAP
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,AP Isolation,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -Gargoyle OS 1.13.0b AP,DNS,QoS,Quotas
Qualcomm-Atheros
Netgear R7800 --DD-WRT 49626 Gateway,DNS,AD-Block,AP&Net Isolation,VLAN's,Firewall,DoT,Vanilla
Netgear R9000 --DD-WRT 49599 Gateway,DNS,AD-Block,AP Isolation,Firewall,Forced DNS,DoT,2,4Ghz only,Vanilla
Broadcom
Netgear R7000 ---DD-WRT 49626 Gateway,DNS,AD-Block,Firewall,Forced DNS,VLAN's,DoT,VPN
NOT USING 5Ghz ANYWHERE
------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913


Last edited by Alozaros on Thu Nov 25, 2021 18:25; edited 3 times in total
Sponsor
the-joker
DD-WRT Developer/Maintainer


Joined: 31 Jul 2021
Posts: 1583
Location: All over YOUR webs

PostPosted: Wed Nov 24, 2021 18:06    Post subject: Reply with quote
Hello there =)

You are connected via Serial, think about this for a second.

Is that really DD-WRT? I dont think so.

Im not familiar with your router anyway, but as long as you dont mess up the CFE/UBoot, which you should backup BTW, so if you mess it up you can always have a working one.

Edit: reading the openwrt site, its not clear what the serial recovery method is for the v2, and it seems to me the commands you have are for TFTP recovery.

You need the correct firmware also, I think you need to read through the recovery procedures and use the correct methods for your version.

What you really want here is recover the FW, doesn't matter if you flash openwrt or the factory or what, you can always get back to dd-wrt.

Or maybe wait for a reply from someone who has serial recovered your router.

Have a nice evening.

_________________
Saving your retinas from the burn!🔥
DD-WRT Inspired themes for routers
DD-WRT Inspired themes for the phpBB Forum
DD-WRT Inspired themes for the SVN Trac & FTP site
Join in for a chat @ #style_it_themes_public:matrix.org or #style_it_themes:discord

DD-WRT UI Themes Bug Reporting and Discussion thread

Router: ANus RT-AC68U E1 (recognized as C1)
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 5180
Location: UK, London, just across the river..

PostPosted: Wed Nov 24, 2021 18:47    Post subject: Reply with quote
the-joker wrote:
Hello there =)

You are connected via Serial, think about this for a second.

Is that really DD-WRT? I dont think so.

Yes it is... Laughing

ok tried those commands with my values

tftp 0x80060000 firmware.bin
erase 0x9f020000 +7B001C
cp.b 0x80060000 0x9f020000 7B0000
boot.m 0x9f020000

file was copied (factory-to-ddwrt 47528), but on boot same loop
i suspect its something else or im missing something...

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 49599 WAP
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,AP Isolation,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -Gargoyle OS 1.13.0b AP,DNS,QoS,Quotas
Qualcomm-Atheros
Netgear R7800 --DD-WRT 49626 Gateway,DNS,AD-Block,AP&Net Isolation,VLAN's,Firewall,DoT,Vanilla
Netgear R9000 --DD-WRT 49599 Gateway,DNS,AD-Block,AP Isolation,Firewall,Forced DNS,DoT,2,4Ghz only,Vanilla
Broadcom
Netgear R7000 ---DD-WRT 49626 Gateway,DNS,AD-Block,Firewall,Forced DNS,VLAN's,DoT,VPN
NOT USING 5Ghz ANYWHERE
------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12837
Location: Texas, USA

PostPosted: Wed Nov 24, 2021 21:07    Post subject: Reply with quote
the-joker wrote:
Hello there =)

You are connected via Serial, think about this for a second.

Is that really DD-WRT? I dont think so.

DD-WRT uses an OpenWRT-based toolchain. This is nothing new. YES that is DD-WRT and his router; I have one just like it.

@Alozaros: You *should* be able to use the OpenWRT method, but I think the steps may be out of order.

Also, you should be trying to flash 47644, possibly the factory-to-ddwrt.bin. You may also have to reset the environment in u-boot. And your thread title is wrong, should be 47656, not 47565 Wink

https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1250813#1250813

EDIT: I sent your serial log to BrainSlayer, not sure if anyone else had already. Thanks for the info, hopefully this will be fixed. Not sure I want to tempt fate until I get the word on 47665.

EDIT2: I am hesitant to try 47665 at the moment, as I would prefer to wait to see if BS has any 'good news' to either wait or that the problem is already fixed in current release.

_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Pogo - A minimal level of ability is expected and needed...
At some point, people just get plain tired of this place.

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 5180
Location: UK, London, just across the river..

PostPosted: Thu Nov 25, 2021 6:18    Post subject: Reply with quote
[ 0.730000] found squashfs at 10A000
[ 0.730000] adjusted length 6D0000, original length 6CA5EA
[ 0.740000] Creating 9 MTD partitions on "ar7240-nor0":
[ 0.750000] 0x000000000000-0x000000020000 : "RedBoot"
[ 0.750000] 0x000000020000-0x0000007e0000 : "linux"
[ 0.760000] 0x00000010a000-0x0000006d0000 : "rootfs"
[ 0.760000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.780000] mtd: partition "rootfs" set to be root filesystem
.........................
0.990000] squashfs: SQUASHFS error: unable to read id index table
................................
1.040000] No filesystem could mount root, tried: squashfs
[ 1.050000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)
[ 1.050000] Rebooting in 1 seconds..
................................................

it seams something messy with SQUASHFS location or...size..
not sure if stripped stock file will work...??
but will wait to see BS final call..

the other things about OpenWrt steps is +$ the dollar symbol is not needed as it doesn't work with it...also not sure if my sizes are correct but according to file size and hex converter those should be
correct...unless OpenWrt size mentioned, is better to be erased to start with..7c0000...

i dearly hope for solution ATM... Rolling Eyes Cool

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 49599 WAP
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,AP Isolation,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -Gargoyle OS 1.13.0b AP,DNS,QoS,Quotas
Qualcomm-Atheros
Netgear R7800 --DD-WRT 49626 Gateway,DNS,AD-Block,AP&Net Isolation,VLAN's,Firewall,DoT,Vanilla
Netgear R9000 --DD-WRT 49599 Gateway,DNS,AD-Block,AP Isolation,Firewall,Forced DNS,DoT,2,4Ghz only,Vanilla
Broadcom
Netgear R7000 ---DD-WRT 49626 Gateway,DNS,AD-Block,Firewall,Forced DNS,VLAN's,DoT,VPN
NOT USING 5Ghz ANYWHERE
------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7323
Location: Dresden, Germany

PostPosted: Thu Nov 25, 2021 6:26    Post subject: Reply with quote
looks more like its not fully flashed and your flash commands (especially the size with +0x1c addition are definitly wrong. flashing must be always aligned to sector sizes with is 0x10000 here in that case

the factory to dd-wrt file is exactly 7B0000 bytes. but the dd-wrt webflash is 7b001c. so i assume you are flashing the wrong file. for recovery you must use factory-to-ddwrt.bin and nothing else

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 5180
Location: UK, London, just across the river..

PostPosted: Thu Nov 25, 2021 6:31    Post subject: Reply with quote
BrainSlayer wrote:
looks more like its not fully flashed and your flash commands (especially the size with +0x1c addition are definitly wrong. flashing must be always aligned to sector sizes with is 0x10000 here in that case

the factory to dd-wrt file is exactly 7B0000 bytes. but the dd-wrt webflash is 7b001c. so i assume you are flashing the wrong file. for recovery you must use factory-to-ddwrt.bin and nothing else


well..thanks for looking on it BS
yep i used the factory file 47528...so lets presume
erase 7b001c, flash 7b0000...??

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 49599 WAP
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,AP Isolation,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -Gargoyle OS 1.13.0b AP,DNS,QoS,Quotas
Qualcomm-Atheros
Netgear R7800 --DD-WRT 49626 Gateway,DNS,AD-Block,AP&Net Isolation,VLAN's,Firewall,DoT,Vanilla
Netgear R9000 --DD-WRT 49599 Gateway,DNS,AD-Block,AP Isolation,Firewall,Forced DNS,DoT,2,4Ghz only,Vanilla
Broadcom
Netgear R7000 ---DD-WRT 49626 Gateway,DNS,AD-Block,Firewall,Forced DNS,VLAN's,DoT,VPN
NOT USING 5Ghz ANYWHERE
------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7323
Location: Dresden, Germany

PostPosted: Thu Nov 25, 2021 6:33    Post subject: Reply with quote
why 7b001c? the size of the file is 7b0000 and all write/erase operations must be sector aligned. 7b001c is wrong. if your file is 7b001c, you are using the wrong file. use factory-to-ddwrt.bin for recovery and nothing else. this file is 0x7b0000
_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 5180
Location: UK, London, just across the river..

PostPosted: Thu Nov 25, 2021 6:39    Post subject: Reply with quote
tftp 0x80060000 firmware.bin
erase 0x9f020000 +7B001C
cp.b 0x80060000 0x9f020000 7B0000
boot.m 0x9f020000

the guide says erase the present flash +7B001C
than copy cp.b 0x80060000 0x9f020000 7B0000 ...

is this correct or it should be

erase 0x9f020000 7B0000
cp.b 0x80060000 0x9f020000 7B0000

instead...as it seams im trying to flash factory file
not the web flash isn't it ?

ok i'll try that as it makes more sense..

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 49599 WAP
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,AP Isolation,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -Gargoyle OS 1.13.0b AP,DNS,QoS,Quotas
Qualcomm-Atheros
Netgear R7800 --DD-WRT 49626 Gateway,DNS,AD-Block,AP&Net Isolation,VLAN's,Firewall,DoT,Vanilla
Netgear R9000 --DD-WRT 49599 Gateway,DNS,AD-Block,AP Isolation,Firewall,Forced DNS,DoT,2,4Ghz only,Vanilla
Broadcom
Netgear R7000 ---DD-WRT 49626 Gateway,DNS,AD-Block,Firewall,Forced DNS,VLAN's,DoT,VPN
NOT USING 5Ghz ANYWHERE
------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12837
Location: Texas, USA

PostPosted: Thu Nov 25, 2021 7:38    Post subject: Reply with quote
My advice to you is to webflash from this point forward, as that takes care of shutting down services that take up resources. Wondering if you are running too many things that are creating an OOM condition that bit you. This may have also been why the last brick happened and you didn't realize it. Let us know how you fared.
_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Pogo - A minimal level of ability is expected and needed...
At some point, people just get plain tired of this place.

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 5180
Location: UK, London, just across the river..

PostPosted: Thu Nov 25, 2021 18:45    Post subject: Reply with quote
Unit Recovered/UnBricked Thanks to everyone especially BS and KP-69

commands/steps used:
1. connect to serial interface (usb to TTL adapter)
connected serial tx to rx, rx to tx and grd...do not need 3.3V at this point
2. I used putty and tftpd32 - set putty to serial and configure serial to:

Bits per second: 115200
Data bits: 8
Parity: None
Stop bits: 1
Flow control: None

Than configure tftpd to:
The tftp server must be listening on 192.168.1.100:69 (Version 2.1 with U-Boot 1.1.4 (Jul 17 2015 - 14:31:22))
also you must copy factory-to-ddwrt file to tftpd32 directory and rename it to firmware.bin and point tftpd32 to it....

3. Make sure to turn your firewall and antivirus off
4. When serial interface shows output, right at the begging you have to quickly type tpl and hit enter...(you must be very quick)

5. Once you are in U-boot command prompt will show aer32>
than commands i used:

tftp 0x80060000 firmware.bin
erase 0x9f020000 +{filesize}
cp.b 0x80060000 0x9f020000 {filesize}
boot.m 0x9f020000

in my case

tftp 0x80060000 firmware.bin
erase 0x9f020000 +7b0000
cp.b 0x80060000 0x9f020000 7b0000
boot.m 0x9f020000

this is very important my factory to ddwrt file has the size of 7b0000 witch converted from hex to decimal mode is 8060928, you have to convert your factory size file to hex and replace it
also erase line and cp.b line must match the hex size
like in my example....

here is link to hex to decimal converter https://www.rapidtables.com/convert/number/hex-to-decimal.html

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 49599 WAP
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,AP Isolation,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -DD-WRT 49599 Gateway,DNS,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -Gargoyle OS 1.13.0b AP,DNS,QoS,Quotas
Qualcomm-Atheros
Netgear R7800 --DD-WRT 49626 Gateway,DNS,AD-Block,AP&Net Isolation,VLAN's,Firewall,DoT,Vanilla
Netgear R9000 --DD-WRT 49599 Gateway,DNS,AD-Block,AP Isolation,Firewall,Forced DNS,DoT,2,4Ghz only,Vanilla
Broadcom
Netgear R7000 ---DD-WRT 49626 Gateway,DNS,AD-Block,Firewall,Forced DNS,VLAN's,DoT,VPN
NOT USING 5Ghz ANYWHERE
------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum