wifi analyzers see just 1 of 2 SSIDs - ArcherC7v3

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
darussiaman
DD-WRT User


Joined: 30 May 2007
Posts: 94
Location: Arizona, USA

PostPosted: Sun Oct 17, 2021 22:58    Post subject: wifi analyzers see just 1 of 2 SSIDs - ArcherC7v3 Reply with quote
I asked this before but now I have better info and context, so I figured I'd make a new post and ask the question in a more organized way.

I currently have 3 routers to compare/play with:
1.) a router/modem box that was installed by our ISP
2.) A Netgear WNDR3700 v3 with an old build, from 2012, of DD-WRT loaded on it.
3.) A TP-Link Archer C7 v3. Currently has build r41791 on it.

So I turned on all 3 routers simultaneously (only #1 is actually connected to modem), and I opened my two wifi analyzer programs, inSSIDer 2.1 and Acrylic Wi-Fi Home 4.5, to compare. In all three routers, each of the two bands (2.4 and 5 GHz) is designated by a unique SSID.

Long story short, both wifi analyzers can only detect one of the two SSIDs that are broadcast by the Archer C7 router, even though Windows does identify both networks separately in its WiFi list, as expected. This behavior also happened on two other builds that I tried: 44715 and 46604. For the other two routers, each SSID is shown separately by the wifi analyzer programs, as expected.

My questions:
1.) This behavior/symptom is unexpected, correct? Can someone confirm that this is NOT supposed to be happening?
2.) Should I worry about it? Does it mean something is wrong with how DD-WRT is working?


Further details:

For router #2 I called the SSIDs "Test Network 2.4" and "Test Network 5". For router #3 (the Archer) I set them as "Test Network 2.4 (2)" and "Test Network 5 (2)".

Attached is a screen shot showing the wifi analyzers side by side. This is hard to see so here's a link to the high-resolution version:
https://postimg.cc/0rjyXbGz

Both wifi analyzers are set to show strongest networks at the top. The two networks from the ISP modem/router are visible--those are the "ARRIS-4199" and "ARRIS-4199-5G". The two networks from the Netgear router (old DD-WRT build) are also visible: "Test Network 2.4" and "Test Network 5". However, from the Archer C7 router (newish DD-WRT build), "Test Network 5 (2)" is missing from both analyzers even though it's there in the Windows wifi list. In the screen shot, the arrows point to the two SSIDs from this router. I also searched "test network" in the search box that is in the top left corner of inSSIDer, and only 3 SSID results come up, which verifies that the expected 4th SSID is not somewhere further down on the list. You can see this in the second screen shot attached.

I did follow the "QCA BEST WIFI SETTINGS" sticky thread.

EDIT: Why is the thread title getting cut off?

_________________
Not all those who wander are lost
Sponsor
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum