New Build - 09/28/2021 - r47495

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3431

PostPosted: Tue Sep 28, 2021 6:33    Post subject: New Build - 09/28/2021 - r47495 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and device specific recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link does not work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (http only) or 'curl -O {file URL}' (https, http or ftp). 'write {file} linux' then 'reboot'.

Repository: Trac SVN changelog since last build r47481 (GitHub mirror)

Notes:
OpenVPN 2.5.3: Guides, Server, PBR, Reverse PBR, Client (see second post), Kill Switch, update tips, scripts and more.
WireGuard 1.0.20210606/Tools: Changelog, Guides, Client, Server, Advanced, PBR, KS, tips and scripts. Thanks BS & egc!
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle since r41813.
MiniDLNACoovaChilliPrivoxyiperf3cakeFreeRADIUSOpenSSLBusyBoxdnsmasqUnboundTorSquidSmartDNSAsterisk
In-kernel Samba (ksmbd 3.4.2): default min/max versions changed. • WSD update ANTFS/NTFS3 kernel mode driver+++
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 (Fragattack) fixed.
• "Assign WAN port to Switch" feature removed; likely no longer required. • MAC Filtering fixed in WebUI (see 47184-47205).
New DD-WRT inspired themes conversion by the-joker & BrainSlayer, micro devices excluded. • Sputnik Agent is removed.
• "Ignore WAN DNS" also ignores WAN domain. Thank you BS & egc, also dTX for reporting, twindragon6 logs and buffpatel!

Issues:
• Show us your findings with steps to reproduce, configuration, output, logs and important information below!

Important:
• For issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Search SVN tickets & discuss in forum before opening. Before reporting: reset & manually set up, not restore from a backup.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
oliver44
DD-WRT User


Joined: 01 Jun 2016
Posts: 153

PostPosted: Tue Sep 28, 2021 13:05    Post subject: Reply with quote
Hello all,

Router ModelLinksys WRT1900ACS v2
Firmware VersionDD-WRT v3.0-r47495 std (09/28/21)
Kernel VersionLinux 4.9.284 #2879 SMP Tue Sep 28 05:10:04 +07 2021 armv7l
Current TimeTue, 28 Sep 2021 16:03:07
Uptime1:46

update- browser-waterfox,after the update I used the backup file from the previous version,i use Material theme,

Connection Type PPPoE-IPv6 Type DHCPv6 with Prefix Delegation-Avoid DHCP6 client release on reconnect Enable, Dhcp6s Enable, Radvd-Enable All-ok

Encrypt DNS-all ok
Port Forwarding ok

Wireless Interface 5GHz-Wireless Mode AP-Wireless Network Mode-AC, Width VHT 80 Mhz-Wireless Channel-36-Short GI,Single User Beamforming, Radio Scheduling, Enable-WPA2 Personal-CCMP-128 (AES, Regulatory Domain Romania , all-ok

Wireless Interface 2.4GHz-Wireless Mode AP-Wireless Network Mode-N, Width VHT 40 Mhz-Wireless Channel-6-TurboQAM (QAM256) support Enable,Short GI , Radio Scheduling, Enable-WPA2 Personal-CCMP-128 (AES)all-ok


in this version the web pages open correctly and without error because it cannot find the server,I think this problem in the previous version was from Dnsmasq ....

Everything behaves perfectly,


_________________

_________________
Internet provider https://en.wikipedia.org/wiki/RCS_%26_RDS RCS & RDS 1Gbps
Linksys WRT1900ACS v.2 -OpenWrt/DD-WRT
WDR3600 rev.1.5 - OpenWrt


Last edited by oliver44 on Wed Sep 29, 2021 18:29; edited 1 time in total
Argenis
DD-WRT User


Joined: 18 Feb 2019
Posts: 157

PostPosted: Wed Sep 29, 2021 7:41    Post subject: Reply with quote
3200ACM V1 (only version?):
ddwrt-linksys-wrt3200acm-webflash.bin/Linux 4.9.284 #2879 SMP Tue Sep 28 05:10:04 +07 2021 armv7l
r47474 20 September 2021/No Reset
Mode: Router
Issues/Errors: None, working like a champ so far for my use cases (in signature)

_________________
Router: Linksys WRT3200ACM WLAN0 and 1 have same SSID
88W8964 802.11ac WLAN0 Mode AP VHT80 80MHz Mixed Mode Channel and Extension Channel Auto Extension LL-6
88W8964 802.11ac WLAN1 Mode AP 20 MHz Mixed Mode Channel Auto
SD8887 802.11ac disabled but visible on GUI and CLI
TX Power 18 dBm
Antenna Gain 0 dBi
U-APSD (Automatic Power Save)Enabled 
Protection Mode None
RTS Threshold Disabled
Short Preamble Disabled 
Short GI Enabled
Single User Beamforming Enabled
Multi User Beamforming Enabled 
AP Isolation Disabled
Beacon Interval 100
DTIM Interval 2
WMM Support Enabled 
Radar Detection Disabled 
ScanList default
Sensitivity Range (ACK Timing) 500 (Default: 500 meters)
Max Associated Clients 256 (Default: 256 Clients)
Minimum Signal for authenticate -128
Minimum Signal for connection -128
Poll Time for signal lookup 10
Amount of allowed low signals 3
Wireless security is WPA2 Personal CCMP-128 only
QAM256 is on
dpp3530
DD-WRT Guru


Joined: 12 Dec 2007
Posts: 551
Location: Pittsburgh, PA USA

PostPosted: Wed Sep 29, 2021 15:47    Post subject: Reply with quote
oliver44 wrote:
in this version the web pages open correctly and without error because it cannot find the server,I think this problem in the previous version was from Dnsmasq ....


I was seeing the same thing on a WRT1900AC. Reverted back to 47377 on the last three builds I tried. I agree with Oliver44 that the problem seems to be resolved in this build.

Router/Version: WRT1900AC v1
File/Kernel: DD-WRT v3.0-r47495 std (09/28/21)
Previous/Reset: r47377 reset and configured from scratch
Mode/Status: Gateway, AP, OpenVPN server, Wireguard server
Issues/Errors: I haven't seen the "Doesn't look like HTML" error in the GUI, nor have I had any name resolution issues in this build. Everything seems stable and speed is good.

I have a second WRT1900AC v1 that I use as a spare. I'm going to swap them out and just do an update from 47377 to 47495 without reset, just to see if it's as stable without the reset.

_________________
__________________________
Linksys WRT-1900AC
DD-WRT v3.0 STD 47618
Linksys EA6700
DD-WRT v3.0 STD 47618
Asus RT-AC56U
DD-WRT v3.0 STD 47618
Netgear AC1450
DD-WRT v3.0 STD 47618
dpp3530
DD-WRT Guru


Joined: 12 Dec 2007
Posts: 551
Location: Pittsburgh, PA USA

PostPosted: Thu Sep 30, 2021 2:10    Post subject: Reply with quote
dpp3530 wrote:
I have a second WRT1900AC v1 that I use as a spare. I'm going to swap them out and just do an update from 47377 to 47495 without reset, just to see if it's as stable without the reset.


After 10 hours of uptime, I can say that the WRT1900AC that was upgraded without reset is just as stable as the one that was reset. Both are much more stable than they were on the previous builds (after 47377).

Thanks to BS and the other devs for all their hard work on this project.

_________________
__________________________
Linksys WRT-1900AC
DD-WRT v3.0 STD 47618
Linksys EA6700
DD-WRT v3.0 STD 47618
Asus RT-AC56U
DD-WRT v3.0 STD 47618
Netgear AC1450
DD-WRT v3.0 STD 47618
oliver44
DD-WRT User


Joined: 01 Jun 2016
Posts: 153

PostPosted: Fri Oct 01, 2021 20:22    Post subject: Reply with quote
After two days of operation I noticed that it loses ipv6 and came back after I changed the Material theme in default...
_________________
Internet provider https://en.wikipedia.org/wiki/RCS_%26_RDS RCS & RDS 1Gbps
Linksys WRT1900ACS v.2 -OpenWrt/DD-WRT
WDR3600 rev.1.5 - OpenWrt
dpp3530
DD-WRT Guru


Joined: 12 Dec 2007
Posts: 551
Location: Pittsburgh, PA USA

PostPosted: Fri Oct 01, 2021 20:41    Post subject: Reply with quote
oliver44 wrote:
After two days of operation I noticed that it loses ipv6 and came back after I changed the Material theme in default...


It's the same when you make any changes on the Administration/Management tab. I updated a Cron job and saw the same thing. This seems to have gone back a few builds, as I saw it in 47377 too.

Are you using Native IPV6 or 6in4? I'm using 6in4 with a Hurricane tunnel. I may be way off base, but I'm thinking it's reapplying the Congestion Control settings when you Apply, causing the tunnel to go down for a minute or so.

_________________
__________________________
Linksys WRT-1900AC
DD-WRT v3.0 STD 47618
Linksys EA6700
DD-WRT v3.0 STD 47618
Asus RT-AC56U
DD-WRT v3.0 STD 47618
Netgear AC1450
DD-WRT v3.0 STD 47618
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 11765
Location: Texas, USA

PostPosted: Sat Oct 02, 2021 0:38    Post subject: Reply with quote
"Apply" restarts (certain) "services"... people don't seem to understand that and think the sky is falling. Give it a few minutes and let things restart. If they don't ever restart, then there's a problem...
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
oliver44
DD-WRT User


Joined: 01 Jun 2016
Posts: 153

PostPosted: Sat Oct 02, 2021 7:40    Post subject: Reply with quote
@dpp3530 @kernel-panic69 Thanks for the reply
Normally my connection is PPPoE Access for IPv4 / IPv6 Dual-Stack, in the settings from the web interface ddwrt I use the following settings: Connection Type PPPoE-IPv6 Type DHCPv6 with Prefix Delegation-Avoid DHCP6 client release on reconnect Enable, Dhcp6s Enable, Radvd-Enable All-ok!

I know that in openwrt I use the configuration with 6in4, you can tell me what are the settings in ddwrt in my case, I am not an expert in these settings.

I know that any change in the web interface leads to the change of ipv4 / 6, in my case ipv6 was lost after two days without making changes in the web interface!

In openwrt I have the following settings:


I look forward to an answer, thank you for everything you do!

_________________
Internet provider https://en.wikipedia.org/wiki/RCS_%26_RDS RCS & RDS 1Gbps
Linksys WRT1900ACS v.2 -OpenWrt/DD-WRT
WDR3600 rev.1.5 - OpenWrt
oliver44
DD-WRT User


Joined: 01 Jun 2016
Posts: 153

PostPosted: Mon Oct 04, 2021 17:29    Post subject: Reply with quote
Normally, my connection is PPPoE Access for IPv4 / IPv6 Dual-Stack, Prefix Delegation-Avoid DHCP6, I don't think it has anything to do with configuration with 6in4, but I saw that in the openwrt configuration there is this package installed...
Now in the latest version I noticed that we also have 6in4 in ddwrt settings but for me it only works Prefix Delegation-Avoid DHCP6!

_________________
Internet provider https://en.wikipedia.org/wiki/RCS_%26_RDS RCS & RDS 1Gbps
Linksys WRT1900ACS v.2 -OpenWrt/DD-WRT
WDR3600 rev.1.5 - OpenWrt
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum