WRT1900AC V2 + Nighthawk M2 (as wan) - Can't figure it out

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
cablecutter
DD-WRT Novice


Joined: 16 Sep 2021
Posts: 2

PostPosted: Thu Sep 16, 2021 17:46    Post subject: WRT1900AC V2 + Nighthawk M2 (as wan) - Can't figure it out Reply with quote
Hi All,

I have the Netgear Nighthawk M2 5g mobile hotspot as my WAN device. I would like to use my WRT1900AC V2 (running most recent firmware but also firmware from 2018/2019 with same result)

On the M2 I have set:
IP Passthrough (disables wifi)
DHCP Disabled
Ethernet Standby OFF
192.168.1.1 (internal IP)

I use Telenor (swedish mobile network supplier)

(Though I have tried all other configurations including using the M2 as the DHCP server / etc)

The M2 works when connected via ethernet to a switch or a unifi wifi hotspot without issue.

I have no idea how to configure the 1900ACV2 for this use case. I've tried seemingly every configuration combo so not sure what to report. I have not touched routing tables / NAT settings etc. I've set the device as a gateway and have tried dynamic routing etc.

The issue is that I cannot reach the internet via lan or the router itself. I also have trouble reaching the M2 even when the WRT1900ACV2 is on the same subnet. Sometimes it works, sometimes it doesn't (on resetting the devices).

How should the DD-WRT based WRT1900ACV2 be configured if the WAN source is a M2 mobile hotspot with IP passthrough enabled?
Sponsor
d33b0_n4p41m
DD-WRT User


Joined: 10 Sep 2021
Posts: 133

PostPosted: Thu Sep 16, 2021 19:54    Post subject: Reply with quote
The Nighthawk M1 and M2 (and others) are quirky with this. Your WRT1900ACV2 LAN IP should be in a separate subnet, for sure. For example, since the M2 is @ 192.168.1.1, DD-WRT should be at 192.168.2.1. But...

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318865

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320692

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321312

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324174

... those are related threads I have found regarding issues trying to make it work.

_________________
An old man said, “Erasers are made for those who make mistakes.” A youth replied, “Erasers are made for those who are willing to correct their mistakes!” Attitude matters! ~ Anonymous
----------
“You are always a student, never a master. You have to keep moving forward.” ~ Conrad Hall
----------
“Life is about moving on, accepting changes and looking forward to what makes you stronger and more complete.” ~ Anonymous
cablecutter
DD-WRT Novice


Joined: 16 Sep 2021
Posts: 2

PostPosted: Fri Sep 17, 2021 16:11    Post subject: Reply with quote
Thanks, it's actually a bit of a relief. I felt like I was going crazy.
go_navy
DD-WRT Novice


Joined: 05 Oct 2021
Posts: 1

PostPosted: Tue Oct 05, 2021 20:34    Post subject: Reply with quote
cablecutter wrote:
Thanks, it's actually a bit of a relief. I felt like I was going crazy.


Were you able to get the setup going?

I have a Linksys WRT1900ACS (DD-WRT) and Netgear MR5100, I just can't get this combo working together. The internet light is either blinking white or solid orange. None of the connected devices get internet. I have the Netgear LB1120 working perfectly fine with the wifi router but not MR5100.

If you were able to get this work, how exactly is your setup? Thanks a lot!
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12456
Location: Texas, USA

PostPosted: Tue Oct 05, 2021 21:17    Post subject: Reply with quote
First thing to consider on any of these is that if it is using 192.168.1.1 as it's ethernet / LAN access IP address, you have to change the IP address of your DD-WRT router. Second thing to consider is figuring out the bridge or IP-passthru mode. I have a feeling this may be related to any previous connections to the device with a laptop via ethernet and/or the mtu setting on the WAN and/or the TTL setting. As previously linked, there's plenty of discussion on the issue(s)...
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum