New Build - 08/01/2021 - r47117

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3431

PostPosted: Sun Aug 01, 2021 5:37    Post subject: New Build - 08/01/2021 - r47117 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and device specific recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link does not work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r47097 (GitHub mirror)

Notes:
OpenVPN 2.5.3: Guides, Server, PBR, Reverse PBR, Client (see second post), Kill Switch, update tips, scripts and more.
WireGuard 1.0.20210606/Tools: Guides, Client, Server, Advanced, PBR, KS, update tips, scripts & more. Thanks BS & egc!
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle since r41813.
SmartDNSMiniDLNAUnboundCoovaChilliOpenSSLdnsmasqPrivoxySquidiperf3cakeTorFreeRADIUS
In-kernel Samba ksmbd 3.3.9++: default min/max versions changed. • WSD updateANTFS/NTFS3 kernel mode driver++
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 (Fragattack) fixed.
• "Assign WAN port to Switch" feature removed to be reworked in a future release.

Issues:
• Show us your findings with steps to reproduce, configuration, output, logs and important information below!

Important:
• For issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Search SVN tickets & discuss in forum before opening. Before reporting: reset & manually set up, not restore from a backup.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Monza
DD-WRT User


Joined: 01 Jul 2018
Posts: 344

PostPosted: Sun Aug 01, 2021 12:54    Post subject: Reply with quote
Upgraded WRT1200AC v1's from r47097 to r47117 using Brave 1.10.97 (64-bit) running on Linux Mint 20.2 OS hardwired via Cat6.

Successful update and reboot. No reset, nothing disabled prior to update, uptime approx 1+ hrs, wired/wireless connected, vpn up immediately (Expressvpn). SFE, QoS and IPv6 are always disabled. OpenVPN client/DNSMasq and radios always enabled. I do not have any Apple devices. I do not use NAS.

Kernel Version Linux 4.9.277 #2763 SMP Sun Aug 1 01:25:43 +07 2021 armv7l

No issues with a routine update session.
o2bad455
DD-WRT User


Joined: 08 Oct 2015
Posts: 185

PostPosted: Mon Aug 02, 2021 2:34    Post subject: Reply with quote
Router/Version: WRT1900ACS(v1) / r47117
File/Kernel: webflash via telnet / Linux 4.9.277 #2763 SMP Sun Aug 1 01:25:43 +07 2021 armv7l
Previous/Reset: r47040 / No
Mode/Status: Gateway, OpenVPN Client, FreeRADIUS Server / Uptime 55 min
Issues/Errors: None / Working well, thanks!

_________________
My DD-WRT Routers:
Linksys WRT1900ACS - Marvell (2x: r47720)
Netgear R7000 - Broadcom (3x: r47720)
Netgear R9000 - Atheros (r47608)
PC x86-64 VM - Atheros (r46316)
Linksys WRT54G/GS - Broadcom (4x: r44715)
pbphoto
DD-WRT User


Joined: 29 Oct 2017
Posts: 243

PostPosted: Tue Aug 03, 2021 1:14    Post subject: Reply with quote
Router Status: Linksys 3200ACM + 1900ACSv1 running r47117 uptime 36 hours.
WIFI performance is good and stable on the 3200ACM. WIFI is disabled on the 1900ACSv1.
UPDATE: 13 days uptime - very stable and reliable build for me.
Kernel: Linux router1 4.9.277 #2763 SMP Sun Aug 1 01:25:43 +07 2021 armv7l DD-WRT
Upgrade: via CLI from r47086 (which was running fine for 8+ days). No issues with upgrade. Did not reset.
Issues:
1) GUI can be painfully slow at times. Opening a telnet also freezes when GUI is acting up - no prompt. Firefox is the only browser that sort of works on my Macbook.
Linksys WRT3200ACM: gateway mode, DNSMasq for DNS and DHCP, Wireguard client (Mullvad), Firewall enabled, QoS enabled HTB-CAKE, PBR enabled, SFE disabled. NAS disabled. WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 1, BI=100, DTIM=2 custom config: basic_rates=60 120 240 supported_rates=60 90 120 180 240 360 480 540. 5ghz: AC/N mixed, 40mhz channel width, channel 44+upper, BI=100, DTIM=2. Both radios: WPA2-CCMP-128, strict rekey enabled, 802.11r enabled, 802.11w disabled, disable eapol retries disabled.
Linksys WRT1900ACSv1: wifi disabled - using it as a semi-intelligent switch only. SFE enabled. Can't get wifi to work reliably post-r44048.
Two Netgear r7800s - as hardwired WAPs in router-mode with nearly identical WIFI settings to the 3200ACM above, just different wifi channels and BI=300, DTIM=1. Vanilla firmware, SFE enabled, DNSmasq disabled, NAS disabled, firewall disabled, QoS disabled,
Clients: Apple MACOS x 4, IOS x 4, Apple TV, Chromecast Audio x 2, Eufy doorbells, Lutron Caseta, Axis Camera, Samsung TV, Nest thermostat, EtekCity outlets (Espressif), BlueSound/BlueOS devices...


Last edited by pbphoto on Sat Aug 14, 2021 12:25; edited 1 time in total
7heblackwolf
DD-WRT User


Joined: 21 Nov 2019
Posts: 66

PostPosted: Wed Aug 04, 2021 13:14    Post subject: Reply with quote
pbphoto wrote:
Router Status: Linksys 3200ACM + 1900ACSv1 running r47117 uptime 36 hours.
WIFI performance is good and stable on the 3200ACM. WIFI is disabled on the 1900ACSv1.
Kernel: Linux router1 4.9.277 #2763 SMP Sun Aug 1 01:25:43 +07 2021 armv7l DD-WRT
Upgrade: via CLI from r47086 (which was running fine for 8+ days). No issues with upgrade. Did not reset.
Issues:
1) GUI can be painfully slow at times. Opening a telnet also freezes when GUI is acting up - no prompt. Firefox is the only browser that sort of works on my Macbook.
Linksys WRT3200ACM: gateway mode, DNSMasq for DNS and DHCP, Wireguard client (Mullvad), Firewall enabled, QoS enabled HTB-CAKE, PBR enabled, SFE disabled. NAS disabled. WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 1, BI=100, DTIM=2 custom config: basic_rates=60 120 240 supported_rates=60 90 120 180 240 360 480 540. 5ghz: AC/N mixed, 40mhz channel width, channel 44+upper, BI=100, DTIM=2. Both radios: WPA2-CCMP-128, strict rekey enabled, 802.11r enabled, 802.11w disabled, disable eapol retries disabled.
Linksys WRT1900ACSv1: wifi disabled - using it as a semi-intelligent switch only. SFE enabled. Can't get wifi to work reliably post-r44048.
Two Netgear r7800s - as hardwired WAPs in router-mode with nearly identical WIFI settings to the 3200ACM above, just different wifi channels and BI=300, DTIM=1. Vanilla firmware, SFE enabled, DNSmasq disabled, NAS disabled, firewall disabled, QoS disabled,
Clients: Apple MACOS x 4, IOS x 4, Apple TV, Chromecast Audio x 2, Eufy doorbells, Lutron Caseta, Axis Camera, Samsung TV, Nest thermostat, EtekCity outlets (Espressif), BlueSound/BlueOS devices...


Have you had issues with your apple clients? I hate being constantly kicked from the internet, wifi link seems ok, but clearly not connected. As a lot mentioned, disable/enable wifi on client seems to temp fix it, but sometimes you have to do it several times. (mbp 2018, iphone 7, ipad mini 2012)

_________________
Linksys WRT3200ACM
pbphoto
DD-WRT User


Joined: 29 Oct 2017
Posts: 243

PostPosted: Wed Aug 04, 2021 19:30    Post subject: Reply with quote
My 3200ACM is running good now with Apple clients. Maybe not as good as 44048 but good. I notice an occasional drop when I roam into my office where the 3200ACM is located - maybe 20 seconds before it reconnects. But gone are the wifi hangups every 5 minutes that I was experiencing post-44048 for 10 months. What did the trick for me was spending about 2 hours resetting it (both partitions) in every possible way, then loading both partitions with the same modern release, and resetting it again in every possible way, then typing everything in from scratch, and running off of partition-1. Note that I have not been so lucky with my 1900ACSv1 - i'll try again someday but I have wifi disabled on it for now. Good luck.

Oh yeah - buying a couple of used netgear 7800s to handle the bulk of the wifi duties in my house also helped Smile
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 243
Location: FL

PostPosted: Wed Aug 04, 2021 21:49    Post subject: Reply with quote
this build has been pretty smooth on mine

on the side can one of yall msg me how to redirect a website and maybe block it maybe via host file since the gui isnt working, tell me where to go i can ssh it OR if yall know a better way thanks!!!

_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2021
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &

WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel follows AP, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 40mhz channel width, channel 100+upper, WPA2-CCMP-128.
Misc Info: WPA2 Personal: "CCMP-128 (AES)" Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv. NOTE: this is now just a wireless access point so to speak but all settings still apply to what ever wireless person connects.
7heblackwolf
DD-WRT User


Joined: 21 Nov 2019
Posts: 66

PostPosted: Thu Aug 05, 2021 14:27    Post subject: Reply with quote
pbphoto wrote:
My 3200ACM is running good now with Apple clients. Maybe not as good as 44048 but good. I notice an occasional drop when I roam into my office where the 3200ACM is located - maybe 20 seconds before it reconnects. But gone are the wifi hangups every 5 minutes that I was experiencing post-44048 for 10 months. What did the trick for me was spending about 2 hours resetting it (both partitions) in every possible way, then loading both partitions with the same modern release, and resetting it again in every possible way, then typing everything in from scratch, and running off of partition-1. Note that I have not been so lucky with my 1900ACSv1 - i'll try again someday but I have wifi disabled on it for now. Good luck.

Oh yeah - buying a couple of used netgear 7800s to handle the bulk of the wifi duties in my house also helped Smile


I don't think the reset procedure you mention solved this. In fact, if such issue could exist, I'll break way lot of things more than stable connection on specific brand clients in case of switching partitions or simply upgrade. I prefer to think what you experience is a placebo and the issue is truly fixed.

I'll try this build. Sadly, I can't test every build that came up since I work with internet and I can't explain myself to the company that I'm testing a beta build for my entire network to work properly. Once done, I'll report here.

If anybody can test if the issue with Apple clients is fixed, I'll be glad. Is a huge deal breaker for me.

_________________
Linksys WRT3200ACM
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3431

PostPosted: Thu Aug 05, 2021 14:50    Post subject: Reply with quote
Backup the config before upgrading. Be prepared for reset and manual reconfiguration when testing builds.
7heblackwolf
DD-WRT User


Joined: 21 Nov 2019
Posts: 66

PostPosted: Thu Aug 05, 2021 16:43    Post subject: Reply with quote
blkt wrote:
Backup the config before upgrading. Be prepared for reset and manual reconfiguration when testing builds.


If you're replying to me, I always do a clean reset when testing a new build. Does NVRAM become shared between 2 dd-wrt partitions? Because that sounds totally crazy.

_________________
Linksys WRT3200ACM
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 11766
Location: Texas, USA

PostPosted: Thu Aug 05, 2021 17:31    Post subject: Reply with quote
7heblackwolf wrote:
blkt wrote:
Backup the config before upgrading. Be prepared for reset and manual reconfiguration when testing builds.


If you're replying to me, I always do a clean reset when testing a new build. Does NVRAM become shared between 2 dd-wrt partitions? Because that sounds totally crazy.

The nvram is shared between both partitions on WRT AC series routers; on stock, DD-WRT, OpenWRT.

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
FlaParrotHead
DD-WRT User


Joined: 04 Nov 2020
Posts: 59

PostPosted: Thu Aug 05, 2021 17:58    Post subject: Reply with quote
pbphoto wrote:
Router Status: Linksys 3200ACM + 1900ACSv1 running r47117 uptime 36 hours.
WIFI performance is good and stable on the 3200ACM. WIFI is disabled on the 1900ACSv1.
Kernel: Linux router1 4.9.277 #2763 SMP Sun Aug 1 01:25:43 +07 2021 armv7l DD-WRT
Upgrade: via CLI from r47086 (which was running fine for 8+ days). No issues with upgrade. Did not reset.
Issues:
1) GUI can be painfully slow at times. Opening a telnet also freezes when GUI is acting up - no prompt. Firefox is the only browser that sort of works on my Macbook.
Linksys WRT3200ACM: gateway mode, DNSMasq for DNS and DHCP, Wireguard client (Mullvad), Firewall enabled, QoS enabled HTB-CAKE, PBR enabled, SFE disabled. NAS disabled. WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 1, BI=100, DTIM=2 custom config: basic_rates=60 120 240 supported_rates=60 90 120 180 240 360 480 540. 5ghz: AC/N mixed, 40mhz channel width, channel 44+upper, BI=100, DTIM=2. Both radios: WPA2-CCMP-128, strict rekey enabled, 802.11r enabled, 802.11w disabled, disable eapol retries disabled.
Linksys WRT1900ACSv1: wifi disabled - using it as a semi-intelligent switch only. SFE enabled. Can't get wifi to work reliably post-r44048.
Two Netgear r7800s - as hardwired WAPs in router-mode with nearly identical WIFI settings to the 3200ACM above, just different wifi channels and BI=300, DTIM=1. Vanilla firmware, SFE enabled, DNSmasq disabled, NAS disabled, firewall disabled, QoS disabled,
Clients: Apple MACOS x 4, IOS x 4, Apple TV, Chromecast Audio x 2, Eufy doorbells, Lutron Caseta, Axis Camera, Samsung TV, Nest thermostat, EtekCity outlets (Espressif), BlueSound/BlueOS devices...


PBP. Have you found ANY iOS or iPadOS browser that works post 44048?
From time to time I’ll check logs or need to swap OpenVPN servers and will frequently do it from an iPhone or iPad for convenience. I’ve tried Firefox and get the same GUI problems many of us see.

_________________
Linksys WRT3200ACM
Linux 4.9.292 #2953 SMP Thu Dec 9 03:26:12 +07 2021 armv7l
DD-WRT v3.0-r48068 std (01/09/22)
Linksys RE9000 Extender (WiFi attached)
OpenVPN with PBR: ExpressVPN
Devices: Sonos, Apple, QNAP, Laserjet other
7heblackwolf
DD-WRT User


Joined: 21 Nov 2019
Posts: 66

PostPosted: Thu Aug 05, 2021 18:24    Post subject: Reply with quote
kernel-panic69 wrote:
7heblackwolf wrote:
blkt wrote:
Backup the config before upgrading. Be prepared for reset and manual reconfiguration when testing builds.


If you're replying to me, I always do a clean reset when testing a new build. Does NVRAM become shared between 2 dd-wrt partitions? Because that sounds totally crazy.

The nvram is shared between both partitions on WRT AC series routers; on stock, DD-WRT, OpenWRT.


Hmm.. that explains why changing partitions with stock seems to mess with dd-wrt. Or dd-wrt OpenWRT coexistence.


FlaParrotHead wrote:
pbphoto wrote:
Router Status: Linksys 3200ACM + 1900ACSv1 running r47117 uptime 36 hours.
WIFI performance is good and stable on the 3200ACM. WIFI is disabled on the 1900ACSv1.
Kernel: Linux router1 4.9.277 #2763 SMP Sun Aug 1 01:25:43 +07 2021 armv7l DD-WRT
Upgrade: via CLI from r47086 (which was running fine for 8+ days). No issues with upgrade. Did not reset.
Issues:
1) GUI can be painfully slow at times. Opening a telnet also freezes when GUI is acting up - no prompt. Firefox is the only browser that sort of works on my Macbook.
Linksys WRT3200ACM: gateway mode, DNSMasq for DNS and DHCP, Wireguard client (Mullvad), Firewall enabled, QoS enabled HTB-CAKE, PBR enabled, SFE disabled. NAS disabled. WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 1, BI=100, DTIM=2 custom config: basic_rates=60 120 240 supported_rates=60 90 120 180 240 360 480 540. 5ghz: AC/N mixed, 40mhz channel width, channel 44+upper, BI=100, DTIM=2. Both radios: WPA2-CCMP-128, strict rekey enabled, 802.11r enabled, 802.11w disabled, disable eapol retries disabled.
Linksys WRT1900ACSv1: wifi disabled - using it as a semi-intelligent switch only. SFE enabled. Can't get wifi to work reliably post-r44048.
Two Netgear r7800s - as hardwired WAPs in router-mode with nearly identical WIFI settings to the 3200ACM above, just different wifi channels and BI=300, DTIM=1. Vanilla firmware, SFE enabled, DNSmasq disabled, NAS disabled, firewall disabled, QoS disabled,
Clients: Apple MACOS x 4, IOS x 4, Apple TV, Chromecast Audio x 2, Eufy doorbells, Lutron Caseta, Axis Camera, Samsung TV, Nest thermostat, EtekCity outlets (Espressif), BlueSound/BlueOS devices...


PBP. Have you found ANY iOS or iPadOS browser that works post 44048?
From time to time I’ll check logs or need to swap OpenVPN servers and will frequently do it from an iPhone or iPad for convenience. I’ve tried Firefox and get the same GUI problems many of us see.


I observed the same issue. Funny thing is that keeps loading, but when I request desktop site half of the times the web loads instantly. Only on iOS/ipadOS, macOS seems ok. DD-WRT is rocket science.

_________________
Linksys WRT3200ACM
FlaParrotHead
DD-WRT User


Joined: 04 Nov 2020
Posts: 59

PostPosted: Fri Aug 06, 2021 4:22    Post subject: Reply with quote
7heblackwolf wrote:
I observed the same issue. Funny thing is that keeps loading, but when I request desktop site half of the times the web loads instantly. Only on iOS/ipadOS, macOS seems ok. DD-WRT is rocket science.


Which browser are you using and where are you requesting the desktop site? I’m not seeing that in Safari, Chrome, or Firefox but may be missing it.

_________________
Linksys WRT3200ACM
Linux 4.9.292 #2953 SMP Thu Dec 9 03:26:12 +07 2021 armv7l
DD-WRT v3.0-r48068 std (01/09/22)
Linksys RE9000 Extender (WiFi attached)
OpenVPN with PBR: ExpressVPN
Devices: Sonos, Apple, QNAP, Laserjet other
tld
DD-WRT Novice


Joined: 26 Nov 2016
Posts: 11

PostPosted: Fri Aug 06, 2021 13:19    Post subject: Reply with quote
I just had a strange issue attempting to upgrade. Note that I didn't reset the router, which may have been the issue. Here's what happened:

I run dd-wrt on partition 2, and when I upgrade, I always switch to partition 1 (which has the factory firmware) and then upgrade from there using factory-to-ddwrt.bin.

When I did those steps this time, after the upgrade, it just came back up to the factory firmware again, as if it didn't switch partitions as it usually does.

What I ended up doing was to install the previous dd-wrt factory-to-ddwrt.bin I was using (which is embarrassingly old...hadn't gotten around to this in forever). That installed fine and booted to that version.

Is that something that may have occurred due to not resetting? Thanks in advance.

Tom
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum