RETRACTED New Build - 07/19/2021 - r47073

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3135

PostPosted: Mon Jul 19, 2021 11:10    Post subject: RETRACTED New Build - 07/19/2021 - r47073 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and device specific recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link does not work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r47040 (GitHub mirror)

Notes:
OpenVPN 2.5.3: Guides, Server, PBR, Reverse PBR, Client (see second post), Kill Switch, update tips, scripts and more.
WireGuard 1.0.20210606/Tools: Guides, Client, Server, Advanced, PBR, KS, update tips, scripts & more. Thanks BS & egc!
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle since r41813.
Select ath10k radios now feature on-the-fly firmware type switching between customized DD-WRT and vanilla QCA binaries!
SmartDNSMiniDLNAUnboundCoovaChilliOpenSSLdnsmasqPrivoxyTorSquidFreeRADIUSiperf3 cake
In-kernel Samba (ksmbd 3.3.9+): default min/max versions changed. • WSD updateANTFS/NTFS3 kernel mode driver++
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 (Fragattack) fixed.
• "Assign WAN port to Switch" feature removed to be reworked in a future release.
• TL-WA901Nv2 Ethernet port not working is fixed (other TL-WA* devices may apply). r47032, #3002, TL-WA901NDv2 thread

Issues:
• Show us your findings with steps to reproduce, configuration, output, logs and important information below!

Important:
• For issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Search SVN tickets & discuss in forum before opening. Before reporting: reset & manually set up, not restore from a backup.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 8127
Location: Netherlands

PostPosted: Mon Jul 19, 2021 11:57    Post subject: Reply with quote
Router Model: Netgear R7800

Firmware Version: DD-WRT v3.0-r47073 std (07/19/21)
Kernel Version: Linux 4.9.274 #327 SMP Mon Jul 19 04:31:41 +07 2021 armv7l

Upgraded from: DD-WRT v3.0-r46885 std (06/05/21)

Reset: No, not this time

Status: Up and running for 2 hours , basic setup as Gateway, static leases, 2,4GHz, 5Ghz (Vanilla Firmware), OpenVPN client to Keepsolid with PBR working, OpenVPN Server with site-to-site setup and local DNS working.
WireGuard client to Keepsolid working, WireGuard client for site-to-site setup to own server working.

Errors: Nothing encountered yet (but not tested USB/NAS)

Thanks BS!

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 8127
Location: Netherlands

PostPosted: Mon Jul 19, 2021 12:02    Post subject: Reply with quote
Router Model: Linksys EA8500

Firmware Version: DD-WRT v3.0-r47073 std (07/19/21)
Kernel Version: Linux 4.9.274 #325 SMP Sat Jul 17 14:25:31 +07 2021 armv7l

Upgraded: DD-WRT v3.0-r46681 std (05/15/21)
Reset: No not this time

Status: Up and running for 2 hours, basic setup as Gateway, static leases, 2.4 GHz and 5 GHz working (vanilla firmware), OpenVPN server working, WireGuard Server working,

Errors: No, Seems like a good build

Big Thanks to the devs!!

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 470

PostPosted: Mon Jul 19, 2021 12:25    Post subject: Reply with quote
Update method: SSH / CLI
Router/Version: Netgear R9000 Nighthawk X10
File/Kernel: DD-WRT v3.0-r47073 std (07/19/21)
Previous/Reset: DD-WRT v3.0-r47040 std (07/12/21) / No
Mode/Status: Gateway / Working Normally
Issues/Errors: Incoming & Outgoing logs show nothing (not a new issue)

Thanks, BS and all of the devs!

_________________
Netgear R9000 X10
DD-WRT v3.0-r47381 std (09/08/21)
Gateway, AP, DNSMasq, SFE, Clock 2000MHz
IPv4 & IPv6 (Prefix Delegation)
Static Leases & DHCP
CloudFlare, QoS Disabled
Vanilla, WiFi & Ethernet
2.4GHz: NG-Mixed, 10 + 6 (2457 MHz HT40), ACK Timing 3150, WPA2 w/AES
5GHz: AC/N Mixed, 100 + 114 (5500 MHz VHT160), ACK Timing 3160, WPA2 w/AES
Xfinity 1.2Gbps/42Mbps
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5505
Location: Texas

PostPosted: Mon Jul 19, 2021 13:11    Post subject: Reply with quote
Netgear WNDR3700 V4
DD-WRT v3.0-r47073 std (07/19/21)
Linux 3.18.140-d6 #121130 Mon Jul 19 08:58:35 +07 2021 mips
GUI install over r47040 --- all ok

#

Linksys EA8500 ...main gateway unit
DD-WRT v3.0-r47073 std (07/19/21)
Linux 4.9.274 #325 SMP Sat Jul 17 14:25:31 +07 2021 armv7l
GUI install over r47033 ---worky ok so far...
...if its as good as r47033 I be happy Cool
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4495
Location: UK, London, just across the river..

PostPosted: Mon Jul 19, 2021 19:04    Post subject: Reply with quote
Router Model: Netgear R7800
Firmware Version: DD-WRT v3.0-r47073 std (07/19/21)
Kernel Version: Linux 4.9.274 #327 SMP Mon Jul 19 04:31:41 +07 2021 armv7l

Upgraded from: DD-WRT v3.0-r47040 via CLI
Reset: No
Status:Operational 12h+
Errors: nothing for my set up WiFi issues from the previous builds resolved, using 2,4ghz Mixed, instead of NG mixed and no fixed rates...also revised few other settings removed ipset rules and some others...still investigating the source of my previous issues...just don't have much time this days...

so far so good, on this build and previous 47040 R7800 got back to rock solid...

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 47117 BS AP,NAT
TP-Link WR1043NDv2 -DD-WRT 47381 BS AP,NAT,AP Isolation,Ad-Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -DD-WRT 47381 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm Atheros/
Netgear R7800 --DD-WRT 47381 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT,Vanilla
Netgear R9000 --DD-WRT 47381 BS AP,NAT,AD-Block,AP Isolation,Firewall,Local DNS,DoT,2,4Ghz only,Vanilla
Broadcom
Netgear R7000 ---DD-WRT 47381 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
xraive
DD-WRT User


Joined: 08 Mar 2016
Posts: 127

PostPosted: Mon Jul 19, 2021 21:31    Post subject: Reply with quote
Router Model / Version: Linksys EA8500
Previous Firmware: DD-WRT v3.0-r47040 std (07/12/21)
Current Firmware: DD-WRT v3.0-r47073 std (07/19/21)
File:: dd-wrt-webupgrade.bin / CLI Flash (easyddup.sh)
Kernel: Linux 4.9.274 #325 SMP Sat Jul 17 14:25:31 +07 2021 armv7l
Reset: No
Wireless: Wireless Mode - Client, Firmware Type - DD-WRT
Routing: Operating - Gateway
Setup: SFE, NTP, DDNS (inadyn-Entware),
Services: DNSMasq (GUI+ additional options on USB Syslog, SSH, FreeRadius, USB, ProFTPD (with users), Samba (with users), CoovaChilli (with local users & radius), WiFiDog,
Administration: Remote Access (HTTPS & SSH), Startup Script (For DNSMasq & inadyn)
Uptime: up 1:52,, load average: 0.00, 0.01, 0.00
Temperature: CPU 52.705 °C / wlan0 45 °C
Status: OK
Issues: See below for issues.

Router Model / Version: Netgear XR500
Previous Firmware: DD-WRT v3.0-r47040 std (07/12/21)
Current Firmware: DD-WRT v3.0-r47073 std (07/19/21)
File:: dd-wrt-webupgrade.bin /CLI Flash (easyddup.sh)
Kernel: Linux 4.9.274 #327 SMP Mon Jul 19 04:31:41 +07 2021 armv7l
Reset: No
Wireless: Wireless Mode - Client, Firmware Type - DD-WRT
Routing: Operating - Gateway
Setup: Basic Setup, NTP, Switch (VLANS and Trunk config using GUI)
Services: DNSMasq (GUI), Syslog, SSH, FreeRadius, USB,
Administration: Remote Access (HTTPS & SSH),
Uptime: up 7:52, load average: 0.07, 0.02, 0.00

Temperature: CPU 55.224 °C / wlan0 45 °C
Status: OK
Issues: None


Issues:

As mentioned first in build (r47000), every time I do a reset using the GUI or Shell the swconfig tab disappears. It only shows up when I install a new firmware without resetting. This happens on this build and the last few builds that I tested dating back to the May build. This also happens on my Netgear XR500.


I also lose access to the router (shell and GUI) when I try to add VLANS after a reset. As soon as I add a VLAN and hit apply, I lose access to the router. I need to reset the router in order to access it again. Perhaps it has something to do with the GUI showing lan ports on VLAN0 while in the CLI lan ports are on VLAN1. See attached picture (before adding VLAN3). Let me know if you need additional info.

Partial Output of "swconfig dev switch0 show" command before adding VLAN3
Code:

VLAN 1:
   vid: 1
   ports: 0t 1 2 3 4
VLAN 2:
   vid: 2
   ports: 0t 5


Partial Output of "swconfig dev switch0 show" command after adding VLAN3
Code:

VLAN 0:
   vid: 0
   ports: 0t 1 3 4
VLAN 1:
   vid: 1
               
      
      
   ports: 0t 5
VLAN 3:
   vid: 3
   ports: 0t 2


Other than that both routers are working fine.

Thanks BS.
abhijitat
DD-WRT User


Joined: 06 Feb 2020
Posts: 143
Location: Maharashtra, India

PostPosted: Tue Jul 20, 2021 2:35    Post subject: Reply with quote
Router/Version: Netgear R7800
Firmware: DD-WRT v3.0-r47073 std (07/19/21)
Kernel: Linux 4.9.274 #327 SMP Mon Jul 19 04:31:41 +07 2021 armv7l
File/Upload: dd-wrt-webupgrade.bin / Upload using CLI
Mode: Gateway/AP
Reset: No
Previous: DD-WRT v3.0-r47033 std (07/08/21)
Setup Using: PPPOE, 2.4 GHz, 5.0 GHz, IPv4, DNSMasq, NTP TimeSync, WireGuard

Status: Working Fine; running vanilla firmware type for 2.4ghz & DD-wrt for 5ghz, uptime 12+ Hrs
WiFi speeds on both 2.4 & 5GHz are better, now I am able to achieve 600+Mbps up & down on 5GHz (wireless channel width 80+80, Connected Link speed 866/866Mbps, client - Intel(R) Wireless-AC 9560 160MHz) & around 850+ Mbps on wired client, it used to be 400-450Mbps earlier for both wired & wireless, can not be a placebo; with no change to configuration & no reset, I think some tweaks by BS has helped to get better work out of R7800, CPU usage around 1%

NAS not tested.

WireGuard server working using two peers.



Thank you BrainSlayer for Wonderful firmware.

Thanks all Guru for your help in forums.
ho1Aetoo
DD-WRT Guru


Joined: 19 Feb 2019
Posts: 810
Location: Germany

PostPosted: Tue Jul 20, 2021 5:47    Post subject: Reply with quote
abhijitat wrote:
wireless channel width 80+80, Connected Link speed 866/866Mbps, client - Intel(R) Wireless-AC 9560 160MHz


for what the mention? the card does not support 80+80
(866Mbit is VHT80 with 2 spatial streams)
and every client that doesn't support VHT80+80 connects only to the first 80Mhz block (the second block remains completely unused)

there are practically no clients at all that support 80+80 (actually only supported by a few Atheros Cards)

If the card would support 80+80 (which it does not) then the card would show VHT160 and 1733,3Mbit in the WLAN status.

this is what Broadcom says about VHT80+80: https://www.broadcom.com/blog/160-mhz-channels-wi-fi-6-superhighway


Quote:
Wi-Fi gurus may ask: Why not bond two discontiguous 80 MHz channels together? This would give network designers five 80 MHz channels in the 5 GHz band to work with in the U.S., including two without DFS constraints. But the devil is in the details.

At the chip level, 80+80 MHz mode requires a device to operate on two channels simultaneously. This means duplication of subsystems to support the second discontiguous channel, making integrated circuits much larger than for contiguous channel support. Smartphone manufacturers would be faced with scaling back other technical upgrades on cameras, processors or sensors in order to make room for larger Wi-Fi chips. Even if these devices did meet size constraints, reduced energy efficiency from running two separate 80 MHz subsystems would drain the phone battery faster. For mobile devices, battery life is paramount, and the key performance indicators of the discontiguous approach will not meet the market needs.

The additional downside of growing a chip to support a second radio subsystem is increased cost. Even if a router or smartphone maker solved the size and power challenges of discontiguous 80+80 support, they would have to further sacrifice other technical upgrades in order to maintain their existing cost structure. In markets where every penny counts, this is clearly a non-starter.


so a pretty useless feature for 99% of the users
unless you connect two dd-wrt routers with VHT80+80 or you have one of the few wifi cards that support it

Quote:
now I am able to achieve 600+Mbps up & down on 5GHz


Nothing new, a normal throughput of an 80Mhz Intel card, has already been on the level for a very very long time.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 10001
Location: Texas, USA

PostPosted: Tue Jul 20, 2021 14:28    Post subject: Reply with quote
Build removed; focus on 47074.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
Display posts from previous:    Page 1 of 1
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum