[SOLVED] No Amazon beyond 44048

Post new topic   Reply to topic    DD-WRT Forum Index -> Advanced Networking
Author Message
RotoBill
DD-WRT Novice


Joined: 13 Feb 2019
Posts: 47

PostPosted: Wed Jun 16, 2021 2:36    Post subject: [SOLVED] No Amazon beyond 44048 Reply with quote
My 3200 works great with 44048. I use NordVPN with PBR to keep my PC's hidden while keeping my Amazon up on my big screen.

But updating to any version newer than 44048 and Amazon gives me "no internet connection" screens in 40 different languages.

What switch do I need to tweak to get Amazon working with the newer FW's

Thanks in Advance

Bill
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12439
Location: Netherlands

PostPosted: Wed Jun 16, 2021 10:38    Post subject: Reply with quote
Will move this topic to the Advanced Networking forum.

Is the Amazon problem with a client which is not using VPN/PBR?

Have you enabled/ticked "Ignore WAN DNS" on setup page on builds above 44048 ?

I suspect a DNS problem

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
RotoBill
DD-WRT Novice


Joined: 13 Feb 2019
Posts: 47

PostPosted: Wed Jun 16, 2021 15:41    Post subject: Reply with quote
Sorry my connection type to my internet provider is a static IP, so I don't have the Ignore WAN DNS option.

I use the DNS numbers provided by NordVPN. Understandably the NordVPN dd-wrt setup page is a little outdated, so maybe I need to change those DNS numbers or some other tweak.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12439
Location: Netherlands

PostPosted: Wed Jun 16, 2021 17:09    Post subject: Reply with quote
You do not need the Ignore WAN DNS when using static.

Just set DNS 1 and 2 to your liking, be sure that those are publicly available (not all VPN servers are publicly available) I would just use OpenDNS or Google etc.

But the main question is still not answered, is the problem on the non VPN/PBR client?

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
RotoBill
DD-WRT Novice


Joined: 13 Feb 2019
Posts: 47

PostPosted: Wed Jun 16, 2021 17:29    Post subject: Reply with quote
Oops... sorry. Yes the client (my TV) is not connected thru the VPN.

I listed just my PC's in the PBR box on the VPN page. All of my TV's are not listed so they can be seen by Amazon.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12439
Location: Netherlands

PostPosted: Wed Jun 16, 2021 17:55    Post subject: Reply with quote
OK the plot is slowly unravelling Smile

I suspect the problem is that you are using pushed DNS servers which will route through the VPN so you Amazon clients are using a DNS server via the VPN while normal traffic goes out via the WAN.

Some websites e.g. Amazon will not like that.

You have 3 choices:
1. This is the current situation I think: route DNS via the VPN, your Amazon clients will not work
2. Route DNS via the WAN, your Amazon will work but you will have a DNS leak
3 Use split DNS so different DNS servers for PBR and Non PBR clients (with different routing of DNS servers)

You can read all about it in our documentation see links in my signature especially of interest will be the "DDWRT DNS problems with Policy based routing" guide.

It is still speculation as I have not seen any screenshots of setup page, DNSMasq page and OpenVPN status page

But as a test add in the additional DNSmasq options:
no-resolv
server=8.8.8.8
server=8.8.4.4

This will let you use these DNS servers which will normally not route via the VPN, with some luck you will have your amazon back

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
RotoBill
DD-WRT Novice


Joined: 13 Feb 2019
Posts: 47

PostPosted: Wed Jun 16, 2021 18:23    Post subject: Reply with quote
So I added the

no-resolv
server=8.8.8.8
server=8.8.4.4

It now appears to be working.

DNS leak came up negative so I'm good there.

Should I change my NordVPN DNS settings to these google ones?
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12439
Location: Netherlands

PostPosted: Wed Jun 16, 2021 18:35    Post subject: Reply with quote
The no-resolv directive means not using resolv.dnsmasq but instead use the servers specified with: server=

So it does not matter what you set otherwise.
One caveat Nord can push routing for their own DNS servers so if you use those it is possible that you will have your problem back.

But you did not provide enough information to give a definitive answer.

DNS problems with PBR can be complicated, if you want to know more you have to read up on the subject

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
RotoBill
DD-WRT Novice


Joined: 13 Feb 2019
Posts: 47

PostPosted: Sat Jun 26, 2021 17:12    Post subject: Reply with quote
I've finally found time to work on this issue again. You mentioned "more info". What can I provide?
RotoBill
DD-WRT Novice


Joined: 13 Feb 2019
Posts: 47

PostPosted: Mon Jul 05, 2021 13:55    Post subject: Reply with quote
Finally solved the problem. I set the DNS to the Smart DNS provided by NordVPN.

Simple
Very Happy
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Advanced Networking All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum