[SOLVED] R7000 - no web GUI no telnet but responds to ping

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
ultimo7
DD-WRT Novice


Joined: 20 Jun 2021
Posts: 2

PostPosted: Sun Jun 20, 2021 12:59    Post subject: [SOLVED] R7000 - no web GUI no telnet but responds to ping Reply with quote
Hi DD-WRT community,
I hope I am posting this message in the right place and that someone will be able to help me.

I own a Netgear R7000 I had upgraded to a version of tomato router years ago and was not using anymore.
I moved things around at home and needed a little vpn router to switch region for my apple tv so I thought to re-use my R7000.
I have had some issues with using it as a Wireless client and decided to give DD-WRT a try.
I re-installed an oem image on it successfully.
From the netgear GUI I then installed this image :
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2020/06-02-2020-r43324/netgear-r7000/factory-to-dd-wrt.chk
which I found recommended on this thread :
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=325487&highlight=r7000

The upgrade worked successfully and the wireless client setup I wanted also looked to work well.
However I noticed that at time the web gui was not responsive and even after a while not available at all. (same for telnet access)
I realized I had not erased the nvram as stated in the thread so I managed to connect via telnet straight after a reboot and did an nvram erase + reboot.

(btw I do all of this from a windows 10 OS hard wired to the R7000 with static IP ...)

Since then no access to Web GUI, no Telnet.
The router is advertising a DD-WRT ssid, I can connect on it with the netgear default password on the back of the router.
It is also running DHCP on default 192.168.1.0/24 network.
When it boots it responds to ping with ttl 100 for a few seconds and then ttl 64.
I have tried to re-tftp the image (and the oem) with no success.
I have also done multiple 30-30-30 hard reset (which I read later are useless on this device?) I have also pressed the reset buton for 10sec (it looks to only reboot the router...)

Anyone could help ? Have I missed something ?

Thanks in advance and sorry if the answer is somewhere on the forum ... I could not find it


Last edited by ultimo7 on Sun Jun 20, 2021 19:33; edited 1 time in total
Sponsor
AlphaCJ44
DD-WRT Novice


Joined: 01 Jan 2021
Posts: 21

PostPosted: Sun Jun 20, 2021 14:15    Post subject: Reply with quote
Hello,

There are always risks involved when you're doing nvram erase.

Anyway, If there's no way to reach the router (webui or telnet, ssh), then you might have to open it up for serial connection and try to flash the oem firmware back from there.. Because it seems something went wrong when you did nvram erase + reboot.


Once such debrick guide is this
https://www.myopenrouter.com/article/how-debrick-or-recover-netgear-r7000-r6300v2-or-r6250-wi-fi-routers


Regards!
thommy181
DD-WRT User


Joined: 16 Mar 2019
Posts: 223
Location: Szczecin, Poland EU

PostPosted: Sun Jun 20, 2021 14:25    Post subject: Reply with quote
If you execute command nvram erase you have default settings in factory default state. You should use rj-45 cord connect to computer and port 1 in your device. Turn on router and wait for boot operation (sometimes you need more than 5 minutes for fully start). After this operation open control panel and set IP for auto configuration from DHCP, DNS too. Now open command line in Windows (cmd.exe). Type command ipconfig /all. Check default gateway IP (standards should be 192.168.1.1), it isn't have other IP when was nvram erased. Now open web browser and type address 192.168.1.1 If router is restored you should type new username and password to GUI. If GUI not respond you should retry restore factory defaults and doing whole operation one more time. Read this document too: https://wiki.dd-wrt.com/wiki/index.php/Netgear_R7000 That's rather helpful for you.

Other hint: you shouldn't use telnet for simple connections that's unsecure option. I suggest you build-in SSHd module.
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1606
Location: WCentral Indiana USA

PostPosted: Sun Jun 20, 2021 16:04    Post subject: Reply with quote
Try NMRPFLASH for netgear routers.

30-30-30 not recommended for your router and may cause damage.
ultimo7
DD-WRT Novice


Joined: 20 Jun 2021
Posts: 2

PostPosted: Sun Jun 20, 2021 19:31    Post subject: Reply with quote
Issue sorted.
First thanks everyone for responding!
Bushant the NRMPFLASH has helped a lot.

I faced a few other problems though ...

I used this guide :
https://forum.dd-wrt.com/phpBB2/download.php?id=42529
to be able to flash the router.
It uploaded successfuly the image (while previously tftp would not work)
But unfortunately I was still in the same situation... no web gui and no command line access (telnet/ssh).
I tried both with a ddwrt image or oem.
I then realised that with the Netgear oem you cannot access directly the web interface on the IP address... you have to connect on routerlogin.net (I believe there is a dns process running on the oem firmware which then redirects you and give you web access).
Also it only work when you are connected via Wifi to the router ... go figure.

I then managed to load the ddwrt image via the Netgear web interface.

However I ended up in the exact same situation than I was at the begining of my journey ... the ddwrt web interface was acting erraticaly, being randomly available ...
Also when I briefly managed to get access it would ask for credentials but default root/admin would not work.
Then I did try the reset that is advised for this router to clear the nvram. (in the guide above)
I pushed the reset button in the back for 10 sec, lights were flashing and it rebooted.
Then I could connect to the web interface consistently (Asking to change default pwd etc ...)

Now the router is stable and working all fine.

All in all I think my issue is that when I installed ddwrt I did not do the proper reset procedure of the nvram.
I used the "erase nvram" command and on this router I should have just pressed the reset button for 10 secs ...

Anyway I hope this can be useful for other people ...

Thanks again for the help!
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1606
Location: WCentral Indiana USA

PostPosted: Sun Jun 20, 2021 20:01    Post subject: Reply with quote
Glad you got it.
Take note that "nvram erase" is currently used from the command line,
https://wiki.dd-wrt.com/wiki/index.php/Hard_reset_or_30/30/30#Hard_Reset_on_ARM_and_other_newer_routers

Also many have problems using chromium based browsers when upgrading or accessing the GUI.
I have never had any problems so I won't make recommendations there Cool
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 10195
Location: Texas, USA

PostPosted: Mon Jun 21, 2021 2:21    Post subject: Reply with quote
I've never had an issue connecting to a Netgear device using it's IP address via wired ethernet; that's a new one on me.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 8184
Location: Netherlands

PostPosted: Mon Jun 21, 2021 5:49    Post subject: Reply with quote
I can remember when going back to stock (using TFTP so your PC was set static DHCP) you had to set the PC back to Automatic DHCP.

Edit: Snippet form the R6400 guide:

Quote:
Sometimes Netgear Stock firmware has a problem with static IP on the client, so if you can not reach your router at 192.168.1.1 you might try to set the client to Automatically obtain IP address (DHCP) and/or power cycle the router

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum