New Build - 06/18/2021 - r46974

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3135

PostPosted: Fri Jun 18, 2021 11:50    Post subject: New Build - 06/18/2021 - r46974 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and device specific recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link does not work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r46958 (GitHub mirror)

Notes:
OpenVPN 2.5.2: Guides, Server, PBR, Reverse PBR, Client (see second post), Kill Switch, update tips, scripts and more.
WireGuard 1.0.20210606/Tools: Guides, Client, Server, Advanced, PBR, KS, update tips, scripts & more. Thanks BS & egc!
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle since r41813.
Experimental build option for Broadcom 8MB+ K2.x devices (limited currently): broadcom_K3X_mipsel32r1
• Broadcom MIPS devices are now on kernel 4.4. • Support added for TP-Link Archer C8 v2 and v3.
SmartDNSMiniDLNA • Unbound 1.13.1 • CoovaChilli 1.6 • Tor 0.4.5.8 • OpenSSL 1.1.1k • Dnsmasq 2.85 • Privoxy 3.0.32
In-kernel Samba (ksmbd 3.3.9+): default min/max versions changed. • WSD updateANTFS/NTFS3 kernel mode driver++.
• Added swconfig support for Broadcom devices.
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 (Fragattack) fixed.
• "Assign WAN port to Switch" feature removed to be reworked in a future release.

Issues, observations, and/or workarounds reported:
DNScrypt 1.95 can still be used in the GUI, but v2 (not compatible) requires Golang and thus Entware. #6246
WDS does not work on Broadcom ARM devices (only MIPS<->MIPS) & bridge modes on k4.4 devices may sometimes work
in some configurations for certain builds but are not supported by the bcmdhd driver. Use client or repeater instead.
VAPs not working at boot fixed for unbridged VAPs in 40562 - 40566. Effective startup commands discussion thread is here.
If start-up scripts do not work from USB add a delay, e.g. wait script or 'sleep 25'.
Broadcom ARM devices if 5 GHz channels are missing, via Telnet/SSH: 'nvram set brcm_unlock=1' 'nvram commit' 'reboot'
Show us your findings with steps to reproduce, configuration, output, logs and important information below!

Important:
• For issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Search SVN tickets & discuss in forum before opening. Before reporting: reset & manually set up, not restore from a backup.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
IONK
DD-WRT User


Joined: 19 Aug 2011
Posts: 310

PostPosted: Fri Jun 18, 2021 12:45    Post subject: Reply with quote
Router/Version: D-Link DIR-868L Rev.A1
File/Kernel: dir868a-webflash.bin / Linux 4.4.272 #3481 SMP Thu Jun 17 14:46:47 +07 2021 armv7l
Previous/Reset: DD-WRT v3.0-r46958 std (06/16/21) / no
Mode/Status: Repeater Bridge on 5GHz AC/N-Mixed (wl0 is purposely turned off) + USB Storage + lighttpd + ProFTPD + Cron / working
Issues/Errors: none

EDIT: I realize 06-10-2021-r46935 suddenly appears today.

_________________
▫ RSS feed for DD-WRT releases: https://politepol.com/fd/NfCoAP5bUJXU
easyddup - A simple upgrade/downgrade utility by yoyoma2


Last edited by IONK on Fri Jun 18, 2021 13:22; edited 1 time in total
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 422

PostPosted: Fri Jun 18, 2021 13:12    Post subject: Reply with quote
Router/Version: Netgear R7000
File: netgear-r7000-webflash.bin
Firmware: DD-WRT v3.0-r46974 std (06/18/21) (prev. DD-WRT v3.0-r46958 std (06/16/21))
Kernel: Linux 4.4.272 #3481 SMP Thu Jun 17 14:46:47 +07 2021 armv7l
Mode: Gateway, Wifi disabled, Wireguard for external access, WAN to DSL, Keep Alive reboot 5:00 in the morning
Reset: No
Status: Ok, up 0:27h.

Router/Version: Asus RT-N66U
File: dd-wrt.v24-46974 NEWD-2_K3.x-big-RT-N66U.trx
Firmware: DD-WRT v3.0-r46974 big (06/18/21) (will go back to DD-WRT v3.0-r46949 big (06/13/21))
Kernel: Linux 4.4.272 #10273 Fri Jun 18 04:20:27 +07 2021 mips
Mode: Gateway, Wifi disabled, WAN disabled, Wireguard Endpoint for external VPS, connected via LAN to R7800, Keep Alive reboot 6:05 in the morning
Reset: No
Status: Wireguard Endpoint does not connect, tunnel does not establish. Active IP Connections on STATUS Router states "0" even when connected with Webif and SSH.
Went back to r46949, Problems gone. Reflashed 46958 --> problems appeared again.
See attached var/log/messages, let me know if anything can be done to further debug this Smile
Settings uploaded to https://i.imgur.com/xsqMQpm.jpg



messages.txt
 Description:

Download
 Filename:  messages.txt
 Filesize:  28.25 KB
 Downloaded:  37 Time(s)

saphirely
DD-WRT User


Joined: 13 Dec 2020
Posts: 71

PostPosted: Fri Jun 18, 2021 15:34    Post subject: Reply with quote
Router/Version: Netgear R6250
Firmware: DD-WRT v3.0-r46974 std (06/18/21)
Kernel: Linux 4.4.272 #3481 SMP Thu Jun 17 14:46:47 +07 2021 armv7l
Mode: Gateway, Wireless AP, unbound
Reset: No, not this time
Previous : r46958
Upgrade: Web and 1st succeed without reset.
Temperatures CPU 76.9 °C / WL1 56.5 °C
Load: 0.11, 0.06, 0.01
Uptime 1h
Errors: No, not at this moment.

WAN: DHCP
MTU:1500 Auto
Shortcut Forwarding Engine: CTF
Flow Acceleration: CTF & FA
STP: Disable

DHCP Server Enabled - Running
Samba Disabled
WRT-radauth Disabled
WRT-rflow Disabled
MAC-upd Disabled
CIFS Automount Disabled
Sputnik Agent Disabled
USB Support Disabled

Works very well.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 8127
Location: Netherlands

PostPosted: Fri Jun 18, 2021 15:38    Post subject: Reply with quote
Maybe the WireGuard server and or client are not properly started, try Save/Apply on the Tunnels page for server and client

I have just upgraded and WireGuard seems to work on my side with server and client now on 46974
(there has been a WG upgrade on commit 46974:
https://svn.dd-wrt.com/changeset/46974 )

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 422

PostPosted: Fri Jun 18, 2021 16:01    Post subject: Reply with quote
@egc, I tried this during my debugging session, to no avail Sad even generated new keys... no success.
Additional tried "ip link set down oet1" (the command from your guide, maybe I missremeber it currently on mobile).
Can connect to my other router from mobile network via wireguard.
My VPS (Endpoint for the N66u) is up-to-date (ubuntu 20.04, Kernel 5.4), restartet WG on it, but no chance :/
mj666
DD-WRT Novice


Joined: 26 Nov 2010
Posts: 37

PostPosted: Fri Jun 18, 2021 16:14    Post subject: Reply with quote
Router/Version: RT-AC66U/Asus RT-AC66U
File DD-WRT v3.0-r46974 giga (06/18/21)
Kernel:
Previous/Reset: 46949/no
Mode/Status: access point, MAC filter/not working
Issues/Errors: not booting up after upgrade. Needed to restore 46949 via ASUS mini webserver. Configuration was reset to defaults. I definitely started less 5 times. Configuration was now redone from scratch but the difference to my former nvram variable backup is minimal.

_________________
Asus AC-RT88U (Gateway, asus_rt-ac88u-firmware_47305.trx)
Asus AC-RT88U (AP, asus_rt-ac88u-firmware_47305.trx)
Asus AC-RT68U (AP, asus_rt-ac68u-firmware_47305.trx)
Asus AC-RT66U (AP, dd-wrt-47305-Asus_RT-AC66U.trx)
Linksys E3000 (AP, dd-wrt.v24-47305_NEWD-2_K3.x_mega-e3000.bin)
Linksys E4200 V2 (openwrt-18.06.5-kirkwood-linksys_viper-squashfs-sysupgrade.bin) not used at the moment
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 8127
Location: Netherlands

PostPosted: Fri Jun 18, 2021 16:54    Post subject: Reply with quote
Zyxx wrote:
@egc, I tried this during my debugging session, to no avail Sad even generated new keys... no success.
Additional tried "ip link set down oet1" (the command from your guide, maybe I missremeber it currently on mobile).
Can connect to my other router from mobile network via wireguard.
My VPS (Endpoint for the N66u) is up-to-date (ubuntu 20.04, Kernel 5.4), restartet WG on it, but no chance :/


The symptoms you describe is because the client cannot connect to the server. the client is up but gets no response form the server.
So could be a network problem or a key problem indeed.

Our WG implementation (setup and routing etc) did not change it is only the core WG files which have been updated.

As you have setup on a WAP check if this rule is still present and working on the WAP:
iptables -t nat -I POSTROUTING -o br0 -j SNAT --to $(nvram get lan_ipaddr)

I saw your IPaddress/Netmask is /32 which actually should work as you also have 0.0.0.0/1,128.0.0.0/1 in allowed IPs and route Allowed IP's but I recommend using /24 for Netmask as a safety measure as the interface will automatically make a route for the tunnel when using /24

In the Server setup guide is a trouble shooting section with things you can show on the client side, you can PM that to me if you wish

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 422

PostPosted: Fri Jun 18, 2021 17:18    Post subject: Reply with quote
Thank you@egc, will commence with your advice and PM you if still no luck.
BUT currently on the road, testing will resume this weekend...
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 8127
Location: Netherlands

PostPosted: Fri Jun 18, 2021 17:37    Post subject: Reply with quote
Router Model: Netgear R6400v2, board_id: U12H332T

Firmware Version: DD-WRT v3.0-r46974 std (06/18/21)
Kernel Version: Linux 4.4.272 #3481 SMP Thu Jun 17 14:46:47 +07 2021 armv7l

Upgraded from: DD-WRT v3.0-r46949M Community Build (06/13/21)
Reset: No not this time

Status: Up and running for 2 hours, basic setup as Gateway, static leases, OpenVPN client with Policy Based Routing up and running, 2,4GHz and 5Ghz working, USB storage NAS working, OpenVPN server working, WireGuard server working with 8 clients (phones , windows and two other routers for site-to-site setup).

Errors: None

Thanks BS!

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
dwardo
DD-WRT User


Joined: 07 Feb 2013
Posts: 93
Location: France

PostPosted: Fri Jun 18, 2021 21:51    Post subject: Reply with quote
Router/Version: TP-Link Archer C9 v1
File/Kernel: archer-c9v1-webflash.bin/Linux 4.4.272 #3483 SMP Fri Jun 18 03:24:17 +07 2021 armv7l
Previous/Reset: r46750/no
Mode/Status: Gateway/2.4GHz & 5GHz AP/Openvpn server/Wireguard server/DHCP server/DNS Server/Port forwarding/ipv4 & ipv6
Issues/Errors: None noticed for now
twindragon6
DD-WRT User


Joined: 29 Jun 2008
Posts: 223

PostPosted: Sat Jun 19, 2021 3:38    Post subject: Netgear Nighthawk R7000 Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r46974 std (06/18/21)
Kernel: Linux 4.4.272 #3481 SMP Thu Jun 17 14:46:47 +07 2021 armv7l
Mode: Gateway, Wireless AP. CTF & FA Enabled. NAT and QOS Off.
Reset: Nope.
Previous: 06-16-2021-r46958
Status: Working really well so far, CPU hot but it's hot here so... still testing.
Temperatures: CPU 66.9 °C / WL0 51.0 °C / WL1 56.0 °C



Logs.txt
 Description:
Full system logs. MAC scrubbed, password scrubbed, the fun stuff at the bottom as usual!

nvram set console_debug=1

cat /var/log/messages (Initial Flash)
dmesg (Initial Flash)
cat /proc/cpuinfo
cat /tmp/dnsmasq.conf
cat /tmp/DNSCache.log
cat /tmp/unbound

Download
 Filename:  Logs.txt
 Filesize:  248.9 KB
 Downloaded:  34 Time(s)

Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4495
Location: UK, London, just across the river..

PostPosted: Sat Jun 19, 2021 6:40    Post subject: Reply with quote
Router Model Netgear R7000
Firmware Version DD-WRT v3.0-r46974 std (06/18/21)
Kernel Version Linux 4.4.272 #3481 SMP Thu Jun 17 14:46:47 +07 2021 armv7l

update: CLI r469496 > r46974
reset: NO
status: Operational 12h+
errors: cat /tmp/dnsmasq.conf

interface=br0,vlan3,br1,br1

interface br1 is added twice...i dont have any rules regarding it in dnsmasq adv config or start up script...

I have vlan 3 added via GUI and its assigned to br1 and has DHCPd on br1...net isolation is turned on...has its own subnet/nat and using default DNS...

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 47117 BS AP,NAT
TP-Link WR1043NDv2 -DD-WRT 47381 BS AP,NAT,AP Isolation,Ad-Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -DD-WRT 47381 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm Atheros/
Netgear R7800 --DD-WRT 47381 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT,Vanilla
Netgear R9000 --DD-WRT 47381 BS AP,NAT,AD-Block,AP Isolation,Firewall,Local DNS,DoT,2,4Ghz only,Vanilla
Broadcom
Netgear R7000 ---DD-WRT 47381 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
hurleyp
DD-WRT User


Joined: 10 Sep 2009
Posts: 329
Location: Ottawa, Ontario, Canada

PostPosted: Sat Jun 19, 2021 13:27    Post subject: Reply with quote
Firmware: v3.0-r46974 std (06/18/21)
Router/Version: Netgear R7000
Kernel: Linux 4.4.272 #3481 SMP Thu Jun 17 14:46:47 +07 2021 armv7l
Previous: v3.0-r46949 std (06/13/21)
Mode/Status: AP wired and wireless / Up and running for 24 hours
Reset: Soft boot before and after upgrade
Temperatures: CPU 61.4 °C / WL0 46.8 °C / WL1 52.0 °C
Issues/Errors: Nothing significant

Updated via webif. No 'nvram erase' this time, last one was in July 2018 (r36325).

Upload and Download speeds are to ISP spec. Nothing unexpected in the syslog.

Current basic R7000 setup (subject to change of course):
- Static WAN IP
- Shortcut Forwarding Engine: CTF, Flow Acceleration: Disabled
- STP - Enabled
- IPv4 only, both WAN and LAN
- LAN DHCP Enabled
- Wireless: AP, Regulatory Domain = CANADA, wl0 Mixed (ch. 6), wl1 AC/N-Mixed (ch. 36, VHT80), AES
- 1 wireless VLAN on wl0
- SNMP disabled, SSH enabled, Telnet disabled
- Firewall enabled, Log Level high
- Syslog: to local server. klogd: disabled.
- USB support - Off
- No custom scripts
- No: ttraf, Tor, VNC, Zabbix, VPN, Radius, OpenVPN
- No: UPnP, DMZ, QoS
- No: Samba, CIFS, JFFS2, miniDLNA, Entware, Optware

_________________
Netgear R7000: v3.0-r47381 std (09/08/21)
EdgeRouter-X: EdgeOS v2.0.9-hotfix 2
NefariousRat
DD-WRT Novice


Joined: 29 Mar 2021
Posts: 5

PostPosted: Sat Jun 19, 2021 16:43    Post subject: Reply with quote
Router/Version: Netgear R6400v1
File/Kernel: DD-WRT v3.0-r46974 std (06/18/21) / Linux 4.4.272 #3481 SMP armv7l
Previous/Reset: r46949 / no
Mode/Status: Gateway / up 4.5 hours without issue
Issues/Errors: None so far
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum