New Build - 05/17/2021 - r46690

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2883

PostPosted: Mon May 17, 2021 7:25    Post subject: New Build - 05/17/2021 - r46690 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and device specific recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link does not work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r46481 (GitHub mirror)

Notes:
OpenVPN 2.5.2: Guides, Server, PBR, Reverse PBR, Client (see second post), Kill Switch, update tips, scripts and more.
WireGuard 1.0.20210219/Tools: Guides, Client, Server, Advanced, PBR, KS, update tips, scripts & more. Thanks BS & egc!
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle since r41813.
Experimental build option for Broadcom 8MB+ K2.x devices (limited currently): broadcom_K3X_mipsel32r1
• Broadcom MIPS devices are now on kernel 4.4. • Support added for TP-Link Archer C8 v2 and v3.
SmartDNSMiniDLNA • Unbound 1.13.1 • CoovaChilli 1.6 • Tor 0.4.5.7 • OpenSSL 1.1.1k • Dnsmasq 2.85 • Privoxy 3.0.32
In-kernel Samba (ksmbd 3.3.9+): default min/max versions changed. • WSD updateANTFS/NTFS3 kernel mode driver++.
• Added CTF (Cut Through Forwarding) and swconfig support to Broadcom devices.
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 (Fragattack) fixed.

Issues, observations, and/or workarounds reported:
DNScrypt 1.95 can still be used in the GUI, but v2 (not compatible) requires Golang and thus Entware. #6246
WDS does not work on Broadcom ARM devices (only MIPS<->MIPS) & bridge modes on k4.4 devices may sometimes work
in some configurations for certain builds but are not supported by the bcmdhd driver. Use client or repeater instead.
VAPs not working at boot fixed for unbridged VAPs in 40562 - 40566. Effective startup commands discussion thread is here.
If start-up scripts do not work from USB add a delay, e.g. wait script or 'sleep 25'.
Broadcom ARM devices if 5 GHz channels are missing, via Telnet/SSH: 'nvram set brcm_unlock=1' 'nvram commit' 'reboot'
Show us your findings with steps to reproduce, configuration, output, logs and important information below!

Important:
• For issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Search SVN tickets & discuss in forum before opening. Before reporting: reset & manually set up, not restore from a backup.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 405

PostPosted: Mon May 17, 2021 9:39    Post subject: Reply with quote
Router/Version: RT N66U
File/Kernel: dd-wrt.v24-46690_NEWD-2_K3.x-big-RT-N66U.trx, 4.4.268 #9023
Previous/Reset: r46380, no
Mode/Status: not functional
Issues/Errors: The device does not work after update. Serial log attached.
During Boot this message is given:
"CPU 0 Unable to handle kernel paging request at", followed by debug information.



putty.txt
 Description:

Download
 Filename:  putty.txt
 Filesize:  73.24 KB
 Downloaded:  64 Time(s)

Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 6132
Location: Romerike, Norway

PostPosted: Mon May 17, 2021 9:58    Post subject: Reply with quote
Router Model: Asus RT-AC66U
Firmware Version: DD-WRT v3.0-r46690 giga (05/17/21)
Kernel Version: Linux 4.4.268 #9011 Mon May 17 05:19:27 +07 2021 mips
Status: Working
elatllat
DD-WRT Novice


Joined: 20 Feb 2020
Posts: 17

PostPosted: Mon May 17, 2021 12:34    Post subject: Reply with quote
Router/Version: Asus RT-AC66U /
File/Kernel: dd-wrt-46690-Asus_RT-AC66U.trx / Linux 4.4.268 #9011 Mon May 17 05:19:27 +07 2021 mips
Previous/Reset: v3.0-r45735 / no
Mode/Status: AP, Gateway, Router / OK
Issues/Errors: no / no
twindragon6
DD-WRT User


Joined: 29 Jun 2008
Posts: 192

PostPosted: Mon May 17, 2021 12:37    Post subject: Netgear Nighthawk R7000 Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r46690 std (05/17/21)
Kernel: Linux 4.4.268 #3076 SMP Sun May 16 19:58:58 +07 2021 armv7l
Mode: Gateway, Wireless AP.
Reset: Nope.
Previous: 04-24-2021-r46446
Status: Working so far, still testing. CPU temps high; unable to capture logs over Wi-Fi, boot takes too long and the logs are already overwritten. I'll try to capture a log file over ethernet later. I switched from "SFE" to "CTF" for the "Shortcut Forwarding Engine," however anytime I try to set the "Flow Acceleration" to "CTF & FA," the unit reboots with "Flow Acceleration" "Disabled". It works with "QOS" "disabled."
Temperatures: CPU 63.6 °C / WL0 49.0 °C / WL1 54.4 °C



CTF With QOS Disabled.jpg
 Description:
CTF with CTF & FA and QOS Disabled.
 Filesize:  9.1 KB
 Viewed:  3046 Time(s)

CTF With QOS Disabled.jpg



CTF.jpg
 Description:
CTF with CTF & FA after reboot.
 Filesize:  9.02 KB
 Viewed:  3064 Time(s)

CTF.jpg



Logs.txt
 Description:
Full system logs. MAC scrubbed, password scrubbed, the fun stuff at the bottom as usual!

nvram set console_debug=1

Download
 Filename:  Logs.txt
 Filesize:  196.9 KB
 Downloaded:  53 Time(s)



Last edited by twindragon6 on Tue May 18, 2021 12:24; edited 4 times in total
turbowells
DD-WRT User


Joined: 14 Sep 2019
Posts: 216
Location: Maine, USA

PostPosted: Mon May 17, 2021 13:21    Post subject: Reply with quote
Router/Version: Asus RT-N12D
File: dd-wrt.v24-#####_NEWD-2_K3.x_mega.bin
Mode: Gateway/OpenVPN client
Previous: r46442
Reset?: N
Status: Not working - Still crashing on WIFI connect. Still no WAN IP. Last working version is r46442.

Crash and boot attached.



crash2.txt
 Description:

Download
 Filename:  crash2.txt
 Filesize:  18.28 KB
 Downloaded:  58 Time(s)

IONK
DD-WRT User


Joined: 19 Aug 2011
Posts: 254

PostPosted: Mon May 17, 2021 14:07    Post subject: Reply with quote
Router/Version: D-Link DIR-868L Rev.A1
File/Kernel: dir868a-webflash.bin / Linux 4.4.268 #3076 SMP Sun May 16 19:58:58 +07 2021 armv7l
Previous/Reset: DD-WRT v3.0-r46681 std (05/16/21) / no
Mode/Status: Repeater Bridge on 5GHz AC/N-Mixed (wl0 is purposely turned off) + USB Storage + lighttpd + cron / working
Issues/Errors: none

_________________
▫ RSS feed for DD-WRT releases: https://politepol.com/fd/NfCoAP5bUJXU
easyddup - A simple upgrade/downgrade utility by yoyoma2
saphirely
DD-WRT Novice


Joined: 13 Dec 2020
Posts: 49

PostPosted: Mon May 17, 2021 14:59    Post subject: Reply with quote
Router/Version: Netgear R6250
Firmware: DD-WRT v3.0-r46690 std (05/17/21)
Kernel: Linux 4.4.268 #3076 SMP Sun May 16 19:58:58 +07 2021 armv7l
Mode: Gateway, Wireless AP, unbound
Reset: No
Previous : r46681
Upgrade: Web and 1st succeed without reset.
Temperatures CPU 74.7 °C / WL1 52.6 °C
Load: 0.01, 0.06, 0.03
Uptime 15 min

Thank fixed Fragattack

I changed Setup-Basic Setup->Short Forwarding Engine SFE (default) to CTF, and Flow Acceleration Disable (Default) to CTF+FA,save and Apply...
Linux mxV270 5.10.0-5mx-amd64 #1 SMP Debian 5.10.26-1~mx19+1 (2021-04-01) x86_64 GNU/Linux
$ speedtest-cli
Retrieving speedtest.net configuration...
Testing from (206.xxx.xxx.xxx)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by Canada [7.59 km]: 17.045 ms
Testing download speed................................................................................
Download: 85.78 Mbit/s
Testing upload speed......................................................................................................
Upload: 35.13 Mbit/s

If tested speedtest.net in brave, it is 92.93D/U34.43.
rnix
DD-WRT User


Joined: 23 Feb 2016
Posts: 160

PostPosted: Mon May 17, 2021 17:41    Post subject: Reply with quote
Router/Version: Asus RT-N18U
Firmware: DD-WRT v3.0-r46690 std (05/17/21)
Kernel: Linux 4.4.268 #3080 Mon May 17 04:50:08 +07 2021 armv7l
Mode: gateway
Previous: r46640
Reset: no
Status: almost working

More issues again with samba as router reboots randomly when I enable/disable samba server from webui.
edit - may be related to CTF after all as once I reverted to SFE, random reboots have stopped.

Question: does ddwrt support port forwarding when both ctf is enabled? I read somewhere it may not work but then again it could be outdated information.
maccent
DD-WRT Novice


Joined: 13 Feb 2020
Posts: 1

PostPosted: Tue May 18, 2021 9:00    Post subject: Reply with quote
Router/Version: D-Link DIR-868L Rev.A1
File/Kernel: dir868a-webflash.bin / Linux 4.4.268 #3076 SMP Sun May 16 19:58:58 +07 2021 armv7l
Previous/Reset: DD-WRT v3.0-r46220 std (03/31/21) / yes
Mode/Status: working as AP.
Issues/Errors: wifi (wl0) constant disconnections on all my devices. something odd, my nvram says 39/64 for the 46220 but 35/64 with the newest
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7152
Location: Dresden, Germany

PostPosted: Tue May 18, 2021 14:57    Post subject: Re: Netgear Nighthawk R7000 Reply with quote
twindragon6 wrote:
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r46690 std (05/17/21)
Kernel: Linux 4.4.268 #3076 SMP Sun May 16 19:58:58 +07 2021 armv7l
Mode: Gateway, Wireless AP.
Reset: Nope.
Previous: 04-24-2021-r46446
Status: Working so far, still testing. CPU temps high; unable to capture logs over Wi-Fi, boot takes too long and the logs are already overwritten. I'll try to capture a log file over ethernet later. I switched from "SFE" to "CTF" for the "Shortcut Forwarding Engine," however anytime I try to set the "Flow Acceleration" to "CTF & FA," the unit reboots with "Flow Acceleration" "Disabled". It works with "QOS" "disabled."
Temperatures: CPU 63.6 °C / WL0 49.0 °C / WL1 54.4 °C


if you change fa setting the unit reboots. this is wanted and required for that special setting. i worked on it for the ctf setting to get rid of it. but for fa acceleration a reboot is required right now. i naddition. it will disable itself if you use anything else but static or dhcp for wan. fa works only for dhcp and static ip on wan port

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s


Last edited by BrainSlayer on Wed May 19, 2021 2:28; edited 1 time in total
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7727
Location: Netherlands

PostPosted: Tue May 18, 2021 15:09    Post subject: Reply with quote
Router Model: Netgear R6400v2, board_id: U12H332T

Firmware Version: DD-WRT v3.0-r46690M Community Build (05/18/21)
Kernel Version: Linux 4.4.268 #1 SMP Tue May 18 14:44:27 CEST 2021 armv7l

Upgraded from: DD-WRT v3.0-r46177M Community Build (03/25/21)
Reset: No not this time

Status: Up and running for 2 hours, basic setup as Gateway, static leases, OpenVPN client with Policy Based Routing up and running, 2,4GHz and 5Ghz with excellent range and speed, USB storage, OpenVPN server working, WireGuard server working with 8 clients (phones , windows and two other routers for site-to-site setup).

Errors: None

Thanks BS!

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Huike
DD-WRT Novice


Joined: 10 Sep 2016
Posts: 13

PostPosted: Wed May 19, 2021 0:34    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r46690 std (05/17/21)
Kernel: Linux 4.4.268 #3076 SMP Sun May 16 19:58:58 +07 2021 armv7l
Mode: Gateway, DHCP client.
Reset: Yes
Previous: 04-24-2021-r46446
Status: Issues. Versions after r46446 have an issue: It can not get an IP address from my ISP. My ISP requires to use VLAN 10 tagging for DHCP clients. Tried to reset the router and manually setup the WAN port as DHCP client with VLAN 10 tagging, but never worked. Have to roll back to version r46446. Please fix it. Thanks.
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 485

PostPosted: Wed May 19, 2021 1:58    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r46690 std (05/17/21)
Kernel: Linux 4.4.268 #3076 SMP Sun May 16 19:58:58 +07 2021 armv7l
Previous: r46681
Mode/Status: Gateway / working
Issues/Errors: Working well so far.

Uptime: 8hrs 53mins
Upgrade: via web UI, no issues
Reset: no
Temperatures: CPU 68.6 °C / WL0 46.7 °C / WL1 52.7 °C
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7152
Location: Dresden, Germany

PostPosted: Wed May 19, 2021 2:06    Post subject: Reply with quote
Huike wrote:
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r46690 std (05/17/21)
Kernel: Linux 4.4.268 #3076 SMP Sun May 16 19:58:58 +07 2021 armv7l
Mode: Gateway, DHCP client.
Reset: Yes
Previous: 04-24-2021-r46446
Status: Issues. Versions after r46446 have an issue: It can not get an IP address from my ISP. My ISP requires to use VLAN 10 tagging for DHCP clients. Tried to reset the router and manually setup the WAN port as DHCP client with VLAN 10 tagging, but never worked. Have to roll back to version r46446. Please fix it. Thanks.


just configure it correct and it will work. consider that /proc/switch does not exist anymore. you have to use swconfig to configure vlans for the wan port. (or simply use the switch gui which works too). this has been already tested, also with vlan10 and it works. so fix your setup since you are likelly using a custom script which does not work anymore. there are such scripts are flying around in french forums.

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum