New Build - 02/28/2021 - r45863

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2787

PostPosted: Sun Feb 28, 2021 15:16    Post subject: New Build - 02/28/2021 - r45863 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and device specific recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link does not work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r45859 (GitHub mirror)

Notes:
OpenVPN 2.5.1: Setup Guides, Server, PBR, update tips, scripts and more.
WireGuard 1.0.20210219/Tools: Setup Guides, Client, Server, Advanced, update tips, scripts and more. Thanks BS & egc!
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle since r41813.
Experimental build option for Broadcom 8MB+ K2.x devices (limited currently): broadcom_K3X_mipsel32r1
• Broadcom MIPS devices are now on kernel 4.4. • Support added for TP-Link Archer C8 v2 and v3.
• Dnsmasq 2.84 • SmartDNS update • MiniDLNA 1.3.0 • Privoxy 3.0.31 • Unbound 1.13.1 • CoovaChilli 1.6 • OpenSSL 1.1.1j
In-kernel Samba (ksmbd 3.3.5+): default min/max versions changed. • WSD updated. • ANTFS/NTFS3 kernel mode drivers.

Issues, observations, and/or workarounds reported:
DNScrypt 1.95 can still be used in the GUI, but v2 (not compatible) requires Golang and thus Entware. #6246
WDS does not work on Broadcom ARM devices (only MIPS<->MIPS) & bridge modes on k4.4 devices may sometimes work
in some configurations for certain builds but are not supported by the bcmdhd driver. Use client or repeater instead.
VAPs not working at boot fixed for unbridged VAPs in 40562 - 40566. Effective startup commands discussion thread is here.
If start-up scripts do not work from USB add a delay, e.g. wait script or 'sleep 25'.
Broadcom ARM devices if 5 GHz channels are missing, via Telnet/SSH: 'nvram set brcm_unlock=1' 'nvram commit' 'reboot'
Show us your findings with steps to reproduce, configuration, output, logs and important information below!

Important:
• For issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Search SVN tickets & discuss in forum before opening. Before reporting: reset & manually set up, not restore from a backup.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 170

PostPosted: Sun Feb 28, 2021 17:08    Post subject: Reply with quote
Router Model: Netgear R8000
Firmware Version: DD-WRT v3.0-r45863 std (02/28/21)
Kernel Version: Linux 4.4.258 #2158 SMP Sun Feb 28 10:07:54 +07 2021 armv7l
Previous Version: DD-WRT v3.0-r45859 std (02/27/21)
Drivers: Experimental
Services: samba, wireguard client, openvpn client, dhcp, wifi 2.4 ghz, usb, nas
Status: working with the exception of accessing usb from win7 explorer
Updated: via webgui
Mode: AP/gateway
Issues: cannot access the usb from win7 explorer
Reset: no
Reboot: no
Uptime: 13 min
Load Average: 0.26, 0.61, 0.57
Temperatures: CPU 46.9 °C

Errors: as reported in the syslog below

Feb 28 12:31:30 DD-WRT user.err wsdd2[1227]: Terminated received.
Feb 28 12:31:30 DD-WRT local5.err ksmbd: [ksmbd-manager/1231]: ERROR: WARNING: child process exited abnormally: 1232
Feb 28 12:31:36 DD-WRT local5.err ksmbd: [ksmbd-manager/2941]: ERROR: Failed to create lock file: File exists
Feb 28 12:37:10 DD-WRT daemon.err httpd[1439]: httpd : Request Error Code 408: Unexpected connection close in intitial request
Feb 28 12:38:40 DD-WRT kern.err kernel: ksmbd: smb2_query_dir:4101: error while processing smb2 query dir rc = 1

Observations:
I did not have to clean the usb after the upgrade and it remained mounted

You are not asked for a username and password on using windows explorer to access the usb

You cannot access the usb; see photo.

Loading of 100% of the files on the usb for nas appear to take longer.



Share.png
 Description:
Moderator edit: Please take advice on how to properly add screenshots and fix your posts. Thank you!
 Filesize:  90.89 KB
 Viewed:  2088 Time(s)

Share.png


jrscs
DD-WRT User


Joined: 09 Aug 2010
Posts: 276

PostPosted: Sun Feb 28, 2021 17:32    Post subject: Reply with quote
Router/Version: RT-AC87U A1
Firmware: DD-WRT v3.0-r45863 std (02/28/21)
Kernel: Linux 4.4.258 #2158 SMP Sun Feb 28 10:07:54 +07 2021 armv7l
Mode/Status: Gateway/AP/Ok
Reset: Yes
Setup Using: 2.4 GHz, 2.4 GHz guest (VAP), 5.0 GHz, IPv4, DNSMasq, Port Forwarding, NTP TimeSync, VNC Repeater, Wake-on-WAN (internet), and Wireguard
Issues/Errors: OK

_________________
Netgear R7800 - DD-WRT v3.0-r45767 std (02/17/21)
Asus AC87U A1 - DD-WRT v3.0-r45767 std (02/17/21)
Repeater Bridges(s)
Asus AC68R A1 - DD-WRT v3.0-r45767 std (02/17/21)
Netgear R6400 V2 - DD-WRT v3.0-r45767 std (02/17/21)
Asus AC66U A1 - DD-WRT v3.0-r45767 giga (02/17/21)
labrok
DD-WRT User


Joined: 11 Feb 2011
Posts: 280
Location: Greece

PostPosted: Sun Feb 28, 2021 18:02    Post subject: Reply with quote
Router/Version: D-link DIR868L rev C
Firmware: DD-WRT v3.0-r45863 std (02/28/21)
Kernel: Linux 4.4.258 #2158 SMP Sun Feb 28 10:07:54 +07 2021 armv7l
Mode/Status: Gateway/AP
Reset: Yes (flashed from factory)

Samba unusable, mount NTFS HDD ok but doesnt appear on dropdown selection, ckdsk it and fixing it, all ok till i need to transfer a file , disk hangs up and get corrupted, needs unmount and chkdsk it again, fixing it enabling DLNA , scanning ok but never ends, uses 100% of CPU just to continue scaning the DLNA for about 1 hour.On memory usage seems that buffers are almost on 0%, rebooting the router disk corrupted again and needs to chkdsk for another 1 time, so much disk checking heve never done in my life, before was ok!! why now we need all this the chkdsk torture?....please help!!


Last edited by labrok on Sun Feb 28, 2021 18:11; edited 3 times in total
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2787

PostPosted: Sun Feb 28, 2021 18:05    Post subject: Reply with quote
Abboo, your images often have a large white space due to the wrong image canvas size.

For Paint.NET "Paste in to New Image" is Ctrl + Alt + V and for other apps see Edit menu.

Those considering to resize an image please copy paste a selection to a new image, or adjust canvas.

Direct bbcode links to external image hosts such as postimages will bypass any image size restrictions.

Screenshot Tutorial
saphirely
DD-WRT Novice


Joined: 13 Dec 2020
Posts: 28

PostPosted: Sun Feb 28, 2021 18:25    Post subject: Reply with quote
Router/Version: Netgear R6250
Firmware: DD-WRT v3.0-r45863 std (02/28/21)
Kernel: Linux 4.4.258 #2150 SMP Sun Feb 28 09:13:09 +07 2021 armv7l
Mode: Gateway, Wireless AP, Unbound
Reset: No
Previous:r45859
Upgrade: Web and 1st succeed without reset.
Temperatures CPU 76.9 // WL1 56.3

Uptime 1.5h
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 469

PostPosted: Sun Feb 28, 2021 19:04    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r45863 std (02/28/21)
Kernel: Linux 4.4.258 #2150 SMP Sun Feb 28 09:13:09 +07 2021 armv7l
Previous: r45859
Mode/Status: Gateway / working
Issues/Errors: Working well so far.

Uptime: 32mins
Upgrade: via web UI, no issues
Reset: no
Temperatures: CPU 66.9 °C / WL0 46.3 °C / WL1 52.1 °C
wabe
DD-WRT Guru


Joined: 17 Jun 2006
Posts: 792

PostPosted: Sun Feb 28, 2021 21:03    Post subject: Reply with quote
Router/Version: Asus RT-AC68U rev C1
Firmware: DD-WRT v3.0-r45863 (02/28/21)
Kernel: Linux 4.4.258 #2150 SMP Sun Feb 28 09:13:09 +07 2021 armv7l
Previous: r45859
Upgrade: via CLI
Reset: no
Mode/Status: Gateway / working
Issues/Errors: Working well

_________________
AC-68U rev. C1 on Build 46294
AC-68U rev. A1 on Build 46177
AC-68U rev. A1 on Build 46069
Cows
DD-WRT Novice


Joined: 06 Dec 2015
Posts: 23

PostPosted: Sun Feb 28, 2021 21:26    Post subject: Reply with quote
Router/Version: Tp-link Archer C1900 v1
File/Kernel: archer-c1900-webflash.bin
Previous/Reset: 02-17-2021 r45767
Mode/Status: Gateway/AP
Issues/Errors: Updated from the Feb 17 build and I noticed my router is now identified as a "Broadcom Northstar" now instead of previously being identified as an Archer C9 and the power led no longer lights up. Everything seems to be fine besides these 2 things that have changed. I noticed on the ddwrt trac there have been a good amount of changes for tplink devices recently so I'm guessing it is related to that. I tried an nvram erase but it didn't seem to change anything.
o2bad455
DD-WRT User


Joined: 08 Oct 2015
Posts: 61

PostPosted: Sun Feb 28, 2021 23:50    Post subject: Reply with quote
Router: Netgear R7000
File: netgear-r7000-webflash.bin
Firmware: DD-WRT v3.0-r45863 std (02/28/21)
Previous: DD-WRT v3.0-r45849 std (02/25/21)
Kernel: Linux 4.4.258 #2150 SMP Sun Feb 28 09:13:09 +07 2021 armv7l
Mode: Gateway, OpenVPN Client, FreeRADIUS Server, 802.1x WLAN
Reset: No
Status: 4:01 hrs up. Performance is solid, thanks!

_________________
My DD-WRT Routers:
HP Laptop/Intel/x86-64 (r46316 - unsupported wifi, testing only so far)
Netgear/Atheros R9000 (bought broken and awaiting delivery)
Linksys/Marvell WRT1900ACSv2 (r46316 - daily use)
Linksys/Marvell WRT1900ACSv1 (r44048 - daily use, reverted for Apple clients)
Netgear/Broadcom R7000 (3x: r45928 - remote use)
Linksys/Broadcom WRT54G/GS (4x: r44715)
twindragon6
DD-WRT User


Joined: 29 Jun 2008
Posts: 176

PostPosted: Mon Mar 01, 2021 13:28    Post subject: Netgear Nighthawk R7000 Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r45863 std (02/28/21)
Kernel: Linux 4.4.258 #2150 SMP Sun Feb 28 09:13:09 +07 2021 armv7l
Mode: Gateway, Wireless AP.
Reset: Nope.
Previous: 02-27-2021-r45859
Status: Working really well so far! I'm not currently using Samba, I have a NAS. I may plug in an old USB for testing. Most Speedtest results hang around the 150Mbps range on the 5GHz wireless for some reason. The link is capable of faster rates but they appear they default back to the 150Mbps rate. The TX Power setting under wl0-Advanced and wl1-Advanced when set to manual has no affect. wl -i eth1 txpwr 70 -o under administration commands does nothing as well!
Temperatures: CPU 53.6 °C / WL0 45.0 °C / WL1 50.2 °C



Speedtest.jpg
 Description:
Faster Rate
 Filesize:  65.14 KB
 Viewed:  1560 Time(s)

Speedtest.jpg



Speedtest-1.jpg
 Description:
150 Mbps Rate
 Filesize:  63.4 KB
 Viewed:  1561 Time(s)

Speedtest-1.jpg



Logs.txt
 Description:
Full System Logs

Download
 Filename:  Logs.txt
 Filesize:  144.95 KB
 Downloaded:  18 Time(s)



Last edited by twindragon6 on Thu Mar 04, 2021 4:13; edited 1 time in total
IONK
DD-WRT User


Joined: 19 Aug 2011
Posts: 217

PostPosted: Mon Mar 01, 2021 16:56    Post subject: Reply with quote
Router/Version: D-Link DIR-868L Rev.A1
File/Kernel: dir868a-webflash.bin / Linux 4.4.258 #2150 SMP Sun Feb 28 09:13:09 +07 2021 armv7l
Previous/Reset: 02-27-2021-r45859 / no
Mode/Status: Repeater Bridge on 5GHz AC/N-Mixed (wl0 is purposely turned off) + USB Storage + SSH / working
Issues/Errors: none

_________________
▫ RSS feed for DD-WRT releases: https://feed43.com/ddwrt-downloads.xml (unofficial)
easyddup - A simple upgrade/downgrade utility by yoyoma2
00diabolic
DD-WRT User


Joined: 17 Aug 2011
Posts: 53

PostPosted: Wed Mar 03, 2021 21:10    Post subject: BIG PROBLEMS... HELP Reply with quote
Router/Version: Asus RT-AC5300
File/Kernel: ac5300-webflash.bin / r45863 std (02/28/21)
Kernel: Linux 4.4.258 #2155 SMP Sun Feb 28 09:47:36 +07 2021 armv7l
Previous/Reset: r41459 / no
Mode/Status: Gateway router for CL modem.
Issues/Errors: After loading this firmware all was good for first day, second day I lost 2.4ghz channel, it was gone from the config page completely. Only had 5ghz radios. I reloaded an older config file and they came back. I will continue to monitor this issue. The disappearing 2.4ghz channel used to be an issue with this router but has been less & less of a problem over the last few versions.
Temperatures CPU 62.5 °C / WL0 49.0 °C / WL1 52.5 °C / WL2 52.5 °C

UPDATE: I'm being forced to go back to the last version. I lose all channels of wifi about every 45mins. Here is the only thing I see in the logs

user.err wsdd2[1162]: error: wsdd-http-v4: open_ep: SO_BINDTODEVICE: No such device
user.err wsdd2[1162]: error: llmnr-tcp-v4: open_ep: SO_BINDTODEVICE: No such device


UPDATE 2. went back to v3.0-r45493 std (01/19/21) and problems gone. Staying on 45493 for now.

Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r45863 std (02/28/21)
Kernel: Linux 4.4.258 #2150 SMP Sun Feb 28 09:13:09 +07 2021 armv7l
Mode: Client Bridge
Reset: Nope.
Previous: 02-27-2021-r45859
Status: Working well over the last 24hrs except when ac5300 went down earlier. Temps are a little high also. I will keep monitoring this.

Temperatures: CPU 72.5 °C / WL0 48.5 °C / WL1 51.0 °C


Last edited by 00diabolic on Thu Mar 04, 2021 16:28; edited 3 times in total
hurleyp
DD-WRT User


Joined: 10 Sep 2009
Posts: 309
Location: Ottawa, Ontario, Canada

PostPosted: Thu Mar 04, 2021 0:16    Post subject: Reply with quote
Firmware: v3.0-r45863 std (02/28/21)
Router/Version: Netgear R7000
Kernel: Linux 4.4.258 #2150 SMP Sun Feb 28 09:13:09 +07 2021 armv7l
Previous: v3.0-r45849 std (02/25/21)
Mode/Status: AP wired and wireless, Up and running for 2+ days.
Reset: Soft boot before and after upgrade
Temperatures: CPU 56.9 °C / WL0 44.4 °C / WL1 49.8 °C
Issues/Errors: Nothing significant

Updated via webif. No 'nvram erase' this time, last one was in July 2018 (r36325).

There is a minor issue with the packet count on wl0.1 and "Connected Clients" stuck at zero. The wl0 and wl1 counts seem correct.
Upload and Download speeds are to ISP spec. Nothing unexpected in the syslog.

Current basic R7000 setup (subject to change of course):
- Static WAN IP
- SFE - On
- STP - On
- IPv4 only, both WAN and LAN
- LAN DHCP Enabled
- Wireless: AP, Regulatory Domain = CANADA, wl0 Mixed (ch. 6), wl1 AC/N-Mixed (ch. 149, VHT80), AES
- 1 wireless VLAN on wl0
- SNMP disabled, SSH enabled, Telnet disabled
- Firewall enabled, Log Level high
- Syslog: to local server. klogd: disabled.
- USB support - Off
- No custom scripts
- NO: ttraf, Tor, VNC, Zabbix, VPN, Radius, OpenVPN
- NO: UPnP, DMZ, QoS
- NO: Samba, CIFS, JFFS2, miniDLNA, Entware, Optware

_________________
Netgear R7000: v3.0-r46166 std (03/24/21)
EdgeRouter-X: EdgeOS v2.0.9-hotfix 1
schnee
DD-WRT Novice


Joined: 14 Apr 2019
Posts: 20

PostPosted: Thu Mar 04, 2021 0:29    Post subject: Re: New Build - 02/28/2021 - r45863 Reply with quote
blkt wrote:
[b][WARNING]: .....
Support added for TP-Link Archer C8 v2 and v3.
......


First of all thanks for adding the support for Archer C8 V3

After flashing the router boots fine. However all LEDs tunred off. Is this by desing?

Here is the GPIO setup for the LEDs and buttons:
GPIO 0 -> WIFI LED
GPIO 1 -> Ethernet LED
GPIO 2 -> USB LED
GPIO 3 -> WIFI Button (INPUT!!!!)
GPIO 4 -> Power LED
GPIO 6 -> WPS LED
GPIO 7 -> Reset / WPS Button (INPUT!!!)
GPIO 8 -> WAN LED

I only tried a few things, no other problems seen so far.

Thanks

_________________
---
Schnee
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum