New Build - 01/31/2021 - r45632

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2894

PostPosted: Sun Jan 31, 2021 22:17    Post subject: New Build - 01/31/2021 - r45632 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and device specific recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link does not work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r45592 (GitHub mirror)

Notes:
OpenVPN version 2.5.0 and Guides
WireGuard 1.0.20200908/Tools: Guides, PBR, Kill Switch, Inbound Firewall, Naming of Peers, Status, Key. Thanks BS & egc!
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle since r41813.
In-kernel Samba (ksmbd 3.3.3), default min/max versions changed, with WSD support and ANTFS kernel mode driver.
• Dnsmasq version 2.84 release with r45632 (2.83 at r45563, prerelease since r45036).

Issues:
• There may be remaining issues for Samba.

Important:
• For issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Search SVN tickets & discuss in forum before opening. Before reporting: reset & manually set up, not restore from a backup.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5432
Location: Texas

PostPosted: Sun Jan 31, 2021 23:26    Post subject: Reply with quote
Linksys EA8500 ...main gateway
DD-WRT v3.0-r45632 std (01/31/21)
Linux 4.9.253 #1083 SMP Sun Jan 31 03:04:45 +07 2021 armv7l
GUI upgrade over r45592
NO reset--all good

#

Netgear WNDR3700 V4
DD-WRT v3.0-r45632 std (01/31/21)
Linux 3.18.140-d5 #105101 Sun Jan 31 02:46:15 GMT 2021 mips
GUI upgrade over r45592
all worky good

Cool Laughing
egorenar
DD-WRT Novice


Joined: 26 Dec 2019
Posts: 30

PostPosted: Mon Feb 01, 2021 9:39    Post subject: Reply with quote
WebUI update.
Working fine so far.
CPU clock still 1700 MHz because i had reboots on previous releases.

_________________
Netgear R9000
-------------------------------------------------------------
Firmware: DD-WRT v3.0-r45767 std (02/17/21)
Overclocking Frequency 1700 MHz
-------------------------------------------------------------
2.4 GHz - Disabled
5 GHz VHT80 AC/N-Mixed Channel 100 UU(+6)
ACK Timing 450, Tx Power 30dbm
SU Beamforming ON, MU Beamforming OFF, U-APSD ON
Protection Mode RTS/CTS, RTS Threshold 784
Beacon Interval 300, DTIM Interval 2
-------------------------------------------------------------
External USB3 drive (extra PSU) + Entware
VPN client, dnsmasq, samba(Entware), nginx, znc
yodog
DD-WRT User


Joined: 04 Mar 2017
Posts: 81

PostPosted: Mon Feb 01, 2021 12:31    Post subject: Reply with quote
is the cpu clock supposed to be something else other than 1700mhz for the r9000? Mine says 1700mhz... it always has...


---nvm---

I just updated from the 11/24/2020 brainslayer firmware for the R9000 and yes, now mine says 2000mhz....


New question:

Did my R9000 just get a 300mhz cpu clock OC boost? If so, that is awesome!!
egorenar
DD-WRT Novice


Joined: 26 Dec 2019
Posts: 30

PostPosted: Mon Feb 01, 2021 12:55    Post subject: Reply with quote
yodog wrote:
is the cpu clock supposed to be something else other than 1700mhz for the r9000? Mine says 1700mhz... it always has...


---nvm---

I just updated from the 11/24/2020 brainslayer firmware for the R9000 and yes, now mine says 2000mhz....


New question:

Did my R9000 just get a 300mhz cpu clock OC boost? If so, that is awesome!!


I'm getting sporadic reboots with 2GHz clock. that's why i set it back to 1.7GHz. Apparently i'm the only one with this issue Sad R9000' CPU can be overclocked since a couple of releases.

_________________
Netgear R9000
-------------------------------------------------------------
Firmware: DD-WRT v3.0-r45767 std (02/17/21)
Overclocking Frequency 1700 MHz
-------------------------------------------------------------
2.4 GHz - Disabled
5 GHz VHT80 AC/N-Mixed Channel 100 UU(+6)
ACK Timing 450, Tx Power 30dbm
SU Beamforming ON, MU Beamforming OFF, U-APSD ON
Protection Mode RTS/CTS, RTS Threshold 784
Beacon Interval 300, DTIM Interval 2
-------------------------------------------------------------
External USB3 drive (extra PSU) + Entware
VPN client, dnsmasq, samba(Entware), nginx, znc
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7154
Location: Dresden, Germany

PostPosted: Mon Feb 01, 2021 13:10    Post subject: Reply with quote
i changed back the default clock to 1700 in current internal build since you had problems with it. the increase of the clock was the result of some tests with my unit. i was even able to increase it to 2300. but i do just allow 2000 so far.
_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7154
Location: Dresden, Germany

PostPosted: Mon Feb 01, 2021 13:12    Post subject: Reply with quote
yodog wrote:
is the cpu clock supposed to be something else other than 1700mhz for the r9000? Mine says 1700mhz... it always has...


---nvm---

I just updated from the 11/24/2020 brainslayer firmware for the R9000 and yes, now mine says 2000mhz....


New question:

Did my R9000 just get a 300mhz cpu clock OC boost? If so, that is awesome!!


yes. since 2 - 3 weeks the device was running with 2000 mhz. you can change the clock speed at the administration->management tab. i now reverted the default speed back to 1700. but you still can set manually a higher clock speed

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7758
Location: Netherlands

PostPosted: Mon Feb 01, 2021 13:14    Post subject: Reply with quote
Firmware Version: DD-WRT v3.0-r45493 std (01/19/21)
Kernel Version: Linux 4.9.253 #1085 SMP Sun Jan 31 04:30:36 +07 2021 armv7l

Upgraded from: DD-WRT v3.0-r45493 std (01/19/21)

Reset: No, not this time

Status: Up and running for 4 hours , basic setup as Gateway, static leases, 2,4GHz, 5Ghz, USB storage NAS working, OpenVPN client to Keepsolid with PBR working, OpenVPN Server with site-to-site setup and local DNS working. WireGuard client to Keepsolid working, WireGuard client for site-to-site setup to own server working

Errors: Yes, since we switched to the CT drivers my old Samsung tablet (which is AC/N capable) will not connect with 2.4 Ghz N/G Mixed.
It can connect on Mixed setting.
Before this build (using the CT driver) it connected at B speed and throughput was only a few Mb/s, however there is progress, it now connects at G speed and throughput is about 30 Mb/s.

Kvalo driver let me connect at N speed but with this build it is workable at Mixed setting so much better.

Thanks BS!

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7154
Location: Dresden, Germany

PostPosted: Mon Feb 01, 2021 13:19    Post subject: Reply with quote
egc wrote:
Firmware Version: DD-WRT v3.0-r45493 std (01/19/21)
Kernel Version: Linux 4.9.253 #1085 SMP Sun Jan 31 04:30:36 +07 2021 armv7l

Upgraded from: DD-WRT v3.0-r45493 std (01/19/21)

Reset: No, not this time

Status: Up and running for 4 hours , basic setup as Gateway, static leases, 2,4GHz, 5Ghz, USB storage NAS working, OpenVPN client to Keepsolid with PBR working, OpenVPN Server with site-to-site setup and local DNS working. WireGuard client to Keepsolid working, WireGuard client for site-to-site setup to own server working

Errors: Yes, since we switched to the CT drivers my old Samsung tablet (which is AC/N capable) will not connect with 2.4 Ghz N/G Mixed.
It can connect on Mixed setting.
Before this build (using the CT driver) it connected at B speed and throughput was only a few Mb/s, however there is progress, it now connects at G speed and throughput is about 30 Mb/s.

Kvalo driver let me connect at N speed but with this build it is workable at Mixed setting so much better.

Thanks BS!



ahm this is no ct driver. its still the same ath10k with own modifications and the firmware is not based on CT. but me and ben share our patches and enhancements. for qca988x is a complete own firmware based on the qca mainline sources with modifications i contributed back to CT. (mainly optimizations). for the QCA99XX based firmwares, its based on CT, but has also own enhancements and optimizations i was contributing back to CT. but this all has nothing todo with the driver.
what else. ack timing settings, 5 and 10 mhz support, auto ack timing. thats all i did. and some end devices do indeen require legacy fallback support to connect. in G/Mixed settings you may have one problem. broadcast frames etc are still transmitted with B rates. this is part of the standard. so for such shit clients which cannot handle the situation where no B rates are allowed, you will get a problem with dhcp

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7758
Location: Netherlands

PostPosted: Mon Feb 01, 2021 14:01    Post subject: Reply with quote
BS thanks for the explanation, I will bring this message very gently to my old Samsung tablet Smile
_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
abhijitat
DD-WRT User


Joined: 06 Feb 2020
Posts: 131
Location: Maharashtra, India

PostPosted: Mon Feb 01, 2021 14:34    Post subject: Reply with quote
Router/Version: Netgear R7800
Firmware:
Kernel: Linux 4.9.253 #1085 SMP Sun Jan 31 04:30:36 +07 2021 armv7l
File/Upload: dd-wrt-webupgrade.bin / Upload using SSH
Mode: Gateway/AP
Reset: No
Previous: DD-WRT v3.0-r45592 std (01/28/21)
Setup Using: PPPOE, 2.4 GHz, 5.0 GHz, IPv4, DNSMasq, USB, NTP TimeSync, wireguard
Status: Working Fine, operational 1day 10+ Hr


Thank you BrainSlayer for Wonderful firmware.

Thanks all Guru for your help in forums.
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 428

PostPosted: Mon Feb 01, 2021 14:42    Post subject: Reply with quote
Update method: SSH
Router/Version: Netgear R9000 Nighthawk X10
File/Kernel: DD-WRT v3.0-r45632 std (01/31/21)
Previous/Reset: DD-WRT v3.0-r45592 std (01/28/21) / No
Mode/Status: Gateway / Working Normally / Clock 2000MHz
Issues/Errors: None

So far, looks great. BTW my R9000 had no problems running @2000MHz and I will keep it there. I have lowered the fan temps to 55/50

_________________
Netgear R9000 X10
DD-WRT v3.0-r46979 std (06/21/21)
Gateway, AP, DNSMasq
IPv4 & IPv6 (Prefix Delegation)
CloudFlare, Ignore WAN DNS
QoS Disabled
Vanilla
Static Leases & DHCP
2.4GHz: 10 + 6 (2457 MHz HT40), ACK Timing 3150, WPA2 w/AES
5GHz: 100 + 114 (5500 MHz VHT160), ACK Timing 3160, WPA2 w/AES
Clock 2000MHz
Xfinity 1.2Gbps/42Mbps
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1583
Location: WCentral Indiana USA

PostPosted: Mon Feb 01, 2021 16:03    Post subject: Reply with quote
R7500v2
DD-WRT v3.0-r45632 std (01/31/21)
Linux 4.9.253 #1084 SMP Sun Jan 31 04:21:49 +07 2021 armv7l

wlan0 WDS STA, wlan0 WDS AP VAP, wlan1 AP
Set on_demand, up_threshold 35

CLI upgrade over 45420 without reset

Working fine
Uptime 1 day, 2:18

_________________
STUBBY DoT install guide----Forum Guide Lines (Please read!) --- How to get help the right way----PIA Setup Guide by egc----Before asking for help - upgrade DD-WRT!
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2894

PostPosted: Mon Feb 01, 2021 18:17    Post subject: Reply with quote
BrainSlayer wrote:
i changed back the default clock to 1700 in current internal build since you had problems with it. the increase of the clock was the result of some tests with my unit. i was even able to increase it to 2300. but i do just allow 2000 so far.

A thread was split off from previous build thread r45592, R9000 Rebooting issues.

In short, egorenar can run stable at 2.0 GHz with r45493 but not r45563 onward.
volvy
DD-WRT Novice


Joined: 18 Mar 2017
Posts: 26
Location: USA

PostPosted: Tue Feb 02, 2021 2:19    Post subject: Reply with quote
Linksys EA8500 gateway / AP
DD-WRT v3.0-r45632 std (01/31/21)
Linux 4.9.253 #1083 SMP Sun Jan 31 03:04:45 +07 2021 armv7l
WebUI upgrade over r45592
NO reset

For some reason the WebUI works fine via wired LAN and via 5ghz, but will only partially load via 2.4ghz... is it just me? Same problem with r45592, but worked fine with r44786.

I also run YAMon3.4.7 and it behaves the same as the WebUI. In addition YAMon will not autostart on bootup, I have to go back an run the script manually. pretty sure it didn't autostart in r44786 either, and that was the first version of DD-WRT I've run on the EA8500.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum