QoS rule not working

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
vinibudd
DD-WRT Novice


Joined: 28 Mar 2019
Posts: 25

PostPosted: Thu May 21, 2020 14:11    Post subject: QoS rule not working Reply with quote
I would like to add a schedule to the qos but it doesn't seem to work

My build r43192

Code
Code:
02 11 * * * root /usr/sbin/svqos `nvram get wshaper_uplink` `nvram get wshaper_downlink` `nvram get wan_iface` `nvram get wan_mtu` 0
06 11 * * * root /usr/sbin/svqos stop
Sponsor
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4258
Location: UK, London, just across the river..

PostPosted: Thu May 21, 2020 14:44    Post subject: Reply with quote
ill rather use custom script...and just call custom script from cron...
also...not sure if cron is working as it should...what router do you have?

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 45993 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 46395 BS AP,NAT,AP Isolation,Ad-Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 46166 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 46259 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 46259 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
vinibudd
DD-WRT Novice


Joined: 28 Mar 2019
Posts: 25

PostPosted: Thu May 21, 2020 14:48    Post subject: Reply with quote
tp link wr940nv6
adelca
DD-WRT Novice


Joined: 16 Feb 2021
Posts: 2

PostPosted: Wed Feb 24, 2021 17:50    Post subject: Reply with quote
Hi, I know this thread is a bit old but I figured I would just reply here rather than creating a new one...

I am using dd-wrt 44715 version on a TP_Link_Archer_C7_V5.

According to this QoS wiki: https://wiki.dd-wrt.com/wiki/index.php/Qos#Time_Based_QoS, we can use a script "/usr/sbin/svqos" to enable/disable QoS in a cronjob...

The "script" to enable QoS has me puzzled Razz

Code:
root@DD-WRT:~# cat /usr/sbin/svqos
#!/bin/sh

# start: [up] [down] [wan_if] [mtu] [imq_wan] [aqd] [imq_lan]
# status: status [wan_if] [imq_wan] [imq_lan]
# stop:   stop xx [wan_if] xx   [imq_wan] [imq_lan]

TC=/usr/sbin/tc
if [ "$1" = "status" ]
then
   echo "Interface: $2"; echo
   $TC -s qdisc ls dev $2
   echo
   $TC -s class ls dev $2
   $TC filter show dev $2
   echo; echo "Interface: $3"; echo
   $TC -s qdisc ls dev $3
   echo
   $TC -s class ls dev $3
   $TC filter show dev $3
   if [ "$4" != "0" ]; then
   echo; echo "Interface: $4"; echo
   $TC -s qdisc ls dev $4
   echo
   $TC -s class ls dev $4
   $TC filter show dev $4
   fi
   exit
fi
root@DD-WRT:~#


I am imaging the script has been "disabled" cause it was giving problems? Confused


Last edited by adelca on Thu Feb 25, 2021 9:17; edited 2 times in total
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7471
Location: Netherlands

PostPosted: Wed Feb 24, 2021 18:02    Post subject: Reply with quote
The text in red is implying as much Smile

44715 is not the latest and greatest build (not saying you should upgrade)

To get the best out of DDWRT and the forum read the forum guidelines with helpful pointers:
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
adelca
DD-WRT Novice


Joined: 16 Feb 2021
Posts: 2

PostPosted: Wed Feb 24, 2021 19:49    Post subject: Reply with quote
rrrrrright... and here I thought that the text in red was referring to start/stopservice wshaper .. DUH! Embarassed

My original plan, when I was feeling brave, was to install the latest dd-wrt build but then I saw a post from msoengineer suggesting to use 44715 for my type of router: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327969&&highlight=44715
So I pooped my pants and went for it... Mr. Green

Ok, I managed to install dd-wrt on my tplink, tweaked WIFI settings, install YAMON, found a bandwidth hungry hippo and used QoS on the web GUI successfully to limit max download/upload based on MAC address... all works great so far (not even 1 week since I am on dd-wrt)... my last little project is to figure out how to schedule QoS and then donate to dd-wrt pals and Al (Yamon) Very Happy

PS: so far I have tried servicestop wshaper(to disable QoS) and servicestart wshaper (to enable QoS) and it is working (I had to configure and enable QoS on the web GUI previously for this to work), next is to schedule it with a cronjob or something similar so my QoS kicks in during the night and off during the day.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum