New Build - 01/19/2021 - r45493

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2791

PostPosted: Tue Jan 19, 2021 20:23    Post subject: New Build - 01/19/2021 - r45493 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and specific device recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link does not work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r45454 (GitHub mirror)

Notes:
OpenVPN Version 2.5.0 and Guides
WireGuard 1.0.20200908/Tools: Guides, PBR, Kill Switch, Inbound Firewall, Naming of Peers, Status, Key. Thanks BS & egc!
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle since r41813.
In-kernel Samba was implemented over the past year and default min/max versions changed, with WSD support.
Experimental build option for Broadcom 8MB+ K2.x devices (limited currently): broadcom_K3X_mipsel32r1
• Broadcom MIPS devices are now on kernel 4.4. N66U/AC66U half memory is fully resolved.
• DHCP and DNS help (English) updated in 43083; ref: #7091
• WAN lease time approaching zero bug on WRT54* devices fixed in 43191; ref: #6456
• Images for WNR3500Lv2 (BRCM NAND flash crash bug) fixed in 43219 (43217); ref: #7098

Issues, observations, and/or workarounds reported:
DNScrypt 1.95 can still be used in the GUI but v2 (not compatible) requires Golang and thus Entware. 6246
WDS does not work on Broadcom ARM devices (only MIPS<->MIPS) & bridge modes on k4.4 devices may sometimes work in some configurations in certain builds but are not supported by the bcmdhd driver. Use client or repeater instead.
VAPs not working at boot fixed for unbridged VAPs with r40564:40566. Workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas (there are a few alternatives, search).
If start-up scripts do not work from USB add a delay (e.g. wait script or 'sleep 25').
For Broadcom ARM devices missing 5GHz channels, via telnet/ssh: 'nvram set brcm_unlock=1' 'nvram commit' 'nvram reboot'

Important:
• For issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Search SVN tickets & discuss in forum before opening. Before reporting: reset & manually set up, not restore from a backup.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 469

PostPosted: Tue Jan 19, 2021 23:56    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r45493 std (01/19/21)
Kernel: Linux 4.4.252 #1865 SMP Tue Jan 19 11:00:40 +07 2021 armv7l
Previous: r45454
Mode/Status: Gateway / working
Issues/Errors: Working well so far.

Uptime: 1hr 12mins
Upgrade: via web UI, no issues
Reset: no
Temperatures: CPU 68.0 °C / WL0 46.7 °C / WL1 52.7 °C
itwontbewe
DD-WRT User


Joined: 29 Sep 2020
Posts: 122

PostPosted: Wed Jan 20, 2021 1:12    Post subject: Reply with quote
Router: Netgear R7000P
Kernel: Linux 4.4.252 #1871 SMP Tue Jan 19 11:49:40 +07 2021 armv7l
Previous/Reset: r45454 / no
Mode/Status: Gateway AP Unbound JFFS2 / ok
Issues: running well
thanks BrainSlayer and dd-wrt community
TurboQAM option is visible again


Last edited by itwontbewe on Fri Jan 29, 2021 20:54; edited 2 times in total
phuklok1
DD-WRT Novice


Joined: 21 May 2020
Posts: 7

PostPosted: Wed Jan 20, 2021 6:35    Post subject: Reply with quote
Router/Version: Asus RT-1900P
Firmware: DD-WRT v3.0-r45493 std (01/19/21)
Mode/Status: Gateway AP, Smb server
Issues/Errors: OK -- thank you!
Uptime: 3 hr 4 min
Upgrade: via cli, no issues
Reset: no
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7449
Location: Netherlands

PostPosted: Wed Jan 20, 2021 9:18    Post subject: Reply with quote
Router Model: Linksys E2000 (converted N320)

Firmware Version: DD-WRT v3.0-r45493 mega (01/19/21)
Kernel Version: Linux 4.4.252 #6329 Tue Jan 19 18:48:51 +07 2021 mips

Upgraded: from DD-WRT v3.0-r45130 mega (12/27/20)
Reset: No, not this time

Status: Up and running for 8 hours, basic setup as Gateway, static leases, OpenVPN client (tun) (on Keepsolid) up and running, VPN download speed 5-6 Mb/s, Wifi 2,4GHz working.
OpenVPN server working, WireGuard client working ( speed around 18 Mb/s )

Errors: No, Seems like a good build

Big Thanks to the devs!!

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7449
Location: Netherlands

PostPosted: Wed Jan 20, 2021 12:04    Post subject: Reply with quote
Router Model: Netgear R6400v2, board_id: U12H332T30_NETGEAR

Firmware Version: DD-WRT v3.0-r45493 Community Build (01/20/21)
Kernel Version: Linux 4.4.252 #1 SMP Wed Jan 20 11:19:43 CET 2021 armv7l

Upgraded from: DD-WRT v3.0-r45454 Community Build
Reset: No not this time

Status: Up and running for 2 hours, basic setup as Gateway, static leases, OpenVPN client with Policy Based Routing up and running, 2,4GHz and 5Ghz with excellent range and speed, USB storage NAS working, OpenVPN server working, WireGuard server working with 8 clients (phones , windows and two other routers for site-to-site setup).

Errors: None

Seems like a good build

Thanks to the devs!

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
saphirely
DD-WRT Novice


Joined: 13 Dec 2020
Posts: 28

PostPosted: Wed Jan 20, 2021 12:57    Post subject: Reply with quote
Router/Version: Netgear R6250 V1
Firmware: DD-WRT v3.0-r45493 std (01/19/21)
Linux 4.4.252 #1865 SMP Tue Jan 19 11:00:40 +07 2021 armv7l
Previous: r45420

Firmware upgrade: Twice
(1st failure with body blinking NETGEAR words, 2nd flash succeed)

Mode/Status: Gateway / working
Issues/Errors: Working well so far.
Wifi 5GHZ support with VHT80 again.

CPU load:0.03 0.02 0.00
WAN IP : CANADA
Dwarden
DD-WRT Novice


Joined: 26 Jan 2009
Posts: 16

PostPosted: Wed Jan 20, 2021 13:19    Post subject: WRT54GL Reply with quote
Router/Version: Linksys WRT54GL 1.1
File/Kernel: 45493, broadcom , dd-wrt.v24_std_special_generic.bin
Previous/Reset: 44715 , no reset
Mode/Status: LAN and AP, router
Issues/Errors:
lost access to GUI web administration and SSH
device isn't pinging back at any IP (pre-flash setting nor default)

yet, it somehow works 'silently' (aka not dead yet)
power LED and WAN activate,
pre-flash AP/LAN settings works (wifi password),
AP/LAN routing works
LAN switching works immediately

note: so far i was unable to figure if i can recover it w/o reset


Last edited by Dwarden on Wed Jan 20, 2021 13:25; edited 2 times in total
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7449
Location: Netherlands

PostPosted: Wed Jan 20, 2021 13:21    Post subject: Reply with quote
Try with a non Chromium based web browser like good old Internet Explorer.

FireFox also can work, be sure to reset the webbrowsers cache and use in private browsing

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Dwarden
DD-WRT Novice


Joined: 26 Jan 2009
Posts: 16

PostPosted: Wed Jan 20, 2021 13:22    Post subject: Reply with quote
posted by mistake about Atheros hardware, moving to correct thread
https://forum.dd-wrt.com/phpBB2/posting_sec.php?mode=quote&p=1233174


Last edited by Dwarden on Fri Mar 26, 2021 10:55; edited 4 times in total
Dwarden
DD-WRT Novice


Joined: 26 Jan 2009
Posts: 16

PostPosted: Wed Jan 20, 2021 14:52    Post subject: Reply with quote
egc wrote:
Try with a non Chromium based web browser like good old Internet Explorer.

FireFox also can work, be sure to reset the webbrowsers cache and use in private browsing


i guess it's dead-end the device doesn't appear on ARP either

seems like the update reset the static IP for the router
(works as transparent, w/o IP)
MysticGold04
DD-WRT User


Joined: 20 Apr 2018
Posts: 97
Location: Somewhere remote

PostPosted: Wed Jan 20, 2021 16:38    Post subject: Reply with quote
I have the same router (WRT54GL 1.1) and it appears bricked as well - Flashing power light is all that happens. 30/30/30 no response. you are right, the switch appears to still work, but it's dead as a router. Since this is a spare to me, I might try to recover by shorting it again - it fixed it last time, and I was able to tftp Linksys firmware to it, and then flash DDWRT.
_________________
ASUS RT-AC68U (R/AP) r46220, testing
ASUS RT-AC68U r46220 Bridge x3
WRT54GL 1.1 FreshTomato 2021.1 (VPN/Work)
Linksys E1200v2 r43266 (sleeping)
twindragon6
DD-WRT User


Joined: 29 Jun 2008
Posts: 176

PostPosted: Wed Jan 20, 2021 16:39    Post subject: Netgear Nighthawk R7000 Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r45493 std (01/19/21)
Kernel: Linux 4.4.252 #1865 SMP Tue Jan 19 11:00:40 +07 2021 armv7l
Mode: Gateway
Reset: No
Previous: 01-13-2021-r45420
Status: Working, so far. See attached logs.



Logs.txt
 Description:
Logs

Download
 Filename:  Logs.txt
 Filesize:  58.27 KB
 Downloaded:  49 Time(s)

Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4243
Location: UK, London, just across the river..

PostPosted: Wed Jan 20, 2021 19:18    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r45493 std (01/19/21)
Kernel: Linux 4.4.252 #1865 SMP Tue Jan 19 11:00:40 +07 2021 armv7l

Update: CLI 45454 > 45493
Reset: no
Status: Operational 3h +
Errors: Working well so far.

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 45993 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 46329 BS AP,NAT,AP Isolation,Ad-Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 46166 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 46259 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 46259 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
00diabolic
DD-WRT User


Joined: 17 Aug 2011
Posts: 59

PostPosted: Wed Jan 20, 2021 21:36    Post subject: Reply with quote
Router/Version: Asus RT-AC5300
Firmware: DD-WRT v3.0-r45493 std (01/19/21)
Kernal: Linux 4.4.252 #1870 SMP Tue Jan 19 11:41:44 +07 2021 armv7l
Previous: r45454
Mode/Status: Gateway / working
Issues/Errors: Working well so far.

Uptime: 12mins
Upgrade: via web UI, no issues
Reset: no
Temperatures: CPU 60.2 °C / WL0 48.5 °C / WL1 46.0 °C / WL2 52.5 °C
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum