New Build - 11-15-2020-r44809

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2, 3  Next
Author Message
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8034
Location: Texas, USA

PostPosted: Sun Nov 15, 2020 12:30    Post subject: New Build - 11-15-2020-r44809 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and specific device recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link doesn't work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r44772 (GitHub mirror)

Notes:
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle. 6920, 6928, 6931, 6932 (WIP 7040)
In-kernel Samba has been implemented this year and default min/max versions have changed 6954, 6957, with WSD support.
• VAP issue is fixed! For any Wireless Mode, create a VAP and both ath0/ath1 should now function properly.
• Local DNS option removed from Services->DNSMasq in changesets 43080 and 43081; ref: #7092
• DHCP and DNS help (English) updated in 43083; ref: #7091
• WireGuard 1.0.20200908 & Tools: PBR, Kill Switch, Inbound Firewall, Naming of Peers, Status, Key, Guides. Thanks BS & egc!
• OpenVPN Version 2.5.0

Issues:
• There may be remaining issues for Samba (for example NTFS), with frequent updates.

Important:
• If reporting issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, serial output, strace, tcpdump etc.
• For firewall NAT or WAN issues provide 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and the /tmp/.ipt file.
• Search existing SVN tickets before opening a new one. Before reporting, reset and manually setup (no nvram backup).
• Be sure to include operating and wireless modes (Gateway, AP, CB, etc.) along with relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
Sponsor
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5398
Location: Texas

PostPosted: Sun Nov 15, 2020 13:25    Post subject: Reply with quote
Netgear WNDR3700 V4
DD-WRT v3.0-r44809 std (11/15/20)
Linux 3.18.140-d5 #96645 Sun Nov 15 06:01:41 +07 2020 mips
GUI install over r44772
used as switch / OVPN server / samba share ext4 --- all is very good Very Happy
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4175
Location: UK, London, just across the river..

PostPosted: Sun Nov 15, 2020 14:22    Post subject: Reply with quote
Router ModelNetgear R7800
Firmware VersionDD-WRT v3.0-r44809 std (11/15/20)
Kernel VersionLinux 4.9.242 #813 SMP Sun Nov 15 02:10:04 +07 2020 armv7l

update: CLI
reset: NO
status: Operational 1h+
errors:

eureka... its working!

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 45849 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 45849 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 45849 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 45859 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 45859 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
ho1Aetoo
DD-WRT Guru


Joined: 19 Feb 2019
Posts: 504

PostPosted: Sun Nov 15, 2020 14:27    Post subject: Reply with quote
Netgear R7800
DD-WRT v3.0-r44809 std (11/15/20)
Linux 4.9.242 #813 SMP Sun Nov 15 02:10:04 +07 2020

something does not work the WLAN throughput is significantly lower

v3.0-r44719

Client:

QCA9984 = 774 Mbit
WCN3990 = 570 Mbit
intel8265 = 524 Mbit

r44809

Client:

QCA9984 = 557 Mbit
WCN3990 = 456 Mbit
intel8265 = 268 Mbit

Channel 116+UU VHT80 Germany

iperf3

DD-WRT v3.0-r44809 std (c) 2020 NewMedia-NET GmbH
Release: 11/15/20
Board: Netgear R7800
warning: this system does not seem to support IPv6 - trying IPv4
-----------------------------------------------------------

Modes:
1 = Download
2 = Upload

Choose Mode: 1

Time in Seconds 1-86400 (24h): 60
Number of parallel streams: 8

starting iperf3 Client on Network controller: Intel Wireless 8265:


Edit:can not be that the intel card is suddenly only 240Mbit fast

that is half as fast as before

Upload is normal on all clients


Last edited by ho1Aetoo on Sun Nov 15, 2020 15:59; edited 1 time in total
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 355

PostPosted: Sun Nov 15, 2020 15:54    Post subject: Reply with quote
Update method: SSH
Router/Version: Netgear Nighthawk X10
File/Kernel: DD-WRT v3.0-r44809 std (11/15/20)
Previous/Reset: DD-WRT v3.0-r44772 std (11/11/20)
Mode/Status: Gateway
Issues/Errors: None

_________________
Netgear R9000 X10
DD-WRT v3.0-r45863 std (02/28/21)
Gateway, AP, DNSMasq
IPv4 & IPv6 (Prefix Delegation)
CloudFlare
QoS: HFSC w/CAKE & ACK, SYN, FIN & RST
Static Leases & DHCP
2.4GHz: 10 + 6 (2457 MHz HT40), ACK Timing 450
5GHz: 100 + 106 (5500 MHz VHT80), ACK Timing 450
Clock 2000MHz
Xfinity 1Gbps(max)/42Mbps
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4175
Location: UK, London, just across the river..

PostPosted: Sun Nov 15, 2020 17:51    Post subject: Reply with quote
ho1Aetoo...
i've read SVN earlier and just noticed the same...
i think BS screwed something with WiFi functions related to rates its on SVN...will be sorted in next firmware i guess

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 45849 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 45849 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 45849 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 45859 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 45859 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
ho1Aetoo
DD-WRT Guru


Joined: 19 Feb 2019
Posts: 504

PostPosted: Sun Nov 15, 2020 18:13    Post subject: Reply with quote
maybe there is something broken in the last 100 commits

it is very nice that so much is developed but for third quite difficult to trace
msoengineer
DD-WRT Guru


Joined: 21 Jan 2017
Posts: 1677
Location: Illinois Moderator

PostPosted: Sun Nov 15, 2020 18:26    Post subject: Reply with quote
ho1Aetoo wrote:
maybe there is something broken in the last 100 commits

it is very nice that so much is developed but for third quite difficult to trace


I assume windows is reporting the proper MCS rate at 866?

_________________
FORUM RULES

TIPS/TRICKS: Best QCA Wifi Settings | Latency tricks | QoS Port priority | NEVER USE MU-MIMO |
Why to NOT use MU-MIMO | Max Wifi Pwr by Country | Linux Wifi Pwr | AC MCS & AX MCS | QCA 5Ghz chnls to use | WIFI Freq WIKI | TFTP R7800 | Don't buy AX | IPERF3 How-To

[R9000]45778 nightly (Main Router)
[EA8500]43192 & 45493 (2xOffsite)
[R7800]napping
[WDR3600]BS 44715 (Offsite)
[A7v5]BS 43038 (Offsite+spare napping)
ho1Aetoo
DD-WRT Guru


Joined: 19 Feb 2019
Posts: 504

PostPosted: Sun Nov 15, 2020 18:33    Post subject: Reply with quote
I can't tell you because I have no windows installed

I tested the QCA9984 and Intel8265 with Linux and the wireless backport driver 5.8.1 (not mainline, but relatively up-to-date)

and the WCN3990 with Android 11

MCS rates look normal


Intel 8265 >

Code:
   inactive time:   160 ms
   rx bytes:   455953194
   rx packets:   147961
   tx bytes:   2372149
   tx packets:   24651
   tx retries:   61
   tx failed:   0
   beacon loss:   4
   beacon rx:   366
   rx drop misc:   32
   signal:     -47 [-47, -47] dBm
   signal avg:   -47 [-47, -47] dBm
   beacon signal avg:   -49 dBm
   tx bitrate:   866.7 MBit/s VHT-MCS 9 80MHz short GI VHT-NSS 2
   tx duration:   0 us
   rx bitrate:   866.7 MBit/s VHT-MCS 9 80MHz short GI VHT-NSS 2
   rx duration:   0 us
   authorized:   yes
   authenticated:   yes
   associated:   yes
   preamble:   long
   WMM/WME:   yes
   MFP:      no
   TDLS peer:   no
   DTIM period:   2
   beacon interval:113
   short preamble:   yes
   short slot time:yes
   connected time:   40 seconds
   associated at [boottime]:   18180.009s
   associated at:   1605465041968 ms
   current time:   1605465081142 ms
ho1Aetoo
DD-WRT Guru


Joined: 19 Feb 2019
Posts: 504

PostPosted: Sun Nov 15, 2020 19:24    Post subject: Reply with quote
@msoengineer

if i remember correctly then you also have an intel card?

if you have time it would be nice if you would do a little test

then you can confirm if the windows driver has the same problem
labrok
DD-WRT User


Joined: 11 Feb 2011
Posts: 280
Location: Greece

PostPosted: Sun Nov 15, 2020 23:21    Post subject: Linksys EA-8500 Reply with quote
flashed after reset to factory from previous problematic r43772 , this one has the same problem, router every 15-20 min is rebooting, no reason to explain it, just reboots out of the blue with CPU remain to 0%,same problem in open wrt, random reboots, only on factory it works stable as rock! i dont want to go to factory firmaware, is there any way to fix it? someone with the same router, using it with samba enabled and as gateway? i know that many have the same router but still nobody have this issue? Also web ui seems extreme laggy, its like trying to open a page with dial up connection!!
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8034
Location: Texas, USA

PostPosted: Sun Nov 15, 2020 23:56    Post subject: Reply with quote
@labrok: For those of us who are not elephants, please state what router this is on. It's entirely impossible to just know these things unless you follow the report format...
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
labrok
DD-WRT User


Joined: 11 Feb 2011
Posts: 280
Location: Greece

PostPosted: Sun Nov 15, 2020 23:57    Post subject: Reply with quote
kernel-panic69 wrote:
@labrok: For those of us who are not elephants, please state what router this is on. It's entirely impossible to just know these things unless you follow the report format...


check the subject line in my post, its Linksys EA-8500
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8034
Location: Texas, USA

PostPosted: Mon Nov 16, 2020 0:20    Post subject: Reply with quote
labrok wrote:
kernel-panic69 wrote:
@labrok: For those of us who are not elephants, please state what router this is on. It's entirely impossible to just know these things unless you follow the report format...


check the subject line in my post, its Linksys EA-8500


Gee, I totally missed that. Probably because I don't look at subject lines, and because I'm looking for people to follow the report format in the OP Laughing Touchė.

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
labrok
DD-WRT User


Joined: 11 Feb 2011
Posts: 280
Location: Greece

PostPosted: Mon Nov 16, 2020 0:45    Post subject: Reply with quote
kernel-panic69 wrote:
labrok wrote:
kernel-panic69 wrote:
@labrok: For those of us who are not elephants, please state what router this is on. It's entirely impossible to just know these things unless you follow the report format...


check the subject line in my post, its Linksys EA-8500


Gee, I totally missed that. Probably because I don't look at subject lines, and because I'm looking for people to follow the report format in the OP Laughing Touchė.

to be honest i wrote it in hurry because router is losing connection all the time and sometimes its not coming back from the reboot, after some research i found that it might be related to power issues or drops which strangely affect only the Router and not the server which is connected on it and uses the same power source, which doesnt seems to reboot will check it 1-2 more days !
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum