New Build - 08/28/2020 - r44251

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 1784

PostPosted: Fri Aug 28, 2020 5:47    Post subject: New Build - 08/28/2020 - r44251 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and specific device recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link doesn't work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r44236 (GitHub mirror)

Notes:
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle. 6920, 6928, 6931, 6932 (WIP 7040)
In-kernel Samba has been implemented this year and default min/max versions have changed 6954, 6957, with WSD support.
• VAP issue is fixed! For any Wireless Mode, create a VAP and both ath0/ath1 should now function properly.
• Local DNS option removed from Services->DNSMasq in changesets 43080 and 43081; ref: #7092
• DHCP and DNS help (English) updated in 43083; ref: #7091
WireGuard 1.0.20200712: PBR, Kill Switch, Inbound Firewall, Naming of Peers, Status, Key, Guides. Thanks egc!

Issues:
• There may be remaining issues for Samba (for example NTFS), with frequent updates.

Important:
• If reporting issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, serial output, strace, tcpdump etc.
• For firewall NAT or WAN issues provide 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and the /tmp/.ipt file.
• Search existing SVN tickets before opening a new one. Before reporting, reset and manually setup (no nvram backup).
• Be sure to include operating and wireless modes (Gateway, AP, CB, etc.) along with relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 288

PostPosted: Fri Aug 28, 2020 9:27    Post subject: Reply with quote
Router/Version: Linksys WRT1900ACS v2
File: ddwrt-linksys-wrt1900acsv2-webflash.bin
Firmware: DD-WRT v3.0-r44251 std (08/27/20) (prev. DD-WRT v3.0-r44236 std (08/22/20))
Kernel: Linux 4.9.233 #2051 SMP Thu Aug 27 08:18:16 +03 2020 armv7l
Mode: Gateway, 2.4G and 5G wifi, Wireguard for external access, WAN to 4G, Keep Alive reboot 6:02 in the morning
Reset: No
Status: 46m up, load average 0.00, 0.00, 0.00, Temperatures CPU 74.1 °C / WL0 46.6 °C / WL1 48.4 °C, no problems.

Everything is working, Ty BS and everyone else involved!
Armin_KH
DD-WRT Novice


Joined: 31 Dec 2019
Posts: 7

PostPosted: Fri Aug 28, 2020 14:34    Post subject: Reply with quote
Router: Linksys WRT1900ACS v2
Firmware: Upgraded from 44213 to 44251
Mode: AP,
2.4GHz wpa2 CCMP-128 N only 40MHz auto channel,
5GHz wpa2 CCMP-128 AC only 80MHz auto channel,
openvpn on VAP 5GHz
Reset: No
status: 1h up,
2.4GHz and 5GHz have connectivity issues same as previous build (44236).
devices can connect to 2.4 but it's super slow and unresponsive
for 5GHz, devices can connect to it right after boot but it became unresponsive after few seconds also devices can't reconnect.
restarted the router and results were the same.
Justanotherbrokenrouter
DD-WRT User


Joined: 27 Apr 2019
Posts: 104

PostPosted: Fri Aug 28, 2020 14:45    Post subject: Reply with quote
👆 How does this happen above! 👆
One says its the best build ever, but the others says connectivity is horrible.

R44048 is by far the best build, and if this build can't be used for a template for other builds then I'm done updating, or using DD-WRT on wrt3200acm.


Last edited by Justanotherbrokenrouter on Fri Aug 28, 2020 16:27; edited 1 time in total
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 288

PostPosted: Fri Aug 28, 2020 15:14    Post subject: Reply with quote
No idea, why it does not work on your side.
Can stream, surf the www, transfer files without problem! Twitch.tv and amazon prime are working.
Speedtest.net result does not indicate problems.
Currently ~20MBit wired available and reach ~20Mbit via wifi.

Fired up syncthing to transfer a backup tablet --> NAS: a few hundred MBit/s.

Everything tested ~3-10m away from router, a few minutes ago.

Currently five devices in 2.4GHz:
Mobile I Xiaomi MI A2 Lite
Mobile II Moto Razr XT910 (only to remote control Coreelec).
HP Notebook 635 (?) the one with E450 chipset using ubuntu 20.04LTS.
A Raspberry 3B+ onboard Wifi.

Two devices in 5GHz:
Sony Z3 tablet compact
Huawei Mediapad M5 8".

And a Nintendo Switch, currently no idea which network it is using, "somewhere" at my place, lost it a few days ago.

Settings of my router:
jlenk
DD-WRT Novice


Joined: 19 Jun 2020
Posts: 3

PostPosted: Fri Aug 28, 2020 17:33    Post subject: Reply with quote
I have a wrt1900ac v1 that was also upgraded from 44213 to this build (44251) and this build(and the one immediately before it) does not work correctly with WIFI(wired works fine). Sometimes it connects for a very short time with poor bandwidth and then gets disconnected. After build 44213 there was a radio firmware update which seems to be the cause of this. I restored back to defaults and reconfigured but that did not make a difference either. Im happy to test anything if that would help find the problem. Otherwise I'm stuck on 44213 which has been working fine.

Thanks
setinstone31
DD-WRT Novice


Joined: 10 Jul 2020
Posts: 5

PostPosted: Fri Aug 28, 2020 19:54    Post subject: Reply with quote
Router: WRT32X

Firmware: Upgraded from 44191 to r44251

Mode: dhcp,2.4GHz Disabled, 5GHz Disabled, QOS, Cubic TCP

Reset: No

status: no issues observed

upgraded fast and seems pretty snappy thanks for this.
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 1784

PostPosted: Fri Aug 28, 2020 21:36    Post subject: Reply with quote
Justanotherbrokenrouter wrote:
👆 How does this happen above! 👆
One says its the best build ever, but the others says connectivity is horrible.

R44048 is by far the best build, and if this build can't be used for a template for other builds then I'm done updating, or using DD-WRT on wrt3200acm.
People have different configuration habits, pebcak, different computers, wireless adapters, drivers, client devices, network topology, ISP requirements you name it. One person's heaven can be another's hell.

I've said for a long time this is a great Ethernet router, but Marvell is done (sold assets to NXP) so Wi-Fi drivers will likely not improve much and if you can rule out configuration issues it's best to disable all internal radios to use an external access point such as EX7300v2 (or go full replacement R7800, R9000 or a cheap used EA8500).

Shortly after r44048 there have been many changes, maybe still a work in progress, ranging from iptables NAT firewall, DHCP, driver changelogs and more so hang back or hang on tight.
Armin_KH wrote:
2.4GHz wpa2 CCMP-128 N only 40MHz auto channel,
5GHz wpa2 CCMP-128 AC only 80MHz auto channel,
I overlooked this. He's using auto and being impatient, rebooting and not allowing the channel process to finish, so pebcak.

Last edited by blkt on Sat Aug 29, 2020 2:37; edited 2 times in total
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 288

PostPosted: Fri Aug 28, 2020 22:30    Post subject: Reply with quote
Armin_KH wrote:

2.4GHz wpa2 CCMP-128 N only 40MHz auto channel,
5GHz wpa2 CCMP-128 AC only 80MHz auto channel,


Please try if setting your wifi from "auto channel" to a "static one of your choice" does solve this.
Lake75
DD-WRT Novice


Joined: 27 Aug 2020
Posts: 1

PostPosted: Fri Aug 28, 2020 23:53    Post subject: Reply with quote
Router/Version: Linksys WRT1900AC v2
File/Kernel: ddwrt-linksys-wrt1900acv2-webflash.bin
Previous/Reset: 44048. No reset
Mode/Status: Gateway, 2.4G N/G, 5G AC-only
Issues/Errors: No Wifi connections

At least for me, 44187 (8/13/2020) is the first build in many years that has finally fixed the ntp issue (i.e. being able to resolve/ping domain names and not relying on ip addresses anymore). But 44187 is also the version that has killed WiFi for me. I've tested every build since then including today's 44251, but they all have the same issue: Being unable to connect or stay connected to (mostly) 5G, as have been reported by many other people. I had to revert back to 44048 again.
MrHuncho
DD-WRT Novice


Joined: 05 Mar 2019
Posts: 12

PostPosted: Sat Aug 29, 2020 0:50    Post subject: Reply with quote
Router: WRT1200AC

Firmware: Upgraded from r44048 to r44251

Mode: dhcp,Openvpn,USB,JFFS2, DNSSEC ,2.4GHz & 5GHz enabled, , Vegas

Reset: Yes

status: Not working

Wifi stopped functioning randomly. Also I can't access router not via ssh nor web GUI, I had to turn the router on\off to get access for few minutes just to downgrade.

I recommend sticking to r44048 if you use this model.
Argenis
DD-WRT User


Joined: 18 Feb 2019
Posts: 81

PostPosted: Sat Aug 29, 2020 2:20    Post subject: Reply with quote
Upgraded 3200ACM from previous version, no issues or problems whatsoever.

Running like a brand new router. Will update if any issues.

_________________
Router: Linksys WRT3200ACM
88W8964 802.11ac ath0 Mode AP VHT80 80MHz Mixed Mode Channel and Extension Auto
88W8964 802.11ac ath1 Mode AP Dynamic 20/40 MHz Mixed Mode Channel and Extension Auto
SD8887 802.11ac disabled but visible on GUI and CLI
OpenVPN enabled, client mode
Port forwarding disabled
DHCP server mode, enabled
DNSCrypt and Validate DNS Replies
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 235
Location: FL

PostPosted: Sat Aug 29, 2020 14:55    Post subject: Reply with quote
Mine is working pretty good since the release... my config is pretty basic as well
_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2020
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &

WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel follows AP, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 40mhz channel width, channel 100+upper, WPA2-CCMP-128.
Misc Info: WPA2 Personal: "CCMP-128 (AES)" Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
Armin_KH
DD-WRT Novice


Joined: 31 Dec 2019
Posts: 7

PostPosted: Sat Aug 29, 2020 16:48    Post subject: Reply with quote
Zyxx wrote:


Please try if setting your WiFi from "auto channel" to a "static one of your choice" does solve this.


tried it and no luck I've set my settings same as you and results were the same still.
also I've disabled the password for both interfaces and that didn't helped either.

syslog 2.4GHz
Code:
Aug 29 21:06:52 Linksys WRT1900ACS daemon.info hostapd: ath1: STA 3c:2e:ff:46:f9:e6 MLME: auth request, signal -18 (Accepted)
Aug 29 21:06:52 Linksys WRT1900ACS daemon.info hostapd: ath1: STA 3c:2e:ff:46:f9:e6 IEEE 802.11: authenticated
Aug 29 21:06:52 Linksys WRT1900ACS daemon.info hostapd: ath1: STA 3c:2e:ff:46:f9:e6 MLME: assoc request, signal -25 (Accepted)
Aug 29 21:06:52 Linksys WRT1900ACS daemon.info hostapd: ath1: STA 3c:2e:ff:46:f9:e6 IEEE 802.11: associated (aid 1)
Aug 29 21:06:52 Linksys WRT1900ACS daemon.info hostapd: ath1: STA 3c:2e:ff:46:f9:e6 RADIUS: starting accounting session CCD5A4DF1038E929
Aug 29 21:06:52 Linksys WRT1900ACS daemon.info hostapd: ath1: STA 3c:2e:ff:46:f9:e6 WPA: pairwise key handshake completed (RSN)
Aug 29 21:06:55 Linksys WRT1900ACS daemon.info dnsmasq-dhcp[1945]: DHCPDISCOVER(br0) 3c:2e:ff:46:f9:e6
Aug 29 21:06:55 Linksys WRT1900ACS daemon.info dnsmasq-dhcp[1945]: DHCPOFFER(br0) 192.168.1.82 3c:2e:ff:46:f9:e6
Aug 29 21:06:55 Linksys WRT1900ACS daemon.info dnsmasq-dhcp[1945]: DHCPDISCOVER(br0) 3c:2e:ff:46:f9:e6
Aug 29 21:06:55 Linksys WRT1900ACS daemon.info dnsmasq-dhcp[1945]: DHCPOFFER(br0) 192.168.1.82 3c:2e:ff:46:f9:e6
Aug 29 21:06:56 Linksys WRT1900ACS daemon.info dnsmasq-dhcp[1945]: DHCPREQUEST(br0) 192.168.1.82 3c:2e:ff:46:f9:e6
Aug 29 21:06:56 Linksys WRT1900ACS daemon.info dnsmasq-dhcp[1945]: DHCPACK(br0) 192.168.1.82 3c:2e:ff:46:f9:e6 iPhone
Aug 29 21:08:01 Linksys WRT1900ACS daemon.info hostapd: ath0.1: STA 3c:2e:ff:46:f9:e6 IEEE 802.11: disassociated due to inactivity
Aug 29 21:08:05 Linksys WRT1900ACS daemon.info hostapd: ath0.1: STA 3c:2e:ff:46:f9:e6 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Aug 29 21:12:29 Linksys WRT1900ACS daemon.info hostapd: ath1: STA 3c:2e:ff:46:f9:e6 IEEE 802.11: disassociated due to inactivity
Aug 29 21:12:33 Linksys WRT1900ACS daemon.info hostapd: ath1: STA 3c:2e:ff:46:f9:e6 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)


5GHz
Code:
Aug 29 20:57:38 Linksys WRT1900ACS daemon.info hostapd: ath0: STA 84:c0:ef:1a:53:06 MLME: auth request, signal -59 (Accepted)
Aug 29 20:57:38 Linksys WRT1900ACS daemon.info hostapd: ath0: STA 84:c0:ef:1a:53:06 IEEE 802.11: authenticated
Aug 29 20:57:38 Linksys WRT1900ACS daemon.info hostapd: ath0: STA 84:c0:ef:1a:53:06 MLME: assoc request, signal -59 (Accepted)
Aug 29 20:57:38 Linksys WRT1900ACS daemon.info hostapd: ath0: STA 84:c0:ef:1a:53:06 IEEE 802.11: associated (aid 2)
Aug 29 20:57:47 Linksys WRT1900ACS daemon.info hostapd: ath0: STA 84:c0:ef:1a:53:06 IEEE 802.11: deauthenticated due to local deauth request
Aug 29 20:57:54 Linksys WRT1900ACS daemon.info hostapd: ath0: STA 3c:2e:ff:46:f9:e6 IEEE 802.11: disassociated
Aug 29 20:57:55 Linksys WRT1900ACS daemon.info hostapd: ath0: STA 3c:2e:ff:46:f9:e6 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
littlebear
DD-WRT Novice


Joined: 13 Jun 2020
Posts: 3

PostPosted: Sat Aug 29, 2020 17:06    Post subject: Could not connect to wireless Reply with quote
I got the same issue as jlenk.
My configuration has both interfaces on. ath0 and ath1, 2.4 y 5. Each has a virtual interface. Devices can see the channels but cannot authenticate, I change the password and same result.
I went back to older build and worked from the start.
I will try to troubleshoot more later today
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum