Igmprt dies on dhcp renewal

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
amadeus
DD-WRT Novice


Joined: 06 Nov 2019
Posts: 26

PostPosted: Thu Aug 20, 2020 7:23    Post subject: Igmprt dies on dhcp renewal Reply with quote
Hello!
I have STB connected to my Netgear r6700v3, but it loses signal on DHCP renewal, due to igmprt dying.
Log when it happens:
Code:

Aug 20 09:12:00 DD-WRT user.info : igmprt : maybe died, we need to re-exec it
Aug 20 09:12:00 DD-WRT user.info : igmprt : successfully started
Aug 20 09:15:00 DD-WRT user.warn igmpproxy[5620]: select() failure; Errno(4): Interrupted system call


How to reproduce:
1. Disable Multicast Filtering
2. Enable IGMP snooping
3. Force DHCP Renew via GUI.

Also, similar ticket on openwrt issue tracker from 2 years ago.

Router Model: Netgear R6700 v3
Firmware Version: DD-WRT v3.0-r44213 std (08/18/20)
Kernel Version: Linux 4.4.232 #862 SMP Mon Aug 17 16:08:18 +04 2020 armv7l


Last edited by amadeus on Thu Aug 20, 2020 7:42; edited 2 times in total
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 6633
Location: Netherlands

PostPosted: Thu Aug 20, 2020 7:36    Post subject: Reply with quote
Latest build can be a lot of things

So what is it for you ?

(helpful forum guidelines see my signature at the bottom of this post)

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
amadeus
DD-WRT Novice


Joined: 06 Nov 2019
Posts: 26

PostPosted: Thu Aug 20, 2020 7:40    Post subject: Reply with quote
egc wrote:
Latest build can be a lot of things
So what is it for you ?

added to the main post. It's DD-WRT v3.0-r44213 std (08/18/20)
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 6633
Location: Netherlands

PostPosted: Thu Aug 20, 2020 7:42    Post subject: Reply with quote
OK, wait for others to chime in and if this is not solved consider filing a bug report.
_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7031
Location: Dresden, Germany

PostPosted: Thu Aug 20, 2020 13:38    Post subject: Re: Igmprt dies on dhcp renewal Reply with quote
amadeus wrote:
Hello!
I have STB connected to my Netgear r6700v3, but it loses signal on DHCP renewal, due to igmprt dying.
Log when it happens:
Code:

Aug 20 09:12:00 DD-WRT user.info : igmprt : maybe died, we need to re-exec it
Aug 20 09:12:00 DD-WRT user.info : igmprt : successfully started
Aug 20 09:15:00 DD-WRT user.warn igmpproxy[5620]: select() failure; Errno(4): Interrupted system call


How to reproduce:
1. Disable Multicast Filtering
2. Enable IGMP snooping
3. Force DHCP Renew via GUI.

Also, similar ticket on openwrt issue tracker from 2 years ago.

Router Model: Netgear R6700 v3
Firmware Version: DD-WRT v3.0-r44213 std (08/18/20)
Kernel Version: Linux 4.4.232 #862 SMP Mon Aug 17 16:08:18 +04 2020 armv7l


harmless. igmprt does auto restart if terminated. this message can be also ignored. igmprt just retries on such a error

in addition. if the dhcp lease is identical on renew. the whole renew is ignored. so i assume your dhcp server running router or peer broke the connection on renew, but not the client. if ip changes, dd-wrt does restart the igmprt service like everything else which is required.

i made a workaround for this issue at 44222, but i really think the bug is on your dhcp server side

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
amadeus
DD-WRT Novice


Joined: 06 Nov 2019
Posts: 26

PostPosted: Thu Aug 20, 2020 14:58    Post subject: Re: Igmprt dies on dhcp renewal Reply with quote
BrainSlayer wrote:


in addition. if the dhcp lease is identical on renew. the whole renew is ignored. so i assume your dhcp server running router or peer broke the connection on renew, but not the


playback of the .m3u file in VLC (second peer) also stops after imgprt dies on DHCP Renew pressed in GUI and DHCP lease expiring on it's own, although the ip address is static and does not change. So I assume it is not the peer that is breaking the connection.

Perhaps igmprt should not be reloaded at all if the DHCP info does not change.

BrainSlayer wrote:

i made a workaround for this issue at 44222, but i really think the bug is on your dhcp server side


thanks, we'll see if it helps in the next build.
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 1598
Location: Canada

PostPosted: Thu Aug 20, 2020 15:46    Post subject: Reply with quote
In the past over a year I had a dedicated E3000 (replacing the ISP Router) taking care the ISP TV service and now changed it to a R7000 with build 44213 (for other reasons not related to this thread). Once setup, TV services (igmp/multicast) have not effected recordings and/or viewing the TV even on the old E3000 with build 35531.

I have broken up TV & Internet services on to 2 gateways/routers for a number of reasons. One I normal like keeping the Internet routers 2xR7800 updated without effecting TV recordings. Second I have YAMon3 running on the R7800 gateway and don't need TV streams effecting the daily data usage.

Since the R7000 with build 44213 is a new "upgrade" if I ran into anything related to your problem I will post back. This R7000 only has +16 hours uptime.

_________________
Home Network on Telus PureFibre - 10GbE Copper Backbone
2x R7800 - Gateway & WiFi & 3xWireGuard - DDWRT r44483 Std
R7000 - Wired ISP 4K IPTV Gateway - DDWRT r44483 Std

Off Site 1

R7000 - Gateway & WiFi & WireGuard - DDWRT r44483 Std
WRT610Nv1 - Client Bridge - DDWRT r33679 Mega K2.4

Off Site 2

R7000 - Gateway & WiFi - DDWRT r44483 Std
E2000 - Wired ISP IPTV PVR Blocker - DDWRT r35531


YAMon 3.4.6 | DNSCrypt-Proxy V2
amadeus
DD-WRT Novice


Joined: 06 Nov 2019
Posts: 26

PostPosted: Fri Aug 21, 2020 18:33    Post subject: Reply with quote
Another weird behaviour that I noticed when I change wireless settings.
Igmprt dies, does not write anything to the log when it happens and does not restart itself, requiring me to restart it manually.

UPD: It seems like it doesn't actually die, because starting it with service igmprt start does not do anything, and I have to restart it with service igmprt restart.

And here are entries from the logs, when I, for example, change beacon interval. After that igmprt stops routing multicast packets.
Code:

Aug 21 20:41:29 DD-WRT user.info : nas : daemon successfully stopped
Aug 21 20:41:29 DD-WRT user.info : bridge : interface vlan1 successfully deleted from bridge br0
Aug 21 20:41:29 DD-WRT kern.info kernel: device vlan1 left promiscuous mode
Aug 21 20:41:29 DD-WRT kern.info kernel: br0: port 1(vlan1) entered disabled state
Aug 21 20:41:29 DD-WRT user.info : bridge : interface eth1 successfully deleted from bridge br0
Aug 21 20:41:29 DD-WRT kern.info kernel: device eth1 left promiscuous mode
Aug 21 20:41:29 DD-WRT kern.info kernel: br0: port 2(eth1) entered disabled state
Aug 21 20:41:29 DD-WRT user.info : bridge : interface eth2 successfully deleted from bridge br0
Aug 21 20:41:29 DD-WRT user.info : bridge : bridge br0 successfully deleted
Aug 21 20:41:29 DD-WRT kern.info kernel: device eth2 left promiscuous mode
Aug 21 20:41:29 DD-WRT kern.info kernel: br0: port 3(eth2) entered disabled state
Aug 21 20:41:29 DD-WRT user.info : bridge : bridge br0 successfully deleted
Aug 21 20:41:29 DD-WRT user.info : servicemanager : waiting for services to finish (1)...
Aug 21 20:41:29 DD-WRT user.info : bridge : bridge br0 successfully added
Aug 21 20:41:29 DD-WRT daemon.info mstpd[648]: error, CTL_set_cist_bridge_config: Couldn't find bridge with index 19
Aug 21 20:41:29 DD-WRT daemon.info mstpd[648]: error, CTL_set_cist_bridge_config: Couldn't find bridge with index 19
Aug 21 20:41:29 DD-WRT daemon.info mstpd[648]: error, CTL_set_msti_bridge_config: Couldn't find bridge with index 19
Aug 21 20:41:29 DD-WRT user.info : bridge : bridge br0 successfully added
Aug 21 20:41:29 DD-WRT kern.info kernel: device br0 entered promiscuous mode
Aug 21 20:41:29 DD-WRT daemon.info mstpd[648]: error, CTL_set_cist_bridge_config: Couldn't find bridge with index 19
Aug 21 20:41:29 DD-WRT daemon.info mstpd[648]: error, CTL_set_cist_bridge_config: Couldn't find bridge with index 19
Aug 21 20:41:29 DD-WRT user.info : bridge : interface vlan1 successfully added to bridge br0
Aug 21 20:41:29 DD-WRT kern.info kernel: device vlan1 entered promiscuous mode
Aug 21 20:41:29 DD-WRT kern.info kernel: br0: port 1(vlan1) entered forwarding state
Aug 21 20:41:29 DD-WRT kern.info kernel: br0: port 1(vlan1) entered forwarding state
Aug 21 20:41:29 DD-WRT user.info : bridge : interface eth1 successfully added to bridge br0
Aug 21 20:41:29 DD-WRT kern.info kernel: device eth1 entered promiscuous mode
Aug 21 20:41:29 DD-WRT kern.info kernel: br0: port 2(eth1) entered forwarding state
Aug 21 20:41:29 DD-WRT kern.info kernel: br0: port 2(eth1) entered forwarding state
Aug 21 20:41:30 DD-WRT user.info : bridge : interface eth2 successfully added to bridge br0
Aug 21 20:41:30 DD-WRT kern.info kernel: device eth2 entered promiscuous mode
Aug 21 20:41:30 DD-WRT kern.info kernel: br0: port 3(eth2) entered forwarding state
Aug 21 20:41:30 DD-WRT kern.info kernel: br0: port 3(eth2) entered forwarding state
Aug 21 20:41:30 DD-WRT kern.info kernel: device br0 left promiscuous mode
Aug 21 20:41:30 DD-WRT kern.info kernel: device br0 entered promiscuous mode
Aug 21 20:41:30 DD-WRT kern.info kernel: device br0 left promiscuous mode
Aug 21 20:41:31 DD-WRT user.info : nas : start nas lan
Aug 21 20:41:31 DD-WRT user.info : nas : start nas for wl0
Aug 21 20:41:31 DD-WRT user.info : nas : NAS lan (wl0 interface) successfully started
Aug 21 20:41:31 DD-WRT user.info : nas : start nas lan
Aug 21 20:41:31 DD-WRT user.info : nas : start nas for wl1
Aug 21 20:41:31 DD-WRT user.info : nas : NAS lan (wl1 interface) successfully started


IGMP snooping is enabled on br0, and br0 is getting deleted as you can see in the logs.
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 1598
Location: Canada

PostPosted: Tue Aug 25, 2020 15:03    Post subject: Reply with quote
An update to service igmp has been working fine with my ISP...

I checked my R7000 (ISP IPTV Router) and still on build 44213...

Code:
root@home:~# uptime
 08:03:09 up 3 days, 15:24,  load average: 0.00, 0.00, 0.00

From "TOP" showing service running...
Code:
 1026     1 root     S      784  0.3   1  0.0 igmprt /tmp/igmpproxy.conf

The only log from the start over 3 days ago...
Code:
root@home:~# cat /tmp/var/log/messages | grep igmp
Dec 31 16:00:15 home user.info : igmprt : successfully started


Since the igmp service is running fine with build 44213 I didn't want to test the new change (set 44226) to igmp on build 44236.

_________________
Home Network on Telus PureFibre - 10GbE Copper Backbone
2x R7800 - Gateway & WiFi & 3xWireGuard - DDWRT r44483 Std
R7000 - Wired ISP 4K IPTV Gateway - DDWRT r44483 Std

Off Site 1

R7000 - Gateway & WiFi & WireGuard - DDWRT r44483 Std
WRT610Nv1 - Client Bridge - DDWRT r33679 Mega K2.4

Off Site 2

R7000 - Gateway & WiFi - DDWRT r44483 Std
E2000 - Wired ISP IPTV PVR Blocker - DDWRT r35531


YAMon 3.4.6 | DNSCrypt-Proxy V2
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum