Buffalo WXR-1900DHP

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3 ... 10, 11, 12  Next
Author Message
GrimSage
DD-WRT Novice


Joined: 09 Mar 2010
Posts: 21
Location: USA

PostPosted: Mon Feb 23, 2015 5:06    Post subject: Buffalo WXR-1900DHP Reply with quote
Hi guys, so i have the new flagship buffalo, i have tried to flash to DDWRT kong build 25974 and from both the gui and from tftp it says invalid file. I have tried to change the file etension to *.enc as per the old buffalo routers as well but still nothing works...any suggestions?

Thanks in advance

_________________
case: Antec 1200 PSU: antec HCG900
CPU: AMD FX-8350 @ 4.5 mobo: Gigabyte 990FXA-UD3 ram: 16gb(2x8gb) g. skill Ares 2133 cl 10 vid card: MSI 780TI 3GB gaming SSD: 240 GB intel 520 series storage drive: seagate 1.5 tb sound card: creative sound blaster Z KB: Razer death stalker pro mouse: corsair M65 headset: astro A50
speakers: logitech A530's monitor: samsung 23" LED 1920x1080

router: buffalo WXR-1900DHP
Sponsor
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Mon Feb 23, 2015 18:57    Post subject: Reply with quote
You need factory to dd-wrt first:

ftp://ftp.dd-wrt.com/betas/2015/02-23-2015-r26339/buffalo_wxr-1900dhp/

OEM fws only accept builds in their format and I only provide those kin d of images for the routers I have.
GrimSage
DD-WRT Novice


Joined: 09 Mar 2010
Posts: 21
Location: USA

PostPosted: Mon Feb 23, 2015 19:03    Post subject: Reply with quote
i DID use the factory to DDWRT first, this isnt my first experience with DDWRT but maybe the download was bad, do you recommend using the latest build, i remember reading that some people were having issues with it bc of the wireless driver or something

oh, and flash through the GUI or through TFTP?

_________________
case: Antec 1200 PSU: antec HCG900
CPU: AMD FX-8350 @ 4.5 mobo: Gigabyte 990FXA-UD3 ram: 16gb(2x8gb) g. skill Ares 2133 cl 10 vid card: MSI 780TI 3GB gaming SSD: 240 GB intel 520 series storage drive: seagate 1.5 tb sound card: creative sound blaster Z KB: Razer death stalker pro mouse: corsair M65 headset: astro A50
speakers: logitech A530's monitor: samsung 23" LED 1920x1080

router: buffalo WXR-1900DHP
jheide44
DD-WRT Guru


Joined: 03 Sep 2013
Posts: 729

PostPosted: Mon Feb 23, 2015 19:32    Post subject: Reply with quote
@GrimSage

saw your original conversation HERE, but kept my mouth shut as I am Buffalo device ignorant.

the only thing I can think of is (if you want to live dangerously) the supported devices wiki says your device support was added a while ago

min required DD-WRT version:
wxr-1900dhp
build 24461
20140623


Aslo, SVN timeline HERE

perhaps you could try an earlier "factory-to-dd-wrt.bin" assuming someone tested a flash earlier on.

trying an older file is likely a long shot, I'd still try to see if anyone on the forum has a better suggestion. (Being ignorant of your device details, this could be a bad idea, so read up & please be careful)

Bug?
either way you might want to consider submitting a formal bug report, here:
http://svn.dd-wrt.com/ (you must register/login for "new ticket" option)
...especially since both you and memerchan are both having the same issue

_________________
reenignE esreveR
Resistance is NOT futile... It's Voltage divided by Current!

[size=9]
_.-:Curently Deployed Devices:-._
Loc_1.0: R6400 -- Kong PTB 35550M 03-28-2018
Loc_2.0: R6300v2 -- Kong PTB 35550M 03-28-2018
Loc_3.0: R6300v2 -- Kong PTB 35030M 02-19-2018
Loc_4.0: R6300v2 -- Kong PTB 28600M 12-31-2015 (Radios OFF) & 5 Ubiquity UniFi APs
Loc_4.1: E4200 -- BrainSlayer K2.6 30880
Others: too many others to list

UNofficial Repo Kong's old builds HERE.

R7000 (& similar HW) Tips/Tricks HERE.

Assumptions:
1. Everyone on the forum has read the relevant forum section announcements.
2. For Broadcom section we have ALL at least tried to understand the "Peacock" thread,
HERE
GrimSage
DD-WRT Novice


Joined: 09 Mar 2010
Posts: 21
Location: USA

PostPosted: Wed Feb 25, 2015 21:11    Post subject: Reply with quote
I tried all of that too...guess I will put the ticket in as nothing seems to work
_________________
case: Antec 1200 PSU: antec HCG900
CPU: AMD FX-8350 @ 4.5 mobo: Gigabyte 990FXA-UD3 ram: 16gb(2x8gb) g. skill Ares 2133 cl 10 vid card: MSI 780TI 3GB gaming SSD: 240 GB intel 520 series storage drive: seagate 1.5 tb sound card: creative sound blaster Z KB: Razer death stalker pro mouse: corsair M65 headset: astro A50
speakers: logitech A530's monitor: samsung 23" LED 1920x1080

router: buffalo WXR-1900DHP
GrimSage
DD-WRT Novice


Joined: 09 Mar 2010
Posts: 21
Location: USA

PostPosted: Mon Mar 09, 2015 19:22    Post subject: Reply with quote
also starting to wonder if my particular router isnt just like partially defective... other things dont work right with it on occasion, but still testing to make sure its not pc hardware thats causing the funniness before i RMA it
_________________
case: Antec 1200 PSU: antec HCG900
CPU: AMD FX-8350 @ 4.5 mobo: Gigabyte 990FXA-UD3 ram: 16gb(2x8gb) g. skill Ares 2133 cl 10 vid card: MSI 780TI 3GB gaming SSD: 240 GB intel 520 series storage drive: seagate 1.5 tb sound card: creative sound blaster Z KB: Razer death stalker pro mouse: corsair M65 headset: astro A50
speakers: logitech A530's monitor: samsung 23" LED 1920x1080

router: buffalo WXR-1900DHP
memerchan
DD-WRT Novice


Joined: 20 Sep 2011
Posts: 19

PostPosted: Wed Mar 25, 2015 13:59    Post subject: Reply with quote
GrimSage

Any progress with the dd-wrt on the Buffalo wxr-1900dhp?
GrimSage
DD-WRT Novice


Joined: 09 Mar 2010
Posts: 21
Location: USA

PostPosted: Thu Mar 26, 2015 13:46    Post subject: Reply with quote
sadly no no luck yet, gonna try the latest build this weekend, and i did submit a ticket for it a few weeks ago so hopefully it will be fixed soon if not already
_________________
case: Antec 1200 PSU: antec HCG900
CPU: AMD FX-8350 @ 4.5 mobo: Gigabyte 990FXA-UD3 ram: 16gb(2x8gb) g. skill Ares 2133 cl 10 vid card: MSI 780TI 3GB gaming SSD: 240 GB intel 520 series storage drive: seagate 1.5 tb sound card: creative sound blaster Z KB: Razer death stalker pro mouse: corsair M65 headset: astro A50
speakers: logitech A530's monitor: samsung 23" LED 1920x1080

router: buffalo WXR-1900DHP
memerchan
DD-WRT Novice


Joined: 20 Sep 2011
Posts: 19

PostPosted: Sun Apr 26, 2015 16:02    Post subject: Reply with quote
Any progress?
darcw0lf
DD-WRT Novice


Joined: 10 May 2015
Posts: 18

PostPosted: Sun May 10, 2015 0:45    Post subject: Reply with quote
any news? I just bought the router, and while I like it I find the NAS kinda sucks XFS only format, at least ddwrt gives an option for ntfs. I tried the flash and got the same error, invalid firmware.
jlaustill
DD-WRT Novice


Joined: 20 May 2015
Posts: 1

PostPosted: Wed May 20, 2015 12:26    Post subject: Reply with quote
Anyone had any luck with this? I have this router and can't figure out how to get dd-wrt installed and it's driving me nuts!
d0ugie
DD-WRT Novice


Joined: 27 May 2015
Posts: 1
Location: New York City

PostPosted: Wed May 27, 2015 16:10    Post subject: when do I tftp? Reply with quote
There's plenty for Buffalo devices but very little information on the flashing procedure (I'm a novice) for the WXR-1900DHP which I bought in part because it was DD-WRT friendly. The information I found for other Buffalos talks about the light blinking patterns, but they don't seem applicable to this router.

I reset the router's configuration, I change my IP to 192.168.11.2, I leave ping -t running with tftp commands ready to fire the factory-to-ddwrt file, I hit them immediately at the first ping, I try at every stage of the lights changing -- tftp hangs and the router boots normally.

I made a little cygwin bash script using netcat to check every second for port 69 to open with a telnet bat looping script also running, I've tried booting dozens of times while attempting to tftp repeatedly at various times during the boot, no luck.

Could someone kindly and specifically spell out when I should hit the button? I'd be most obliged.


Tl;dr when during boot do I tftp firmware with the WXR-1900DHP? Thanks.
trieutan
DD-WRT Novice


Joined: 03 Nov 2012
Posts: 1

PostPosted: Sun Jun 07, 2015 4:55    Post subject: Reply with quote
Buffalo just start to sell the dd-wrt NXT version of WXR-1900 called DHPD http://www.buffalotech.com/products/wireless/dd-wrt-nxt/airstation-extreme-ac1900-dd-wrt-nxt-wireless-router. ddwrt nxt wiki also listed wxr-1900 as one of the first few supported devices http://www.dd-wrt.com/nxt/wiki/doku.php?id=hardware:buffalo:buffalo_wxr1900dhp . I tried the instruction manual, booting router while pressing AOSS button. The router (TFPT client) indeed request "firmware.ram" from my pc TFTP server but timeout immediately. Not sure why.

PS: I tried to go to buffalo website on the new router but the device is so new, they even didn't upload the firmware yet, maybe we can use that firmware for the "user friendly" variant.
vducv
DD-WRT Novice


Joined: 07 Jun 2015
Posts: 3

PostPosted: Sun Jun 07, 2015 8:58    Post subject: Reply with quote
I am facing same problems with you guys. Invalid FW upgrade with ddwrt in web upgrade page. I even tried Japaneses FW, not successes. When TFTP link with pushing AOSS button, its transmitted a second then break down.

I think web upgrade page response deny DDWRT FW, because DDWRT FW is developed in the Japaneses version router. US and JP wxr1900 have same hardware, but original factory FW is different, thus US buffalo does not accept DDWRT FW for JP buffalo.

I am continue trying TFTP upgrade method. If I can install factory JP FW, I think ddwrt FW will be accepted.
vducv
DD-WRT Novice


Joined: 07 Jun 2015
Posts: 3

PostPosted: Sun Jun 07, 2015 22:38    Post subject: Reply with quote
That are TTL responses when TFTP firmware.
-------------------------------------------------------------
CFE mem: 0x07E00000 - 0x07FA045C (1705052)
Data: 0x07E58EB4 - 0x07E5940C (1368)
BSS: 0x07E59418 - 0x07E9E45C (282692)
Heap: 0x07E9E45C - 0x07F9E45C (1048576)
Stack: 0x07F9E45C - 0x07FA045C (8192)
Text: 0x07E00000 - 0x07E4D748 (317256)
Boot: 0x07FA1000 - 0x07FE1000
Reloc: I:00000000 - D:00000000

Device eth0: hwaddr CE-E1-D5-A0-2C-9E, ipaddr 192.168.11.1, mask 255.255.255.0
gateway not set, nameserver not set
wating 3 seconds...
loading fw...Device eth0: hwaddr CE-E1-D5-A0-2C-9E, ipaddr 192.168.11.1, mask 255.255.255.0
gateway not set, nameserver not set
Loader:raw Filesys:tftp Dev:eth0 File:192.168.11.2:firmware.ram Options:(null)
Loading: . 0 bytes read
Entry at 0x00008000
Closing network.
Starting program at 0x00008000
Goto page 1, 2, 3 ... 10, 11, 12  Next Display posts from previous:    Page 1 of 12
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum