Special characters in files when access by FTP

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> General Questions
Author Message
wonder_wonder
DD-WRT User


Joined: 06 Jun 2016
Posts: 75

PostPosted: Tue Jun 09, 2020 19:05    Post subject: Special characters in files when access by FTP Reply with quote
Special characters in files

Hi.
I use the DDWRT FTP server, everything works fine, but there are files that have special characters, such as "á" or "ñ" and these appear strange when I access via ftp. But if I access by browsing (I have samba) they look fine.
If I force filezilla to use UTF-8 then they appear fine, but if I leave it in auto, they are shown that way.
For example the word "Sesión" appears "Sesión".
Can I reset or reconfigure this in the FTP server settings?

Thanks in advance and I hope you are all well!

Edit: I forget, if I have some file in my FTP with this special characters I can't download with ftp client, indicate error in download.
Sponsor
SurprisedItWorks
DD-WRT Guru


Joined: 04 Aug 2018
Posts: 953
Location: Appalachian mountains, USA

PostPosted: Tue Aug 18, 2020 21:46    Post subject: Re: Special characters in files when access by FTP Reply with quote
wonder_wonder wrote:
Special characters in files

Hi.
I use the DDWRT FTP server, everything works fine, but there are files that have special characters, such as "á" or "ñ" and these appear strange when I access via ftp. But if I access by browsing (I have samba) they look fine.
If I force filezilla to use UTF-8 then they appear fine, but if I leave it in auto, they are shown that way.
For example the word "Sesión" appears "Sesión".
Can I reset or reconfigure this in the FTP server settings?

Thanks in advance and I hope you are all well!

Edit: I forget, if I have some file in my FTP with this special characters I can't download with ftp client, indicate error in download.

I don't know anything about dd-wrt ftp in particular, and my ftp experience is shockingly old, but ftp traditionally had an default text mode (did they actually call it ascii?) and a binary mode. I believe that if you typed the command "binary" to your ftp client it would switch to binary mode and then deliver subsequent files with no changes whatever. Understand though that if you are working from anything but another (since dd-wrt is one) linux computer, a strict binary copy is really not what you want for a text file, since line-ending conventions and character-set conventions get involved.

On such a subject, google (remarkably) is your friend.

_________________
Five WRT1900ACSv2's on 42926, 44048.
VLANs, multiple VAPs, NAS, client-mode travel router, OpenVPN client (AirVPN), DDNS, wireguard server, two wireguard clients (AzireVPN), use of two DNSCrypt DNS providers (inc Quad9) through OpenVPN and wireguard clients.
wonder_wonder
DD-WRT User


Joined: 06 Jun 2016
Posts: 75

PostPosted: Tue Aug 18, 2020 22:32    Post subject: Reply with quote
Yes, I search in google (always search before post) but not view about this,

Only have this with dd-wrt (my computer also is linux) and some versions, not have this "bug" (if can call a bug), others versions I don't have this problem, but the best version work for me I have this problem...

Regards.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> General Questions All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum