New Build - 08-02-2020-r44048

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2, 3, 4  Next
Author Message
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7450
Location: Texas, USA

PostPosted: Sun Aug 02, 2020 20:06    Post subject: New Build - 08-02-2020-r44048 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and specific device recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link doesn't work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r43904 (GitHub mirror)

Notes:
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle. 6920, 6928, 6931, 6932 (WIP 7040)
In-kernel Samba has been implemented this year and default min/max versions have changed 6954, 6957, with WSD support.
• VAP issue is fixed! For any Wireless Mode, create a VAP and both ath0/ath1 should now function properly.
• Local DNS option removed from Services->DNSMasq in changesets 43080 and 43081; ref: #7092
• DHCP and DNS help (English) updated in 43083; ref: #7091
WireGuard 1.0.20200712: PBR, Kill Switch, Inbound Firewall, Naming of Peers, Status, Key, Guides. Thanks egc!

Issues:
• There may be remaining issues for Samba (for example NTFS), with frequent updates.

Important:
• If reporting issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog/serial output, strace etc.
• For firewall issues provide 'iptables -L', 'iptables -t nat -L' and the /tmp/.ipt file.
• Search existing SVN tickets before opening a new one. Before reporting, reset and manually setup (no nvram backup).
• Be sure to include operating and wireless modes (Gateway, AP, CB, etc.) along with relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]

_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
Sponsor
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 288

PostPosted: Sun Aug 02, 2020 21:41    Post subject: Reply with quote
Router/Version: Linksys WRT1900ACS v2
File: ddwrt-linksys-wrt1900acsv2-webflash.bin
Firmware: DD-WRT v3.0-r44048 std (08/02/20) (prev. DD-WRT v3.0-r43845 std (07/18/20))
Kernel: Linux 4.9.231 #1979 SMP Sun Aug 2 03:35:09 +03 2020 armv7l
Mode: Gateway, 2.4G and 5G wifi, Wireguard for external access, WAN to 4G
Reset: No
Status: 3m up, load average 0.07, 0.16, 0.07, Temperatures CPU 76.5 °C / WL0 48.2 °C / WL1 50.1 °C, will edit if problems appear.
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 328
Location: South Carolina

PostPosted: Mon Aug 03, 2020 0:41    Post subject: DD-WRT v3.0-r44048 std (08/02/20) Reply with quote
WRT3200ACM V1 r44048 Firefox 79.0.0 (64-bit) webflash

OpenVPN CLIENT seems fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES) Conditional 40MHz Mixed
2.4GHz wpa2 CCMP-128 (AES) Conditional 20MHz N Only
NAS via USB Samba Conditional - Abends with out of memory errors from time to time.

Wifi Stays clean as long as I "keep alive" auto boot every 24 hours
Argenis
DD-WRT User


Joined: 18 Feb 2019
Posts: 81

PostPosted: Mon Aug 03, 2020 4:05    Post subject: Reply with quote
Upgraded 3200acm from 23 July build, and 32x from 32 July build.

3200ACM had to re-setup the password for one of the wireless networks, after that all good, no issues.

32x still has the 50% load issue (with close to 0% cpu usage).

_________________
Router: Linksys WRT3200ACM
88W8964 802.11ac ath0 Mode AP VHT80 80MHz Mixed Mode Channel and Extension Auto
88W8964 802.11ac ath1 Mode AP Dynamic 20/40 MHz Mixed Mode Channel and Extension Auto
SD8887 802.11ac disabled but visible on GUI and CLI
OpenVPN enabled, client mode
Port forwarding disabled
DHCP server mode, enabled
DNSCrypt and Validate DNS Replies
pbphoto
DD-WRT User


Joined: 29 Oct 2017
Posts: 104

PostPosted: Mon Aug 03, 2020 8:23    Post subject: Reply with quote
Just upgraded to 44048 after running 43471 for the last 44 days without issues. All upgrades were done via GUI over Safari.

Issues: None so far. Uptime is 20 minutes - i'll report back if any issues develop. Throughput, latency, buffer-bloat all are about the same as with 43471 - excellent.

Wireguard client: Using Mullvad client config following parts of Hellakenut's "idiots guide for commercial clients" and egc's updated guide to eliminate the startup script.

Kernel: Linux 4.9.231 #1979 SMP Sun Aug 2 03:35:09 +03 2020 armv7l

Linksys WRT3200ACM: gateway mode, DNSMasq for DNS and DHCP, Wireguard client (Mullvad), Firewall enabled, QoS enabled HTB-CAKE, PBR enabled (SFE disabled). WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 1, WPA2-CCMP-128. 5ghz: AC/N mixed, 80mhz channel width, channel 100+6, WPA2-CCMP-128.

Linksys WRT1900ACSv1: router mode, hardwired ethernet lan to WRT3200ACM above. WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 11, WPA2-CCMP-128. 5ghz: AC/N mixed, 80mhz channel width, channel 36+6, WPA2-CCMP-128.

Clients: Apple MACOS x 4, IOS x 4, Apple TV, Chromecast Audio x 2, Eufy doorbell, Lutron Caseta, Axis Camera, Samsung TV, Nest thermostat, EtekCity outlets (Espressif)..
iVitor
DD-WRT User


Joined: 10 Jul 2009
Posts: 94

PostPosted: Mon Aug 03, 2020 9:19    Post subject: Reply with quote
Argenis wrote:
32x still has the 50% load issue (with close to 0% cpu usage).
Could you please provide more details? (e.g., where are you seeing that load, and what is your configuration)
From the previous build (r43904) until today, my WRT32X shows a 0.00, 0.00, 0.00 load average. There is the expected load spike right after rebooting the system (or flashing a new build), but it all goes back to normal as expected. Clearly there is some other factor at play, hence why you should provide more details (i.e., if BS cannot reproduce the bug then he cannot fix it).
Argenis
DD-WRT User


Joined: 18 Feb 2019
Posts: 81

PostPosted: Mon Aug 03, 2020 21:46    Post subject: Reply with quote
iVitor wrote:
Argenis wrote:
32x still has the 50% load issue (with close to 0% cpu usage).
Could you please provide more details? (e.g., where are you seeing that load, and what is your configuration)
From the previous build (r43904) until today, my WRT32X shows a 0.00, 0.00, 0.00 load average. There is the expected load spike right after rebooting the system (or flashing a new build), but it all goes back to normal as expected. Clearly there is some other factor at play, hence why you should provide more details (i.e., if BS cannot reproduce the bug then he cannot fix it).


Gladly. I've attached a picture of the GUI and the top command output showing where the load is present as such, and I will provide a dump as well.

Edit: The suggestion about disabling the ATH2 via command line doesn't work, this build doesn't show it.

_________________
Router: Linksys WRT3200ACM
88W8964 802.11ac ath0 Mode AP VHT80 80MHz Mixed Mode Channel and Extension Auto
88W8964 802.11ac ath1 Mode AP Dynamic 20/40 MHz Mixed Mode Channel and Extension Auto
SD8887 802.11ac disabled but visible on GUI and CLI
OpenVPN enabled, client mode
Port forwarding disabled
DHCP server mode, enabled
DNSCrypt and Validate DNS Replies


Last edited by Argenis on Mon Aug 03, 2020 23:46; edited 1 time in total
whatsashell
DD-WRT Novice


Joined: 26 Mar 2017
Posts: 35

PostPosted: Mon Aug 03, 2020 22:34    Post subject: Reply with quote
What fixed this for me (nic 100%) was go down an older version (oct 2019 or before) where you can see ath2 in the GUI. Disable it. Then upgrade to a newer firmware.

I suspect if you ssh into the router and disable the ath2 interface that would fix it as well.
Argenis
DD-WRT User


Joined: 18 Feb 2019
Posts: 81

PostPosted: Tue Aug 04, 2020 0:25    Post subject: Reply with quote
whatsashell wrote:
What fixed this for me (nic 100%) was go down an older version (oct 2019 or before) where you can see ath2 in the GUI. Disable it. Then upgrade to a newer firmware.

I suspect if you ssh into the router and disable the ath2 interface that would fix it as well.


This might be the solution. I will give this a shot. I initially left all interfaces on, because on certain builds, having some of them off would cause a massive upgrade/install crash.

The current build also doesn't really see the interface so it can't be shut off, and knowing how the drivers are touchy and proprietary that's the way to go. Thanks for the suggestion.

_________________
Router: Linksys WRT3200ACM
88W8964 802.11ac ath0 Mode AP VHT80 80MHz Mixed Mode Channel and Extension Auto
88W8964 802.11ac ath1 Mode AP Dynamic 20/40 MHz Mixed Mode Channel and Extension Auto
SD8887 802.11ac disabled but visible on GUI and CLI
OpenVPN enabled, client mode
Port forwarding disabled
DHCP server mode, enabled
DNSCrypt and Validate DNS Replies
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 1784

PostPosted: Tue Aug 04, 2020 0:34    Post subject: Reply with quote
To confirm, is it necessary to load an older build to disable ath2?

None of the below can accomplish the same task in r44048?

Restore Factory Defaults from Web GUI -> Administration -> Factory Defaults

Hardware Reset (hold reset button 10 seconds while already powered on)

"nvram erase && reboot" from command line Telnet or SSH.
Argenis
DD-WRT User


Joined: 18 Feb 2019
Posts: 81

PostPosted: Tue Aug 04, 2020 1:32    Post subject: Reply with quote
blkt wrote:
To confirm, is it necessary to load an older build to disable ath2?

None of the below can accomplish the same task in r44048?

Restore Factory Defaults from Web GUI -> Administration -> Factory Defaults

Hardware Reset (hold reset button 10 seconds while already powered on)

"nvram erase && reboot" from command line Telnet or SSH.


I have installed from scratch a couple of times after even erasing NVRAM and it still came back.

I'll try that first though (since I have to lose all settings anyways) and report back before going back to a 2019 build.

Edit 1: I tried the reset from GUI, reset via button, nvram reset and reboot and the 50% load issue persists on this build. I'm installing a 2019 build and seeing how that fares by disabling the third interface before upgrading to the latest.

Edit 2: Tried build 30 October 2019, load at regular levels. Reset everything, disabled Ath2 and upgraded to this build, 50% load issue showed up.
Reset everything and went back to 30 October 2019 build, left it on, upgraded to latest without resetting settings, then with resetting settings and both had the 50% load issue, I'm guessing I'm staying with that build on the WRT32x, that router is a lemon even though it's supposed to be identical to the 3200acm.

Edit 3: Ended up with build DD-WRT v3.0-r41686 std (12/10/19) due to httpd issues on that other one, but this one doesn't have the load issue on the 32X

_________________
Router: Linksys WRT3200ACM
88W8964 802.11ac ath0 Mode AP VHT80 80MHz Mixed Mode Channel and Extension Auto
88W8964 802.11ac ath1 Mode AP Dynamic 20/40 MHz Mixed Mode Channel and Extension Auto
SD8887 802.11ac disabled but visible on GUI and CLI
OpenVPN enabled, client mode
Port forwarding disabled
DHCP server mode, enabled
DNSCrypt and Validate DNS Replies
iVitor
DD-WRT User


Joined: 10 Jul 2009
Posts: 94

PostPosted: Tue Aug 04, 2020 9:14    Post subject: Reply with quote
Just to provide another datapoint, my WRT32X was "dirty flashed" throughout at least a year, and it did have the ath2 disabled in an older build. Furthermore, my wireless tab in the web interface still shows the ath2 interface, but that device is unavailable in the Linux command line. Can't really play with the router because it's in active use, but (so far) the findings in this thread about the ath2 interface are matching my running configuration.
PavelVD
DD-WRT User


Joined: 26 Jul 2019
Posts: 67

PostPosted: Tue Aug 04, 2020 9:47    Post subject: Reply with quote
Router: Linksys WRT1900ACSv2
Firmware: DD-WRT v3.0-r44048 std (08/02/20) prev. r43904
Kernel: Linux 4.9.231 #1979 SMP Sun Aug 2 03:35:09 +03 2020 armv7l
Browser: Opera Stable 69.0 (Windows 10 64-bit)
Reset: No
Mode:
Dnsmasq: Cache DNSSEC data, Validate DNS Replies (DNSSEC), Check unsigned DNS replies, No DNS Rebind.
DNSCrypt2 (dnscrypt-proxy 2.0.39 Entware)
2.4 GHz: AP NG-Mixed, Channel 5, Full 20 MHz, TurboQAM (QAM256) support.
5 GHz: AP AC/N-Mixed, Channel 161+Lower, Wide HT40, Allow Channel Overlapping.
Security: WPA2 Personal CCMP-128 (AES)
NAS via USB:
/dev/sda - Block device, size 931.5GiB, Partition: 1-Ext4, 2-Ext4 , 3-swap.
Samba shared: Protocol Version SMB 3.00\SMB 3.00
NFS Server shared: Shared the same partitions as in Samba.
Surveillance: Windows SMB customers, wired, are more stable. If you connect on WiFi, then... it's not good at all. (This does not apply to this particular firmware; the last three behave the same way.)
I would even say that with 5 GHz customers connected, work is impossible.
Errors:
Part of the log

_________________
Linksys WRT1900ACSv2
Automatically adjustable temperature, always within the range of 59-68°С.
SurprisedItWorks
DD-WRT Guru


Joined: 04 Aug 2018
Posts: 992
Location: Appalachian mountains, USA

PostPosted: Tue Aug 04, 2020 13:48    Post subject: Reply with quote
PavelVD wrote:
NFS Server shared: Shared the same partitions as in Samba.
Surveillance: Windows SMB customers, wired, are more stable. If you connect on WiFi, then... it's not good at all. (This does not apply to this particular firmware; the last three behave the same way.)
I would even say that with 5 GHz customers connected, work is impossible.
Errors:
Part of the log

What does any of this mean? Problems with this build or others? If the latter, why report here? Those two minutes of log errors were just there? Or did you do something to trigger them? "More stable" vs "work is impossible"? Huh?

Looking back, you've reported major samba issues so many times in new-build threads recently, with those problems really different and more severe than others have reported, that perhaps you need to start a thread on them and see if any useful advice on things to explore in the config and network setup can be conjured up from the community. If not, then maybe that discussion would lead to some notion of what to report in a ticket. Just a thought.

_________________
Five WRT1900ACSv2's on 42926, 44048.
VLANs, VAPs, NAS, client-mode travel router, OpenVPN client (AirVPN), DDNS, wireguard servers, wireguard clients (AzireVPN), two DNSCrypt DNS providers (incl Quad9) via OpenVPN/wireguard clients.
PavelVD
DD-WRT User


Joined: 26 Jul 2019
Posts: 67

PostPosted: Tue Aug 04, 2020 17:03    Post subject: Reply with quote
Your comments are fair, I'm trying to get better.
Since SAMBA has been updated, I've really had problems. Every time I experience a new build, but I return to r42054. I carefully follow the messages on the forum and read the tips, in particular tried this:
https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1212244#1212244 (Tried other protocols, the result does not change.)
There's a phrase:
SurprisedItWorks wrote:
I gather that Samba issues in recent builds is due to a move a small number of months ago to Samba code embedded in the linux kernel. It's taken a while to get the kinks out. Maybe some are still in there.

That's why I report problems in the thread so that developers can see them, and wait patiently.
Each build contains a message:
kernel-panic69 wrote:
Issues:
• There may be remaining issues for Samba (for example NTFS), with frequent updates.

I tried to change the markings of the discs, but it didn't help me either.
I'm not doing anything out of the ordinary. I work on a laptop connected by LAN. If necessary, I turn off the wire and switch to Wi-Fi, that's where it all starts.
I'm trying to do it specifically now for the test. Preliminarily reset the reset button and reintroduced all settings.
Router restarted and wrote this text; Connection - LAN.
As soon as LAN was disabled, my PC lost its network drive. After a few seconds, the drive became available and I made an attempt to copy the file on the PC. Copying failed, here's what appeared in the log:
Code:

Aug  4 19:37:55 LinkSYS daemon.info dnsmasq-dhcp[2510]: DHCPREQUEST(br0) 192.168.1.121 20:0d:b0:41:c6:a9
Aug  4 19:37:55 LinkSYS daemon.info dnsmasq-dhcp[2510]: DHCPACK(br0) 192.168.1.121 20:0d:b0:41:c6:a9 MyLenovo
Aug  4 16:37:58 LinkSYS kern.debug kernel: [ 4947.364491] ieee80211 phy0: Mac80211 start BA 20:0d:b0:41:c6:a9
Aug  4 16:38:04 LinkSYS authpriv.info dropbear[4305]: Child connection from 192.168.1.121:57758
Aug  4 16:38:05 LinkSYS authpriv.notice dropbear[4305]: Password auth succeeded for 'root' from 192.168.1.121:57758
Aug  4 16:41:01 LinkSYS daemon.err httpd[1560]: httpd : Request Error Code 408: No request appeared within a reasonable time period.
Aug  4 16:41:54 LinkSYS kern.err kernel: [ 5183.281481] ksmbd: ksmbd_conn_write:214: Failed to send message: -11
Aug  4 16:41:59 LinkSYS kern.err kernel: [ 5188.321487] ksmbd: ksmbd_conn_write:214: Failed to send message: -11
Aug  4 16:42:04 LinkSYS kern.err kernel: [ 5193.371468] ksmbd: ksmbd_conn_write:214: Failed to send message: -11

Further work on Wi-Fi (5 GHz) became impossible, I connected the wire.

_________________
Linksys WRT1900ACSv2
Automatically adjustable temperature, always within the range of 59-68°С.
Goto page 1, 2, 3, 4  Next Display posts from previous:    Page 1 of 4
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum