New Build 07-15-2020-r43813

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4  Next
Author Message
nolimitz
DD-WRT Guru


Joined: 26 Nov 2010
Posts: 572

PostPosted: Thu Jul 16, 2020 19:35    Post subject: Reply with quote
tinkeruntilitworks wrote:
going to stock might not be necessary

i flashed kong 38570 and all the channels were there
i did a gui reset

then flashed kong 39345 and the lower channels appeared to disappear

then i did a nvram erase

after setting it back up the all channels were back
i set up 80 width upper upper channel 48

then flashed to the current build

at first it appears all the channels are available
after a reboot the lower and upper channel are available

once you get the channels i wouldn't nvram erase again


i did the following:

1. flash stock
2. flash 39345
3. nvram erase
4. all channels will be available
5. flash 43813, no reset, all channels available
6. power cycle, only 2 channels available
7. restored old nvram backup (after brcm_unlock which had 5 channels only), all channels are available (6 channels).
8. power cycle, 6 channels still available

can you check the last octet of wl0 and wl1?
Sponsor
tinkeruntilitworks
Guest





PostPosted: Thu Jul 16, 2020 19:53    Post subject: Reply with quote
im not absolutely certain what your asking

i see a hardware mac address and assume they are unique
claudinei
DD-WRT User


Joined: 21 Mar 2009
Posts: 63

PostPosted: Thu Jul 16, 2020 20:12    Post subject: Asus RT-AC3200 Reply with quote
Router: Asus RT-AC3200
Firmware: DD-WRT v3.0-r43813 std (07/15/20)
Previus: DD-WRT v3.0-r43718 std (07/09/20)
Kernel: Linux 4.4.230 #583 SMP Wed Jul 15 08:35:08 +04 2020 armv7l
Status: working
Mode: Gateway
Reset: No
Services: SAMBA, FTP, DNS on Pi-Hole

_________________
RT-AC68U
RT-AC3200
TL-MR3020
TL-WDR3600 v1
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 97

PostPosted: Thu Jul 16, 2020 21:01    Post subject: Reply with quote
kernel-panic69 wrote:
@novasbc: If you are using class A or B subnets, use the proper subnet mask and desired start IP address. There have been changes to the configuration and that's probably why it's not working. Just a thought.

@Abboo: Did you ensure your network settings were correct after upgrading?

@tinkeruntilitworks: Good to hear, and sorry for all the grief. I don't always remember everything, and I guess I expect people to have read a lot of the same threads and posts I have, perhaps. No worries, all good!


I have not changed the way I upgrade. It is the same for all builds I have tested. When I revert to the older build I made no changes and it worked and still working. Something with the current two builds not working with my Netgear R8000; I cannot surf the net.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7213
Location: Texas, USA

PostPosted: Thu Jul 16, 2020 21:36    Post subject: Reply with quote
There may have still been some issue with dhcp

https://svn.dd-wrt.com/changeset/43819
https://svn.dd-wrt.com/changeset/43820

But I have had no issues with this build on any device. I generally don't reset, though.

_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
tinkeruntilitworks
Guest





PostPosted: Thu Jul 16, 2020 22:28    Post subject: Reply with quote
so i guess it's not a wireless issue

It's the nvram erase command

Which sucks because of how often that is suggested
MysticGold04
DD-WRT User


Joined: 20 Apr 2018
Posts: 76
Location: Troubleshooting

PostPosted: Fri Jul 17, 2020 0:18    Post subject: Reply with quote
Router/Version: Asus RT-AC68U
File/Kernel: asus_rt-ac68u-firmware.trx (r43813)
Previous/Reset: Merlin 384.18 / YES
Mode/Status: 2.4Ghz AP / 5Ghz Client
Issues/Errors: No issues so far. Up 2 hours.

**Also just updated another RT-AC68U being used as a Client Bridge and my trusty Linksys WRT54GL. No issues to speak of.

_________________
ASUS RT-AC68U (R/AP) Merlin 384.19
ASUS RT-AC68U r44236 AP/Bridge
ASUS RT-AC68U FT 2020.5 Bridge
WRT54GL 1.1 r44236-std (old faithful)
Linksys E1200v2 r43266 (sleeping)
thommy181
DD-WRT User


Joined: 16 Mar 2019
Posts: 133
Location: Szczecin, Poland EU

PostPosted: Fri Jul 17, 2020 16:10    Post subject: New Build 07-15-2020-r43813 Reply with quote
Router/Version: Netgear WNR3500L v2
Kernel: Linux 4.4.230 #2602 Wed Jul 15 14:17:35 +04 2020 mips
Reset: No
Mode: Internet gateway and WIFI AP
Statuss: Working
Uptime: almost 28h

Device is updated via ssh. Generally router working good. I see two small problems:
1) I can't to put own configuration to setup -> switch config tab. After make own configuration and click save and apply settings options I have default configuration again. This problem is exist for a long time.
2) Administration -> Commands tab have a problem. When I change configuration and click save firewall options the configuration isn't refresh and I must totally reboot device for correctly firewall configuration.
Generally router is usable and operate good.
xraive
DD-WRT User


Joined: 08 Mar 2016
Posts: 75

PostPosted: Sun Jul 19, 2020 10:20    Post subject: Reply with quote
Router Model / Version: Netgear R6300V2
Previous Firmware: DD-WRT v3.0-r43800 std (07/14/20)
Current Firmware: DD-WRT v3.0-r43813 std (07/15/20)
File: netgear-r6300v2-webflash.bin
Kernel: Linux 4.4.230 #578 SMP Wed Jul 15 08:06:57 +04 2020 armv7l
Reset: No
Mode: Wireless - AP, Operating - Gateway (WAN PPPoE)
Setup: SFE, NTP, DDNS (inadyn/Entware), DNSMasq (GUI+ additional options on USB, Syslog, SSH, Telnet, USB, Samba (with users), Remote Access (HTTPS & SSH), Startup Script (For DNSMasq & inadyn), Adblock for DD-WRT by Yamaraj
Uptime: up 6:38, load average: 0.76, 0.53, 0.48
Temperatures: CPU 79.1 °C / WL0 48.9 °C / WL1 55.9 °C
Issues: None
Status: Working. Have about 30 clients on it.
tinkeruntilitworks
Guest





PostPosted: Wed Sep 09, 2020 13:17    Post subject: Reply with quote
i was curious if the nvram erase command still caused issues in the latest build. it does. the lower channels are gone. i must have accidentally deleted the kong builds to recover the channels. the only mirror i know of seems to be gone. http://ddwrt-kong.clonevince.fr/ . are there any other mirrors? i have not been able to recover the channels with any bs builds i've tried. seems weird that going back to stock and flashing the current build doesn't resolve the issue
tinkeruntilitworks
Guest





PostPosted: Thu Sep 10, 2020 12:10    Post subject: Reply with quote
it's possible it causes other issues as well. my roku tv remote would die in days.

the nvram erase is a common command. it is often suggested for trying to fix bugs.

going back to stock then flashing another bs build does not fix the issue

i have repeatedly reported the issue.

i have had my fill

*
I previously asked for my account to be deleted. I should keep it. Some posts you need to be logged into to see. Also not sure if posts would disappear. Don't want to lose the unbound thread.


Last edited by tinkeruntilitworks on Fri Sep 11, 2020 20:07; edited 2 times in total
tinkeruntilitworks
Guest





PostPosted: Fri Sep 11, 2020 10:58    Post subject: Reply with quote
why is kong build 39345 able to fix the issue but nothing from bs? i cant find the kong builds so now my wireless is broken again. why cant i get a response? am i not believed? or does no one care?

*
found this on reddit Internet Archive copy of the Kong builds from Feb 2019 https://web.archive.org/web/20190204145633/http://www.desipro.de/ddwrt/

https://www.reddit.com/r/DDWRT/comments/d448r3/internet_archive_copy_of_the_kong_builds_from_feb/

its 39960M and it worked to recover the channels. it seems 39345 or newer kong builds will recover after an nvram erase
RageX
DD-WRT Novice


Joined: 01 Jan 2020
Posts: 34

PostPosted: Sat Sep 12, 2020 12:18    Post subject: Reply with quote
From the svn BS said he wasn't going to fix it since this issue is "country" related settings implemented by the chipset vendor. It may be difficult to fix every country-setting related issue for every router since they are all different and there are hidden nvram settings for each.

Your best bet is to try the known nvram tinker fixes that are around, and that you have figured out for yourself. Personally I had a similar issue with my DIR-890L and I had to fix it with a nvram change to a particular setting to even show the country-related settings. Flashing to stock or other versions of firmware doesn't change anything, but tweaking that one setting fixed the issue.
tinkeruntilitworks
Guest





PostPosted: Sat Sep 12, 2020 12:32    Post subject: Reply with quote
on the r7000p there are clearly more bugs than country codes. he is just using that as an excuse to not even look into the issue. with my roku remote dying in days it seems its more than the lower channels not being available as well


after recovering the channels from the kong build the lower channels remain after a gui reset and pin reset. they are clearly supposed to be there

after an nvram erase on bs you have to do an extra reboot to even be able to select the one available channel
RageX
DD-WRT Novice


Joined: 01 Jan 2020
Posts: 34

PostPosted: Sat Sep 12, 2020 13:13    Post subject: Reply with quote
In the end most of us aren't paying anything for the firmware, so we don't have too much right to demand bug fixes when he has given his reasons.

I suppose with the R7000P it affects you because of router region settings, but not "his" model over in Europe. Kong did things a bit differently but I understand that it may not be feasible to test 10 different country models for each model of router for each build release. Kong's version probably changes certain nvram settings on install.

If you think there are other issues unrelated to country settings, try opening another ticket in the svn.
Goto page Previous  1, 2, 3, 4  Next Display posts from previous:    Page 3 of 4
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum